A dynamic, open source programming language with a focus on simplicity and productivity. (quote: ruby-lang.org)

learn more… | top users | synonyms

1
vote
1answer
68 views

Where is my ruby installed when i install through RVM?

right now i am running ruby 1.9 , which i installed using RVM . I needed that to run my redmine 2.4.2 , since i had trouble using 1.8. Now i need to configure my passenger mod to point to ruby 1.9 ...
0
votes
0answers
28 views

How to install ruby backport on 12.04

The following commands do not work: apt-get install ruby1.9.3 installs 1.8.7 as specified by ruby --version apt-get install ruby/trusty is held back with: ruby : Depends: ruby1.9.1 (>= ...
0
votes
1answer
87 views

Getting always - “xmpfilter: command not found”

I have installed vim plug-in - t9md/vim-ruby-xmpfilter. My .vimrc contains 1 set nocompatible " We're running Vim, not Vi! 2 syntax on " Enable syntax highlighting 3 filetype ...
1
vote
1answer
586 views

GitLab Omnibus Ubuntu 12.04

I am trying to build GitLab from the Omnibus project in my Ubuntu 12.04 64-bit following this link After issuing sudo apt-get install ruby ruby-bundler I downloaded the source from here and after ...
0
votes
1answer
2k views

ERROR: While executing gem (some::Gem) no such name (http://some.url) [closed]

I'm trying to install rails using $ sudo gem install rails But I get this error: ERROR: While executing gem ... (Gem::RemoteFetcher::UnknownHostError) no such name ...
1
vote
1answer
246 views

puppet rspec no such file to load — rspec-puppet (LoadError)

I have no prior experience at all of ruby. I am not interested in ruby (and so have no knowledge of rails etc) as such but am using puppet to manage a group of servers. I have written some modules ...
1
vote
1answer
888 views

How to uninstall rubymine from UBUNTU

I was trying to upgrade from RubyMine 5.4.3.2.1 to 6 for that I was trying to uninstall RubyMine 5.4.3.2.1. I removed RubyMine directory from where I installed RubyMine. Now everytime I need to run ...
1
vote
1answer
1k views

How to uninstall RubyMine 5.4.3.2.1?

I was trying to upgrade from RubyMine 5.4.3.2.1 to 6 for that I was trying to uninstall RubyMine 5.4.3.2.1. I removed RubyMine directory from where I installed RubyMine. Now everytime I need to run ...
0
votes
0answers
34 views

eventmachine 0.12.10 installing failed

please check gem_make.out file here: gem_make.out and also the complete process which failed at here: eventmachine fail error file
1
vote
1answer
3k views

install libmysqlclient-dev 5.6

I can't use the mysql ruby gem because I get this error: Incorrect MySQL client library version! This gem was compiled for 5.6.15 but the client library is 5.5.34. (RuntimeError) apt-get is ...
0
votes
1answer
168 views

How to access Ruby on Rails Assets from a Host Machine

I am running a Ruby on Rails server on an Ubuntu VirtualBox guest machine. I can access the local server from my host machine by setting the Ubuntu network adapter to bridged. My app's hmtl is ...
0
votes
0answers
146 views

Installing rbenv apt-get vs git checkout

I'm finding confliccting advice on how to install rbenv (and ruby) in recent ubuntu versions (13.10). Many guides suggest cloning from git, and updating bashrc etc. For example this guide on ...
1
vote
0answers
371 views

Ruby 2.0.0 RVM error installing on Ubuntu 13.10

Ruby 2.0.0 RVM error installing on Ubuntu 13.10: Error running 'requirements_debian_update_system ruby-2.0.0-p353', please read /home/sergey/.rvm/log/1385231754_ruby-2.0.0-p353/update_system.log ...
1
vote
1answer
149 views

Gsl ruby gem on Ubuntu Saucy (13.10)

I'm trying to install the gsl gem on Ubuntu Saucy I installed the relevant gsl packages with sudo apt-get install gsl-bin libgsl0-dev But then installing the gem fails In file included from ...
0
votes
0answers
59 views

Adding a scale to a popup menu

For some reason when I add a slider (scale) to a popup menu it doesn't work. It shows but doesn't move. How can I get the slider to work? Just put this in a Gtk::Window: require 'gtk3' #gtk2 will ...
1
vote
2answers
455 views

Unable to Install Guard

I've seen Guard and it's usefulness in web development and would like to install it. Naturally, I expected to be able to use sudo gem install guard to do so (yes, it is a Ruby Gem). However the ...
0
votes
2answers
361 views

why there is difference between psql -version output and the psql version connected to my application? how can I resolve this

I am building up a rails application that I cloned from my friend. I am using Ubuntu 13.10, rails 3.2.14. I am using a postgresql database and when I try to run rake db:migrate it gives me some error ...
5
votes
1answer
4k views

How to install ruby?

I am pretty new to ruby world and I don't know about installing it. Viewing methods from blogs with google search but feeling confuse. Could somebody help me to setup ruby in my Ubuntu 13.10?
5
votes
2answers
127 views

Is it possible to update the app indicator from code?

I use ruby-libappindicator bindings to manage ubuntu application indicators. I want to indicate if port 3000 is used by any application. Port checking isn't a problem but I also need to update the ...
0
votes
1answer
490 views

Rails 3: No route matches error

I am trying to create a simple form in Rails 3. But facing this issue: Showing /home/praveen/rails_projects/mebay/app/views/ads/new.html.erb where line #2 raised: No route matches ...
0
votes
0answers
41 views

Create a new rails show the error message

Bundler could not find compatible versions for gem "bundler": In Gemfile: rails (= 4.0.0) depends on bundler (< 2.0, >= 1.3.0) Current Bundler version: bundler (1.0.15) I ...
0
votes
3answers
436 views

Why has Ubuntu 13.10 more recent packages than 13.04?

I don't understand how some packages are managed in Ubuntu. How are they moved from unstable to testing? The Debian FAQ says: Unstable has the most recent (latest) versions. But the packages ...
0
votes
0answers
290 views

Problem with bundle install in RoR

I am using RVM and using ruby-1.9.2-p180 When I enter my project I get: You are using '.rvmrc', it requires trusting, it is slower and it is not compatible with other ruby managers, you can switch ...
0
votes
0answers
47 views

problem running Jekyll

I try to run jekyll but I can the error: /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': /usr/lib/ruby/vendor_ruby/jekyll.rb:131: syntax error, unexpected ')', expecting keyword_end ...
1
vote
1answer
2k views

VPS apache config - Invalid command 'PassengerDefaultRuby' after adding latest passenger gem

used to have this list of rubies in my vps: ruby-1.9.2-p320 [ i686 ] =* ruby-1.9.3-p194 [ i686 ] ruby-1.9.3-p374 [ i686 ] ruby-1.9.3-p392 [ i686 ] today I installed a new app on this vps ...
3
votes
1answer
2k views

Can't install rvm

I want to install RVM: ubuntu@ext:~$ rvm The program 'rvm' is currently not installed. You can install it by typing: sudo apt-get install ruby-rvm ubuntu@ext:~$ sudo apt-get install ruby-rvm Reading ...
0
votes
0answers
58 views

How use jasperserver in rails application

I am having problem in creating reports using jasperreport server. I gone through many sites, But I am not able not understand jasperserver with rails application.Could any one provide me a detail ...
0
votes
0answers
225 views

Can't install ruby-1.8.7-p334 via rvm

I'm having difficult installing Ruby on my computer. I initially wanted to install the ruby-2.0.0-p247 but RVM could not find the package. When running the following command: rvm install ...
1
vote
3answers
1k views

How do you login into /bin/bash automatically?

Im on 12.04 LTS and am doing to Ruby on Rails development. When I start up my terminal and type in ruby -v it will list my Ruby as 1.8.7. When I type in /bin/bash --login then ruby -v will list it as ...
1
vote
1answer
129 views

What version of Ruby am I really running?

Im running Ubuntu 12.04 lts and have installed Ruby via RVM. Problem is when I just type ruby -v into the terminal it says that my Ruby Version is 1.8.7 and using the shotgun gem for Sinatra it ...
2
votes
0answers
119 views

Installing Ruby [duplicate]

I found a tutorial in this site showing how to install Ruby. The problem is I found the terminal is asking to install packages that are already installed Reading package lists... Installing ...
0
votes
1answer
146 views

gssapi requires Ruby version >= 1.9.1. on gem install

I'm trying to install knife-cloudstack plugin using gem install on Ubuntu 12.04 with chef-client configured and got error as said in title. >gem install knife-cloudstack ERROR: Error installing ...
-1
votes
1answer
41 views

“No XS-Ruby-Versions” error message when building Ruby package

I am trying to build a Ruby package using git-buildpackage. I am getting this error near the end of the process: dh clean --buildsystem=ruby --with ruby dh_testdir -O--buildsystem=ruby ...
6
votes
2answers
12k views

How to find and install latest Ruby version using RVM?

I finally got RVM working and now I would like RVM to install the latest stable ruby version. In the tutorial I am using they installed ruby 1.9.3 with command : rvm install 1.9.3 Now I want to ...
0
votes
0answers
67 views

Ruby -v and RVM list different versions

I installed ruby via rvm into Ubuntu 12.04 lts. In terminal when I type ruby -v to check what version of ruby im on it list 1.8.7. Problem is I never installed this version and when I type rvm list, ...
-1
votes
1answer
324 views

I have a problem to install metasploit on ubuntu 12.04

I have installed metasploit on my ubuntu 12.04 but the problem when i write aboziad@aboziad:~$ msfconsole Could not find rake-10.0.4 in any of the sources Run `bundle install` to install missing ...
0
votes
0answers
119 views

Problem using rails with ubunt 12.04 and unable to run console command

When I am using rails console command something like this is happening: peeyush@peeyush-WS:~/issues$ rails console /home/peeyush/.rvm/rubies/ruby-1.9.3-p429/lib/ruby/1.9.1/irb/completion.rb:9:in ...
0
votes
0answers
33 views

Program taking forever to run

For a programming course, I'm parsing politician data out of a csv in Ruby and populating a database with it. The program runs horribly slow on my Ubuntu! But on other Ubuntu machines and Apple ...
0
votes
0answers
319 views

RubyMine start genarates “Permission denied” error

I am starting RubyMine IDE with the following command: mine . executed in the project directory. Unfortunately, I have to re-install my Ubuntu 13.04 and to install again the RubyMine IDE. During ...
0
votes
0answers
122 views

Working with existing database of a rails project in ubuntu12

I want to run a ruby on rails project in my Ubuntu 12 mechine.After running the command bundle install i used the following command rake db:drop db:setup it shows -- ...
1
vote
2answers
82 views

Will a Ruby installation installed by a package manager conflict with one installed with RVM?

I installed the Heroku Toolbelt the other day, and it looks like Ruby was a requirement, so the package manager installed it for me. But I was planning to install Ruby through RVM. Will the two Rubys ...
1
vote
1answer
426 views

Upstart - Bluepill not starting without sudo

I have an upstart service to start bluepill (Ruby gem to monitor processes). The upstart config is below. description "Start up the bluepill service" start on runlevel [2] stop on runlevel [016] ...
1
vote
1answer
319 views

Issue With Upstart And RVM Gem?

Im trying to get a RVM gem to run via upstart... I can't seem to get it to work: siriserver.conf #siriserver start on filesystem or runlevel [2345] stop on runlevel [!2345] respawn exec ...
2
votes
1answer
937 views

Upstart tracking wrong PID of process - not respawning

I originally asked this question on StackOverflow. Then realised that this is probably a better place. I have bluepill setup to monitor my delayed_job processes. (Ruby On Rails application) Using ...
1
vote
0answers
94 views

How should I configure Jenkins for Ruby on Rails?

I am using Ubuntu 12.04 and I have installed Jenkins on my system. What additional software and plugins do I need for running Ruby on Rails jobs, and how should I configure them?
0
votes
0answers
18 views

Post-retirement plans for Ruby package in Precise 12.04LTS? [duplicate]

Now that Ruby 1.8.7 is officially retired, is it at all possible that the default ruby package in precise might be updated all the way up to 2.0? I understand that backporting is generally not done ...
1
vote
0answers
90 views

Dotdeb alternatives for Ruby or Python?

I really like Dotdeb, but it doesn't include packages for Ruby and Python. While I could build my own repository, I wouldn't want to reinvent the wheel (and then be forced to drive). Are there any ...
1
vote
1answer
2k views

Installing Ruby On Rails stack on Ubuntu? [duplicate]

I'm looking to install ruby on rails on Ubuntu similarly to how its described in the RailsIntaller.org for MAC/Windows. Instructions and guides that I've seen to do this on Ubuntu seem to be all over ...
22
votes
1answer
6k views

How to install jekyll?

According to the jekyll site, this is how you make a new website with jekyll: ~ $ gem install jekyll ~ $ jekyll new myblog ~ $ cd myblog ~/myblog $ jekyll serve gem install jekyll didn't work, nor ...
0
votes
3answers
2k views

How to open a Ruby file in terminal?

I have a ruby file saved on my desktop as test.rb. How can I open it with terminal? I have already tried to use /home/desktop/test.rb and what I get in response is bash: /home/desktop/test.rb: No ...