Ruby on Rails, or simply Rails, is an open source web application framework written in Ruby.

learn more… | top users | synonyms

-3
votes
0answers
21 views

Best Version of Ubuntu for Rails Development [closed]

Is there a best version of ubuntu for rails development. Because I have been having problems with 14.04 LTS.
0
votes
1answer
20 views

Ubuntu-touch ruby / rails development: installing with rvm

I have a Bq10 tablet running Ubuntu-touch OTA-11. I want to be able to work with Ruby and rails apps. Usually I use rvm for this. Is it possible to install rvm [or something similiar] using ubuntu-...
1
vote
1answer
59 views

Unable to connect to PostgreSQL

I had PostgreSQL 9.3 working fine but when I tried to upgrade to 9.5 I began encountering errors. So I purged Postgres from my system following the first answer of this question. Then I installed ...
0
votes
0answers
85 views

Cannot load such file bcrypt_ext

While using metasploit i'm getting this issue /.rvm/gems/ruby-2.1.8@metasploit-framework/gems/bcrypt-3.1.11/lib/bcrypt.rb:16:in `require': incompatible library version - /home/.rvm/gems/ruby-2.1.8@...
0
votes
0answers
80 views

cannot load such file — rspec/expectations (LoadError)

I got this when I run rspec spec its a sample project, and its very simple too but I couldnt found an answer for this case, I think it's an error in installation. Here is my tree and my files. Thanks ...
1
vote
1answer
191 views

Pgadmin3 not working on ubuntu 15.10

I installed postgres than pgadmin3 on ubuntu 15.10. install was successful but when I type pgadmin3 in terminal and hit enter I get this following error : Fatal Error: Mismatch between the program ...
0
votes
0answers
52 views

Ubuntu Memory Low

When I SSH in, my memory usage is at57%. It looks like I have very little RAM available but I don't think that was the case before... ubuntu:/etc/projects/myapp$ free -h total ...
1
vote
0answers
30 views

Why does second terminal tab prompt bundle install

If I run rails s in the terminal, it works. If I open a new terminal window or tab and run rails c I get the following error: Run bundle install to install missing gems. If I run cd .. and ...
0
votes
1answer
135 views

Ubuntu 14.04 LTS:error parsing `Gemfile`: Undefined local variable or method `urce' for Gemfile. Bundler cannot continue

I'm new to Web App Development beginning with Ruby On Rails. To get started I followed this. I'm in the final steps where it asks to create a Database (I'm using mysql) by running rake db:create but ...
1
vote
2answers
2k views

Can't access docker container exposed port

I am running a rails app inside of a docker container but trying to reach it from a browser the browser shows ERR_CONNECTION_REFUSED . when running docker ps I get a086ed5a6c4a rails ...
0
votes
0answers
15 views

How to https available on ubuntu server for Rails site

I am working on Rails 3.0.6 application where I have to setup https for that site. I created and setup certificates on server /etc/apache2/ssl/ here (.crt and .key files) and changes here /etc/apache2/...
0
votes
1answer
211 views

Error occuring while setting up the mysql database in production

I am trying to run command rake db:setup RAILS_ENV="production" But it's giving the following error : DEPRECATION WARNING: Passing a string to ActiveRecord::Base.establish_connection for a ...
1
vote
2answers
109 views

Invoking mysql prompt in ubuntu

I am not able to access the mysql prompt as after typing this mysql - u root in the command line according to the book Agile Web Development with Rails, 4th Edition . Instead i am getting a list of ...
0
votes
1answer
32 views

Rails installation runtime error

hi guys I'm trying to install rails using ubntu desktop 14.04 my ruby version is ruby 2.2.3p173 (2015-08-18 revision 51636) [x86_64-linux] i install it with rvm my gem version gem -v 2.5.0 when i ...
0
votes
2answers
1k views

Rails server error: “Could not find a JavaScript runtime.”

trying to run the rails server i get this error: /var/lib/gems/2.1.0/gems/execjs-2.6.0/lib/execjs/runtimes.rb:48:in `autodetect': Could not find a JavaScript runtime. See https://github.com/rails/...
1
vote
0answers
25 views

Installing RVM error

I am trying to install RVM for Ruby on Rails. This message appears: Requirements installation failed with status: 100. What do I need to do? How do I fix this?
0
votes
0answers
66 views

Simplest Way to do a Local Home Rails Server on Ubuntu 14.04 without Subscription Services

I've been browsing many tutorials with regards to deploying a rails app unto a server; however , many of these articles require something like "Digital Ocean" VM's to run. I just want a very simple ...
1
vote
1answer
631 views

Gem Debugger won't install with bundle install

I have installed ruby on rails using rvm. I am using 2.2.0 ruby and 4.2.0 Rails. I tried running bundle install on an older project that I developed on a former pc but I get : Gem::Ext::BuildError: ...
1
vote
1answer
2k views

Can't run bundle install in ubuntu

I have installed ruby on rails using rvm . I am trying to bundle install an older project that I had on a former pc but I get the following error when I run the bundle install command: Installing ...
2
votes
1answer
93 views

One or more prerequisites required to install Kaltura failed

I am following https://github.com/instructure/canvas-lms/wiki/Kaltura-setup-instructions to install Kaltura. But I am getting issue in sudo php install.php step. sneha@SCS-I82:~/Downloads/...
2
votes
1answer
51 views

Missing imap PHP extension error

I am following this link for Kaltura installation. But I am getting issue in sudo php install.php step. sneha@SCS-I82:~/Downloads/kalturaCE_v3.0.0-instructure$ sudo php install.php Thank you for ...
0
votes
0answers
2k views

Apache2 service not restarting rails ubuntu

When I type : `sudo /etc/init.d/apache2 restart` or `service apache2 restart` I get this result Job for apache2.service failed. See "systemctl status apache2.service" and "journalctl -xe" for ...
0
votes
2answers
171 views

Is ther any tool in ubuntu to convert pdf to doc

I am looking for a tool or middle-ware which converts PDF to DOC. which should convert exact PDF content (with all image and style.) I have tried abiword. No use. not converting properly. If we can ...
0
votes
2answers
285 views

Spree sample data fetch giving error on bundle exec rake db:seed

Trying to get the sample data for my spree app. Used following steps: bundle exec rake railties:install:migrations bundle exec rake db:migrate bundle exec rake db:seed bundle exec rake spree_sample:...
1
vote
1answer
612 views

Why is my system unable to locate libreadline when I'm certain I've installed it?

I am trying to set up my chromebook for development with crouton and ubuntu. I am using the railsgirls recipe to install rails and I'm getting stuck at: E: Unable to locate package libreadline I ...
1
vote
2answers
1k views

failing to install RVM while trying to install RoR

I am trying to install RoR on my system. I am following digital ocean's tutorial. While I try to install RVM \curl -L https://get.rvm.io | bash -s stable with this command I am getting the below error:...
1
vote
0answers
44 views

Job on Upstart not started

I'm trying to start my application at boot, but I can not ... the script in upstart calls another script, I'm not getting or whether the 2nd script is called, follows the two scripts: 1º Script ...
0
votes
0answers
118 views

Start Rails Application on Boot Ubuntu

I am trying to make my application Ruby on Rails (OpenProject) starting with the system boot, but to test the script as root, returns me the error: /usr/bin/env:ruby: No such file or directory. My ...
0
votes
1answer
1k views

Ruby on Rails install and run problem

I installed Ruby + Rails and its dependencies on a fresh installation of Ubuntu 14.04 using the following commands, Pre Install Checklist sudo apt-get update sudo apt-get upgrade Add apt ...
1
vote
0answers
1k views

Problems Installing Metasploit Framework on Ubuntu

I have encountered 3 problems while following this guide to installing Metasploit Framework on Ubuntu and Debian: 1) After installing proper version of ruby, there is a command given for installing ...