0
votes
0answers
85 views

Error installing rails 3.2.14

I get the following error while installing Rails 3.2.14: With sudo apt-get install rails apt 0.8.16~exp12ubuntu10.16 for amd64 compiled on Nov 15 2013 15:33:57 Supported modules: *Ver: Standard .deb ...
0
votes
0answers
98 views

Installing rbenv apt-get vs git checkout

I'm finding confliccting advice on how to install rbenv (and ruby) in recent ubuntu versions (13.10). Many guides suggest cloning from git, and updating bashrc etc. For example this guide on ...
0
votes
3answers
418 views

Why has Ubuntu 13.10 more recent packages than 13.04?

I don't understand how some packages are managed in Ubuntu. How are they moved from unstable to testing? The Debian FAQ says: Unstable has the most recent (latest) versions. But the packages ...
1
vote
2answers
68 views

Will a Ruby installation installed by a package manager conflict with one installed with RVM?

I installed the Heroku Toolbelt the other day, and it looks like Ruby was a requirement, so the package manager installed it for me. But I was planning to install Ruby through RVM. Will the two Rubys ...
0
votes
0answers
18 views

Post-retirement plans for Ruby package in Precise 12.04LTS? [duplicate]

Now that Ruby 1.8.7 is officially retired, is it at all possible that the default ruby package in precise might be updated all the way up to 2.0? I understand that backporting is generally not done ...
0
votes
1answer
128 views

Download a particular version of a package with apt

I wish to download a particular version of a package. The package in question is ruby1.9.3 which has a Ubuntu native version and a Brightbox PPA version. I have the PPA version installed and that ...
0
votes
1answer
1k views

trouble updating “sudo apt-get update” [duplicate]

I've been trying to install ruby on rails and it requires me to run this command. I am new to Linux so I'm not very familiar with everything but this is what comes out after I type "sudo apt-get ...
2
votes
2answers
188 views

How can I install Vagrant on 12.04 if ruby-json is already installed?

I tried to install the software , which are in software center and new software like virtual box, but it is showing the error: Items cannot be installed or removed until the package catalog is ...
0
votes
1answer
2k views

Couldn't find any package by regex - ruby

I need to install ruby1.9.3-dev sudo apt-get install ruby1.9.3-dev Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package ...
0
votes
0answers
1k views

Unable to install rubygems on ubuntu

When i try to execute sudo apt-get install rubygems i get the following response Reading package lists... Done Building dependency tree Reading state information... Done The following packages ...
1
vote
1answer
4k views

Could not find a valid gem 'rails' (>= 0) in any repository

I am trying to install rails using the following command: sudo gem install rails and get the following error: ERROR: Could not find a valid gem 'rails' (>= 0) in any repository ERROR: ...
4
votes
2answers
2k views

Problem installing ruby and gems

I just installed ruby using apt-get with the following command: sudo apt-get install ruby1.9.1-full But when I try to do sudo gem install ... it says that I have not installed gems and that I shoud ...
2
votes
2answers
966 views

Can't install libopenssl-ruby

I'm trying to install ruby on rails and I can't seem to install libopenssl-ruby. I'm on a VPS and I've installed Jaunty as the newer releases don't seem to work very nicely. When I do: apt-get ...