1
vote
2answers
131 views

Ruby: Problem with Different Versions

I posted this question before but I had 11.04 which is not supprted. So now I updated to 11.10, but still the problem is not solved. I want to use ruby 1.9.1 . The problem I am facing is shown below. ...
3
votes
1answer
3k views

How do I start a ruby/gem program?

I have installed taskjuggler (gem install taskjuggler), but now I have no idea how to start it... $ taskjuggler taskjuggler: command not found $ gem taskjuggler ERROR: While executing gem ... ...
0
votes
1answer
35 views

Do I need to reinstall language environments?

I recently installed Ubuntu 11.10 (using wubi) and want to make it my main development environment. I have Java, ruby, gcc, haskell, python (and the list goes on) environments, compilers and ...
0
votes
1answer
309 views

How to automatically hide error messages in GNOME Shell's notifications?

I'm using Ubuntu 11.10 and gnome-shell 3. I`m using Guard to notify test pass or failure. How to automatically hide error messages from libnotify in gnome shell? When I have green test notification ...
2
votes
1answer
553 views

ruby ri: Nothing known about Array

There doesn't seem to be any ri documentation on core ruby classes on my system. Using ri -c I see that there are docs for a few gems I've installed, but that's it. $ ri Array Nothing known about ...
2
votes
2answers
335 views

Error while installing rails

Following this tutorial here, to install ruby on rails on ubuntu 11.10 with sqlite3 when I run the following command sudo gem install rails I get the following error : ERROR: Could not find a ...
5
votes
1answer
2k views

Foreman doesn't start with “Invalid gemspec” error

Like this post I am also trying to complete this heroku tutorial I have installed and used everything (node.js, npm, express) successfully until I got to Foreman. I installed Foreman by first ...
0
votes
1answer
283 views

ruby-sinatra fails to install

I want to install the package ruby-sinatra on a ubuntu server 10.11. It fails because this package depends on ruby-rack, which is an virtuall package. What can I do?
6
votes
2answers
918 views

Why is it so difficult to setup Ruby on Rails on Ubuntu?

I've spent a few hours this morning trying to setup Rails on a fresh instance of Ubuntu and I noticed that the process is incredibly more convoluted than on Windows. On Windows I go to ...
4
votes
2answers
2k views

Passenger (mod-rails) can't find libopenssl-ruby

Trying to build an nginx server with Phusion Passenger on Ubuntu 11.10 (hurray for the new version!). Running "passenger-install-nginx-module" outputs the following error: * OpenSSL support for ...