Questions about managing/using repositories in general and about selecting Ubuntu repositories in particular. Most of the latter questions could be added under the "ppa" and "apt-get" tags as well.

learn more… | top users | synonyms (1)

0
votes
1answer
135 views

Why older version of package repositories of Ubuntu don't get updated?

Suppose my Ubuntu version is Natty and I want to install the latest nodejs using apt-get. However, the latest nodejs is only available in the package repository of Quantal.(see ...
1
vote
2answers
2k views

How to add Ubuntu repositories on Kubuntu?

I have noticed that Kubuntu (I am using 12.04 version) doesn't use exactly the same repositories that Ubuntu. Or at least, that is what I think. For example, if I search for Steam on Muon Software ...
2
votes
1answer
516 views

Can i exclude certain repositories from apt-get upgrade?

I have installed percona extra backup by adding their repository. This worked and i was able to install the software successfully. However now I am trying to run "apt-get upgrade" and it is trying ...
1
vote
0answers
110 views

Failure in downloading repository information

I update my system and all is fine but then after some time a sign appears at the top panel and tells me something is wrong with the some repositories and tells me to do a check for update, when I do ...
7
votes
2answers
204 views

Unofficial/Local repositories and how do they differ from PPAs in Launchpad

I normally tend to use the PPAs (Personal Package Archives) found in launchpad.net, but I have noticed more and more that some repositories are being created in other places or a website that manages ...
2
votes
1answer
75 views

How can I get a package update in the repositories?

I use a software (Anki) which is in version 0.9.9.8.6-2.1 in the Debian repository and in version 1.2.11-1 in the Ubuntu repository. Quite a lot has changed meanwhile (changelog). The latest version ...
0
votes
1answer
698 views

Php repository without suhosin

I don't really know how to or want to compile php from source, but i need php without suhosin. As you may know the main repository comes with suhosin patch. this is causing errors on my website and I ...
0
votes
1answer
1k views

How do I get the plasmoid repository

I had a load of plasmoids, beginning with plasma-widget- and kde-applet and kde-plasmoid-, which I think I had added from a PPA, but I can't for the life of me find which one it is (I did a fresh ...
0
votes
1answer
89 views

Which repository are free software on 12.04

I know restricted and multiverse are not free software, but what about source code and independent? EDIT : I'm referring to free as in freedom.
1
vote
3answers
1k views

How to add Debian experimental repo to Ubuntu?

I would like to install cups-1.6.1-2 (link) from the experimental repository. I suppose I have to add something to /etc/apt/sources.list but I can't figure out what. Can anyone figure out (or know) ...
0
votes
4answers
916 views

dod cac reader setup ubuntu 12.04

I read that I need to download cackey from forge.mil but the download isn't there any more. How can I get my CAC reader working now? Is there a sudo apt-get command for it? Does someone have a copy ...
1
vote
0answers
131 views

Need help fixing “E: The method driver /usr/lib/apt/methods/htp could not be found.”

I've tried and tried, but can't seem to find anything that works. I also see that I have no sources.list, help with both would be nice and probably necessary
1
vote
0answers
20 views

why is minetest outdated in the Ubuntu repositories? [duplicate]

The Game Minetest in the ubuntu repositories is version 0.3.1 it has no been nearly a year since this release and version 0.4.5 has recently come out. Is there any reason why this is?
0
votes
2answers
515 views

What happened to php-5.4.11 from Ondrej PPA? [closed]

I am in 12.04 so I added Ondrej's PPA to get PHP 5.4. So far so good but php-5.4.12 seems to be broken with our code and after a while of struggling I decided to downgrade to php-5.4.11 but apt-cache ...
0
votes
2answers
2k views

E: Unable to locate package repo

E: Unable to locate package repo this error comes after sudo apt-get install repo
0
votes
0answers
19 views

Error Updating System [duplicate]

Hello :) I am new to Ubuntu. And I am getting this error: A red triangle in the taskbar (I was not allowed to post a pic) I just used shutter for the first time! Great App!! With this message: ...
1
vote
0answers
693 views

apt-get update will not work on my server

I've just installed Ubuntu Server 12.04 on my spare box, and I'm using a command line interface only to get my feet a little wet. ping google.com does work, so I know my connection is up and running. ...
1
vote
2answers
2k views

Will eclipse update from the ubuntu repositories?

If I install a default eclipse from the ubuntu program central, I get an eclipse with traces from the version Helios and the screen that starts Eclipse says Indigo. The latest version of Eclipse is ...
0
votes
1answer
94 views

How can I install m2vrequantiser in Mythbuntu 12.04?

m2vrequantiser can be used by mytharchive to create DVDs and .iso's but it's apparently not available in 12.04 universe repository. Is there some way to get it for 12.04.1?
1
vote
0answers
55 views

Understanding the working of Apt Virtual HTTP Repository

My university has a virtual HTTP repository which we can access by changing our proxy to 10.1.1.224:3142. Our regular proxy to access the internet is 10.1.8.44:8080. It incredibly speeds up download ...
2
votes
1answer
2k views

Cannot install Handbrake in 64-bit Ubuntu 12.10

When I go into Synaptic and try to install the handbrake-gtk, after it gives me the list of all the other packages it has to install, I get this message: The following packages have unresolved ...
2
votes
2answers
2k views

Failed to download repository information | Ubuntu 12.10

I already checked for a possible answer to my question, but, how to fix this since my details are different from the other people here. Here's my error information on Software Updater: [W:Failed to ...
0
votes
2answers
307 views

Force Ubuntu to only download updates form canonical.com mirrors

How do I force a Ubuntu machine to only download updates from official canonical.com mirrors? Right now it sometimes downloads from non canonical mirrors, which get flagged in our network monitoring ...
-1
votes
2answers
112 views

why does Ubuntu downloads apps from 93.184.215.223?

Does anyone know I why my ubuntu machine makes a connection to 93.184.215.223 when I use apt-get? I thought all the software repositories were at *.canonical.com. I haven't added any 3rd party ...
1
vote
1answer
103 views

Removed repository still being showed in synaptic origin section

I'm sure to have correctly purged a certaing ppa: it doesn't anymore appear in sources.list nor in sources.list.d folder. It doesn't even appear in Synaptic's repository list, but if I open the ...
2
votes
1answer
52 views

After Upgrading from 12.04.to 12.10 will i have to install my drivers again?

I want to upgrade from 12.04 to 12.10 but will i have to install the broadcom drivers and some softwares that i installed from backtrack repository??
4
votes
1answer
804 views

How do I install Unity Web apps from the software repositories?

I found .deb files in my cache for some webapps I installed. Then I used apt-get to install some other web apps. But the icons aren't showing up on the unity bar. How do I rectify this?
2
votes
1answer
386 views

Creating Your Own Bazaar Server

I'm trying to run your own bazaar server on Ubuntu 12.04 server - so far after reading stuff in internet i found this "tutorial" http://michael.lustfield.net/content/creating-your-own-bazaar-server - ...
1
vote
0answers
154 views

Fixing Networking Errors after Updating

I have Ubuntu 12.04.1 installed on my Desktop (because 12.10 won't work with my GPU). Last Thursday, January 24th, I installed the updates that were recommended to me. I admit that I did not read ...
0
votes
1answer
7k views

Error while trying to do sudo apt-get update [duplicate]

Possible Duplicate: How to install software or upgrade from old unsupported release? i'm not able to do sudo apt-get update in ubuntu 10.10 Here is my error Hit http://dl.google.com stable ...
3
votes
1answer
141 views

Returning Packages To Default

Is there a way to make my system go back to how it was when first installed ubuntu without doing the standard installation again? I want my packages, repositories, configuration files to go back to ...
1
vote
0answers
49 views

How do I add the latex backport PPAs to synaptic in 12.04? [duplicate]

Possible Duplicate: How do I install the latest TeX Live 2012? I would like to synaptic to have access to the repository files on this website: http://www.tug.org/texlive/debian.html I ...
0
votes
0answers
58 views

Ubuntu Maverick Meerkat 10.10 Repository Mirrors Go Offline! What now? [duplicate]

Possible Duplicate: How to install software or upgrade from old unsupported release? Is there a Ubuntu 10.10 Maverick Meerkat software repository mirror that is still online and has all the ...
12
votes
3answers
929 views

Are ubuntu packages (deb-files) only md5sum secured?

Introductory Background to the question below### (so the question is more usable to more people) Inside of an Ubuntu/debian-style package (*.deb file) there is a file named /DEBIAN/md5sums which has ...
1
vote
1answer
212 views

Why re-enabled sources are still marked as “disabled on upgrade to quantal”?

After having a lot of software sources disabled on upgrade to Lubuntu quantal (see question here) I have decided to re-enable most of them, which I did, without problems, except that the note that ...
4
votes
1answer
20k views

Failed to fetch repositories [duplicate]

Possible Duplicate: How to install software or upgrade from old unsupported release? How can I fix a 404 Error using the Ubuntu archives? I am having trouble downloading the Ubuntu ...
0
votes
1answer
3k views

Cloning a repository?

I need to clone a repository. The command is: git clone https://github.com/androportal/linux-sunxi.git If I do it this way it takes a long time to install/download. Now I opened this link and I got ...
1
vote
1answer
90 views

What is to be done with all the sources disabled on upgrade?

After upgrading from Lubuntu 12.04 to 12.10 I see a lot of repositories disabled in the list of sources. What should I do?
0
votes
2answers
2k views

software-properties-gtk does not start

I'm using Ubuntu 12.10. Yesterday I noticed that software-properties-gtk does not work anymore. I have no idea why and what to do. When I start via Terminal I get the following output: ...
3
votes
2answers
2k views

I'm having dependency problems with wine and multiarch on 12.04x64. I need a solution

EDIT 3: See bottom, for TL;DR-ish version. I want to install wine1.5, from the ppa:ubuntu-wine/ppa repository. Fair enough right? (I'm running 12.04 x64 and a custom kernel.) I added their ...
-1
votes
1answer
224 views

what is repository mirror in Debian and ubuntu?

What is a local mirror of a debian apt repository? any simple explanation. Is it the same as ubuntu repository? what is the best way to create one? and is it mandatory to keep the same folder ...
1
vote
3answers
497 views

Is there a repository (ppa) that collects closed-source, non-free software?

If I am not mistaken, programs like Spotify or Steam are not included in any of the Ubuntu repositories (main, restricted, ...). And I guess they will never be? Correct me if I am wrong. If I am ...
12
votes
2answers
13k views

Why am I getting “Command 'deb' not found”?

I have come across several installation instructions that include the command deb. But it appears that this command is not available on my installation. Where can I get this command? Is there a ...
1
vote
2answers
1k views

How to get BURG on 12.10 (Quantal Quetzal)

I've been using BURG for years to get rid of the eye sore that is the standard GRUB interface. When I upgraded to Quantal, the repository does not contain the updated information. I.e. after I add ...
0
votes
1answer
413 views

Pirateplayer Not able to install, old repository for Qt desktop components!

I have a slow connection so I used to have pirateplayer to download programs from svt.se but after update to Ubuntu 12.10 it wont be able to install. It wont compile because the repository only ...
4
votes
1answer
388 views

apt-move says the packages are moved but they are gone

I'm trying to setup a Ubuntu mirror with selected packages from different repositories, by using apt-move, which I've been using on Ubuntu 10.04 without (too much) problems. I've installed apt-move ...
1
vote
1answer
259 views

Repositories added for “Maya” not “Precise”

I wanted to test Cinnamon in my Xubuntu 12.04. After installing it, when I try to add a PPA it is added for "maya" not "precise". I purged Cinnamon PPA but it is still the same... what can I do about ...
3
votes
2answers
8k views

How to remove medibuntu repository and packages?

I followed directions to add medibuntu but it has messed up some codecs and dependencies so I can no longer watch videos I have run this command, originated by a forum post: sean@sean-P55-USB3:~$ ...
1
vote
3answers
976 views

How to get list of installable packages from repositories?

I wanted to install a few packages but had to power down my laptop as I had a few chores to do. I did add the packages' repositories and forgot to install the packages. As my browser history clears on ...
3
votes
1answer
70 views

is Python available in any Ubuntu installation?

Quite simply: is python already provided in any of the latest installations Ubuntu or does it have to be installed explicitly by the user? Thanks.