Questions about managing/using repositories in general and about selecting Ubuntu repositories in particular. Most of the latter questions could be added under the "ppa" and "apt-get" tags as well.

learn more… | top users | synonyms (1)

1
vote
0answers
120 views

can't add key - keyserver timed out

I'm trying to install mongodb on ubuntu 15.10. While following this - Install Mongo 3.2 on Ubuntu 15.10 - i got the following error message: W: GPG error: http://repo.mongodb.org trusty/mongodb-org/...
1
vote
1answer
31 views

How to push OpenPGP keys for a (custom) Ubuntu repository to clients running on Ubuntu server?

I have a number of devices running on Ubuntu trusty, syncing with a custom Debian package repository for software updates via unattended-upgrades. However, the OpenPGP key used to sign the release ...
0
votes
0answers
143 views

Need Help, Accidentally Deleted Ubuntu Repositories

My computer was running out of space on the hard drive so a friend told me to get the Ubuntu Tweak Tool, run the Janitor and delete everything it said to delete. Never listening to that friend again. ...
8
votes
1answer
3k views

How can I fix “W: <…> The repository is insufficiently signed by the key <…> (weak digest)” in my private repository?

I maintain a series of private repositories. The gpg keys used to sign the repo were made with "Key-Type: RSA" and "Key-Length: 4096". The version of GPG used to generate the keys is 1.4.16 on ...
1
vote
0answers
20 views

Testing an APT repository

I am trying to setup a distribution mechanism for Raspbian (Raspberry Pi) on a Ubuntu server. I have read most of the posts here and articles I could find about setting up an APT repo. I don't know if ...
0
votes
1answer
125 views

How to cancel a release upgrade completely?

So, the software updater comes up and says that there is a new Ubuntu version, do you want to upgrade it or not. I accidentally press yes. After that I interrupted the upgrade by closing it, and ...
1
vote
0answers
24 views

Ubuntu automatic Updates

I keep receiving that my Ubuntu updates are old and I should manually update. I do that and I get a message that the repositories can not download and I should check my internet connection. My ...
0
votes
0answers
10 views

Bash debugging symbols for 4.3-7ubuntu1.5

I want to install debugging symbols for bash 4.3-7ubuntu1.5 on Ubuntu 14.04.3 LTS. I tried to follow steps described in this blog - http://linux-debugger-bits.blogspot.co.uk/2014/04/bash-symbols.html ...
2
votes
0answers
26 views

Ubuntu 12.04: apt-get can't parse repository url if username contains @ ('at' sign)

I added a repository URL that contains to '@' (at sign) to /etc/apt/sources.list.d/myrepo.list deb https://FOO@BAR:PASS@domain.com/xyz precise non-free apt-get update fails with: Couldn't resolve ...
0
votes
0answers
6 views

Downloading from outdated repositories - 14.10 [duplicate]

I am running an old version of Ubuntu (14.10, not LTS) and I would like to upgrade to Wily Werewolf. Unfortunately I cannot upgrade via apt because the repositories are outdated, and I'm only willing ...
0
votes
0answers
18 views

How do you fix bad repository [duplicate]

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file) ...
0
votes
2answers
70 views

Go back to ubuntu packages after installing from an external repository?

I had to work with some kali packages, so i added the last kali repository to my file /etc/apt/sources.list . Everything went fine, and I installed some packages and worked with some. But during the ...
3
votes
3answers
3k views

Repository failure with google chrome

Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/chrome/deb stable InRelease' doesn't support architecture 'i386' is what i get when ...
0
votes
1answer
318 views

How can I get rid of this NO_PUBKEY errors?

sudo apt-get update is giving me this error at the end. I'm using "Y PPA Manager" and it seems that now all PPA's are O.K., but the problem (I think) is with the official Ubuntu repos: W: GPG error: ...
0
votes
0answers
60 views

Remove / purge repository spotify and opensuse

When I go to Software & Updates and then to Other Software I get this boxes unchecked: http://repository.spotify.com stable non-free and http://download.opensuse.org/repositories/home:/Horst3180/...
1
vote
3answers
147 views

installing ansible on ubuntu

I'm following this document to install ansible: https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-ansible-on-ubuntu-14-04 I'm try to add ansible to my ubuntu repositories ...
1
vote
0answers
56 views

apt-get equivalent to yum's --enablerepo

Is there an easy way to use a repository/PPA only when needed as we'd do in a RHEL based distro with yum's --enablerepo, --disablerepo flags . For example yum --enablerepo=epel install vlc yum --...
0
votes
1answer
411 views

Upgrading an Ubuntu localrepo from trusty to xenial

Please forgive my ignorance as I am new to Ubuntu. I have created a local repository of Trusty using apt-mirror. My question is how to upgrade this repo to Xenial? Also in the mirror.list file how to ...
0
votes
0answers
84 views

Third-party repositories error message when updating

I am getting the following error message when trying to install updates: Check if you are using third-party repositories. If so, disable them, because they are a common source of problems. ...
5
votes
1answer
2k views

Force update from unsigned repository Ubuntu 16.04

I using an unsigned repo in Ubuntu 16.04 from Debian multimedia deb http://www.deb-multimedia.org jessie main To install deb-multimedia-keyring I'm running apt-get update && apt-get install ...
0
votes
2answers
166 views

How can I easily install a newer version of python on Ubuntu 14.04 using apt-get without upgrading the entire OS?

I am stuck on Ubuntu 14.04 and upgrading to 15.10 is probably not an option. The highest version of python supported by Ubuntu 14 is 2.7.6. This is very old. I want to install a newer version. I ...
2
votes
1answer
566 views

Is there any viber PPA?

I'm using Ubuntu Gnome 15.10 and I'm looking for a viber ppa for automatic updates. I've already installed viber via .deb file from the official website but ppa will be better. Thanks for the answers!
0
votes
0answers
89 views

how to execute apt-get install -f without removing packages

I was advised by apt-get to run apt-get install -f but what I get is: $ sudo apt-get install -f [sudo] password for ron: Reading package lists... Done Building dependency tree Reading state ...
4
votes
1answer
84 views

Same Package - Multiple Repos

Which repository will Ubuntu choose to download a package from if the same package is available in more than one repos? Suppose a package A was initially installed from repository X and later I added ...
1
vote
0answers
155 views

Failed to download repository information Ubuntu 15.10

Since installing drop-box (whether this had any bearing I don't know) I have this error with any installation or update using the software centre or command-line using apt-get. E: GPG error: http://...
2
votes
3answers
375 views

How to add PPAs through a list? [closed]

I need to add PPAs on Ubuntu 14.04.3 from a file that contains a list of repositories, as follows: sudo add-apt-repository ppa: $ (cat ppas.list) or sudo add-apt-repository $ (cat ppas.list) or ...
1
vote
1answer
454 views

Android Studio - empty project after importing from Github

I have a big problem with android studio. Now I'm working on a project and I have to pair the repository from github to android studio. The connection and the clone of the folder went well. I can't ...
1
vote
0answers
53 views

Remove specific packages from internal apt repository

I have created an internal apt repository using apt-mirror. I need to remove only certain packages (source, lucid) from the repo. I have attempted to use the clean.sh script to do this, but it only ...
2
votes
0answers
375 views

warning: the following packages cannot be authenticated!

I am trying a local installation of the juju charms. Deply charm on machine1 copy deb files from /var/cache/apt/archive to /root/test on machine2 Modify the /etc/apt/sources.list to /root/test apt-...
1
vote
1answer
197 views

Update Python 2.7 to latest version of 2.x [duplicate]

My version of python2 on my ubuntu 14.04 machine is Python 2.7.6, how can I upgrade it to the the latest version of Python 2.X. The latest is currently 2.7.11. I have tried apt-get update/upgrade, ...
0
votes
1answer
81 views

Why isn't X2Go Server in the main Ubuntu repository?

While the X2Go client (package "x2goclient") can be downloaded from the main Ubuntu repository; this is not true for the X2Go server. One needs to get it from a different repository by doing the ...
0
votes
0answers
37 views

Can't connect to repositories via HTTP, but I can via FTP

I apologize in advance, but I'm pretty new to all of this. I'm having some issues connecting to ANYTHING via HTTP, especially the repositories. I can connect via FTP, but I'd like to resolve the ...
0
votes
2answers
39 views

How to create package file for packages

I am trying for offline installation of certain packages using apt-get. I have modified sources.list file to reflect the local cache directory path where I have kept all the required packages. However,...
0
votes
0answers
31 views

Why is there an old version of haproxy in Ubuntu repository?

Usually, I have found Ubuntu repositories to be more up-to-date as compared to Debian repositories, but in the case of haproxy, it's version in Ubuntu's repositories (1.4) is older than that in Debian'...
-1
votes
1answer
389 views

Ubuntu 15.10 updates - Failed to download repository information - check internet connection [duplicate]

I had previous problems like this, first it did not want to update anything. It always sad: Failed to download repository information check your internet connection, but i have internet connection ...
0
votes
1answer
112 views

Changed Python version, “apt-add-repository” not working ERROR

hi after installed python 3.5 in ubuntu, i had 2.7.6 and i wanted to be updated cause i will be working and learning python, so i installed the latest python version 3.5 and switched version to it, i ...
0
votes
1answer
34 views

When we install packages from ppa , are the packages downloaded at the location /var/cache/apt/archive?

When we install packages from ppa , are the packages downloaded at the location /var/cache/apt/archive? I am making a local repository of all the packages installed with apt-get. I see that packages ...
-1
votes
1answer
200 views

Kali repo on Ubuntu 15.10

Does anyone knows if is possible to install Kali Linux repositories on Ubuntu 15.10 and how? I've found many tuts on doing that for previous releases but nothing for Wily.
0
votes
0answers
25 views

Centralized Patching in Ubuntu

Is there an Ubuntu equivalent to patching systems of Red Hat Satellite? Something that would allow me to: Take a snapshot of the official Ubuntu Repositories. Modify the packages per any errata that ...
1
vote
0answers
34 views

Where can I download ubuntu with preinstalled packages?

I have an ubuntu ISO image. While installing it, I need to download some packages from ubuntu repository to play media files. Can i get an ubuntu with preloaded package like windows? Windows has some ...
2
votes
1answer
36 views

Distribute own application on PPA or use own server with repository?

I am writing an advanced cross-platform open-source application. It is commercial app, but free&open-source (GPLv3). The thing is, this app is related to data security, so we need, that the source ...
0
votes
0answers
13 views

Enable the Universe repository for Wordpress [duplicate]

I am looking at the instructions on this Ubuntu page. I have opened the sources.list document and all I see is what looks like Ubuntu packages. I think I want to run: sudo add-apt-repository ppa:&...
0
votes
0answers
27 views

Missing Archive Repositories Lead to Lock-Out

I am running a Dell GX520 computer. I am only operating Ubuntu. I haven't been able to install updates for a couple weeks. While trying to upgrade from 14.04 to 15.1, my efforts to fix broken packages ...
0
votes
0answers
8 views

New versions of Libreoffice [duplicate]

Why there are no new versions of Libreoffice in official Kubuntu 14.04 repositories? I don`t want to use PPA packages.
0
votes
1answer
35 views

Host git repo on my VPS

I am trying to host a git repo on my VPS. However, I want to place the repo under the user home directory. Example http://DOMAIN_NAME/~askubuntu/gitrepo.git I have apache2 installed which allows me ...
3
votes
1answer
242 views

How to disable apt key checking for private repositories under Ubuntu 14.04?

Under Ubuntu 14.04 I cannot get this to work. Our PCI auditor told us we can not have direct outbound access to the Ubuntu repo's, so I mirror them with reprepro. Likewise, we do not have outbound ...
0
votes
0answers
42 views

accidentally migrate to kali from ubuntu

helo everybody the problem began when I install katoolin..... first i install kali repos and then some of kali tools. Later the update software told me tha ther was a major update and i install it. ...
1
vote
1answer
38 views

How do I change an application installed using PPA?

I installed an application using Personal Package Archives (PPA). I installed the application by adding the "unstable" PPA, and now I want to switch to the "stable" PPA. So I removed the "unstable" ...
-1
votes
1answer
90 views

Cannot add PPA repository

Whenever I try run the following command it gives me an error: dmacs@dmacs-HP40:~$ sudo apt-get-repository ppa:nae-team/ppa sudo: apt-get-repository: command not found I don't know how to fix this.
6
votes
0answers
393 views

apt-mirror not downloading packages [closed]

I am mirroring an Ubuntu 14.04 repo with apt-mirror, but I am facing some troubles when downloading packages. Sometimes apt-mirror gets the index files and says it has to download about XXX Mb, but it ...