RAID stands for redundant array of independent disks, and allows for disks to be linked in various ways. Common RAID setups in Ubuntu are a hardware RAID, FakeRAID and software RAID.

learn more… | top users | synonyms

0
votes
0answers
7 views

Mount RAID 1 disk in Ubuntu 14.04

I have a dead WD My Book Live Duo case but the 2 HDDs inside are still ok. These drives are configured as RAID 1. I contacted WD's technical support and they told me to use Linux to access the files. ...
0
votes
0answers
5 views

Help! One of my raid partitions has disappeared

First time posting but I can't solve this by my self, so pleas help me. I have a problem, I can't access one of my partitions. I have three 2 TB disks that are running "hardware/intel software ...
0
votes
0answers
15 views

Rebuilding a RAID 1 array on a production server (Ubuntu 12.04.2 LTS)

I manage a production server which has a RAID 1 array with two identical hard drives. Apologies in advance, I've read many threads on this but due to the critical nature of the server, it will save ...
4
votes
2answers
1k views

How can I use Kernel 3.19 in 14.04 now?

So I'm rebuilding my storage server. For stability, I want to use Ubuntu server 14.04 LTS as the OS. However, I'm planning to use Btrfs with RAID 5, and this has been greatly improved in kernel 3.19. ...
1
vote
1answer
2k views

mdadm warning (system unbootable) from update-initramfs, mkconf's suggested fix seems inconsistent with mdadm's description of problem

Summary: update-initramfs says system unbootable, message points to mkconf which suggests rewrite to mdadm.conf that would appear to break the RAID, system up (for now) but next reboot may kill it, ...
0
votes
0answers
97 views

Boot message conflicting device mode

HI I'm running ubuntu server 14.1. There is a nvidia fakeraid array active. The raid is working, however on boot I see these messages (1 of 3 messages): Systemd-udevd[599]: conflicting device node ...
0
votes
0answers
7 views

RAID 1 disk from old server not recognized when taken off to a new machine

I had an old Ubuntu server at home, with two 1TB HDD in RAID1 configuration. I stored a lot of my works and stuff there, then eventually stopped using the server and let it get the dust for some time. ...
0
votes
2answers
3k views

Ubuntu 13.10 software raid

I had already Ubuntu OS installed on my desktop PC, where the software RAID 5 is configured ( 3 partitions /, swap and home ). This system was upgraded from the 11.04 till 13.04, it was quite messy, ...
1
vote
3answers
6k views

How do I know what physical drives/partitions are behind my /dev/mapper/isw_dghbbcaabe_RAID_Volume11?

This is a just upgraded Ubuntu 10.04.1 LTS machine. The /dev/mapper/isw_dghbbcaabe_RAID_Volume11 is "new" to the upgrade but I don´t know what physical drives/partitions are included in the "device". ...
2
votes
1answer
39 views

How to fix unbootable server after upgrade to 14.04

I had a pretty vanilla install of 12.04 running on a headless server with a software RAID1 array. I ran do-release-upgrade to upgrade to 14.04, and it seemed to run without issue. The only mistake I ...
1
vote
0answers
10 views

Slow raid5 resync with WD Green drives

The Question Why is my initial resync so slow? Initially cat /proc/mdstat reported ~ 30000K/sec. I then increased /sys/block/md0/md/stripe_cache_size from 256 to 16384. That increased the speed to ...
0
votes
0answers
9 views

Ubuntu OS on SSD and RAID 1 for data files

I have an ubuntu server OS installed on 80GB SSD HDD. I also have 2 1TB HDD used for data storage.Both were used as RAID 1 before. Now as my OS got corrupted I reinstalled with Ubuntu server 14.04. I ...
0
votes
2answers
4k views

XFS File System Fails - Can't read Superblock

After this (Iomega Home Media disk corruption - data recovery help asked) problem solved... i have a new one.. I'm trying to understand why my Iomega Home Media Stopped working, and need for that to ...
0
votes
0answers
31 views

Rebuild a vaporized dmraid array using mdadm

Executive Summary While upgrading from Utopic to Vivid, my system removed dmraid, which I was using as the RAID controller for the array that I booted from. How can I rebuild the array using mdadm ...
1
vote
1answer
22 views

Is it possible to use a dedicated parity drive without striping?

I'm setting up a log server. I'd like to set them up so that each disk is independent of the next, but the last disk is parity of all the rest. The reason why I want this is because: You can't ...
1
vote
4answers
4k views

Why isn't md raid assembled after reboot?

I'm trying to get an Intel RAID setup. The problem I have is that after a reboot the raid is not available. These are the steps I go through to setup the Intel RAID using the mdadm command. I've ...
0
votes
1answer
8 views

Anyone else having trouble accessing dynamic windows partitions from Ubuntu?

So, I have been trying to access my striped (software raid disk from Ubuntu) for at least six months. Now I know there are guides out there, but they are a bit hard to follow, at least for me. So I ...
0
votes
1answer
26 views

btrfs performance parallel access

I'm running a Raid5 (3x 500GB Sata2 HDD) based on btrfs 3.12 (Ubuntu 14.04 x64) and a VirutalBox VM uses this volume. As long as no other process accesses the volume, the VM runs fine. But recently I ...
4
votes
1answer
8k views

Dual-Boot Ubuntu 14.04 and Windows 7 on FakeRAID Installation error - question marks “????…”

I am trying to install Ubuntu 14.04 on FakeRAID along Win7. Win 7 has been already installed, and dmraid is running. During the installation I choose to manually partition, this is the structure: ...
0
votes
1answer
211 views

SSD is not showing up in boot loader installation device list while installing ubuntu 14.04 alongside windows

I've windows 7 installed in my SSD and trying to install ubuntu 14.04 in same SSD drive. But when I try to install ubuntu alongside windows it shows only HDD in the drive selection list. If I try to ...
0
votes
2answers
379 views

mdadm raid1 boot error

I created a RAID with Intel-Rapid-Storage(RST) - containing 2 3TB HDDs. Then I installed Ubuntu Server 14.04.1 64Bit. Everything worked fine and then I did a reboot. Then I got the following error ...
1
vote
2answers
93 views

Upgrade 12.04->14.04 broke mdadm RAID10. Boot stops

Server was an Ubuntu 12.04 x64 and was running just fine. All four drives in server are SATA spin-drives. /dev/md0 - swap RAID10: sda1, sdb1, sdc1, sdd1 /dev/md1 - root RAID10: sda2, sdb2, sdc2, sdd2 ...
1
vote
1answer
896 views

MDADM RAID1 Home Server System disk error: incrementally starting raid arrays mdadm: Create user root not found

I'm not sure what else to check. Everything below looks sane to me but the system hangs on boot. This is a home server with four disks crammed into a Dell OP620. Each pair of disks are assembled as ...
0
votes
0answers
19 views

How to install Hardware RAID Controller in Ubuntu Server

I am setting up an Ubuntu Server and I have a RAID drive with 5 disks with a VIA V-Raid controller, but I cannot configure the RAID drive as Ubuntu does not see it. What should I do? I need the RAID ...
0
votes
2answers
5k views

Driver hp raid controller b120i

I have a problem with a installation of ubuntu 12.04 server on HP SL4540 with raid controller b120i. Ubuntu during installation does not recognize the raid controller, and displays the disk ...
0
votes
1answer
25 views

Installing Ubuntu On a Seperate HDD

I was wondering if I could install ubuntu on a 500GB HDD while there are already 2 other HDDs in RAID 0 with windows 8 installed. Any help is appreciated.
9
votes
2answers
12k views

How to Install Ubuntu 14.04 with RAID 1 using desktop installer?

Many people claim that it is impossible to install Ubuntu onto RAID 1 with the Desktop CD. Is this really true? If not, how can it be done?
1
vote
0answers
151 views

Cannot install Ubuntu - stuck at 'Installation Type'

I am trying to install Ubuntu on my computer, but am stuck at choosing the device and partition to install to. I have three harddrives, one of them was going to be dedicated to Ubuntu, but two of the ...
0
votes
2answers
825 views

Installing Ubuntu Server 14.04 on a pre-built RAID Array

So I've got a RAID array built (Via the ASUS motherboard, 2 disks, RAID 1). When I try to install Ubuntu server on it, the process runs as normal (Apart from the drive is detected as md126p1 rather ...
1
vote
0answers
28 views

RAID not assembling after reboot, throws “uuid not in config file” even though it is

I created a RAID5 array using 4 x 2.0Tb drives using the disks GUI. I used mdadm --detail --scan >> /etc/mdadm/mdadm.conf to save the configuration. I opened the mdadm.conf file and double ...
0
votes
0answers
20 views

Software RAID 1 is only showing half its expected capacity

While installing Ubuntu 14.10 I manually partitioned and set up software RAID 1. I have 4 HDDs, each 2 TB. On each drive I set 8 GB of swap space and made the rest ext4 and bootable (both as software ...
1
vote
1answer
46 views

How To Mount RAID0 on Ubuntu (to recover data from Acer Aspire S5 Ultrabook)

Recently I ran into booting issues with windows 7 on my Acer Aspire S5 ultrabook. Before bootup, the system indicated that one of the physical disks (the ultrabook has two 128 GB SSDs in preinstalled ...
0
votes
1answer
86 views

How do I install Ubuntu 14 with UEFI and software raid0 on GPT SDDs

I usually work on a Mac and would like to setup a Linux workstation for Development. I have no experience installing Linux, because the servers I work with are hosted VMs. Most of the Ubuntu specific ...
1
vote
1answer
31 views

Partitioning Unallocated LVM Space as New Physical Partition with Hardware RAID

I'm a newbie to linux and partitioning and apologies in advance if this has been answered before; I've searched extensively on the web for answer, and after being unsuccessful I decided to post a ...
1
vote
0answers
67 views

Unable to install ubuntu alongside windows 8.1 with raid0: no partitions detected

I tried installing Ubuntu 14.04 alongside windows 8.1 on my machine using an Ununtu USB drive in UEFI mode, but no luck: My machine is Asus UX301, preinstalled with Windows 8, upgraded to 8.1. Got ...
0
votes
0answers
14 views

Shouldn't have left SATA port empty when creating RAID?

I recently added an md RAID5 to one of my computers. The boot & root filesystems were on the motherboard's SATA port 1, which became /dev/sda. I left port 2 empty for future use (oops?!) and ...
0
votes
1answer
13 views

Hide partitions on RAID0 in GRUB2

I'm trying to hide two Windows versions from each other. I know how to do this on a single drive, however, it seems to be somewhat more difficult on a RAID0. More precisely, I don't know how to ...
1
vote
0answers
56 views

Ubuntu Server 14.04 TLS plus Hardware RAID

I have just completed hadrware installation of my new RAID server which will run with Ubuntu Server OS. I have installed Ubuntu Server OS and everything run seemingly without problems. However, I ...
1
vote
1answer
70 views

Will the boot-degraded flag remain after upgrading to 14.04?

I am currently running Ubuntu 12.04 and have a RAID setup with the boot-degraded option. If I upgrade to 14.04 will the boot-degraded option remain? I manage this server remotely and would hate to ...
1
vote
0answers
30 views

Getting '??? ???' when trying to install Ubuntu

I am trying to install Ubuntu on my older laptop and whenever I get to the format your hard drive part it pops up with the message ??? ???. I am pretty sure it is to do with how my partitions were set ...
5
votes
2answers
7k views

Should swap and RAID-1 mix?

I have a box with a small RAID-1 array being used for swap space. I only did this since I was setting up mirrors for every other partition in the system. Today I read this question and it prompted ...
0
votes
0answers
45 views

UBUNTU Server Installer Does not Recognize the Hard Drives On A RAID-Based Server

My Usual Workflow: Usually I get/build a server, add the hard drives into it, then I install UBUNTU-Server through a bootable USB. Current Problem: I do have a set of servers, that have RAID ...
0
votes
2answers
5k views

How to install software raid 0 on ubuntu 12.04 server with mdadm?

I need to install a software raid-0 array on a Ubuntu 12.04 server with mdadm through commandline (SSH). The drive setup is as follows: SDA = OS SSD SDB = HDD for raid 0 SDC = HDD for raid ...
0
votes
0answers
30 views

Boot failure - /dev/mapper does not exist

I had a previously bootable version of Ubuntu, however now when I try to boot I see the error message ALERT! /dev/mapper/isw_bdacadajjgh_ARRAY0p5 does not exist. Dropping to a shell This is a work ...
0
votes
0answers
13 views

Unable to mount the FreeAgent GoFlex device

$ mount /root/Desktop/image.dd /root/mnt/recover -t ntfs Failed to read last sector (625137344): Invalid argument HINTS: Either the volume is a RAID/LDM but it wasn't setup yet, or it was not setup ...
2
votes
3answers
8k views

How to install Ubuntu Desktop 13.04 with mirror RAID?

I've now spent hours trying and failing to figure out how to install Ubuntu Desktop 13.04 on my new desktop while setting up RAID as part of the installation. I tried following the following two ...
2
votes
1answer
30 views

mount ssd disk on new acquired server

I have just acquired a new 3x 120Go SSD server (within soyoustart Soft Raid), but I can only see/use one SSD disk! Should I mount the other 2 disks ? What should be the new content of fstab file ? ...
0
votes
0answers
31 views

Crashed Ubuntu 12.04 Server -> Need Help Recovering & Transitioning To New Server

I have been running an Ubuntu 12.04 server with a single 2 TB hard drive in a somewhat-older small form-factor (SFF) PC for a while now. I had a headless CrashPlan client installed on it to back up ...
1
vote
0answers
47 views

Ubuntu 14.10 does trim SSD RAID 0 discs?

I've got Ubuntu 14.10 in a RAID 0 set up with 2 x Samsung Evo 840 SSD 256Mb, for performance reasons while acessing/modificating very large files. I've also got a schedule backup to another HDD for ...
0
votes
0answers
50 views

Can't run commands on server, Ubuntu 14.04

I'm pretty new at this, so it's likely that the problem is user error... Basically, I can SSH into the server and navigate around, but when I try to: sudo apt-get update I get a message: ...