RAID stands for redundant array of independent disks, and allows for disks to be linked in various ways. Common RAID setups in Ubuntu are a hardware RAID, FakeRAID and software RAID.

learn more… | top users | synonyms

0
votes
0answers
68 views

Booting Ubuntu 14.10 alongside Windows 8 stops working on installation of nvidia drivers

So I've built my own PC, and I'm trying to install Windows 8.1 and Ubuntu 14.10 alongside each other onto a 3 disk RAID5 array. The PC also has a fairly beefy video card (a Gigabyte Nvidia GeForce ...
0
votes
1answer
27 views

Ubuntu 14.04 Installation on acer altos G520

I got an old server and I'm trying to install Ubuntu from USB. Everything is fine till I selected Ubuntu Live or Ubuntu installation. The Display starts to switch between differnt resulution modes. ...
1
vote
1answer
45 views

mhddfs not working as expected

when I run df -h I get: Filesystem Size Used Avail Use% Mounted on /dev/sda2 74G 3.0G 67G 5% / none 4.0K 0 4.0K ...
0
votes
0answers
55 views

Server 14.04: fdisk sees disks, but GUI doesn't

I've got six drives that I'm looking to set up in a RAID10 configuration. 2x 2TB, 2x 1TB, 2x 500GB. The motherboard in this server (pretty old) supports hardware RAID10, but only with 4 disks, so I ...
1
vote
0answers
40 views

How do I use the RAID array in 12.04 LTS

extreme tenderfoot here. Have installed 12.04 LTS on SSD 64 Gb have 4x80 Gb HDD's. Would like to boot from SSD and use the RAID for well large files, low to moderate games, and occasional ...
1
vote
0answers
34 views

How to start RAID array?

a few months ago two volumes in my Synology DiskStation 412+ NAS crashed and until now I am still unable to recover the data but I am motivated and won't give up. I am able to see the hard drives ...
0
votes
0answers
99 views

Software RAID with FakeRAID already enabled Ubuntu 14.10

Somewhat new to the Linux world, so I apologize if this seems a bit foggy: I dumped a bunch of drives into an old case with the goal of making a Ubuntu NAS. I enabled the on-board RAID option on my ...
1
vote
1answer
277 views

Installing Linux with RAID 1 for first time ever

I want to install Ubuntu 14.10 Server 32 bit on a system, with specifications: Intel motherboard(DG965WH),Two SATA hard-drives and I want to install Linux Server for the fist time ever.without dual ...
0
votes
1answer
51 views

Grub halts on menu until enter is pressed

I have installed an Ubuntu server and it stops on the Grub Menu until ENTER is pressed without timing out and using the default entry. At first I thought that the problem was due to a reboot after a ...
0
votes
1answer
37 views

Ubuntu Server Raid 0 Install Question

I have installed Ubuntu -1410-utopic-64-minimal on my server. I have 2 3 TB HDDs. I installed in raid 0. This was my first time setti8ng up a raid. I don't know if I did it right. This is what shows ...
0
votes
1answer
30 views

why does mounting a volume on a building raid cause sync speed to drop?

I have an array with 4 disks in RAID 10 configuration : root@backup:~# mdadm --detail /dev/md127 /dev/md127: Version : 1.2 Creation Time : Mon Feb 23 16:01:29 2015 Raid Level : raid10 ...
0
votes
2answers
56 views

12TB storage, can someone help me? :)

I have thought about making a RAID 5 with 4 hard drives, 4TB each. There are files with few KB and other files with some GB. I want it to be as stable as possible. This will not be mounted as / or ...
0
votes
1answer
192 views

How should I encrypt Ubuntu Server 14.04 with AES on RAID 10 and RAID 5?

After researching I've come to the conclusion that my set up is just not standard enough to have a direct answer floating about on the interwebs. My Hardware: i7 950 CPU 24 GB DDR3 7 2TB 7200 RPM ...
1
vote
2answers
177 views

Upgrade 12.04->14.04 broke mdadm RAID10. Boot stops

Server was an Ubuntu 12.04 x64 and was running just fine. All four drives in server are SATA spin-drives. /dev/md0 - swap RAID10: sda1, sdb1, sdc1, sdd1 /dev/md1 - root RAID10: sda2, sdb2, sdc2, sdd2 ...
1
vote
3answers
80 views

Backing up or mirroring my existing hard drive

I'll try to keep it short - I have windows 7 and ubuntu 14.04 LTS installed. Windows has recently stopped working (involving all kinds of messages during start up that say that my hard drive is ...
0
votes
1answer
214 views

Raid Drive Won't Assemble

I had a server with Raid 5, and I wanted to wipe everything and do Raid 10. I deleted the raid 5 as best I could, zeroing superblocks, removing it from fstab, etc. And I created the raid 10. Now, I ...
0
votes
0answers
78 views

How to setup a RAID 1 array in 14.10?

I need to know how to set up my 2 1TB WD Red hard drives in a RAID 1 array. I've tried following a tutorial on this, but it was a very old tutorial. Please help me with a detailed response.
0
votes
0answers
150 views

Adaptec 8805 kernel panic on Ubuntu 14.04.1 64bit

I use QUADStor with Adaptec 8805 and constantly falls into a kernel panic by reason of AAC (adaptec) Current driver version: 1.2-0 (30200) Clean installed system with quadstor ... same errors ...
1
vote
1answer
31 views

Files take up more space on new RAID array

I just upgraded and reinstalled my home server. One thing I did was going from software raid to a raid card. After doing this and starting to copy back my backups, I've noticed that my first ~1TB ...
0
votes
0answers
64 views

How do I only install ubuntu 12.04 in hp z400 workstation?

I am trying to install ubuntu 12.04 in hp z400 workstation which has windows installed before. When I tried to install ubuntu, I got this error: “Unable to install GRUB in /dev/sda”. When I chose ...
0
votes
0answers
79 views

failed/degraded raid5 array recovery

First, thank you for your time and effort with helping to recover this raid array. I have a personal raid 5 array that is in rough shape. The failed array has eight 2 TB drives that were built up ...
0
votes
1answer
236 views

Ubuntu 14.04 Desktop on RAID-5 with LVM, GRUB failed to install

I want to configure a home media center and file storage, to keep the data safe I want to use RAID-5 (I have 4 HDs) and LVM for future scaling. I've configured RAID-5 and LVM, but GRUB installation ...
0
votes
1answer
86 views

Installing Ubuntu on RAID with LVM, failed to boot

I've installed Ubuntu on RAID-5 with LVM and made a /boot partition but it failed to boot. Can anyone help or point to a resource describing the process? Update: I decided to re-install the OS. This ...
0
votes
0answers
177 views

How to install Ubuntu Server 14.10 on an existing IMSM container (mdadm) of a machine that does not support the EFI specification?

How can I install Unbuntu server (14.04LTS or 14.10) on an existing IMSM container (using Intel's RST technology) on a machine that does not support the EFI specification? This is actually a business ...
0
votes
0answers
18 views

Ubuntu Ver 14.04

New to Ubuntu, we have a NAS drive that has a burned out board, inside the NAS are 2 x 2TB Drives with a RAID 1 COnfig. I have been told to use Ubuntu to access the data on one of the Raid Drives, I ...
0
votes
0answers
182 views

Dell Optiplex 780 stops booting at hardware RAID screen

I installed Ubuntu server on a Dell Optiplex 780. I have two 500GB WD blues in a hardware RAID1 on the machine. Any time I try to boot to the RAID, though, it hangs. There is a chart that has the RAID ...
2
votes
1answer
36 views

Mounting Drives, Replacing with an Array

So I currently have a boot drive, and a 500gb Drive, and a 2TB Drive. I have just aquired a HP ProLiant Microserver, and I will be aquiring 4x2TB Drives in around a month, which I will put in Raid 5. ...
0
votes
1answer
146 views

Problems with iSCSI timing out on write operations

I am running on 14.04.1 with iscsid version 2.0-873 I have an Enhance Ultrastor E3160 that is formatted raid5 on the backend and formatted as EXT4 on my system. I can see the device, attach it, ...
1
vote
1answer
321 views

Fakeraid in Ubuntu 14.04 wont auto assemble on boot

I'm trying to setup a 4TB raid 1 using fakeraid (intel matrix storage manager) as secondary storage. I'm able to assemble the raid manually using mdadm with the following commands: sudo mdadm ...
1
vote
1answer
52 views

Can't reboot after installing 10.04LTS

I am trying to upgrade from 8.04LTS to 10.04LTS and onwards to 14.04. I first tried to download 10.04 via the Internet but the install crapped out half way through. I have now tried three times to ...
0
votes
1answer
82 views

Going from a single 3TB disk to a 4-disk 6TB RAID10

I have a 3TB standalone disk (EXT4 in a 4-bay eSATA box) that I would like to integrate into a RAID10 array by adding 3 more 3TB disks. I'm hoping to do this nondestructively, as it would take ...
0
votes
0answers
88 views

New SSD causing segfault on boot (14.04 LTS)

I have an Ubuntu 14.04 LTS 32 bit system configured as follows: 2 x 3Tb drives, in a RAID 1 array, mounted as /home 2 x 1 Tb drives, partitioned as: a /boot partition (/boot2 on the other drive) a ...
0
votes
0answers
53 views

Ubuntu 12.04 failed to boot in recovery mode with Degraded RAID1

I have Ubuntu 12.04 LTS installed in RAID1. Suddenly the system failed to boot (using Ubuntu with linux 3.2.0-45-generic Pae) with an error message There appears to be one or more degraded RAID ...
3
votes
2answers
142 views

sudo does not change sysfs parameters [duplicate]

I can not run following command with sudo to change a sysfs paramete: $ sudo echo 300 > /sys/block/md0/md/stripe_cache_size bash: /sys/block/md0/md/stripe_cache_size: Permission denied However, ...
1
vote
0answers
182 views

Boot message conflicting device mode

HI I'm running ubuntu server 14.1. There is a nvidia fakeraid array active. The raid is working, however on boot I see these messages (1 of 3 messages): Systemd-udevd[599]: conflicting device node ...
0
votes
0answers
20 views

Do I need to set SATA mode to RAID in BIOS if I use software RAID? [duplicate]

I just had a problem with my RAID array and I had to rebuild it. Everything seem to be fine now. I am also having problems with the shutdown command (does not power off the server) and I reloaded the ...
2
votes
2answers
36 views

“Unable to reduce RAID LV - operation not implemented”

I've created a logical volume using Ubuntu 14.04 that started off at 80GiB. I resized it to 128GiB, but now I'd like to reduce back to 80GiB. There's an ext4 file system filling the volume. My command ...
0
votes
0answers
24 views

Recover files from one drive from a raid1 array

A couple years ago I created a raid 1 array using two 1TB drives in a computer running Ubuntu 12.04. These drives stored my files (pictures, videos and music) and acted as a server for other computers ...
0
votes
0answers
51 views

How can I find the exact model of a hard disk in a raid?

I have a ProLiant DL380p Gen8 with 4 Plextor solid state drives RAIDed. Since one of these disks has failed (as I see in HP iLO4 of my server) I need to find the exact model of these disks to replace ...
0
votes
1answer
66 views

How to check file-level write performance?

In a very similar question, the accepted answer suggests to do: dd if=/dev/zero of=/tmp/output bs=8k count=10k; to measure the write speed of a hard disk. My tests were inconclusive. I have an ...
0
votes
0answers
30 views

Problem with installation trying to find strange disk

When I use synaptic to install anything (in this case k4dirstat) I always get cascading errors. They start at: run-parts: executing /etc/kernel/postinst.d/zz-runlilo 3.11.0-19-generic ...
1
vote
0answers
1k views

/dev/disk/by-uuid/XXXXX does not exist dropping to a shell

I have just installed ubuntu 14.04 and when I reboot and remove the media I get the Gave up waiting for root device. Common problems: -Boot args (cat /proc/cmdline) -check rootdelay= (did the ...
0
votes
0answers
24 views

Do I likely have a bad WD Red HDD? [duplicate]

upon install of a new WD Red HDD in my server I reboot and get the Ubuntu 14.04 loading screen of An error occurred while mounting /home. Brief description: Btrfs Raid 1 filesystem 4 existing disks ...
0
votes
0answers
147 views

Optiplex 740 E - Unbuntu 14.10 - raid install problems

I am trying to install ubuntu 14.10 onto dual 160gb drives setup in raid by the motherboard of my optiplex. I get through the install, but when after I get the a-ok that the install went well and then ...
0
votes
1answer
127 views

Dual-booting Ubuntu on Raid system with UEFI Windows 10

Details of Raid: Type: Hardware RAID 0 (Stripe) Member Hard Drives: 1) SSD 70GB 2) HDD 160GB 3) HDD 250GB Size: 180GB I see.... However I made this specific setup because as you can see I had ...
0
votes
0answers
51 views

Re-install 14.04 and keep raid and lvm setup and data

I upgraded my 10.04 server to 12.04 and then immediately to 14.04. I had installed gnome in part to get graphic support for Boinc. 14.04 does not support my Nvidia Quadro NVS 285 video adapter, or ...
0
votes
1answer
36 views

Restoring Windows [duplicate]

I have been trying to get Ubuntu to work on my laptop for the last few days. I have been extremely unsuccessful in doing so. All I want to do at this point is to get Windows back. I have an exact ...
0
votes
1answer
177 views

I am unable to mount my previous btrfs RAID 1 home directory on reinstall of Ubuntu server 14.04 (was using 14.10)

Update 2 I mounted as degraded to /home and something interesting happened: jake@DAVYJONES:~$ sudo mount -o degraded /dev/sdb1 /home jake@DAVYJONES:~$ sudo btrfs fi show Label: Home uuid: ...
0
votes
0answers
72 views

MDADM: 3-drive RAID5 won't assemble (event count off by 2)

I just upgraded from 12.04 LTS to 14.04 LTS and when i tried to fire up my RAID it will not assemble... even using --force won't help, which is odd because yes the event counts are off but only by ...
0
votes
1answer
43 views

Installation on 3 HD setup: mdadm is missing

I have an SSD (sda) and 2 HDs (sdb,sdc). My target is to install Ubuntu on the SSD and setup a RAID0 over the 2 HD. I manually installed mdadm and created the md0 device and created also the ...