RAID stands for redundant array of independent disks, and allows for disks to be linked in various ways. Common RAID setups in Ubuntu are a hardware RAID, FakeRAID and software RAID.

learn more… | top users | synonyms

0
votes
1answer
8 views

RAID in Ubuntu 14.04.1

I'v been red about how to create RAID partitions during installations but it seems to need "alternative installation CD". Unfortunately, there is no download link for alternative ubuntu 14.04. Why? Is ...
0
votes
1answer
18 views

How to report a bug to the installer?

I'm trying to install Ubuntu server on an old Mac workstation with EFI firmware, and I'm trying to use software raid for the root partition. The installation aborts during package installation(maybe ...
0
votes
0answers
7 views

mdadm reports "

I'm running a software raid1 array with two 32GB USB 3.0 sticks holding my 14.04 LTS server. Querying the array returns the following: root@microserver:/home/leuser# cat /proc/mdstat Personalities : ...
0
votes
1answer
9 views

File recovery data copy

This is my first time using Ubuntu, and I'm using it to recover data from the drives of my dead READYNAS. The commands used to access/mount the RAID were obtained from here: ...
0
votes
1answer
21 views

raid10: can't read superblock

Up until a few minutes ago I had a functioning raid 10 device (/dev/md0) consisting of 4 x 3TB disks. My operating system (headless ubuntu server 14.04.1 lts) is mounted on a 120GB SSD seperate from ...
1
vote
2answers
34 views

Ubuntu OS on SSD and RAID-5 for data files

I want my NAS to run a lot like Freenas or Nas4free in that I have a separate drive for my OS and all other files (like WWW, media, plex media server and minecraft) run off the raid-5 (3*3tb WD reds). ...
0
votes
1answer
55 views

Installing Ubuntu 14.04.1 LTS with hardware RAID

I have been having some issues with trying to install Ubuntu off of a live usb. The system has a Intel hardware RAID controller and I wish to run my two HDDs in RAID 1. I have come across and issue ...
0
votes
0answers
23 views

Cannot mount 2 windows merged ntfs volumes in ubuntu 14.04

when my brand new Ubuntu is trying to mount my two hard drives that was merged in windows 7 I get this message: Error mounting /dev/sdc1 at /media/luttikon/Media 1: Command-line `mount -t "ntfs" -o ...
0
votes
0answers
8 views

Questions About Raid 1 Configuration

I am considering setting up a RAID 1 configuration. My intention is to secure my data by having it on two hard drives. I have a couple questions. 1. What if one hard drive fails? Will Ubuntu ...
0
votes
2answers
62 views

grub fails to install to MBR (RAID+LVM+LUKS)

Please note the edit at the end I'm building a home server (my first attempt at it) using Ubuntu Server 14.04.1 on an old machine (BIOS doesn't support UEFI), and I want to set up the whole system on ...
1
vote
1answer
19 views

Guidance on moving a raided / to a new set of disks

Running Ubuntu 14.04.1 up to date. Besides a ZFS pool I'm using for my data, I have my root partition on a mirrored software raid, and would like to move to two larger disks. Here is my parted ...
0
votes
0answers
76 views

Failed Dual Boot: Windows 8.1 & Ubuntu 14 - No operating system found

Please help, my situation is as below: I decided to give a try to dual boot windows 8.1 (Preinstalled with VAIO S on RAID0 (Intel RST)) and Ubuntu 14. However, all my boot entry on efi boot (left ...
0
votes
2answers
18 views

Is there anyway to undo wipefs?

So I (very stupidly) performed a wipefs on my XFS formatted 4tb Linux (software) raid 5 array in trying to convert over to a bcache setup (I was following some instructions online and should have paid ...
0
votes
0answers
32 views

Xen 4.4 on Ubuntu 14.04 dom0 “Gave up waiting for root device”

I've failed to get any response from users on the Linux Mint forums, however, Mint being an Ubuntu egg, I thought I'd try here. I attempted to install Xen hypervisor 4.4 on a clean install of Linux ...
0
votes
0answers
28 views

ubuntu 12.4 server is stuck on blank screen after grub [duplicate]

server 12.4 64 bit installed with raid and lvm ubuntu 12.4 server is stuck on blank screen after grub. and in grub recovery server given below error system wait for the right device ? missing ...
1
vote
0answers
25 views

update-grub fails on lvm cryptoroot

Disclaimer: I'm running this server now but I did NOT install it. I have two disks connected to an Intel Hardware Raid Controller running in RAID1. On top of it there is a fully encrypted 12.04 ...
0
votes
1answer
25 views

Can I mount two USB3 'flash' thumb-drives in a RAID configuration?

I am asking before I buy... I am getting a new Chromebook to run Ubuntu on. For storage I would like to use the two USB ports with a thumb-drive in each (I don't plan on using any other USB doodads). ...
0
votes
1answer
63 views

GRUB Bootloader not loading with Software RAID1 on Fresh 14.04 Server Install

I've looked at all of the forums, and tried doing multiple fresh installs and continue getting the error "Unable to install GRUB in /dev/mdx - This is a fatal error" My current setup is 2 2T drives, ...
0
votes
0answers
31 views

Mirror my LVM data disks - Ubuntu 14.04 Server

First of all, this is my first post, and I am very new to Ubuntu and everything Linux. My problem is this: I recently installed Ubuntu server 14.04 on my home server's 1TB drive. I also have 2x 2TB ...
0
votes
1answer
32 views

save failed software RAID array

I have a machine where the sata card failed and caused me to lose my raid array. I tested the drives externally and they are in good shape. I have moved the drives to a new machine (with enough ...
0
votes
0answers
17 views

Raid 0 with usb?

Is there a way to use two or three external hard drives to set up a Raid 0? Are Pci cards for this purpose available/dependable?
0
votes
1answer
30 views

How can I recover my RAID 5 array after removing 3 or 4 of 7 disks?

I'd like to undo what I've mistakenly done. From Disks I removed 4 of 7, 2 TB disks from the software RAID 5 array. I am unable to bootup and come to this: error: disk 'mduuid/long UUID number' ...
0
votes
0answers
101 views

Having trouble mounting a 12TB Raid on Ubuntu Server

I am running a Ubuntu server on my off of my 2008 MacPro, it runs great and works really well except I am not able to run any raid setups directly on it. I have a large library that needs to be ...
2
votes
2answers
57 views

Can I write data safely to a RAID-1 ARRAY while it is resyncing?

Will the files be in all drives on the array when the sync is complete? What if a disk fails while sync is in progress?
1
vote
1answer
59 views

Will a fresh installation of Ubuntu recognize two drives that have been in a RAID?

I have a computer with three hard drives - one is the boot drive and the other two are in RAID1. The RAID is software RAID created during the Ubuntu installation. If I reformat and reinstall Ubuntu on ...
3
votes
3answers
49 views

Serious RAID problem that panics system

System: Dual Xeon E5-2630 CPU, 32GB RAM, Primary disk is a SATA-III 512GB Crucial SSD OS: Xubuntu 14.04.1 I am having a serious problem with RAID on this new system and hope some of you can provide ...
1
vote
1answer
28 views

How to setup device mapper RAID on LVM on Ubuntu 12.04

I have read that LVM can be setup as raid without using mdadm. I have setup LVM with two physical HDD and would like to set up RAID1 but I can't find any guidance. Is there any documentation on how ...
0
votes
1answer
71 views

Breaking boot-up Raid 1 array into two independent drives

I am running Ubuntu 14.10 which boots from two identical drives configured as a Raid 1. I would like to break up the array so to keep the existing data on one drive and use the second drive to ...
1
vote
0answers
106 views

How to add software RAID-1 to an existing non-RAID system?

I couldn't find any tutorials for converting a non-RAID system (Ubuntu 14.04 in my case) into a disk-level RAID-1 system after installing a second disk (/dev/sdb) Is the following correct? sgdisk ...
0
votes
0answers
66 views

can not boot: mountall main process terminated with status 2

i installed ubuntu 14.10 server and somehow it does not want to boot anymore: mountall main process terminated with status 2 my software RAID5 /dev/md1 should be mounted to /. I can mount it RW in ...
0
votes
0answers
8 views

Degraded RAID, which isn't

Here's my issue. I rebuilded my RAID-1 Array a while ago, but after I do a reboot, it always gets degraded, saying that one of my drives aren't attached. I also noticed that if I stop and then start ...
1
vote
0answers
40 views

Unable to access a Drive

I am new to this platform so I don't Know much about Ubuntu, Now I have installed the latest Ubuntu version that is Ubuntu 14.04.1 LTS (64 bit), I already have windows 8 installed in my PC and I have ...
0
votes
0answers
38 views

Unable to uninstall/install apps do to mdadm

So I upgraded from 12.04 to 14.04 and I had a software raid 5 running. Since the upgrade my raid array seems fine? I can still access it and put files on it etc but when I run any apt-get install or ...
0
votes
0answers
49 views

Dual Boot Windows 8.1/Ubuntu on RAID/Single drive system

I have a PC over an AMD platform with the following configuration: AMD Athlon II X4 630, ASRock 990FX Extreme4, 8GB RAM, GeForce 8800GS, 2x500GB Hard disks on RAID0 configuration (1TB) with Windows ...
1
vote
1answer
56 views

RAID - Ubuntu vs. Gentoo [closed]

I'm migrating a PC working as file server from Gentoo to Ubuntu. Gentoo doesn't recognize the RAID by BIOS because apparently Gentoo connects with each and every individual hard drive directly. ...
0
votes
1answer
72 views

mount an mdadm raid 1 drive at book

I was wondering if you guys could help. I am looking to mount my mdadm RAID 1 at boot. The drive location is /dev/md127 and I would like it to mount to /media/server at boot. It is formatted to ...
1
vote
0answers
109 views

LUKS on software RAID not mounting on boot

I am trying to setup an encrypted disk using LUKS on a software RAID that was setup using mdadm on 14.04.1 LTS (GNU/Linux 3.8.13.26 armv7l) (Odroid U3). The problem is that the LUKS container is not ...
0
votes
0answers
18 views

Mdadm:insufficient head-space for reshape on /dev/sdb1

I want to grow the space of RAID10, I have already added two discs to the RAID array, but when I do: sudo mdadm --grow /dev/md0 --raid-devices=6 It gives this message : Mdadm:insufficient ...
0
votes
1answer
36 views

install ubuntu12.04 on dell r710 raid 5

I have created a virtual disk 0 with raid 5 on Dell r710. This virtual disk 0 consists of 6 physical disks. Each disk comes with 1TB disk space. I used the bootable CD that I created to try to ...
0
votes
0answers
15 views

Unbuntu RAID 1 lost (md0)

I've had this setup for over a year and today I seem to have most md0 which was my data raid.. My OS raid is still working... From dmesg (both ata3.00 and ata4.00 are reporting the same [ ...
0
votes
0answers
72 views

Problems with RAID1 after 14.04.1 update, related to bad geometry: block count

I did some research but I can't quite point out how to resolve my problem. So I need to askubuntu. I setup my RAID some time ago, so I don't remember all the details, all I know is that is RAID1 and ...
1
vote
1answer
191 views

Recover data from RAID1 array (My Book Live Duo)

I have a WD My Book Live Duo device which I used as a network drive with a RAID1 configuration. The device, which was working flawlessly for almost 2 years suddenly stopped working, that is; it was ...
0
votes
1answer
23 views

2nd and 3rd disks mirrored for backup on Ubuntu Desktop

I wish to set up a small home server providing NAS and Web server functionality to my home network. I'd like to be able to store family pictures and other things I'd want backed up. So I had ...
0
votes
1answer
53 views

mdadm doesn't seem right

I watched a youtube video where a guy made a raid 1 with 2x 2 gb usb drives. I am using 2 x 3tb disks to have a raid 1 mirror. My concern is my sdb1 size=-1364702208K sdd1 size=-1364702208K. which is ...
0
votes
0answers
33 views

on fakeraid, could not mount / at boot, then boots to purple screen

I'm running Ubuntu 14.04 beside Windows 8 on an Asus UX51VZ-XB71 which comes with two SSDs configured in a fake raid-0. I can install 14.04 successfully by booting into the live usb, assembling my ...
0
votes
1answer
128 views

Install Adaptec RAID 6405 on Ubuntu 12.04 (3.13.0-37-generic)

I'm trying to install an Adaptec RAID controller on Ubuntu 12.04. So far, I've downloaded different versions of the driver, but executing the specified commands yields some errors. sudo dpkg -i ...
0
votes
0answers
62 views

unable to install ubuntu on sata hard disk

I would like to install lubuntu in my old pc. I have a pci sata/raid from Syba sa3114 which connect 3 sata hard disk 1TB When I install and create the partition, I recive the following message: The ...
0
votes
0answers
191 views

mhddfs constantly disconnecting (“Transport endpoint is not connected”)

I'm using mhddfs in conjunction with SnapRAID and it has started disconnecting the fuse drive at least once a day. I know I can unmount/remount for a quick fix, but I'm implementing this in a media ...
0
votes
0answers
24 views

Mainboard RAID or something else?

I am trying to install Ubuntu Server on my new machine. I configured RAID through the BIOS prior to installing the OS. I set it up for RAID-1. When I go through the install process the installer ...
0
votes
1answer
23 views

users and shares on external partition

I have tried my upmost to get this working and have lost the will to live but am not going to give up! Basically, I have 1 SSD which I have just installed Ubuntu 14.4.01 on fresh and I have created a ...