Qt is an application framework originally created by Trolltech and currently managed by Digia. The KDE desktop uses the Qt framework for its applications.

learn more… | top users | synonyms

53
votes
1answer
37k views

Should I use PyQt or PySide for a new Qt project?

Recently I've been involved in conversations about creating a Quickly template for a Qt and QtQuick Ubuntu app. The idea is to make it as easy to develop Qt apps from concept to package as it is right ...
40
votes
4answers
56k views

How do I install and switch to the Unity 2D desktop?

I read that there is now a 2D version of Unity built on Qt. How do I install it, and once it's installed, how do I switch to it?
33
votes
3answers
85k views

How can I install Qt 5.x on 12.04 LTS?

If you want to develop with QML 2.0 and Qt5, the base packages don't seem to exist in repository for 12.04. What PPA should I add? Is it a binary installer? a compile the toolkit yourself? Those ...
29
votes
4answers
19k views

Why is Canonical choosing QT over GTK for Unity's next generation?

So much has been written that I'm kind of confused, but if I'm not mistaken Canonical is building the next generation of Unity for mobile devices with Qt, and in the near future the desktop will also ...
26
votes
3answers
34k views

What's the development package for Qt5 in 14.04

I want to build a Qt5 example on my desktop machine. I installed qt5-default and qtdeclarative5-dev, but I'm still getting this error: Project ERROR: Unknown module(s) in QT: quick qml Which ...
26
votes
4answers
11k views

What's the difference between GTK and QT?

Please bear with me as I'm a newcomer to Linux. I've been writing GUI programs in REALbasic on a Mac for several years. I'm trying to learn Python and I want to write GUI apps for Linux (primarily ...
25
votes
4answers
61k views

How to use Qt Creator with Python?

I want to use Qt for developing Ubuntu desktop, phone and tablet applications but I don't want to learn a new programming language (C++, JavaScript). Is it possible to write Qt application in Python ...
24
votes
2answers
23k views

What is KDE, GTK, GTK+, QT, and/or GNOME?

I'm new to Ubuntu (and Linux in general). Sometimes when looking at programs in the Ubuntu Software Center, I see things about the programs being 'for the GTK+ environment', or 'for GNOME', or a ...
17
votes
3answers
6k views

Differences between Qt and GTK programs?

Refering to this question, there are two different versions of the Autokey program: Autokey (Qt-based) and Autokey-GTK. What are the differences between a Qt-based program and the GTK one and are ...
16
votes
1answer
501 views

How to change index in OptionSelector immediately (without animation)?

In my app, I use an OptionSelector to choose from a list of bike stations. I also have a map component with placemarkers for each station. When I tap a placemarker, it also changes the OptionSelector ...
15
votes
5answers
14k views

How to change the binding of Windows key which runs Unity's Dash?

Currently, I am using the Unity Qt panel in my Gnome desktop, and when I press the Windows key, the Unity's dash launches, and I can't use any compiz based shortcuts. Same behaviour is exhibited ...
15
votes
4answers
7k views

How can I theme my Qt app to resemble one written in Gtk?

Mark Shuttleworth recently blogged about the decision to include the Qt libraries in the 11.10 release, with a followup from Jono Bacon. The thing that puts me off Qt apps is that they don't blend in ...
15
votes
1answer
70k views

How to install Qt4 in Ubuntu 12.10

I tried to use Qt5 but I have some problems while making Debian packaging process with Qt5 so I would like to have Qt4 on Ubuntu 12.10. How can I install Qt4.
14
votes
5answers
11k views

make qt programs look good under XFCE?

I use xfce. My problem is - some programs look nice and some sort of ugly. AFAIK this is because XFCE is gtk and most programs use gtk theme, but some programs use qt and thus don't use gtk themes (...
13
votes
3answers
15k views

Cannot mix incompatible Qt library

I found a lot of problems similar to mine on the web, but still no real solution. I'm having the annoying Cannot mix incompatible Qt library (version 0x40806) with this library (version 0x40802) ...
13
votes
2answers
998 views

What are the conceptual and technical differences between “Apps” and packages?

I'm a bit confused by the recent announcement (http://developer.ubuntu.com/2011/09/announcing-the-ubuntu-app-developer-site/) of the new "App" developer site. I've fallen out of Ubuntu development and ...
13
votes
4answers
9k views

Receiving error while trying to debug in QtProject

I installed the latest version of the QtProject so now I can debug C++ code. While trying to debug for the first time I got this error: ptrace: Operation not permitted. Could not attach to the ...
12
votes
1answer
5k views

Make a Debian Package (.deb) from a Qt Project

I did several projects on Qt Creator and I would like to distribute them in an installable format (in this case, Debian Packages). More info about my Qt installation (and my system): Qt version 4.8....
11
votes
3answers
3k views

Will the new Unity desktop be programmed in Qt?

Will the desktop version of Unity, scheduled to appear in 11.04, be programmed using Qt? I ask this in relation to Matt Zimmerman's blog posting of several days ago, where he intimated that Qt was ...
11
votes
2answers
1k views

Quickly template for PyQt?

Because I like Qt and Python, is there a Quickly template for PyQt similar to the PyGTK one?
11
votes
3answers
881 views

What are the accessibility problems of Qt?

Jonathan Ridell said in a blog post that there were accessibility problems with Qt. I would just like to know what those problems are. Thank you very much and keep up the excelent work. Ubuntu Rocks!
10
votes
7answers
15k views

GTK+ in Kubuntu apps look bad

I have installed Evolution email client on Kubuntu 11.10 and it's not so cute as expected. Eclipse also looks bad. I have the GTK+ Appearance plugin in KDE System Settings and already tried QTCurve ...
10
votes
2answers
18k views

What package do I need to build a Qt 5 & CMake application?

I'm trying to build sdrangelove, which wants Qt 5 and uses CMake for its build system, on Ubuntu 13.10. What package do I need to install to give it the file it's asking for here? There are a lot of *...
10
votes
1answer
1k views

How to create a new Quickly application template?

Cannot find the answer elsewhere, I'm asking for a documentation of the process to create a new template for quickly. I'm interested in writing a pyside (python + qt4) template like the pygtk one. ...
10
votes
4answers
955 views

What is the recommended widget toolkit for Ubuntu desktop?

As I understand it, Qt - C++ and QML - or HTML5 are recommended for writing Ubuntu for Phones applications. Also, correct me if I'm wrong, but Python is the preferred language for Ubuntu Desktop. ...
10
votes
2answers
2k views

How do I get QSystemTrayIcon to show up in Gnome 3?

I can get a QSystemTrayIcon to show up in Unity by installing the sni-qt package which acts as a broker between the application and an application indicator for the program. However, running the ...
10
votes
3answers
13k views

“QtQuick version 2.0 is not installed” while trying to run CurrencyConverter Example for Ubuntu Phone

I was following the step-by-step guide on how to develop an Ubuntu Phone application but Qt Creator throughs the error message (module "QtQuick" version 2.0 is not installed) when I run it with ...
10
votes
2answers
914 views

How to use gettext to make QML files translatable

I'd like to write a QtQuick app based on Python (PySide) and QML. I know Qt apps have got their own translation technology, but I would like to stick to gettext for this one. I'd like to know if it's ...
10
votes
1answer
533 views

Howto create a new C++ based Ubuntu touch project in Ubuntu SDK?

There is no option to start a C++ and QML based project in Ubuntu SDK. It only offers to create a QML project with no C++ codes. If I try to add C++ classes to the QML project, I get this error: ...
9
votes
1answer
821 views

What does the takeover of Nokia mean for the Ubuntu SDK?

Well, the title says it all: What does the takeover of Nokia by Microsoft mean for the Ubuntu SDK, as the Ubuntu SDK relies on Qt which is (was?) a Nokia project?
9
votes
1answer
14k views

How do I install Qt5, which comes as a .run file? [duplicate]

I downloaded http://qt-project.org/downloads Qt5 Libary for Linux 64bit The library format is .run But if I try to open it, I'll get the following error sh ./qt.run ./qt.run: 1: ./qt.run: cannot ...
9
votes
2answers
2k views

Unity Launcher API for C++

I am trying to develop some program in QT with QT SDK. Yesterday I was reading about Unity Launcher API on official ubuntu website. But there is example only for Vala and python. Is possible to use ...
9
votes
2answers
911 views

Make sniqt recognize all tray abilities (or create a working indicator in Qt)

There is this old thread of mine: How do I create a working indicator with Qt/C++? where I was suggested to use the QSystemTray library for making a tray icon in Ubuntu for my application. Sniqt is a ...
8
votes
2answers
18k views

Qt5 installation and path configuration

I have installed Qt5 from the Qt5 project site, to the following directory /opt/Qt5 I would also like to mention that I had Qt4 installed previously, I have removed all instances of Qt4 through ...
8
votes
1answer
952 views

Can I make ReText use a different font type for displaying code?

I'm using ReText 3.1.4 (Lubuntu 12.10) to make notes for myself. I want to know if it's possible to use a different font for displaying text that is marked as code in preview mode: In the image, ...
8
votes
1answer
2k views

Icon theme doesn't affect some Qt-applications [duplicate]

I changed the icon theme in Ubuntu 12.04, but it doesn't affect Qt-applications. They have the default theme. For KDE applications the icon theme can be changed with the systemsettings package. This, ...
8
votes
3answers
7k views

Making python 3.3 default python 3 interpreter instead of 3.2

So, to keep it simple. Ubuntu 12.10 has python 3.2 pre installed and it is linked to "python3". I downloaded python 3.3 and it's command is "python3.3". However, I downloaded pySide for python3 from ...
8
votes
2answers
5k views

How to add shortcut to unity launcher programmatically?

I'm developing a program in Qt that will help users to manage (create, edit and delete) their quicklists in Unity launcher. I got to a point where I created .desktop file and I don't know how to ...
8
votes
3answers
5k views

How to run Java application in KDE with Qt-like UI?

Continuing my question in Install Ubuntu or Kubuntu? I have tried Kubuntu (KDE), and it was very cool as cool as Ubuntu (GNOME). but there is little problem with its user interface when we start Java ...
8
votes
1answer
3k views

Installation of capybara-webkit ruby gem

I have following errors when I try to install capybara-webkit ruby gem Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /home/s/.rvm/rubies/ruby-1.8.7-p371/bin/...
8
votes
1answer
436 views

apt-get install <package> equivalent using C++ apt-pkg library

I am building a small QT (C++) application where I ask user the software he want to install. Once he selected some packages a, b, c from the list all I have to do is run sudo apt-get install a b c ...
8
votes
1answer
9k views

How to add Qt5 to Qt Creator?

I've added the Qt5 Daily repository, installed the qt5-meta-full and added /opt/qt5/bin/qmake to Qt Versions. Now I get :-1: error: Unknown module(s) in QT: declarative Is it possible yet to use ...
7
votes
2answers
630 views

What is the default icon set in Ubuntu 16.04?

I would like my Qt configuration to match the default Ubuntu 16.04 style. What is the default icon set from the below list of icon sets?
7
votes
2answers
10k views

Can I sell my PyQt4-app without having a PyQt license?

I would like to sell a Python application that uses PyQt4. The commercial licenses for Qt PyQt cost thousands of Euros together. Do I need to buy a commercial license? Consider this from a "packaged"...
7
votes
1answer
12k views

How to upgrade QT Creator?

I just installed QT Creator 2.4.1 (Based on QT 4.8.0 64bit) from Ubuntu Software Center and noticed that it was not the latest version. How do I upgrade it from terminal? My Ubuntu is 12.0.4LTS. ...
7
votes
2answers
4k views

How to pass the image preview from the QML Camera component to a C++ plugin

I'm writing an Ubuntu Touch QML app that captures and processes images from a camera device. The processing is done by a C++ plugin to which I'm passing the URL of the image. I can successfully save ...
7
votes
1answer
1k views

How will Qt 5.0 be packaged for Raring?

Note: as per the FAQ, "Issues with the next version of Ubuntu" may not be asked as questions here but in my opinion, this is not an issue but merely a question asking about policy. If you feel this ...
7
votes
1answer
3k views

Are Qt Quick Controls available on Ubuntu 13.10?

I was looking to do UI development in QML, and I really want it to look native. I found the QtQuick.Controls (http://qt-project.org/doc/qt-5.1/qtquickcontrols/qtquickcontrols-index.html), but when I ...
7
votes
1answer
1k views

Can't change keyboard layout in some Qt programs

The problem after a recent update in my Ubuntu 13.10 with Unity. When typing something in Qt Creator 3.0.1 or in my own program compiled with Qt 5.2.1 (from qt-project.org), I can't change keyboard ...
7
votes
1answer
15k views

how to install both qt5-qmake and qt4-qmake

There is no qt5-qmake on default LTS 12.04 repository so I am using ppa from ubuntu-sdk-team ppa:ubuntu-sdk-team/ppa However since this or previous month, it stopped working to me. Now when I try to ...