Qt is an application framework originally created by Trolltech and currently managed by Digia. The KDE desktop uses the Qt framework for its applications.

learn more… | top users | synonyms

40
votes
4answers
55k views

How do I install and switch to the Unity 2D desktop?

I read that there is now a 2D version of Unity built on Qt. How do I install it, and once it's installed, how do I switch to it?
10
votes
1answer
1k views

How to create a new Quickly application template?

Cannot find the answer elsewhere, I'm asking for a documentation of the process to create a new template for quickly. I'm interested in writing a pyside (python + qt4) template like the pygtk one. ...
9
votes
3answers
12k views

“QtQuick version 2.0 is not installed” while trying to run CurrencyConverter Example for Ubuntu Phone

I was following the step-by-step guide on how to develop an Ubuntu Phone application but Qt Creator throughs the error message (module "QtQuick" version 2.0 is not installed) when I run it with ...
29
votes
3answers
79k views

How can I install Qt 5.x on 12.04 LTS?

If you want to develop with QML 2.0 and Qt5, the base packages don't seem to exist in repository for 12.04. What PPA should I add? Is it a binary installer? a compile the toolkit yourself? Those ...
28
votes
4answers
18k views

Why is Canonical choosing QT over GTK for Unity's next generation?

So much has been written that I'm kind of confused, but if I'm not mistaken Canonical is building the next generation of Unity for mobile devices with Qt, and in the near future the desktop will also ...
20
votes
2answers
21k views

what is KDE, GTK, GTK+, QT, and/or GNOME?

I'm new to Ubuntu (and linux in general). Some times when looking at programs in the Ubuntu Software Center, I see things about the programs being 'for the GTK+ environment', or 'for GNOME', or a ...
11
votes
2answers
1k views

Quickly template for PyQt?

Because I like Qt and Python, is there a Quickly template for PyQt similar to the PyGTK one?
10
votes
7answers
14k views

GTK+ in Kubuntu apps look bad

I have installed Evolution email client on Kubuntu 11.10 and it's not so cute as expected. Eclipse also looks bad. I have the GTK+ Appearance plugin in KDE System Settings and already tried QTCurve ...
14
votes
3answers
6k views

How can I theme my Qt app to resemble one written in Gtk?

Mark Shuttleworth recently blogged about the decision to include the Qt libraries in the 11.10 release, with a followup from Jono Bacon. The thing that puts me off Qt apps is that they don't blend in ...
6
votes
1answer
506 views

How to insert Video element in my Ubuntu application?

I saw on some sites that you can insert videos with the Video element by importing Qt 4.7 and QtMultimediaKit 1.1 . But I have an error by compiling the project (it's a tabbed touch UI project): ...
5
votes
2answers
1k views

Google Earth and Skype theme

I use Google Earth and Skype since version Jaunty, and so far emulation Qt theme for GNOME runs perfectly, but when I use the default theme Ambiance and Radiance in Maverick, both applications look ...
13
votes
4answers
9k views

Receiving error while trying to debug in QtProject

I installed the latest version of the QtProject so now I can debug C++ code. While trying to debug for the first time I got this error: ptrace: Operation not permitted. Could not attach to the ...
15
votes
5answers
14k views

How to change the binding of Windows key which runs Unity's Dash?

Currently, I am using the Unity Qt panel in my Gnome desktop, and when I press the Windows key, the Unity's dash launches, and I can't use any compiz based shortcuts. Same behaviour is exhibited ...
25
votes
4answers
11k views

What's the difference between GTK and QT?

Please bear with me as I'm a newcomer to Linux. I've been writing GUI programs in REALbasic on a Mac for several years. I'm trying to learn Python and I want to write GUI apps for Linux (primarily ...
8
votes
1answer
2k views

Icon theme doesn't affect some Qt-applications [duplicate]

I changed the icon theme in Ubuntu 12.04, but it doesn't affect Qt-applications. They have the default theme. For KDE applications the icon theme can be changed with the systemsettings package. This, ...
4
votes
2answers
173 views

QT interfaces broken

I ran into a strange issue a couple of days ago and i have no idea what to do. Some of my programs interfaces seem to be broken recently. It is rather odd because i haven't done any major updates. It ...
4
votes
1answer
9k views

QGtkStyle was unable to detect the current GTK+ theme

When I start any Qt app, I get this message in the terminal, and the Qt app doesn't use the same theme as my Gtk apps: QGtkStyle was unable to detect the current GTK+ theme. How do I make QGtkStyle ...
1
vote
1answer
945 views

Ubuntu App Development. Unable to install Ubuntu SDK and buggy Ubuntu emulator

Hello I have installed Ubuntu 14.04.1 and I have no more patience to struggle with my problem. I can't install ubuntu-sdk package: Some packages could not be installed. This may mean that you have ...
7
votes
1answer
3k views

Are Qt Quick Controls available on Ubuntu 13.10?

I was looking to do UI development in QML, and I really want it to look native. I found the QtQuick.Controls (http://qt-project.org/doc/qt-5.1/qtquickcontrols/qtquickcontrols-index.html), but when I ...
6
votes
1answer
3k views

How to change QT (KDE) application icons for gnome?

I'm running gnome3 on Ubuntu 12.04 and my dolphin looks like this: I really don't like these oxygen themed icons and want to use the Faenza icons. I tried backing up the oxygen icons and ...
4
votes
1answer
2k views

Ubuntu Touch app with c++ core and QML interface. How to create?

How to create Ubuntu Touch application with c++ core? In examples I see only pure QML apps.
3
votes
2answers
497 views

Upgraded to Ubuntu 15.10 Wily and get QNativeImage: Unable to attach shared memory segment

I just upgraded to Ubuntu 15.10. I am still using the latest NVIDIA binary driver 352.41 from nvidia-352 w/ GT730 card. When I start spyder and spyder3, the display is garbled with window elements ...
3
votes
0answers
1k views

Qt Apps problems in Ubuntu 12.04 [closed]

I have a few Qt applications on my Ubuntu 12.04 Laptop, and not all of these seem to be running as desired. The applications in question are Tomahawk, Clementine, Rstudio and Speedcrunch. Not all ...
3
votes
3answers
9k views

How to setup Qt Creator to compile Windows executables?

The version of Qt Creator that ships in the repos. can compile Linux executables out of the box. However, it seems like some configuration is necessary to get it to compile Windows applications. I ...
2
votes
1answer
2k views

Font rendering problems with QT applications in Xubuntu

I'm currently using Xubuntu 14.04 but the same problem is present in 13.10 and 13.04, and maybe in previous versions. I always install truetype fonts and remove the anti-alias. In all the GTK ...
1
vote
1answer
98 views

How to make a project of Krusader

An example for my general question An introduction to translating and debugging source code : I had installed the 'Qt 4 Designer' and I have downloaded the krusader-2.4.0-beta3.tar.bz2 file. Among the ...
3
votes
1answer
306 views

Why does Software Center report qt4 as unmet dependency, when I already have qt5 installed?

I installed qtspim which requires qt4 to be installed. As I already have qt5 installed on my system, qtspim is working fine. However, Software Center reports dependency error. When I run apt-get ...
2
votes
2answers
4k views

Can't Set Environment Variables in ~/.profile

All, I need to set environment variables in my ~/.profile since I am running a program (QtCreator) that doesn't start a bash shell. I cannot for the life of me get it to work though. QtCreator will ...
2
votes
2answers
14k views

How to install qt 4.8 from repository?

How to install qt 4.8 and QtCreator from repository ?
1
vote
1answer
2k views

Installing Qt 5.5.1 on Ubuntu 14.04 - throws qt.network.ssl error on terminal

I am planning to install qt 5.5.1 on my ubuntu 14.04 running on virtual machine. I have downloaded the installer from qt-io and when I try to install the setup, I notice the below warning on my ...
0
votes
1answer
6k views

error while installling qt mobility tool kit

I am installing qt mobility tool kit but it shows an error message : 1.2.0/src/multimedia' make[2]: Warning: File Makefile' has modification time 1.1e+04 s in the future g++ -c -pipe -g ...
0
votes
2answers
615 views

How can I create an installation package?

I'm programming a Qt app in Ubuntu. Well, I'm newbie in Linux but good at Qt. I wanna know how to Create Qt Static Libraries(Qt has installed from Synaptic), Create an installation package and How to ...
53
votes
1answer
36k views

Should I use PyQt or PySide for a new Qt project?

Recently I've been involved in conversations about creating a Quickly template for a Qt and QtQuick Ubuntu app. The idea is to make it as easy to develop Qt apps from concept to package as it is right ...
17
votes
3answers
6k views

Differences between Qt and GTK programs?

Refering to this question, there are two different versions of the Autokey program: Autokey (Qt-based) and Autokey-GTK. What are the differences between a Qt-based program and the GTK one and are ...
7
votes
1answer
13k views

how to install both qt5-qmake and qt4-qmake

There is no qt5-qmake on default LTS 12.04 repository so I am using ppa from ubuntu-sdk-team ppa:ubuntu-sdk-team/ppa However since this or previous month, it stopped working to me. Now when I try to ...
22
votes
3answers
26k views

What's the development package for Qt5 in 14.04

I want to build a Qt5 example on my desktop machine. I installed qt5-default and qtdeclarative5-dev, but I'm still getting this error: Project ERROR: Unknown module(s) in QT: quick qml Which ...
1
vote
1answer
184 views

How to import Qt app into Quickly on 10.04?

How to import my Qt app into Quickly? The goal of this is to package my Qt app using Quickly.
0
votes
2answers
605 views

Autokey (autokey-qt) freezes and won't insert text

Per some suggestions on here and lifehacker, I began using autokey. It worked great for a week, but as of today it now hangs when I try to enter name new phrases. usually won't close when I push ...
13
votes
4answers
10k views

make qt programs look good under XFCE?

I use xfce. My problem is - some programs look nice and some sort of ugly. AFAIK this is because XFCE is gtk and most programs use gtk theme, but some programs use qt and thus don't use gtk themes ...
9
votes
2answers
903 views

Make sniqt recognize all tray abilities (or create a working indicator in Qt)

There is this old thread of mine: How do I create a working indicator with Qt/C++? where I was suggested to use the QSystemTray library for making a tray icon in Ubuntu for my application. Sniqt is a ...
7
votes
1answer
992 views

Can't change keyboard layout in some Qt programs

The problem after a recent update in my Ubuntu 13.10 with Unity. When typing something in Qt Creator 3.0.1 or in my own program compiled with Qt 5.2.1 (from qt-project.org), I can't change keyboard ...
6
votes
2answers
2k views

QtCreator plugins and templates missing

I just downloaded the Ubuntu phone SDK and QT creator according to the instructions. When I fire up QTCreator, I get a screen as shown If I ignore this message and hit continue, there are no ...
4
votes
2answers
536 views

How To Use i18n.tr in Ubuntu Touch Projects

I have been using i18n.tr for a while in my Ubuntu-Touch projects. I know what this function is about but I don't know how to add a translation to my project. Where do I have to place my translation ...
3
votes
2answers
3k views

Qt 5 configuration

I have a problem setting Qt5 apps correctly on my computer. I'm running Ubuntu 14.04 with KDE4, I have configured the look in the KDE system settings and that look is used in every qt4 apps and gtk ...
2
votes
1answer
267 views

I have installed QT4.8.7 but CMAKE codul not match the path

I got the error message CMake Error at /usr/local/share/cmake-3.4/Modules/FindPackageHandleStandardArgs.cmake:148 (message): Could NOT find Qt4 (missing: QT_QTOPENGL_INCLUDE_DIR ...
10
votes
2answers
16k views

What package do I need to build a Qt 5 & CMake application?

I'm trying to build sdrangelove, which wants Qt 5 and uses CMake for its build system, on Ubuntu 13.10. What package do I need to install to give it the file it's asking for here? There are a lot of ...
8
votes
3answers
5k views

How to run Java application in KDE with Qt-like UI?

Continuing my question in Install Ubuntu or Kubuntu? I have tried Kubuntu (KDE), and it was very cool as cool as Ubuntu (GNOME). but there is little problem with its user interface when we start Java ...
6
votes
1answer
1k views

What is the correct way to use g_signal_connect() in C++ for dynamic unity quicklists?

I want to make my application use dynamic unity quicklists. For building my application I am using C++ and the QtCreator IDE. When a menu action is triggered I want to be able to have access to a ...
5
votes
2answers
3k views

Why don't Qt4 apps in Lubuntu pick up the GTK theme? [duplicate]

I've installed Lubuntu and replaced the default players with Clementine for audio and VLC for video. The problem I have is that neither pick up the GTK theme, the way they usually do in Gnome/Xfce. ...
4
votes
1answer
494 views

Does Ubuntu Phone APIs include Qt Mobility?

I'm currently developping an application for Meego/Harmattan. This app uses Qt Mobility API, and can easily be ported to SailfishOS. I would like to know if this API is also supported in Ubuntu Phone ...