Qt is an application framework originally created by Trolltech and currently managed by Digia. The KDE desktop uses the Qt framework for its applications.

learn more… | top users | synonyms

0
votes
1answer
134 views

Trying to make my sixaxis ps3 controller work on my computer for minecraft

Ok so I followed the steps on here and on steps 8 and 9 I got this g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DDEVDIR=\"/dev/input\" -DICON24=\"/usr/local/share/pixmaps/qjoypad/icon24.png\" ...
0
votes
0answers
52 views

Qt C++ windowMinimized no reaction on Ubuntu

Heloo all! Me and a friend are creating an app for linux, everyting works but the custom minimize button doesnt whant to work on Ubunutu 14.04, there is no reaction when presed clicked an so on. Any ...
0
votes
1answer
195 views

debug symbols for Ubuntu 12.04

I try to watch how programs work by running them by the 'Qt Creator' debugger. For better orientation I'd like to see also the system (core) utilities fully in the call stack window as I am used from ...
1
vote
1answer
244 views

Can both appmenu-qt and appmenu-qt:i386 be installed at the same time?

OK, so here's the backstory. Skype recently released version 4.3 on Ubuntu. It now has a menu bar, which it did not before. The only issue is that because it is 32-bit software, it's menu bar is not ...
1
vote
1answer
364 views

emit signal with custom type objects array parameter from c++ and receive in qml

I would like to emit a signal from a Qt C++ class which includes a parameter that is an array of custom objects (inherited from QObject) and receive the parameter in its qml slot, but i'm afraid it is ...
1
vote
1answer
76 views

How to make a project of Krusader

An example for my general question An introduction to translating and debugging source code : I had installed the 'Qt 4 Designer' and I have downloaded the krusader-2.4.0-beta3.tar.bz2 file. Among the ...
1
vote
1answer
567 views

LD Library Path

I am not sure whether my LD_LIBRARY_PATH is working. I installed Qt5.2.1 on Ubuntu and tried to execute an application from the command line using sudo ./App1. ( App1 needs sudo access, hence I ...
0
votes
0answers
43 views

How do you change qt themes by hand?

I am running a light desktop with Fluxbox and trying not to install anything more than I absolutely have to. I was wondering how one would go about changing qt4 and qt5 themes by hand much like you ...
0
votes
1answer
230 views

Setting up Themes in LX-Qt

I recently installed LX-Qt on Ubuntu Server. Everything went fine, but there seems to be an issue with the themes. When a theme is set in "Qt Configuration" (currently "QtCurve"), it doesn't change ...
2
votes
1answer
275 views

Ubuntu SDK: How do I implement a “onClick” for an image in QML?

I have a background image for my page, and I want to implement a sort of page refresh when the background is clicked. However, I didn't find any actions for the image element in QT quick. What's the ...
1
vote
1answer
320 views

QML: Overriding a signal handler from other element

Is it possible to override an elements action (eg onTriggered() of a Timer) from within the onClick() of a button? Something like so-> Button { id: centerBtn ...
0
votes
0answers
117 views

cannot find -lQtMultimedia

Using QtCreator with Qt 4.8 I need QT += multimedia in my pro.file I have already installed qtmobility-dev. Still my multimedia package is not found. Why?
0
votes
1answer
1k views

Install old QtCreator on Ubuntu 14.04

I want to build my application on Ubuntu. The last versions have been tested and programmed under Windows, because it is a multiplatform application. Sadly, under Ubuntu the systray icon did not work ...
3
votes
1answer
79 views

Unable to access i18n in QML app's JS file

I'm having trouble importing the i18n library included in Ubuntu.Components 0.1 for use in a JS file. I initially ran into my question/problem while hacking on the 'Clock' Ubuntu Touch core app, but ...
0
votes
0answers
401 views

How to install Qt4.6 libraries on Ubuntu 12.04?

I use Ubuntu 12.04. I am working with Qt IDE. I need Qt4.6 libraries for supporting my applications. Instead of this Ubuntu 12.04 provide Qt Creator IDE based on Qt4.8.0 libraries by ...
2
votes
2answers
987 views

QML Qt 5.2 problem with mp4 video

I have qt 5.2(ubuntu sdk) installed on Ubuntu 14.04 When I try to run QML code: MediaPlayer { id: mediaPlayer source: "../path/test.mp4" autoPlay: true } VideoOutput { id: video ...
1
vote
0answers
331 views

run qt designer/qt assistant with commands designer/assitant respectively

I'm used to an environment where I run the qt designer/qt assistant simply typing designer/assitant in the terminal. I am talking about qt 4. I've been installing packages such as qtcreator and ...
0
votes
0answers
115 views

Systray not showing

I have an application called foo that runs as root. The foo calls system function to execute the other application which show tray icon using Qt. The Systray Icon Example in Qt is working properly ...
0
votes
0answers
148 views

How to fix no sound problem after startx in alsa sound driver

My development env is: OS: ubuntu 12.04.3 language: Qt 4.8.1 alsamixer ver: v1.0.25 I am using .xinitrc contents like this: alsactl restore rm -rf /tmp/.* clear while(true) do ~ => ...
2
votes
1answer
119 views

Build-Essentials installation failing

I am having trouble accessing the several critical header files that show to be a part of the build process. The "Ubuntu Software Center" shows "Build Essentials" as installed: Next I did the ...
1
vote
1answer
1k views

unable to run make during installation of kernel 3.3.6

desktop:~/Desktop/linux-3.3.6$ make xconfig make[1]: Warning: File `scripts/kconfig/.zconf.tab.o.cmd' has modification time 1.7e+04 s in the future CHECK qt * Unable to find the QT4 tool qmake. ...
1
vote
0answers
54 views

Qml HUD integration without MainView?

I'm working on an app with Qt Quick Components, I don't want to use any Ubuntu specific components because I want the desktop version of my app to be more portable than that (Qt 5.2 is enough of a ...
0
votes
1answer
1k views

Qt5-default package not found

I am trying to do: sudo apt-get installl qt5-default Reading package list... Done Building dependency tree Reading state information... Done E: unable to locate package qt5-default On a Qt-forum I ...
1
vote
1answer
150 views

Qt Audio Engine not in Ubuntu SDK

I am using Ubuntu 14.04. I installed Ubuntu SDK with no problems using the instructions on Ubuntu website. I created a new QML project. I want to create an app that uses Qt Audio Engine. Here is my ...
3
votes
2answers
87 views

How to go back from a PageStack's Page to the parent tab in the UI Toolkit

So in a previous question I tried to use the Ubuntu UI Toolkit to nest a PageStack within the Tabs component. It seemed to work, but it had its quirks, so I'm now trying another option, which in ...
4
votes
2answers
129 views

How to hide the header of the Tabs component

I'm writing an app using the Ubuntu SDK, and I've got a PageStack component inside aTabs component. When I load one of the pages inside the PageStack, it all works well, and in the header the name of ...
2
votes
1answer
997 views

Font rendering problems with QT applications in Xubuntu

I'm currently using Xubuntu 14.04 but the same problem is present in 13.10 and 13.04, and maybe in previous versions. I always install truetype fonts and remove the anti-alias. In all the GTK ...
2
votes
1answer
105 views

Weird error when launching VLC from command line [duplicate]

Does anyone know how to solve this error? I tried viewing the content of the files in question, but I can only see weird characters. cannot load module `/usr/lib/vlc/plugins/gui/libqt4_plugin.so' ...
3
votes
1answer
796 views

QML: How to do variables?

In QML, I am just looking for a way to do fairly simple variables: Bool String Integer
3
votes
1answer
549 views

Qt4 interface not working for VLC

This is what happens if I try to run VLC: main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface. main interface error: option qt-volume-complete does not exist ...
-1
votes
1answer
106 views

Problems with GTK themes

A few weeks ago, I installed razor-qt on 14.04. everything was okay, but whenever i open a gtk application, it defaults to the elementary theme, as i had the pantheon de installed on it before. the ...
2
votes
0answers
123 views

Unity launcher, dash and menu fonts are not anti-aliased

I am running Ubuntu 14.04. After installing Qt4 settings manager and tinkering with it (changing the font face for Qt apps) I notice that unity launcher, dash and menu and date indicator fonts are not ...
2
votes
1answer
147 views

QML: QtQuick Extension Plugin - What is URI?

When starting a new Qt Quick Extension Plugin, it asks me to specify Object Class Name (Easy enough), but also something called URI. What does URI stand for? What does this project need URI for? ...
1
vote
0answers
30 views

What are the steps needed to implement a Qt class or member function into a QML project for Ubuntu-Touch? [duplicate]

Qt contains many classes and functions that are useful for a QML project, but not readily available. The existing solutions do not employ a method that is platform independent, thus it is unclear ...
2
votes
0answers
296 views

Multitouch in Qt

I've got a fresh install of Kubuntu 14.04 and Qt Creator/5.2.1, and I'm trying to get multi-touch working for the example applications like photosurface. My input device is an Acer T272HL 10 point ...
3
votes
1answer
62 views

What is the difference between Ubuntu.Components and QtQuick?

QtQuick 2.0 Ubuntu.Components 0.1 Are two common imports when developing applications for Ubuntu. Are these classes? Can you import member functions this way? If yes, how can tell what member ...
0
votes
1answer
798 views

Using KDE - Application Menus Missing in Qt Apps

I have multiple desktop environments installed on my Ubuntu 14.04 installation, and am primarily using KDE (today). Here's the problem I've noticed. When I've been building some newer versions of ...
0
votes
5answers
4k views

[Solved]Symbol lookup error: /usr/lib/i386-linux-gnu/libQtOpenGL.so.4: undefined symbol: _ZNK14QWidgetPrivate17hasHeightForWidthEv

I installed skype using several process in my newly installed Ubuntu 14. 04 64 bit... it shows a skype icon in dash... but when I click on it, nothings happens. What can I do? I tried almost ...
1
vote
0answers
29 views

Use SystemSettings 1.0?

I'm developing a new app that I need to use the SystemSettings module for (I need to get the device serial, IMEI and stuff). When looking for a way to get these numbers I came across Ubuntu System ...
3
votes
2answers
637 views

Difference between Qt Creator and Ubuntu SDK?

Having downloaded them both when I installed the Ubuntu SDK, I wonder if there is any tangible difference between the two, such as the libraries being employed.
7
votes
1answer
625 views

Can't change keyboard layout in some Qt programs

The problem after a recent update in my Ubuntu 13.10 with Unity. When typing something in Qt Creator 3.0.1 or in my own program compiled with Qt 5.2.1 (from qt-project.org), I can't change keyboard ...
5
votes
2answers
2k views

QML: Simplest way to write to a text file?

QML at the moment lacks basic system commands, so I am looking for the most simple template to write to /tmp/text.txt.
1
vote
0answers
92 views

Cannot import directory path to qmlscene

I am trying to import directory in QML as explained, here: http://qt-project.org/doc/qt-5.0/qtqml/qtqml-syntax-directoryimports.html. I have the following ubuntu-app | - extras1 | - extras2 | - ...
2
votes
1answer
193 views

Why wouldn't sound be heard on the phone when it works on the desktop with an Ubuntu Touch app?

I have an Ubuntu Touch application in the works. The application needs to playback sound. I've used QtMultimedia from C++ for sound playback. The sound plays fine on PC but not on the phone. The odd ...
8
votes
1answer
229 views

apt-get install <package> equivalent using C++ apt-pkg library

I am building a small QT (C++) application where I ask user the software he want to install. Once he selected some packages a, b, c from the list all I have to do is run sudo apt-get install a b c ...
0
votes
1answer
172 views

How do I fix X problem to invoke Cadence IC6.10 in Ubuntu 13.10

I installed Cadence IC6.10 in my Ubuntu 13.10. When I tried to invoke the Cadence, I got the following error message: ============================================================= Qt Warning: X ...
0
votes
1answer
227 views

Problem installing QtOctave

First I installed MATLAB and I got stuck here: No MATLAB executables were found in the directories you specified. This package requires at least one local installation of MATLAB. I was unable to ...
1
vote
2answers
374 views

What's the best way to make a Qt executable program run as a service in Ubuntu

I've written my Qt code for an embedded system which is running on Ubuntu. I want to run my program as a service in Ubuntu so I can stop or start it using monit. I've seen some people creating a new ...
4
votes
2answers
3k views

Qt5 installation and path configuration

I have installed Qt5 from the Qt5 project site, to the following directory /opt/Qt5 I would also like to mention that I had Qt4 installed previously, I have removed all instances of Qt4 through ...
1
vote
1answer
67 views

How to set a default file manager for qt's app?

I am running on ubuntu with awesomeWM which does not have specific file manager. When I launch vlc or any other Qt app and try to open a file from there, it does segfault after the following error ...