Qt 5 is the 5th major version of the popular GUI toolkit for implementing graphical applications. This version contains major changes, and Qt Quick is central to it.

learn more… | top users | synonyms

19
votes
1answer
39k views

How can I install Qt 5.x on 12.04 LTS?

If you want to develop with QML 2.0 and Qt5, the base packages don't seem to exist in repository for 12.04. What PPA should I add? Is it a binary installer? a compile the toolkit yourself? Those ...
13
votes
1answer
564 views

How will the Ubuntu Phone SDK impact desktop development [closed]

If I was to develop an application for Ubuntu after the Ubuntu Phone announcement, I would be concerned with several issues. I know that these things will not change immediately, but I'm thinking ...
9
votes
2answers
1k views

Playing Sound with Ubuntu QML Toolkit preview

I've installed the Ubuntu QML Toolkit Preview as per the instructions on http://developer.ubuntu.com/get-started/gomobile/ (with a minor fiddle to get it working on 12.04). I'm trying to write an app ...
7
votes
1answer
1k views

How will Qt 5.0 be packaged for Raring?

Note: as per the FAQ, "Issues with the next version of Ubuntu" may not be asked as questions here but in my opinion, this is not an issue but merely a question asking about policy. If you feel this ...
7
votes
1answer
5k views

How to add Qt5 to Qt Creator?

I've added the Qt5 Daily repository, installed the qt5-meta-full and added /opt/qt5/bin/qmake to Qt Versions. Now I get :-1: error: Unknown module(s) in QT: declarative Is it possible yet to use ...
6
votes
1answer
1k views

Are Qt Quick Controls available on Ubuntu 13.10?

I was looking to do UI development in QML, and I really want it to look native. I found the QtQuick.Controls (http://qt-project.org/doc/qt-5.1/qtquickcontrols/qtquickcontrols-index.html), but when I ...
5
votes
1answer
584 views

Qt5 Qtcreator using a c++function in main.qml to create a file /tmp/

I want to write an app for Ubuntu Touch based on the QtQuick2ApplicationViewer template and the app needs to write to a file (e.g. '/tmp/test.log'). I tested with using a function/macro Q_INVOKABLE: ...
4
votes
1answer
9k views

How can I uninstall Qt5 that I installed from .run?

I installed Qt from qt-linux-opensource-5.0.1-x86_64-offline.run file. It works fine, but I am unable to use KDE libs in it. So can anyone please say how to uninstall it?? I could also not find any ...
4
votes
2answers
2k views

Missing documentation for Qt5 on Ubuntu 13.04

I use Qt Creator for building applications and recently I decided to upgrade my Ubuntu from 12.10 to 13.04 and upgrade my current project from Qt4 to Qt5. The problem is that the Help section provides ...
4
votes
1answer
2k views

Problem building a Qt5 project with QWebKit

I'm trying to port a simple project from Qt4 to Qt5. The project uses QWebKit. I installed the qt5-default and libqt5webkit5-dev packages. I then changed the qmake project file to contain this: QT += ...
3
votes
1answer
4k views

qtchoose doesn't run due to “'/usr/lib/x86_64-linux-gnu/qt5/bin/qtchooser': No such file or directory” error

When I try to start qtchooser i get this notification: qtchooser: could not exec '/usr/lib/x86_64-linux-gnu/qt5/bin/qtchooser': No such file or directory I've installed Qt5 from ...
3
votes
1answer
500 views

Embedding C++ Objects into QML with Context Properties

According to Qt5 documentation: exposing methods including qt slots all public slots of C++ classes that inherit from QObject, are accessible from QML Here what I did: C++ class MyClass : public ...
3
votes
1answer
4k views

What package do I need to build a Qt 5 & CMake application?

I'm trying to build sdrangelove, which wants Qt 5 and uses CMake for its build system, on Ubuntu 13.10. What package do I need to install to give it the file it's asking for here? There are a lot of ...
3
votes
1answer
86 views

Install newly developed app on Ubuntu Touch device

Host OS: Ubuntu 12.04.4 LTS Ubuntu Touch Device: Nexus4 Running Ubuntu 13.10 My dev environment is QtCreator with the ubuntu-sdk plugin I'm trying to deploy the QML / C++ sample app (the one ...
3
votes
1answer
207 views

How to access geolocation information on Ubuntu Touch?

It's strangely hard to find any documentation on accessing geolocation information for Ubuntu Touch specifically and even Qt5 more generally. The Qt Mobility APIs provided this in Qt4, and they seem ...
3
votes
1answer
978 views

Ubuntu SDK and QtCreator will not start

I have tried sudo apt-get purge ubuntu-sdk qtcreator qtcreator-plugin-ubuntu qtcreator-plugin-cordovaqt and then sudo apt-get install ubuntu-sdk but QtCreator will still not start. It does not show up ...
3
votes
0answers
31 views

Unable to build QtQuick 2 projects

I'm running Xubuntu 14.04, and I have the following packages installed: qt5-default (5.2.1) qtcreator (3.0.1-0ubuntu4) qml (5.2.1-3ubuntu15.1) They were installed from the official repos and are ...
3
votes
0answers
396 views

Ubuntu and Qt creator keyboard layout change problem

When I run Qt Creator on my Ubuntu 14.04 with English layout, it always types in English and it won't change if I change my layout to other language. In front, when I run Qt Creator with Persian ...
2
votes
1answer
2k views

Ubuntu 14.04 QtCreator Qt5 examples missing

After upgrading to Ubuntu 14.04 I removed the official qtcreator in order to install the modified version from the software center because I'd like to try the SDK. Fortunately, the docs are now ...
2
votes
1answer
2k views

Compiling code that depends on QT4 with QT5 installed

I have QT5 installed on 12.10 I believe because it is a dependency for the Ubuntu SDK and the Ubuntu touch tools which I have been using. I have QT4 installed as well, infact I had it installed ...
2
votes
1answer
2k views

How do I install the QtWebKit 3.0 module for Qt Creator?

I'm trying to add a webview to my project, but the module isn't installed. I'm new to qml and qt and I'm not sure how to install the module. Thanks
2
votes
1answer
204 views

Why does Software Center report qt4 as unmet dependency, when I already have qt5 installed?

I installed qtspim which requires qt4 to be installed. As I already have qt5 installed on my system, qtspim is working fine. However, Software Center reports dependency error. When I run apt-get ...
2
votes
2answers
343 views

Qt5 with Qt 4.7 on Ubuntu 13.04. How to install it both without conflicts?

I'm using Qt5 and need Qt 4.7 now (for embedded device). Is it possible to install it additionally on Ubuntu 13.04?
2
votes
1answer
1k views

QtQuick not found (Lubuntu)

On a fresh Lubuntu 13.04 installation, I installed Qt5 from the official ubuntu repositories. But this installation of Qt5 can't find the QtQuick module. What am I missing? qmlscene test.qml ...
2
votes
1answer
159 views

ListView Subtitled delegate, icon size and title word wrapping?

I'm working on an ubuntu mobile app and I have a few questions about customizing a listview. The listitem may contain an icon, but will have a title and subtitle. What I'm having trouble with is ...
2
votes
1answer
217 views

Getting QT5 to work with the “Create a currency converter phone app”-tutorial [closed]

I'm trying to get into developing for the ubuntu phone, and I'm following the Create a currency converter phone app tutorial by the letter. Problem is that when I try to preview the app, I get a ...
2
votes
0answers
88 views

Issue in QT 5.2.1 app in linking libquazip.so library during making .deb package for ubuntu 14.04

I am making .deb package for the QT 5 .2.1 desktop app for ubuntu 14.04 64 bit. I have installed QT 5.2.1 on Ubuntu 14.04 and made a demo app for the testing purpose in which I have used quazip ...
2
votes
0answers
227 views

After compiling QT 5 how do I to update my system? With update-alternatives?

I'm on Ubuntu 12.04. I followed the instructions in this guide in order to compile QT5. Everything compiled fine. My problem now is that my QT related programs are still pointing to an older ...
2
votes
0answers
431 views

Qt 5.1.1 installation problem

I am new to ubuntu and using 12.04 LTS. I tried to install Qt5.1.1 without software manager. I downloaded the qt-linux-opensource-5.1.1-x86-offline.run file and ran it. It ran smoothly and got a ...
1
vote
2answers
636 views

unmet dependencies, I can't install ubuntu-sdk [duplicate]

I have been trying to install the ubuntu developer environment so that I may begin gaining practice in app development. But once I try to install ubuntu-sdk I get the following error: The following ...
1
vote
1answer
266 views

Zeal from the PPA has unmet dependences

I'm trying to install Zeal through ppa in Ubuntu 13.04, but is giving the error: The following packages have unmet dependencies: zeal : Depends: libqt5core5 (>= 5.0.2) but 5.0.1+dfsg-0ubuntu4.1 ...
1
vote
1answer
253 views

How do I install and reference QtLocation 5.0?

I am trying to run a sample application in Qt Creator which has an import QtLocation 5.0 statement at the top. I have already installed the Ubuntu SDK. I searched the software center for ...
1
vote
3answers
6k views

How can i uninstall QtCreator 2.6.1 from 12.04?

I downloaded QtCreator 2.6.1 from the official website http://qt-project.org/downloads#qt-creator because i'm using ubuntu 12.04. Now i need to uninstall it. How can i do it? 64-bit Linux Installer ...
1
vote
1answer
273 views

importing C++/Qt module in QML

I have made a module to execute a shell script from within QML. The problem that I'm having is that I don't know how to import the module into my QML script. This is for a UT application BTW.
1
vote
1answer
756 views

Qt5 installation and path configuration

I have installed Qt5 from the Qt5 project site, to the following directory /opt/Qt5 I would also like to mention that I had Qt4 installed previously, I have removed all instances of Qt4 through ...
1
vote
2answers
671 views

How to install libqtwebkit5?

How can I install libqtwebkit5 library? I need it for a Qt project. I tried with: $ sudo apt-get install libqtwebkit5 Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
133 views

Qt 5 configuration

I have a problem setting Qt5 apps correctly on my computer. I'm running Ubuntu 14.04 with KDE4, I have configured the look in the KDE system settings and that look is used in every qt4 apps and gtk ...
1
vote
0answers
172 views

How to deploy my Qt app statically on ubuntu ? It is running on ubuntu 14.04 only

I wrote a application with Qt 5.x and the compiled binary is only working on my development machine running 14.04 on other machines running 14.04 on linux mint 16 I already inserted the CONFIG ...
1
vote
0answers
19 views

Use SystemSettings 1.0?

I'm developing a new app that I need to use the SystemSettings module for (I need to get the device serial, IMEI and stuff). When looking for a way to get these numbers I came across Ubuntu System ...
1
vote
0answers
499 views

How to configure debian/rules file for packaging with CDBS and Cmake, Qt5 on Ubuntu 12.04

this is the first time I ask here. Recently I played packaging --a new thing for me-- in Launchpad. I tried compiling Sigil 0.7.4 for Ubuntu Precise. The source code had to be compiled with Qt5, while ...
1
vote
1answer
335 views

QtCreator crashes on registering namespace

I just installed Ubuntu 13.10 (Desktop) x64 on my computer and wanted to install Qt5 with QtCreator. So, I downloaded it from: http://qt-project.org/downloads ...
1
vote
0answers
170 views

Qt 5.1 packages

Is there any ppa containing Qt 5.1 prebuilt binary packages? I found this one, but it doesn't seem really well-provided. I'm running Raring, but I see that even Saucy still has Qt 5.0.2.
1
vote
0answers
67 views

Music app missing from Ubuntu Touch

I recently installed the Ubuntu Touch build dated 3rd oct on my phone. After that, I used adb shell and did: apt-get update apt-get upgrade apt-get dist-upgrade. Then I rebooted my phone, and ...
1
vote
0answers
302 views

QT5.0 Cross compile for AM1808

I have a requirement to implement the JSON for file transfer. I found that QJsonDocument is only supported to the QT5.0. So that I am trying to Cross compile the QT5.0 for my processor(AM1808 ARM9). ...
1
vote
0answers
711 views

Problem during Qt 5.1 installation

I downloaded the Qt 5.1.0 installation file for Linux, and trying to install gives me an error. It stops when copying these files: ...
1
vote
0answers
170 views

Error while executing standard Ubuntu Touch program

I've followed the instructions for the standard app and it was all working ok. I had some issues with ComponentsShowcase.qml, because of which I messed up the app. So, I removed the PPAs and added ...
1
vote
0answers
644 views

Setting Qt5 qmake as default Qt builder

By default Qt4 is the default Qt builder in ubuntu 12.10, I want to know how can I make Qt5 qmake as default Qt builder. PS Qt5 qmake installed in /usr/lib/x86_64-linux-gnu/qt5/bin/qmake
1
vote
1answer
2k views

Recent Qt repository

Is there any repository for latest Qt versions (recent version is 5.0.1 while ubuntu has 4.8) ? PS I found this PPA but it tagged as [deprecated]!!!, so I'm wondering what if there is official one ...
1
vote
0answers
138 views

Ubuntu Phone App Development Clarification

I attempting to follow the Ubuntu Phone App development tutorial to make a Currency Converter, and I am simply unable to complete the tutorial. I have installed all of the latest QT/Phone related ...
1
vote
0answers
67 views

12.04 /opt/qt5 don't exist [closed]

I installed Qt5 using official PPA and also I followed instructions how to setup ubuntu components. But also I noticed that /opt/qt5 folder don't exist, therefore I can't use qmlscene. How to fix ...