Qt Creator is a cross-platform integrated development environment (IDE) using the Qt Framework. Questions about how to use the tool to develop your applications, installation issues.

learn more… | top users | synonyms

19
votes
4answers
42k views

How to use Qt Creator with Python?

I want to use Qt for developing Ubuntu desktop, phone and tablet applications but I don't want to learn a new programming language (C++, JavaScript). Is it possible to write Qt application in Python ...
13
votes
4answers
4k views

Why Ubuntu.Components 0.1 missing from QTCreator?

First of all i need to create a "hello world" app using QML & QT Creator as described here http://developer.ubuntu.com/get-started/gomobile/ Second, when i was trying to install QML platform and ...
11
votes
3answers
4k views

Qt Quick UI templates missing from Qt Creator's New File or Project dialog

After following the getting started guide on the Go mobile page, everything seems just fine. All the Ubuntu specific stuff is there, but when I try to create a new project using the Qt Quick 2 UI ...
8
votes
1answer
7k views

How to add Qt5 to Qt Creator?

I've added the Qt5 Daily repository, installed the qt5-meta-full and added /opt/qt5/bin/qmake to Qt Versions. Now I get :-1: error: Unknown module(s) in QT: declarative Is it possible yet to use ...
7
votes
4answers
13k views

How can I use gnome-terminal in qt creator?

I can adjust the settings to use a terminal rather than just plain output. However, I can't seem to figure out the correct command to input for using gnome-terminal. I can use 'xterm -e', a fine ...
6
votes
3answers
4k views

Missing documentation for Qt5 on Ubuntu 13.04

I use Qt Creator for building applications and recently I decided to upgrade my Ubuntu from 12.10 to 13.04 and upgrade my current project from Qt4 to Qt5. The problem is that the Help section provides ...
6
votes
2answers
2k views

QtCreator plugins and templates missing

I just downloaded the Ubuntu phone SDK and QT creator according to the instructions. When I fire up QTCreator, I get a screen as shown If I ignore this message and hit continue, there are no ...
6
votes
2answers
1k views

How do I work around sudo 'segmentation fault' on basic bash commands?

I am sure the answers are out there, but alas there are too many answers (here and elsewhere) to other questions stopping me from finding them. I just encountered something substantially similar to ...
6
votes
0answers
1k views

Multiple Windows at QtCreator startup [closed]

I'm using QtCreator for a while. No problems everything worked fine. But, when I started some hours before it opens with multiple windows named QtCreator along with one main QtCreator window. Others ...
5
votes
2answers
2k views

QtCreator wont start anymore. Symbol lookup error

Since yesterday I'm unable to start QtCreator. Trying to start QtCreator from terminal gives me this error message, which I haven't found anything on: qtcreator: symbol lookup error: ...
5
votes
1answer
1k views

libdb4.8++ is no longer available

I'm trying to use QT-Creator to build a program and I get the message that libdb4.8++ is needed and is not available. I've tried to use libdb5.1 and libdb4.8 but it still asks for libdb4.8++ I'm ...
4
votes
2answers
7k views

Ubuntu 14.04 QtCreator Qt5 examples missing

After upgrading to Ubuntu 14.04 I removed the official qtcreator in order to install the modified version from the software center because I'd like to try the SDK. Fortunately, the docs are now ...
4
votes
2answers
3k views

How to create a Debian source package with Qt Creator?

What do I need to do to get a package that I can submit to the Ubuntu Software Center?
4
votes
1answer
482 views

How to run an application in /opt?

I want to know how one can run his application in /opt and installed in /opt. I want it for the ubuntu app showdown http://developer.ubuntu.com/showdown/ I will be using qt with qt creator and c++; ...
4
votes
2answers
432 views

using ubuntu-sdk to create app with problems

I upgraded my ubuntu 14.04 to 14.10 to use the latest ubuntu-sdk. But When I created a simple UI project there is just a red wave line under the "import Ubuntu.Components.1.1". So I moved my mouse to ...
4
votes
1answer
1k views

Debugging applications in QTCreator

Every time I go to debug some code in QTCreator, I get this GDB error returning. Current setup: Ubuntu 11.04 QT Creator version: 2.1.0 GDB Version: GNU gdb (Ubuntu/Linaro 7.2-1ubuntu11) 7.2 ...
4
votes
0answers
634 views

Ubuntu and Qt creator keyboard layout change problem

When I run Qt Creator on my Ubuntu 14.04 with English layout, it always types in English and it won't change if I change my layout to other language. In front, when I run Qt Creator with Persian ...
4
votes
0answers
421 views

QtCreator creates unwanted windows [closed]

This issue occurs on raring with the build "qtcreator 2.8.1-0ubuntu1~raring1~test1", the latest from the software center. It works fine in general, but if you click on "Welcome" and than on "Develop", ...
3
votes
3answers
7k views

Qt Creator won't recognize any Qt version

I've just installed Qt Creator from the Ubuntu Software Center. When I try to open any project other than a Qt Quick project I get following error message: No valid qt versions found. Please ...
3
votes
2answers
866 views

Difference between Qt Creator and Ubuntu SDK?

Having downloaded them both when I installed the Ubuntu SDK, I wonder if there is any tangible difference between the two, such as the libraries being employed.
3
votes
1answer
66 views

What is the difference between Ubuntu.Components and QtQuick?

QtQuick 2.0 Ubuntu.Components 0.1 Are two common imports when developing applications for Ubuntu. Are these classes? Can you import member functions this way? If yes, how can tell what member ...
3
votes
1answer
1k views

QML: How to do variables?

In QML, I am just looking for a way to do fairly simple variables: Bool String Integer
3
votes
2answers
284 views

How to configure version control for Qt?

It might be just a basic thing for many, but I'm stuck at "Qt version control", and it's really annoying me. I'm on Ubuntu 12.04 LTS and my Qt version is 2.4.1. Here's the message which is displayed: ...
3
votes
1answer
390 views

How to properly package an Ubuntu Touch application with Qt Creator (Ubuntu SDK)

In the new Ubuntu SDK there is an option to "Create application package" in "Build/Ubuntu Touch". Is there any tutoriel to explain how it works? It seems that it creats a "debian" folder with many ...
3
votes
1answer
1k views

Ubuntu SDK and QtCreator will not start

I have tried sudo apt-get purge ubuntu-sdk qtcreator qtcreator-plugin-ubuntu qtcreator-plugin-cordovaqt and then sudo apt-get install ubuntu-sdk but QtCreator will still not start. It does not show up ...
3
votes
1answer
2k views

How to install qtquick 2.0 and ubuntu components 0.1? [closed]

I am facing this problem while making a currency converter program in qt creator. The program is as follows: import QtQuick 2.0 import Ubuntu.Components 0.1 Rectangle { id: root width: ...
3
votes
2answers
75 views

How to make an application use local shared library instead of the system one

I have qtcreator installed using the qt online installer. It ships which its own version of qt library. The qt library are also installed in the system directories, but those are older. I have ...
3
votes
0answers
122 views

How can I get menu items in a Qt Quick application?

I'm using Qt Creator 3.1.1 on Ubuntu 14.10 (the version installed when you install Ubuntu SDK - the two seem to be the same application). I'm running the default Unity 7 desktop. When I create a new ...
3
votes
0answers
102 views

Unable to build QtQuick 2 projects

I'm running Xubuntu 14.04, and I have the following packages installed: qt5-default (5.2.1) qtcreator (3.0.1-0ubuntu4) qml (5.2.1-3ubuntu15.1) They were installed from the official repos and are ...
3
votes
0answers
236 views

(QML) Flickable not working as supposed

So, while building an Ubuntu app I needed to use Flickable for scrolling, so now I have code of the form Page{ ... Flickable { anchors.fill: parent content.height: element1.height + ...
3
votes
0answers
771 views

TypeError: Cannot call method 'hasOwnProperty' of null, while creating a QMLscene window

I am trying to make a simple Ubuntu Touch web application with Qt Creator. I have set up a new project according to the tutorial and committed the files to Bazaar. I have set a url instead of the ...
2
votes
3answers
15k views

Where does apt-get install libqt4?

I've been searching for literally hours and I cannot figure out where for the life of me libqt4 is installed by apt-get. I installed: libqt4-dev libqt4-core libqt4-gui libqt4-xml libqt4-opengl ...
2
votes
1answer
478 views

Ubuntu SDK: How do I implement a “onClick” for an image in QML?

I have a background image for my page, and I want to implement a sort of page refresh when the background is clicked. However, I didn't find any actions for the image element in QT quick. What's the ...
2
votes
1answer
651 views

Set Application Icon

I'm building a QML application with the Ubuntu SDK. I've figured out how to add an application icon to the .desktop file, but I'm not sure where to add the window icon itself. I've seen code for ...
2
votes
2answers
1k views

Can I create a proprietary application using Qt?

I am using Qt4 to build an application and for some reason I want to keep it proprietary. Qt4 is released under LGPL, does that force me to release the code to my application. I ask this question ...
2
votes
1answer
178 views

How do you equally space out elements in a Row?

Row{ width: parent.width spacing: ???? Checkbox{} Checkbox{} Checkbox{} Checkbox{} } So just to be clear, the checkboxes should be spaced in such a manner that however wide ...
2
votes
1answer
43 views

Why does the Ubuntu SDK tell me, “do not use comma expression”, and what should I use instead?

So for example: onCurrentlyExpandedChanged: flickable.DragOverBounds, flickable.contentHeight += itemHeight,console.log(itemHeight) The commas will have a yellow underline, and the tooltip will ...
2
votes
1answer
1k views

Problem with QtCreator after update

I installed the ubuntu-sdk 2 days back on my machine (12.04) and the Qt version that is installed is 5.0.2. Everything was working perfectly, but today there were some updates from the ...
2
votes
1answer
2k views

enviroment variables are not loaded

I use Qt Creator to manage my C++ codes on xubuntu 12.04 LTS. I have a bunch of environment variables defined in .bashrc_vars that are loaded in .bashrc. These variables are required for building my ...
2
votes
2answers
23k views

PuTTY X11 proxy: wrong authorisation protocol attempted

I am using putty from windows vista to connect to ubuntu server and run my qtcreator using Xming. I am able to log-in into the server, but I am unable to run qtcreator. the following message ...
2
votes
2answers
518 views

Can't install g++ in Software Center

I can't install g++ in software center. I can install other programs. For example, after I found g++ can't be installed, I installed chrome for test purpose through software center, and it worked! ...
2
votes
1answer
211 views

ListView Subtitled delegate, icon size and title word wrapping?

I'm working on an ubuntu mobile app and I have a few questions about customizing a listview. The listitem may contain an icon, but will have a title and subtitle. What I'm having trouble with is ...
2
votes
2answers
276 views

QML app with C++ plugin (cmake) adding resource file

How to add qrc file to "QML app with C++ plugin (cmake)" project ? I can't find a working instruction. I found only one thing, add this to CMakeLists.txt: qt5_add_resources(RESOURCES ...
2
votes
2answers
194 views

QT Creator wants me to remove many programs before I can install it via Ubuntu Software Center

I've just upgraded my Ubuntu-gnome version from 14.04 to 14.04.02 and somehow I lost my QT Creator software which I commonly use to do my coding. I decided to install it again. When I tried to ...
2
votes
1answer
179 views

QML: QtQuick Extension Plugin - What is URI?

When starting a new Qt Quick Extension Plugin, it asks me to specify Object Class Name (Easy enough), but also something called URI. What does URI stand for? What does this project need URI for? ...
2
votes
2answers
2k views

“No executable specified.” Ubuntu SDK Unity8

Was working last night, but today when I started up again, I could not run unity8 out of QtCreator/UbuntuSDK. After building and running, it just states: "No executable specified." FYI; This is a ...
2
votes
1answer
546 views

How do I add a qrc file to my Ubuntu Touch qml project?

My UT QML project makes use of a set of images, and I was planning use them via "qrc:///pathtoimages/myimage.png" style of url. In Ubuntu SDK, I can "add new... Qt / Qt Resource File". The file is ...
2
votes
1answer
3k views

Recent Qt repository

Is there any repository for latest Qt versions (recent version is 5.0.1 while ubuntu has 4.8) ? PS I found this PPA but it tagged as [deprecated]!!!, so I'm wondering what if there is official one ...
2
votes
3answers
1k views

Mobile app development issues with qmlviewer not being found?

I am trying to follow the Mobile app development tutorial found here. When I try to run the currency converter in QT Creator I get this error: Starting external tool '/usr/bin/qmlviewer' '' ...
2
votes
1answer
2k views

Default program for opening .pro Qt project files

I would like to set Qt Creator (the one which is in the Nokia Qt SDK, not the one in Canonical PPAs) as the default program to open .pro Qt project files. But it appears that my Ubuntu install (12.04 ...