0
votes
1answer
44 views

What's the development package for Qt5 in 14.04

I want to build a Qt5 example on my desktop machine. I installed qt5-default and qtdeclarative5-dev, but I'm still getting this error: Project ERROR: Unknown module(s) in QT: quick qml Which ...
1
vote
1answer
72 views

Qt 5 configuration

I have a problem setting Qt5 apps correctly on my computer. I'm running Ubuntu 14.04 with KDE4, I have configured the look in the KDE system settings and that look is used in every qt4 apps and gtk ...
0
votes
1answer
89 views

Ubuntu Qmake is not an executable

I have the latest versions of qtcreator, qt5-qmake build-essential and g++ installed. In option of Build & Run and choose qmake in /usr/bin/qmake I get this error: The qmake executable ...
1
vote
0answers
19 views

Use SystemSettings 1.0?

I'm developing a new app that I need to use the SystemSettings module for (I need to get the device serial, IMEI and stuff). When looking for a way to get these numbers I came across Ubuntu System ...
1
vote
1answer
568 views

Qt5 installation and path configuration

I have installed Qt5 from the Qt5 project site, to the following directory /opt/Qt5 I would also like to mention that I had Qt4 installed previously, I have removed all instances of Qt4 through ...
0
votes
1answer
76 views

Missing package in Ubuntu SDK - qtdeclarative5-ubuntu-webapps-api

Installing the Ubuntu SDK failed because of missing package qtdeclarative5-ubuntu-webapps-api this was the message from apt-get: The following packages have unmet dependencies: ubuntu-html5-sdk ...
2
votes
0answers
217 views

After compiling QT 5 how do I to update my system? With update-alternatives?

I'm on Ubuntu 12.04. I followed the instructions in this guide in order to compile QT5. Everything compiled fine. My problem now is that my QT related programs are still pointing to an older ...
1
vote
1answer
312 views

QtCreator crashes on registering namespace

I just installed Ubuntu 13.10 (Desktop) x64 on my computer and wanted to install Qt5 with QtCreator. So, I downloaded it from: http://qt-project.org/downloads ...
3
votes
1answer
4k views

What package do I need to build a Qt 5 & CMake application?

I'm trying to build sdrangelove, which wants Qt 5 and uses CMake for its build system, on Ubuntu 13.10. What package do I need to install to give it the file it's asking for here? There are a lot of ...
0
votes
0answers
170 views

QtCreator install not recognized

I've installed QtCreator 5.1.1 according to this site Install Qt-5 and everything is working well with it. I installed it /opt/QT5. Unfortunately, Muon software center does not list QtCreator in its ...
5
votes
1answer
1k views

Are Qt Quick Controls available on Ubuntu 13.10?

I was looking to do UI development in QML, and I really want it to look native. I found the QtQuick.Controls (http://qt-project.org/doc/qt-5.1/qtquickcontrols/qtquickcontrols-index.html), but when I ...
2
votes
0answers
422 views

Qt 5.1.1 installation problem

I am new to ubuntu and using 12.04 LTS. I tried to install Qt5.1.1 without software manager. I downloaded the qt-linux-opensource-5.1.1-x86-offline.run file and ran it. It ran smoothly and got a ...
2
votes
2answers
324 views

Qt5 with Qt 4.7 on Ubuntu 13.04. How to install it both without conflicts?

I'm using Qt5 and need Qt 4.7 now (for embedded device). Is it possible to install it additionally on Ubuntu 13.04?
2
votes
1answer
1k views

QtQuick not found (Lubuntu)

On a fresh Lubuntu 13.04 installation, I installed Qt5 from the official ubuntu repositories. But this installation of Qt5 can't find the QtQuick module. What am I missing? qmlscene test.qml ...
0
votes
1answer
1k views

“Failed to load platform plugin ”xcb“ ” while launching qt5 app on linux without qt installed

I wrote application for linux which uses QT5. But when I am trying to launch it on the linux without QT SDK installed, the output in console is: Failed to load platform plugin "xcb". Available ...
1
vote
0answers
627 views

Setting Qt5 qmake as default Qt builder

By default Qt4 is the default Qt builder in ubuntu 12.10, I want to know how can I make Qt5 qmake as default Qt builder. PS Qt5 qmake installed in /usr/lib/x86_64-linux-gnu/qt5/bin/qmake
4
votes
2answers
2k views

Missing documentation for Qt5 on Ubuntu 13.04

I use Qt Creator for building applications and recently I decided to upgrade my Ubuntu from 12.10 to 13.04 and upgrade my current project from Qt4 to Qt5. The problem is that the Help section provides ...
19
votes
1answer
37k views

How can I install Qt 5.x on 12.04 LTS?

If you want to develop with QML 2.0 and Qt5, the base packages don't seem to exist in repository for 12.04. What PPA should I add? Is it a binary installer? a compile the toolkit yourself? Those ...
1
vote
1answer
2k views

Recent Qt repository

Is there any repository for latest Qt versions (recent version is 5.0.1 while ubuntu has 4.8) ? PS I found this PPA but it tagged as [deprecated]!!!, so I'm wondering what if there is official one ...
2
votes
1answer
2k views

How do I install the QtWebKit 3.0 module for Qt Creator?

I'm trying to add a webview to my project, but the module isn't installed. I'm new to qml and qt and I'm not sure how to install the module. Thanks
2
votes
1answer
156 views

ListView Subtitled delegate, icon size and title word wrapping?

I'm working on an ubuntu mobile app and I have a few questions about customizing a listview. The listitem may contain an icon, but will have a title and subtitle. What I'm having trouble with is ...
-1
votes
1answer
125 views

Is there any plan to merge `qt-components-ubuntu` into official QT/QML?

Is there any plan to merge qt-components-ubuntu into official QT/QML? Is it ongoing already? It's quite sad that ubuntu forked qt. I want to use qml to build a desktop app, and widgets introduced in ...
2
votes
1answer
201 views

Why does Software Center report qt4 as unmet dependency, when I already have qt5 installed?

I installed qtspim which requires qt4 to be installed. As I already have qt5 installed on my system, qtspim is working fine. However, Software Center reports dependency error. When I run apt-get ...
0
votes
0answers
55 views

Software center requires qt4, I have qt 5 [duplicate]

Possible Duplicate: Why does Software Center report qt4 as unmet dependency, when I already have qt5 installed? i have installed qtspim which depends upon qt4. I have already installed qt5 ...
7
votes
1answer
5k views

How to add Qt5 to Qt Creator?

I've added the Qt5 Daily repository, installed the qt5-meta-full and added /opt/qt5/bin/qmake to Qt Versions. Now I get :-1: error: Unknown module(s) in QT: declarative Is it possible yet to use ...
7
votes
1answer
1k views

How will Qt 5.0 be packaged for Raring?

Note: as per the FAQ, "Issues with the next version of Ubuntu" may not be asked as questions here but in my opinion, this is not an issue but merely a question asking about policy. If you feel this ...