6
votes
1answer
140 views

apt-get install <package> equivalent using C++ apt-pkg library

I am building a small QT (C++) application where I ask user the software he want to install. Once he selected some packages a, b, c from the list all I have to do is run sudo apt-get install a b c ...
1
vote
1answer
587 views

How do I install libqt4.7.4?

I need to use libqt4.7.4 (or .3) on the latest build of Ubuntu. Is there any easy way to revert to that version. Will it break anything? sudo apt-get install qt4-dev-tools=4.7.4 errors with 'Version ...
1
vote
0answers
197 views

unmet dependencies: libqt4-dev qt4-qmake [duplicate]

Possible Duplicate: How do I resolve unmet dependencies? Is there anything I can do about this ? It seems that synaptic has updated qt4-qmake to version 4.7.2 but all the dependent ...
0
votes
2answers
1k views

Minimal package to install Qt Assistant

We are using Qt Assistant as our help system for a custom application that will run on Ubuntu. In building the .deb package, I need to include a "Requires:" value that makes my package dependent on ...