3
votes
0answers
31 views

apt-get install <package> equivalent using C++ apt-pkg library

I am building a small QT (C++) application where I ask user the software he want to install. Once he selected some packages a, b, c from the list all I have to do is run sudo apt-get install a b c ...
1
vote
0answers
148 views

Recompile Qt Creator with Qt4

Qt Creator on Ubuntu 13.04 has the cursor theme wrong. I've read this is because Qt5 applications do not integrate in Ubuntu well. So I want to recompile Qt Creator using Qt4. I've downloaded the ...
0
votes
1answer
2k views

How to install SIP+PyQt with apt-get + pip + virtualenv?

[I originally posted this question, under a different title, in StackOverflow (here), but later I realized that my problem is very specific to apt-get, hence I am re-posting it here. Sorry for the ...
0
votes
1answer
501 views

Unable to install qt-sdk unmet dependencies

I tried to install qt-sdk under ubuntu 12.10 how can I fix this issue? install log: apt-get install qt-sdk Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
1answer
4k views

How to install qt sdk (qt 4.x) by apt-get (the full version)?

I've installed QtSdk-offline-linux-x86-v1.2.1 on Ubuntu 12.10 it has some bugs, crashes all the time. It does not appear in the Ubuntu Software Center and would not upgrade to the new version by ...
0
votes
1answer
419 views

getting the following error in installing qt creator through software center

getting the following error in installing qt creator through software center. The following packages have unmet dependencies: qtcreator: Depends: libqt4-help (>= 4:4.7.1) but 4:4.8.1-0ubuntu4 is ...
0
votes
3answers
6k views

Where does apt-get install libqt4?

I've been searching for literally hours and I cannot figure out where for the life of me libqt4 is installed by apt-get. I installed: libqt4-dev libqt4-core libqt4-gui libqt4-xml libqt4-opengl ...
3
votes
2answers
1k views

QT 4 packages create dependency problems

I am using Ubuntu 12.04. I recently performed an upgrade for my system. Now, when I try to install a package (aptitude for example), I see this: Reading package lists... Done Building dependency tree ...
0
votes
2answers
907 views

Minimal package to install Qt Assistant

We are using Qt Assistant as our help system for a custom application that will run on Ubuntu. In building the .deb package, I need to include a "Requires:" value that makes my package dependent on ...