Python is an interpreted programming language that is often, but not solely, used as a scripting language. A version of Python is included by default on all Ubuntu distributions.

learn more… | top users | synonyms

0
votes
0answers
211 views

No module named _sqlite3

So I am trying to run MLST in bio-python and I have python installed Python 2.7.11 (default, Mar 19 2016, 17:53:01) [GCC 4.8.4] on linux2 But I keep getting the error: File "metaMLST-index.py"...
0
votes
0answers
53 views

How to start a Python script in LXTerminal using crontab at boot-up

I have a script called myscript.py (in /home/pi) that I want to run in the terminal every time the Pi boot up. I want to activate this by using 'crontab'. However after searching and trying stuff ...
0
votes
0answers
60 views

Install python and django on ubuntu 14.04

I am new in python/django and following this link and "Global Install through pip(section)" for installation, when I run apt-get install python-pip, I get below error aagyat@ubuntu:~$ sudo apt-get ...
0
votes
0answers
108 views

How to run a program at startup Raspberry Pi

I have a problem with running a script with python at startup. Actually, I managed to start it at boot but the program does not work as I wanted. In this code, I try to start the script that gives me ...
0
votes
0answers
27 views

Unity plugin not working due to python update

I wanted to install some modules of nodeJS.Therefore, I had to install an old version of Python 2.7.11. This change resulted in losing my quick launcher and menu bar which means that unity has been ...
0
votes
0answers
20 views

Apt is unsure whether a package is or isn't installed when doing a command-not-found

I wanted to install python virtualenv for python3.3+, and tried this command: $ pyvenv-3.4 The program 'pyvenv-3.4' is currently not installed. You can install it by typing: sudo apt-get install ...
0
votes
0answers
39 views

USB web-cam video of Raspberry-pi in WxPython with control buttons

I was wondering if there is a way to record video from a USB web-cam of Raspberry-pi(including sound). I'd like to be able to record a section of video as well as play the recorded video later using ...
0
votes
0answers
225 views

Cannot upgrade pip behind proxy

I've tried all the suggestions in this other question, but it just isn't working for me: Unable to upgrade pip I'm running Ubuntu 12.04, and was able to install pip 1.0 using apt, but that version ...
0
votes
0answers
64 views

can't install rednotebook because of python dependencies

I can't install rednotebook in ubuntu 16.04. How can I handle this problem? Thanks. sudo apt-get install rednotebook -f Reading package lists... Done Building dependency tree Reading state ...
0
votes
0answers
18 views

Error on installing python-egenix-mxdatetime

I get an error on installing python-egenix-mxdatetime specific the 3.1.3 version. First I downloaded the package from egenix site, then tried to install python-egenix-mxdatetime using the below ...
0
votes
0answers
18 views

How to install l2cs on unbuntu?

I have to install l2cs on my 12.04 ubuntu server but I don't know how to do that. I'm beginner on dedicate servers and I need to some help to do that. Can someone to provide a set-by-step tutorial ...
0
votes
0answers
2k views

pip use on Ubuntu 16.04

I installed python packages on Ubuntu Trusty using pip and was able to call the installed packages as expected, but on Ubuntu Xenial (installed in a virtual machine) I did the same thing using pip but ...
0
votes
0answers
19 views

Python build errors when installing packages via setup.py

I'm running Python 3.4.3 on Ubuntu 14.04. I have an issue where whenever I install a package via python setup.py install, if there is any building involved the process errors. This happens even though ...
0
votes
0answers
24 views

In Spyder, the window turns gray the moment I type “plt” (for matplotlib.pyplot)

I'm following a course on Machine Learning on Udacity, https://github.com/tensorflow/tensorflow/blob/master/tensorflow/examples/udacity/1_notmnist.ipynb, and after importing the data I'd like to try ...
0
votes
0answers
37 views

Why is the network unreachable whenever I don't use avahi-autoipd

I'm building a mobile mesh server and whenever I attempt to send broadcasts (shortest path determination), in python3, it fails. I run the following shell commands on both devices (currently ...
0
votes
0answers
103 views

Could not find suitable distribution for Requirement.parse('l2cs>=2.0.2')

I get an error on Ubuntu 14.04 Searching for l2cs>=2.0.2 Reading https://pypi.python.org/simple/l2cs/ No local packages or download links found for l2cs>=2.0.2 error: Could not find suitable ...
0
votes
0answers
84 views

Problem in gst mad in Ubuntu 16.04

Developed a software in python which uses Gstreamer for the working. We installed it and work on ubuntu 15.10. For that installed some components like libmad0-dev, libmadlib-dev and gstreamer0.1*. ...
0
votes
0answers
36 views

Getting this error :Sub-process /usr/bin/dpkg returned an error code (1) when I try to run sudo apt-get install python-matplotlib

I tried installing matplotlib, to make graphs on python on Ubuntu 14.04 and am getting the following error. I am unable to resolve this error: (env)ubuntu@ubuntu-Inspiron-5423:~/tweepy$ sudo apt-get ...
0
votes
0answers
24 views

Dependency problem

I use Ubuntu on my offline laptop. Since I want to install python, I have to install a lot of dependencies as well, and to install those dependencies I need even more dependencies of the dependencies....
0
votes
0answers
49 views

How to install and run qt-designer for python

I'm new to ubuntu, I entered the following commands sudo apt-get install python-pyqt and sudo apt-get install qt-designer. Both the commands executed successfuly but I'm not able to figure out how to ...
0
votes
0answers
48 views

Electrum on Ubuntu 12.04 LTS Offline Computer

I am a ubuntu newbie and want to run Electrum Bitcoin Wallet on an always offline Ubuntu Laptop. The instruction is: Install dependencies: sudo apt-get install python-qt4 python-pip Install ...
0
votes
0answers
82 views

How I can install regex package for python 3.4 without errors?

I have a little problem (or a big one?). I want to install regex package for Python 3.4. But then I use pip or our installation methods I am getting error: universe@universe-AOD270:~/Downloads/...
0
votes
0answers
26 views

How to run EasyModeller (GUI for Modeller) on Ubuntu 14 x64?

I have successfully installed Modeller. I want to try to use the front end GUI software EasyModeller. However, when I try to run it I receive the error message as follows: user@pc:~/Downloads/...
0
votes
0answers
46 views

OS error permission denied

I'm trying to execute a python script but I'm getting an OSError saying “Permission denied”. I tried to change the permissions of the temp folder by sudo chmod 777 -R temp but it did not work here ...
0
votes
0answers
55 views

Can't edit a file in Ubunutu 14.04

I'm trying to edit a python file called resize.py /usr/local/lib/python3.4/dist-packages/moviepy/video/fx/resize.py I gave myself permissions to unlock the file using sudo chmod 776 /usr/local/...
0
votes
0answers
24 views

How to use python 2.6.?.? for Ubuntu 14.04.03 as a default python and gnome and server should update?

Our requirement is very simple. And we need help regarding it on How to update after removing python 2.7.? or higher version and install 2.6.? as default one? Because when I do this the it stops ...
0
votes
0answers
30 views

problem with installing mysql-server5.5 with ubuntu12.04, socket file not found

I am trying to create a database in ubuntu 12.04 after installing mysql-server5.5 but I got the following problem. after checking it seems the subfolder var\run\mysqld that should contain the socket ...
0
votes
0answers
57 views

Running a Python script on an apache2 version 2.4 server

I have a python script (python.py) located in the /var/www/html/Python folder. The script saves some images to another directory (/var/www/html/Data). I have the x file permission on the python.py ...
0
votes
0answers
19 views

Can use a custom notification daemon for my own different notifications in my app?

I want to use a notification bubble that allows clickable buttons inside it (for a media player), but the default notify-osd/notify-send does not allow that (or is limited). Can i use other ...
0
votes
0answers
140 views

How to make python script executable upon double-click?

I have tried ticking the execute as application box in properties but still doesn't execute. I want the program to run when I double-click instead of opening the code in gedit. Any suggestions?
0
votes
0answers
40 views

How do I uninstall python2.7 on 15.10?

I have 2 versions of python installed on my computer, not using pythonbrew but as 2 seperate packages (2.7 as python and 3.5 as python3), I'd like to remove 2.7 and reinstall 3.5 because this causes ...
0
votes
0answers
31 views

How can I start a job of a python script from a .desktop file?

I have created following .desktop file to start a python program (uses tkinter if this is relevant): [Desktop Entry] Type=Application Name=Program Icon=utilities-terminal Exec=gnome-terminal -e "bash ...
0
votes
0answers
26 views

Where are pyqt4 modules

Beginning to study pyqt. I have PyQt4 somewhere in my directories. I would like to know where, which directory. Also where is exit.png, exit24.png stored?
0
votes
0answers
88 views

how we install pillow in virtualenv in ubuntu 14.04

Please include code that reproduces the issue and whenever possible, an image that demonstrates the issue. The best reproductions are self-contained scripts with minimal dependencies. I create one ...
0
votes
0answers
586 views

Caravel installation failed

sudo pip install Caravel > x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall > -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -...
0
votes
0answers
54 views

how to update python version of spark to python 3.0 on ubuntu

I install spark on my ubuntu, and I have already update python to python3. And also alias python=python3 in ~/.bash_aliasesfile. But when I start spark under pyspark, it always display the version of ...
0
votes
0answers
70 views

Importing Gedit from gi.repository with Python3.4

I'm using Ubuntu 15.10. I have the following problem: When I wrote the following line in the Python2.7 console: from gi.repository import Gedit Everything happens as it should and Python IDLE 2.7 ...
0
votes
0answers
89 views

How to fix error executing djangocms -p in virtualenv …exit code 2 ..?

As I am new to djangocms. I am unable to figure out how to fix this. Please help. command I executed : mkvirtualenv mordern_business pip install djangocms-installer djangocms -p modern_business ...
0
votes
0answers
197 views

Pyinstaller in Wine leads to: ImportError: No module named pkg_resources

I'm trying to follow instructions here to create a windows .exe from my pyqt4 project created in pycharm from Ubuntu 14.04 Everything seems to work until the last step: cornelis@Bob:~/Downloads$ ...
0
votes
0answers
61 views

How to create a portable Python?

Is it possible to install Python (the Python interpreter together with some of the dependencies it needs to run) into a folder on the users home directory or a usb drive and move this installation ...
0
votes
0answers
66 views

Libreoffice unoconv hangs when conversion process started

I am working on an application, in which I am using unoconv for converting ppt and doc files. It is working on localhost, where I have an X server, but on ubuntu-server, it hangs up. As I read on the ...
0
votes
0answers
70 views

IO Error: 32:Broken pipe , popen

I have a simple python script which installs mono-complete on machine. but what I observed is my first call always fail with error IO Error: 32:Broken pipe here is my script, I am not sure what is ...
0
votes
0answers
280 views

How to install pip and django for python 3.5

I have 3 versions of python that are 2.7, 3.4 and 3.5. I have set by default python version 3.5 in my terminal setting. But when I installed the pip3 and djanago it both gone into python 3.4 dist ...
0
votes
0answers
117 views

I tried to install the igraph package in ubuntu 14.04 using the following command

I tried to install the igraph package in ubuntu 14.04 using the following command pip install --user python-igraph After several processes I'm getting something like this Extracting igraph-0.7.1....
0
votes
0answers
18 views

Blender crashes on entering sculp mode on 12+(?) ubuntu

I think I once posted this long ago, but then it was either taken down or I deleted, since I found a way around it. I had hoped it would go away in time, but it didn't... So, the exact same version of ...
0
votes
0answers
51 views

problem building X86 for gem5

development Environment ubuntu 14.04 kernel version 4.4.3 Dear gem5 and ubuntu users, After downloading gem5, I executed the following commands and everything went well: ("in /usr/src/gem5/" ...
0
votes
0answers
54 views

How to add asynchronous subprocess call for Python Gtk Glade Button on_click method?

I am new to Python and Gtk. I have created an ubuntu application using Quickly-create. I have added a button to run the adb pull command for my rooted android phone. I wish to add a spinner which will ...
0
votes
0answers
87 views

Attempting to uninstall and reconfigure pygame for python 3.4.4 or Ubuntu 14.04

First off I want to mention I'm a scrub with ubuntu. Also I am a bit unsure if my python version is 3.4.4, but that is what it sais on my tgz file when I search for it, so I think that is correct. I'...
0
votes
0answers
181 views

Unsupported machine type Use -machine help to list supported machines

I am trying to create virtual machine on ubuntu 15.10 using virtual machine manager i have installed kvm but when i use display vnc for virtual machine it shows the following error and when i use ...
0
votes
0answers
51 views

packages 'not yet configured' - how should I solve this?

Ok, I have to rephrase my question. I'm not able to install packages because a bunch of them have apparently been installed, but not configured. When I try to configure them, however, the dependency ...