Python is an interpreted programming language that is often, but not solely, used as a scripting language. A version of Python is included by default on all Ubuntu distributions.

learn more… | top users | synonyms

0
votes
1answer
92 views

error: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

I ran the following commands in the terminal for a 14.04 Ubuntu server $ cd reddit/r2 $ python setup.py build $ sudo python setup.py develop After the last line I get an error, please see bellow ...
0
votes
0answers
90 views

Could not find suitable distribution for Requirement.parse('l2cs>=2.0.2')

I get an error on Ubuntu 14.04 Searching for l2cs>=2.0.2 Reading https://pypi.python.org/simple/l2cs/ No local packages or download links found for l2cs>=2.0.2 error: Could not find suitable ...
1
vote
1answer
339 views

pip3 install of jupyter issues: 'notebook' is not a Jupyter command

I'm running Ubuntu 16.04 and installed jupyter using pip3 install jupyter as described on the jupyter.org website. The install appeared to work without issue. There were no missing zeromq references ...
3
votes
2answers
15k views

Python 2.7.6 on Ubuntu 12.04 How to?

I'm developer and I need to make my enviroment work with Python 2.7.6 (not 2.7.3) on the Ubuntu 12.04. Please, provide me some notes how to do that?
5
votes
1answer
360 views

Does pip overwrite packages installed by apt-get?

What happens if I accidentally pip install a package that I already installed using apt-get beforehand? Do I simply get to use the latest version (i.e. probably the one I installed using pip)? What ...
2
votes
2answers
2k views

Ubuntu 16.04 VIM without python support!

Although Ubuntu 16.04 release notes mention that: The default VIM package has been built against python3 instead of python2. Yet after I installed vim with the following command: sudo apt-get ...
0
votes
0answers
27 views

Why is the network unreachable whenever I don't use avahi-autoipd

I'm building a mobile mesh server and whenever I attempt to send broadcasts (shortest path determination), in python3, it fails. I run the following shell commands on both devices (currently ...
0
votes
0answers
65 views

Problem in gst mad in Ubuntu 16.04

Developed a software in python which uses Gstreamer for the working. We installed it and work on ubuntu 15.10. For that installed some components like libmad0-dev, libmadlib-dev and gstreamer0.1*. ...
0
votes
0answers
24 views

Dependency problem

I use Ubuntu on my offline laptop. Since I want to install python, I have to install a lot of dependencies as well, and to install those dependencies I need even more dependencies of the dependencies....
1
vote
0answers
31 views

YouCompleteMe plugin of VIM not working with NLTK

I have recently installed the YouCompleteMe plugin for vim through Vundle. It works really well for Python. Problem starts when I import the third party library nltk. For example if I do the following ...
2
votes
4answers
13k views

Bash cut and grep commands through python

I've tried to read a txt file and find the lines which contain a certain word "checkout_revision". I want to find these lines one by one in a for loop and store them in my variable, let say temp. I ...
0
votes
0answers
30 views

Getting this error :Sub-process /usr/bin/dpkg returned an error code (1) when I try to run sudo apt-get install python-matplotlib

I tried installing matplotlib, to make graphs on python on Ubuntu 14.04 and am getting the following error. I am unable to resolve this error: (env)ubuntu@ubuntu-Inspiron-5423:~/tweepy$ sudo apt-get ...
5
votes
1answer
35k views

How can I install python-dev off apt-get?

I have tried this and this and this and this Well nothing works with me, i got my amd64 system, 14.04 up and runnig, as I try to install wagtail, a django cms, i get the error. pysass.c:4:20: ...
8
votes
1answer
16k views

Upgrading to python 2.7.5 on Ubuntu 12.04

Ubuntu 12.04 comes with python v 2.7.3 by default. I want to upgrade it to v 2.7.5. I tried the instructions given in this question, sudo apt-get install build-essential sudo apt-get install ...
0
votes
1answer
50 views

pyhton-pkcs11 package in 16.04

I see that pyhton-pkcs11 isn't included in 16.04 repositories. Only pyhton3-pkcs11. Is there any way to install Python2 package version ?
-1
votes
1answer
67 views

importerror: no module named bootstrap3_datetime

While runing "python manage.py migrate" i got error "importerror: no module named bootstrap3_datetime" but in my pip freeze it is installed. django-bootstrap3==7.0.1
5
votes
2answers
14k views

How to play a fixed frequency sound using Python

I have tried a number of ways of playing a fixed frequency sound (e.g. 1000Hz) and nothing works. I have downloaded "beep" and that makes no noise. I tried interfacing to pyao, and that had no ...
1
vote
0answers
79 views

How to install wxpython for virtualenv

I am on 14.04. The system python version is 2.7.6. I am testing a software meant for python 2.7.9. So I have a virtualenv running python 2.7.9. Running this pip install wxpython doesn't work. So I ...
0
votes
1answer
209 views

ImportError: No module named 'PyQt5.QtWebEngineWidgets'

I try to run a python script using PyQt5 QtWebEngineWidgets but it throws errors: from PyQt5.QtWebEngineWidgets import ( ImportError: No module named 'PyQt5.QtWebEngineWidgets' I think there is a ...
2
votes
0answers
117 views

Snapcraft Python2 building numpy with python-dev

just starting to get my hands dirty with snappy. I am trying to port a python project to a snappy app. The python code relies on numpy 1.5.1, which relies on python-dev being installed. My snapcraft ...
0
votes
0answers
31 views

How to install and run qt-designer for python

I'm new to ubuntu, I entered the following commands sudo apt-get install python-pyqt and sudo apt-get install qt-designer. Both the commands executed successfuly but I'm not able to figure out how to ...
0
votes
0answers
42 views

Electrum on Ubuntu 12.04 LTS Offline Computer

I am a ubuntu newbie and want to run Electrum Bitcoin Wallet on an always offline Ubuntu Laptop. The instruction is: Install dependencies: sudo apt-get install python-qt4 python-pip Install ...
0
votes
1answer
231 views

Install python 2.7.11 on Ubuntu without compiling or replacing the pre-installed version

I'm using Ubuntu trusty which comes with python 2.7.6 pre-installed. I need to install 2.7.11 in like /usr/local/bin/python without touching /usr/bin/python or compiling from source. There are some ...
-1
votes
1answer
86 views

force to use Python 3 [duplicate]

i want to port Python Scripts to python 3. How can i force Ubuntu to use python 3 instead of python 2 which is installed, as well. Due to the size of the project, i'd prefer not to write something ...
0
votes
0answers
52 views

How I can install regex package for python 3.4 without errors?

I have a little problem (or a big one?). I want to install regex package for Python 3.4. But then I use pip or our installation methods I am getting error: universe@universe-AOD270:~/Downloads/...
0
votes
2answers
163 views

Use pip with Python 3.5

I have a AWS Ubuntu instance where I manually installed Python3.5 (downloaded it, configured, and ran make, make install). Then I changed the symbolic link sudo ln -fs /opt/python3.5/bin/python3.5 /...
1
vote
1answer
317 views

Python NameError: global name 'resolution' is not defined

I'm working on developing a python application for Ubuntu that enables a user to have their desired resolution without requiring graphics drivers. In order to do this I've been using xrandr. However ...
1
vote
1answer
154 views

How to get pip functional again?

I ran into the issue below, while running pip trying to install rpyc. Even if i try to run pip without any arguments it still outputs the same error. Any help would be greatly appriciated, Thanks. ...
0
votes
0answers
21 views

How to run EasyModeller (GUI for Modeller) on Ubuntu 14 x64?

I have successfully installed Modeller. I want to try to use the front end GUI software EasyModeller. However, when I try to run it I receive the error message as follows: user@pc:~/Downloads/...
1
vote
2answers
49 views

How to create a debian/control file that differs based on Ubuntu release?

I have great deal of source code that we maintain, producing many different Ubuntu packages. All of these packages need to build on Ubuntu LTS releases from 08.04 forward. (Yes, I know these are old ...
0
votes
2answers
1k views

Django 1.8 gets installed in Python 2.7 instead of Python 3.4

I have to versions of Python installed, 2.7 and 3.4. I installed Django 1.8 as recommended on the Django tutorial. However it got installed in Python 2.7 instead of Python 3.4 so when I type 'import ...
7
votes
2answers
2k views

do-release-upgrade: python install is corrupted

I was upgrading from 13.10 to 14.04 (dev for now, stable in a few hours) using do-release-upgrade and encountered the following problem: Can not upgrade Your python install is corrupted. Please fix ...
10
votes
3answers
983 views

How to run a Python program directly?

How to run a Python program directly? I have created a .py file (say, mnik.py) in gedit. It runs smoothly in terminal. Command goes python3 mnik.py But whenever I click on the file it is opened ...
0
votes
1answer
556 views

How to install wxpython ubuntu 16.04

I have a problem with playonlinx, and it requires me to install wxpython, but I have it already installed. I've used different methods, but every-time I do import wx, it gives me this error: ...
1
vote
1answer
3k views

Has anybody got access to a H264-stream of an IP-Cam over SimpleCV?

I wonder if it's possible to get access of the H264-encoded mainstream of my Hikvision IP-cam DS-2CD2032-I over SimpleCV. The H264-stream I got in the browser is rtsp://192.168.1.199:554/ISAPI/...
1
vote
0answers
162 views

Problems after installing Python 3.5.1

I installed Ubuntu 16.04 completely now on my machine aswell as the newest Python version (3.5.1). now i have problems with following packages: python-cairo python-gobject-2 python-pip python-pkg-...
0
votes
0answers
18 views

Change back default python in ubuntu 12.04 [duplicate]

My default python version on my Ubuntu 12.04 is python 3. I remember, a long time ago, I asked someone to change the default python version to 3. I didn't really do a lot, so I had no problems. But ...
1
vote
2answers
226 views

Error installing Django

I have try to run this command and get a error easy_install Django (django-mike)zapbuild@jaskaran:~/Documents/python/django-mike$ easy_install Django error: can't create or remove files in install ...
15
votes
2answers
3k views

Putting an arbitrary gtk.Widget into an appindicator.Indicator

Putting any gtk.Widget inside a gtk.Menu works, somewhat, by putting an empty gtk.MenuItem in first. It doesn't seem to be reliable - but it basically works. With an appindicator.Indicator, it doesn't ...
1
vote
0answers
19 views

Python in terminal- Trying to use ''erase'' and it writes more

im really new to both Ubuntu and trying to learn to use python. Ive just installed python. When i start python in terminal "python3.5" my keys are adding more when i try to erase text. When i try to ...
0
votes
1answer
68 views

uninstall python 2.7.6 and install 2.6 instead

I need to uninstall python 2.7.6 and install 2.6 instead. how can I manage that. which python command gives (/usr/bin/python). my environment is ubuntu 14.04.
0
votes
0answers
52 views

Can't edit a file in Ubunutu 14.04

I'm trying to edit a python file called resize.py /usr/local/lib/python3.4/dist-packages/moviepy/video/fx/resize.py I gave myself permissions to unlock the file using sudo chmod 776 /usr/local/...
0
votes
1answer
536 views

How to remove Python 2 in 16.04?

Ubuntu has dropped Python 2 in 16.04. It is still installed after an upgrade, though (it was not part of the "obsolete packages"). Is there a clean way to remove Python 2 and all its dependencies in ...
0
votes
2answers
852 views

Django and SQLite3 doesn't work

My problem is following, I'm starting with tutorial https://docs.djangoproject.com/en/1.8/intro/tutorial01/ , and after I type in terminal python manage.py runserver I'm getting an error: Traceback (...
1
vote
2answers
44 views

Compiling python3 code in terminal with interpreter [closed]

When I compile my code simply with the command python3 name.py, it's being run, but then the whole story ends and I can't do anything with the compiled data. I want to somehow compile my program to ...
1
vote
1answer
56 views

shell script storing run time with python

I am trying to store the run time of a python program using this { time python experiments.py --model iwae --k $k ; } 2> time$k.txt when I do this in a shell script, I get 40.35user 3.12system ...
0
votes
1answer
54 views

How can I install a newer python on Trusty?

I'd like to install a newer python 2.7 on trusty. Installing "python" installs python 2.7. The newest version available on trusty is 2.7.6. I'd like to install the most updated version of 2.7. I am ...
0
votes
0answers
19 views

How to use python 2.6.?.? for Ubuntu 14.04.03 as a default python and gnome and server should update?

Our requirement is very simple. And we need help regarding it on How to update after removing python 2.7.? or higher version and install 2.6.? as default one? Because when I do this the it stops ...
0
votes
0answers
29 views

problem with installing mysql-server5.5 with ubuntu12.04, socket file not found

I am trying to create a database in ubuntu 12.04 after installing mysql-server5.5 but I got the following problem. after checking it seems the subfolder var\run\mysqld that should contain the socket ...
0
votes
2answers
30 views

Problem to compile python and C++ code using ubuntu Ubuntu 12.04.5 LTS: problem with gcc

I am trying to compile a code involving python and C++ in Ubuntu 12.04.5 LTS and I have this type of error hammouc@kw13921:~/Documents/mimclib$ make python setup.py clean running clean removing '...