Python is an interpreted programming language that is often, but not solely, used as a scripting language. A version of Python is included by default on all Ubuntu distributions.

learn more… | top users | synonyms

14
votes
1answer
2k views

Putting an arbitrary gtk.Widget into an appindicator.Indicator

Putting any gtk.Widget inside a gtk.Menu works, somewhat, by putting an empty gtk.MenuItem in first. It doesn't seem to be reliable - but it basically works. With an appindicator.Indicator, it doesn't ...
1
vote
0answers
617 views

Cx_freeze - How can I Install the shared libraries to /usr/lib [closed]

I am using cx_freeze to compile my python script and when I compile the program, all the files are placed in one specified folder. The executable wont run if the shared libs are not within the same ...
1
vote
1answer
446 views

Accessing googlecl using python script

I am trying to create a python gtk program which uses googlecl tools like listing google calendar appointments, accessing the google blog etc. However I do not know how to call the command in python ...
15
votes
1answer
3k views

How can I write Nautilus scripts in Python?

I want to write a Nautilus script in Python. Is that possible? If it is possible, how can I do that?
11
votes
3answers
20k views

How do I make the terminal run python 3.1?

Currently, when I type "python" at the terminal I get v2.6 which is all fine and dandy but how can I set it to use v3.1 instead? Is there a "path" variable out there somewhere that I can change like ...
3
votes
1answer
373 views

Can't launch CoverGloobus: ImportError

I installed CoverGloobus on my ubuntu 10.10. But every time I try to run it, I get this error: [WARNING] Using default configuration Traceback (most recent call last): File ...
4
votes
3answers
137 views

What is the right way to reinstall from source after package was installed via apt?

I have a python package previously installed via apt(by default). Now I want to install new version and compile it manually from the sources with all the required modules. How can I do that? I ...
18
votes
4answers
4k views

How to program a status icon that will display in Ubuntu as well as in other distributions?

The application in question does some action (here connecting audio to network streams) and runs minimized if these actions were successful. Therefore a status icon is needed to display the state of ...
5
votes
1answer
2k views

Installing Python 2.4 for development?

I have a VM of Ubuntu 10.10 x86, and I need to build a Mercurial installation against Python 2.4. I have to do this because the web host I am working on has Python 2.4 as the latest copy of Python. ...
4
votes
1answer
321 views

Trouble setting language

I am really struggling with this language issue. I went to System->Administration->Language Support and moved Turkish (Türkçe) to the top. Then I clicked "Apply System-wide" and restarted. ...
5
votes
2answers
3k views

How do I setup gunicorn?

Upstart doesn't like to start gunicorn because it tries to call setpgrp (see github issue), what would be the best way to start [gunicorn] on a 10.04.1 server install? - Ideally with automatic ...
3
votes
3answers
535 views

Python 3 error when running the print command

All I wrote in the interpreter was as follows: >>> print "Hello, World!" File "<stdin>", line 1 print "Hello, World!" ^ SyntaxError: invalid syntax How ...
7
votes
1answer
3k views

How can I play a system sound with Python?

I am writing a small reminder-app and want to play a system sound once the timer has reached 0. What is the easiest way to play that sound, and which sound would you recommend?
15
votes
3answers
3k views

Why does Ubuntu use Python 2.6 and not 3.X?

I have recently started learning Python and thus have learned that Ubuntu (10.10) uses Python 2.6. It seems to me that Python 3.X is still rather unpopular in the Linux/Ubuntu community. Why is that? ...
3
votes
1answer
833 views

Compile Mercurial

I'm trying to install latest version of Mercurial (1.6.4) into my Ubuntu 10.10 but I'm getting this error when I do "make install": Couldn't import standard zlib (incomplete Python install) Worth ...
1
vote
1answer
846 views

How to make WINE be quiet about MSVCR errors?

I downloaded the Python 2.7 MSI installer for Windows and proceeded to install it with Wine. It worked without any problems. However, running wine python.exe leads to a whole bunch of these errors: ...
1
vote
2answers
692 views

A complete free guide for game development in Python or C# [closed]

That's what i know: C#; Python; What is OpenGl; What is SDL (barely); Now i'd like to make a sketch for a 2D platform game ( i.e. a ball that has to avoid some obstacles till reaches the end of ...
6
votes
3answers
501 views

How do I integrate an application in the sound menu using python?

I don't necessarily expect a whole tutorial for creating a sound indicator entry here on askubuntu, but I've searched and searched, and I can't seem to find any documentation on creating a sound ...
7
votes
2answers
430 views

How do I control the position of an indicator created with appindicator.Indicator?

I've created a simple indicator in python using the appindicator module. However, it always shows up to the left of the existing indicators. Is there some way to control what position the indicators ...
5
votes
2answers
7k views

How to call a number from command-line with Skype?

I've seen several links suggesting it is possible to make a call from the command-line with skype. The instructions suggest something along the lines of: skype --callto:+14445551234 However, this ...
24
votes
2answers
12k views

What's the best way to get Python 2.5 and 2.7

Ubuntu 10.04 has only two supported Python versions 2.6 and 3.1. Developers often need more, to test that their Python code works on 2.7, 2.5 (and maybe even 2.4 and older ones). What's the best way ...
5
votes
2answers
337 views

Drag forward installed Python packages when upgrading

As somebody who runs multiple webservers each running a set of Django sites, keeping on top of my Python stack is very important. Out of (probably bad) habit, I rely on Ubuntu for a number of my ...
1
vote
1answer
756 views

Debugging python memory leaks [closed]

I'm trying to debug a memory leak in telepathy-butterfly. I tried to use valgrind, but Empathy does not connect to MSN when telepathy-butterfly is run this way. So, I figured out the only option left ...
12
votes
3answers
4k views

How to use Rhythmbox python console

Maybe this is obvious and I am missing it, or maybe someone's already written a great guide and my (seeming exhaustive) googling is failing to turn it up, but I cannot figure out for the life of me ...
6
votes
2answers
5k views

What is the default character encoding?

I don't myself know how deep this question actually goes (for example, for all I know there could be several, depending on my task). Particularly, I am interested in what kinds of strings are used to ...
2
votes
3answers
1k views

How to create clickable notifications using pynotify?

Is it possible to show notifications displayed in right top (like these about being connected to a wifi), that can be clicked? Right now I can either create a notification, that can't be clicked or ...
3
votes
2answers
592 views

Is there a simple way to get Django 1.2.* (latest stable) installed?

I want to start developing for it. I could easy_install or pip install but I'd prefer a proper repo. Is there a PPA that's up to date?
3
votes
4answers
792 views

Setting up a build system for Python app

In trying to sort out this issue, I have run into the following problem. I have a Python script that gets installed to /usr/lib/. But I need to get this script into a build system so that I can get ...
4
votes
1answer
196 views

Trouble creating a package for my PPA

So I tried following the steps here to create a package to upload to my PPA. I ran dh_make and edited the files. However, when my package gets generated by debuild, none of the programs files show up ...