Python is an interpreted programming language that is often, but not solely, used as a scripting language. A version of Python is included by default on all Ubuntu distributions.

learn more… | top users | synonyms

0
votes
0answers
25 views

Quickly version numbering

I have been experimenting with quickly, and more specifically, packaging. I have been using this command: quickly create I am quickly (heh heh get it, 'quickly') getting frustrated that the version ...
0
votes
0answers
96 views

power down happened during version upgrading

While upgrading from Ubuntu 13.10 to 14.04 unfortunately a power down happened and the PC got powered off. When again booted, I was neither able to upgrade version nor install any software through ...
0
votes
0answers
437 views

fresh install, python-software-properties unmet dependencies

attention: This might be more a question for "gis.stackexchange" but it is Ubuntu-related Geonode 2.0 is available for Ubuntu 12.04 but not for Ubuntu 14.04. According to the docs it should be ...
0
votes
0answers
53 views

anki issues how to make work

Hi further to my question ealrier Below is the error message I get from my computer when I try to use Anki (2.0.28) Today, I have ascertained that it is my computer and not the files for anki which ...
0
votes
0answers
131 views

Error processing package mumble-django

Everytime when i try to install update from the terminal this error is displayed. How do I sort it out? Setting up mumble-django (2.10-2) ... dpkg: error processing package mumble-django ...
0
votes
0answers
48 views

Samsung tv serial commands with python

I have a Samsung Plasma display that I use a Python script to turn on and off with its serial interface. (ex-link). import time, serial ser = serial.Serial(port='/dev/ttyUSB0', baudrate=9600, ...
0
votes
0answers
75 views

Configuration error for pep8 and flymake for emacs

I am trying to configure pep8 to ignore E221, E222, and E226 (all related to spacing around operators). I followed this documentation https://pep8.readthedocs.org/en/1.4.6/intro.html to generate a ...
0
votes
0answers
162 views

python download just mp3 from youtube

I want just to download mp3 tracks from youtube, I know that services like youtube-dl download first an .mp4 and then they convert it. Is it possible to download just a .mp3 in a 256 kb/s format? If ...
0
votes
0answers
150 views

Unable to install bsddb185, Python library for opening Berkeley DB version 1.85 files on Ubuntu

I am writing a python program that makes use of some legacy Berkeley DB 1.85 files. Unfortunately I am unable to install the bsddb185 Python package, either for Python version 2.x and for Python 3. ...
0
votes
0answers
31 views

Why doesn't 'launcher.set_property(“urgent”, True)' work?

My script: #!/usr/bin/python # update bar on dash icon by stdin # ex: for i in {0..100};do echo "$i";sleep 0.3;done | ./$0 import sys, time from gi.repository import Unity, Gio, GObject, Dbusmenu ...
0
votes
0answers
56 views

How to create an installer for a python GTK3 application?

I have just finished developing a Python 2.7 application using Gtk3 for GUI. My question is, how can I now create an installer for Windows, Mac, and Linux (possibly three different installers) for my ...
0
votes
0answers
300 views

Cannot compile GDB7.8 with Python support

I am trying to install GDB7.8 with Python support. From the source folder, I am running ./configure --with-python When I did tab-complete from --with- I did not see Python in the list. But when I ran ...
0
votes
0answers
65 views

By mistake I removed Python. Terminal, music player, video player, Software Center etc. are gone

I work on Ubuntu 14.04 to install Python and other packages I entered the following command : sudo apt-get install python python-pip python-pyparsing python-mysqldb gunicorn nginx git-core ipython ...
0
votes
0answers
27 views

Packaging using Quickly and Python 3

I have written an application using Quickly with Python 3. I have adjusted everything necessary for running with Python 3, converted headers to #!/usr/bin/python3, fixed helpers.py, etc. But when I ...
0
votes
0answers
72 views

I'm receiving a GDB test error installing Python 3.4.1 on 14.04

I'm trying to create a VirtualBox VM with Ubuntu 14.04 and Python 3.4.1. I've downloaded the source https://www.python.org/ftp/python/3.4.1/Python-3.4.1.tgz And I've updated OpenSSL to resolve a ...
0
votes
0answers
14 views

ubuntu 12.4 starts with a balch window agter installing kivi

Iam running ubuntu 12.4 in dual boot with windows 7 on my machine .I installed kivi (with ubuntu), and when I just have rebooted the machine , ubuntu starts with a balck window .I tyed the recovery ...
0
votes
0answers
62 views

upgrade to 14.04 broken: python error: NameError: name 'MAGIC' is not defined

my release upgrade is broken, shows following error related to python: http://www.pasteall.org/53013 My all python versions are: python python2.7 python3.3 python3m python2 python3 ...
0
votes
0answers
148 views

gdb uses python3.3

Currently in Ubuntu 14.04 it seems that gdb uses Python 3. I'd like to downgrade to using the gdb version that uses Python2. Is there any way I could go about doing that easily?
0
votes
0answers
201 views

Install Scipy at virtualenv

I asked a question a few days back, on how to run an older version of matplotlib and I got an amazing answer back. What I had to do was to execute these commands: mkdir matplotlib_1.1.1 cd ...
0
votes
0answers
330 views

Install pygame in anaconda

I have anaconda on Ubuntu 14.04. I want to install the pygame module with anaconda. I already run sudo apt-get install python-pygame, but this only works on python, not in anaconda.
0
votes
0answers
78 views

Untrusted Package Errors when installing Okular and ACE Stream

Whenever I try to install a new application, I get 'Untrusted Package Errors'. For example, at the moment I'm trying to install 'Okular', but I keep getting an Untrusted Package Error upon ...
0
votes
0answers
60 views

multiple connection pycurl ppp0 and ppp1

I have already looked at this question Dialing into multiple PPP connections and it's working well but multiple connections are not available if I'm adding table ppp0, the other ppp1 cant connect ...
0
votes
0answers
112 views

I need someone to go through my conky scripts and correct my mistakes

I modified some conky scripts that I downloaded online. I cant quite figure out how to make the rss feed run. I tried two methods to get the rss feed - the rss command in conky (used in dinamalar ...
0
votes
0answers
12 views

Qiime softwares not recognized by PHP. How to configure extentions for it?

I have a script in bash that calls some python functions installed from Qiime packge. I put a echo "end of bash script" only for control. If I call this bash script from terminal it works good. But ...
0
votes
0answers
68 views

Run Twisted server on startup

I am pretty new to Ubuntu and tried to install portia according to this howto: https://github.com/scrapinghub/portia#running-portia Everything worked fine after I run the command twistd -n slyd. I ...
0
votes
0answers
63 views

configure python and cvblob

Hi I'm trying to configure cvblob in order to use it with python ,using the explanition h here but when i came to test it i got this error: ...
0
votes
0answers
19 views

Error while trying to run Pycocuma Contact Management program

I need help understanding this message! mainctrl = MainController() File "/usr/lib/python2.7/dist-packages/pycocumalib/MainController.py", line 79, in __init__ self.view = view = ...
0
votes
0answers
55 views

Bash if password filled save it

I am trying to save a password to gnome keyring via python script. The python script will be runned from bash script if password is filled in zenity GUI. Example: User inserts hes/hers password to ...
0
votes
0answers
65 views

xdot python script for viewing graphs generated by graphviz is not working on ubuntu 14.04

After upgrading my system to ubuntu 14.04 i am not able to open graphs generated by graphviz using xdot. Prior to that i was using ubuntu 12.04 and there was no problem of such sort observed. below is ...
0
votes
0answers
25 views

How to install pythoncard?(any alternate method)

How to install pythoncard?I have tried browsing the software center for it and I installed it,but when I run a pythoncard-based program,it shows me that there is no module named pythoncard.Can I ...
0
votes
0answers
45 views

Django chmod using wrong user:group

I have installed django and some other services to start up one front-end community forum. However i've managed to do it everythings run but i have problem with CHMOD permissions. My nginx server ...
0
votes
0answers
261 views

After starting upgrade to Ubuntu 14.04 and reverting to 13.10, eclipse pydev debugger stopped working

I started the upgrade to UBuntu 14.04, but it failed and the system reverted back to old settings. I have been convinced to stay with 13.10 for now. However, when running python code in eclipse with ...
0
votes
0answers
183 views

/usr/bin/ld: error: cannot find -lpython2.7

While installing pyscard.py I get this error, gcc -pthread -shared -Wl,-rpath,$ORIGIN/../lib -g -L/home/builder/jenkins/workspace/Python_Masters/ARCH/x86_64/label/Linux/core/lib ...
0
votes
0answers
132 views

system-config-samba and galternatives won't work on Trusty with similar errors

Fresh installed Trusty, then I installed two programs I always use, galternatives and system-config-samba. They both fail with similar output: system-config-samba output: gksu system-config-samba ...
0
votes
0answers
84 views

ninja ide programming python 2.x and 3.x

is it possible to program python 2.x and 3.x with Ninja IDE? if so, where do I specify which version I'm currently using? thanks peeps edit: actually, it seems that in the same file, ninja ide ...
0
votes
0answers
43 views

Multiple button clicked signals emitted for a single click

Writing a cut/copy/paste feature for a simple filebrowser in gtk. Every cut/copy button/paste click emits a progressively higher number of signals . Here is the part of the program that deals with ...
0
votes
0answers
191 views

Issues with python-pip and speedtest-cli

dpkg: error processing python-pkg-resources (--configure): subprocess installed post-installation script returned error exit status 137 dpkg: dependency problems prevent configuration of ...
0
votes
0answers
117 views

install 64 bit mysql

I had installed mysql by using below command. sudo apt-get install mysql-server But this a 32-bit mysql installation. i want to install 64-bit mysql. Please advice me how to delete 32bit mysql and ...
0
votes
0answers
45 views

MySQLdb on Brython?

Hi there I'm working on a server-based point of sale for a sports club, and downloaded Mysqldb lib so that I can access and modify it through python scripts, they work great!, so I decided to use ...
0
votes
0answers
110 views

tesseract OCR Engine reorganization problem

i'm trying to use 'tesseract' on JPG image's. its seems that it doesnt recognize the number's and character's in the command-line currently. but when i use OCRFeeder manually and select the bounds ...
0
votes
0answers
221 views

OpenERP server problem message when installing an app

I recently installed open erp v7 on ubuntu 13.10, I could install the warehouse app fine, as well as the sales app , but I'm having trouble installing a few other apps. It looks like it is either a ...
0
votes
0answers
19 views

itunes2rhythm python3 script errors

while trying to run this script https://github.com/guillier/itunes2rhythm in python3 i am getting multiple errors about localhost blah blah. I think what is happening is that the library file is ...
0
votes
0answers
37 views

Create tab using Gtk+3 and Python and load file into it

I want to create an Ubuntu app using Gtk+3 and Python. In the app I want to be able to get the file from the user; create a tab and load the file into it (i.e. into the TextView that will be ...
0
votes
0answers
40 views

Launch a new window from Gtk+3 app

I want to create an Ubuntu app using Python and Gtk+3. I want to get the contents of the file displayed in the main window and load it into a separate window (load it into another TextView for ...
0
votes
0answers
223 views

Install module BZ2 on python

I'm trying to install the module bz2 on python v2.7. I'm using Ubuntu 12.04 LTS and I have already installed libbz2-dev through Synaptic. I read that I need to rebuild python to take the changes of ...
0
votes
0answers
271 views

Unmet dependency issue installing libmapnik

I'm trying to install CartoDB, and have run into the dreaded "you may have requested an impossible situation" message: $ sudo apt-get install -y libmapnik-dev python-mapnik mapnik-utils Reading ...
0
votes
0answers
241 views

Customize gedit color theme as python idle

class Player(): My gedit used python idle theme so when i type this piece, 'class' show orange but 'Player' is black. so if i want change classname or function name's color into blue, what should i ...
0
votes
0answers
176 views

Telnet and opennig command prompt script in linux

I don't have any major scripting experience and I am really confused about the script which I am working on it. I am using dynagen in Linux and created a basic topology with two routers ...
0
votes
0answers
85 views

Error when recompiling python

Im trying to recompile python 2.7 on ubuntu 12.04, I already installed libsqlite3-dev' and then I proceeded to to this: $python Python 2.7.4 (default, Apr 19 2013, 18:28:01) [GCC 4.7.3] on linux2 ...
0
votes
0answers
97 views

How to install python gtkhtml2

I've try to install Straw 0.27 (using sudo python setup.py install), but got error: Error: 'gtkhtml2' module in package 'python-gnome2-extras' is required to install Straw I've installed ...