Python is an interpreted programming language that is often, but not solely, used as a scripting language. A version of Python is included by default on all Ubuntu distributions.

learn more… | top users | synonyms

0
votes
1answer
22 views

Finding modules on python

Python can't find my modules on the IDE but can find it from the terminal. Does anyone know how to fix this? Terminal: >>> import matplotlib >>> Python IDE: >>> ...
0
votes
1answer
37 views

Unable to compile in geany

Whenever I try to compile any file whether c , c++ or python in geany I get this error.
0
votes
1answer
37 views

Python playback can't chose Bluetooth device in Volume Control

Using Radio Tray in Xubuntu 15.10. Outputs fine to headphone jack on the computer. But when I try to change the output to the bluetooth device (Philips Fidelio) in the pulseaudio Volume Control, ...
0
votes
1answer
49 views

error trying to exec 'cc1': execvp: No such file or directory (possible SAGE/python issue)

I see that there are a number of topics on this error message, but I've tried every solution I have found to no avail. This is my first question here, but I'm going to try and include all of the info ...
0
votes
0answers
14 views

Import VIPS Error

I want to use VIPS module in python, but this time I had a problem when I want to run through the terminal. example: from gi.repository import Vips and the error message appears as follows: ...
0
votes
0answers
26 views

python3 won't import LCM

I am not sure if this problem is given by some incompatibility between LCM (lightweight communications and marshalling) and python3 or by the fact that I have more than one python version (python 3 ...
3
votes
1answer
504 views

Using pip3-installed python 3 packages when apt-installed packages exist too?

I have numpy 1.8.2 installed in /usr/lib/python3/dist-packages (via apt), and the newest version (1.9.2) installed in /usr/local/lib/python3.4/dist-packages (via pip). Both paths are in sys.path (in ...
1
vote
1answer
28 views

Cannot launch Pydev in Eclipse

I first installed Java; then installed Eclipse IDE using this (no problems at all). Then I installed Pydev using this. But whenever I launch Eclipse in my home folder it opens Java IDE not Python ...
4
votes
4answers
3k views

Unable to Uninstall Program : Own by OS

I was trying to uninstall program using pip uninstall South and it give me following error Not uninstalling South at /usr/lib/python2.7/dist-packages, owned by OS I'm in production machine and ...
0
votes
0answers
31 views

no module named imagehash

I have a Problem in installing imagehash package. I have used the following command to install imagehash pip install imagehash It says that REQUIREMENT ALREADY SATISFIED with an exception error. ...
0
votes
0answers
203 views

installing nylas N1.deb

raymond@akornor:~/Downloads$ sudo gdebi N1.deb Reading package lists... Done Building dependency tree Reading state information... Done Building data structures... Done ...
4
votes
4answers
483 views

How to create a web interface for my Python script? [closed]

I have a computer in my university office, with Ubuntu on it, ssh running, and Python. I'm connecting on it myself using ssh to run Python programs and see the output. Only command-line output, ...
0
votes
3answers
2k views

ImportError: No module named tkinter

When I try to install tkinter using this command: sudo apt-get install python-tk I get this message meaning it is already installed: Reading package lists... Done Building dependency tree ...
0
votes
0answers
34 views

problem while installing imagehash package ubuntu 15.04

When I tried to install python package imagehash using command pip install imagehash, it showed an error in the terminal: Command "/usr/bin/python -c "import setuptools, ...
0
votes
1answer
263 views

How to upgrade pip to latest?

I installed pip using get-pip.py after that pip freeze throws below error Exception: Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in ...
2
votes
2answers
506 views

How to add permissions to files installed by dpkg-buildpackage or debuild

I build a package from my own source using dh_make and dpkg-buildpackage. The install-file in /debian specifies the destinations for the project files. To make the installed program work, they need to ...
0
votes
1answer
113 views

Cannot install Python Imaging Library using pip

I'm attempting to install the Python Imaging Library on Ubuntu 15.10 by running pip install PIL. When I try and run that (or even pip uninstall PIL) I get this error: Traceback (most recent call ...
0
votes
2answers
43 views

installing packages from usb to ubuntu server 14.04 [duplicate]

I want to install these packages to my Ubuntu server from USB as i have tried many thing by editing mirrors in /etc/apt/sources.list to install some packages for Ubuntu server 14.04 know I want to try ...
2
votes
2answers
110 views

Accidentally deleted /usr/lib/python3.4

I am on ubuntu 14.04 and I accidentally deleted python3.4 I am trying apt-get install python3.4 dpkg-reconfigure -a apt-get install -f But I am seeing the following errors dpkg: error processing ...
3
votes
2answers
4k views

Installing pyusb on ubuntu 13.10

I tried this link, but got the following message on shell: sudo apt-get install python-pip : vineet@vineet:~$ sudo pip install --upgrade pyusb Downloading/unpacking pyusb Could not find a version ...
34
votes
7answers
4k views

Why does Python in Linux require the line #!/usr/bin/python?

Pretty simple question: In Linux, why does Python require the line #!/usr/bin/python at the start of a python file, since Windows doesn't? What does it do? 'cause the description "Links to ...
1
vote
1answer
286 views

Problem when trying to install fpdb on ubuntu machine

I've been trying to get fpdb working on my Ubuntu desktop, but every time I try to install it from the Gz file, my system won't let me use ./configure (saying file not found), and when I try to ...
8
votes
2answers
6k views

Python 3.5 has just been released, can I get it as a package for Ubuntu 15.4?

I want the very latest version of Python, but I don't want to bypass the apt package manager: I don't want to do an old-school source install because that can make it harder to uninstall when the ...
3
votes
1answer
194 views

Installing Cuda7.0 after removing cuda 7.5

I was setting up to use google's shiny new library TensorFlow. So being excited I began the tensorFlow pip install. Noticing that I needed cuda I went to the Cuda website and downloaded the 7.5 deb ...
0
votes
2answers
98 views

Broken packages relating to Python 3.4

I recently tried to install ubuntu-desktop to a machine that had previously just had ubuntu server on it. For some reason I am getting a message about broken packages. I've tried following up on the ...
0
votes
1answer
118 views

QGIS not working with Python installation on Wily 15.10: broken paths/dependencies

When I try to run QGIS, I get the following errors at startup: An error occured during execution of following code: import pyplugin_installer Traceback (most recent call last): File "", line 1, ...
3
votes
2answers
548 views

How do I install pybel such that my python environment recognizes it?

On Chemistry Stack Exchange I asked a question regarding Open Babel & Python being used together. The problem is that the answer I was provided (by Geoff Hutchinson) requires Python to be able to ...
0
votes
3answers
1k views

Install pygame in anaconda

I have anaconda on Ubuntu 14.04. I want to install the pygame module with anaconda. I already run sudo apt-get install python-pygame, but this only works on python, not in anaconda.
14
votes
2answers
5k views

Installing Pylint for Python3 on Ubuntu

My understanding is that the latest release of Pylint (1.0.0 at the time of this writing) has support for Python 3, but I can't get it to work on 64-bit Ubuntu 13.04 with Python 3.3. I followed the ...
1
vote
1answer
4k views

How do I update Python from 3.4.3 to 3.5? [duplicate]

I'm also using Jupyter and Anaconda, will it break/delete them or any python modules?
2
votes
0answers
60 views

Install Acire and Python Snippets on Ubuntu 14?

This site is out of date - I'm using Ubuntu 14. Is there an alternative for Ubuntu 14?
3
votes
4answers
819 views

Setting up a build system for Python app

In trying to sort out this issue, I have run into the following problem. I have a Python script that gets installed to /usr/lib/. But I need to get this script into a build system so that I can get ...
3
votes
1answer
30 views

Make “About” Window in glade [closed]

I tried to create about window like About MATE in Mate DE on Ubuntu 14.04, and this is the .py file that I made : #!/usr/bin/env python import sys try: import pygtk pygtk.require("2.0") ...
0
votes
1answer
76 views

Issue with tweepy installation

I am facing following error while installing tweepy on Ubuntu. sudo pip install tweepy Downloading/unpacking tweepy Running setup.py egg_info for package tweepy Traceback (most recent call ...
5
votes
1answer
202 views

Trouble creating a package for my PPA

So I tried following the steps here to create a package to upload to my PPA. I ran dh_make and edited the files. However, when my package gets generated by debuild, none of the programs files show up ...
-2
votes
3answers
45 views

Any way to see if a long running process bash command succeeded? [closed]

I have a long running process that was parsing text and my laptop died at some point because it was unplugged. I really don't want to unnecessarily run the process again because it takes over a day, ...
1
vote
2answers
41 views

data file re-organisation

I have a .data and I need to re-organise it so that 3 consecutive lines are joined together in a single line. Just to be clear, I have the following ... D611102 = 'SVM_PRS_Hydr_L01', T = 0.0, C = ...
0
votes
1answer
79 views

How do I install sqlite3 ODBC drivers with unixODBC?

According to the unixODBC drivers page (straight out of the 90s), I should download the SQLite3 drivers from: http://www.ch-werner.de/sqliteodbc The instructions for building sqliteodbc from the ...
0
votes
0answers
63 views

Can't install pip on virtualbox'd ubuntu 14.04 (Windows 10 host)

So while I haven't been able to solve this problem and suspect it's a hardware one, I managed to install ubuntu 14.04 on a virtualbox. However, for some reason pip isn't installed and I can't install ...
0
votes
0answers
125 views

Cant' properly install PyInstaller

Something went wrong while installing, but nonetheless I got message 'success' message: $ sudo pip3 install pyinstaller [sudo] password for user: Downloading/unpacking pyinstaller Downloading ...
0
votes
0answers
35 views

error : this version information could not be downloaded

I have downloaded the eric ide for python. when ever i try to open the ide the error above said keep popping up on my screen please help
0
votes
0answers
23 views

How to delete files installed by a python script? [duplicate]

I installed a program using $ sudo python setup.py install Now I want to delete it however python doesn't have a delete or uninstall option. Any suggestions?
4
votes
2answers
2k views

Can't find Spyder or Ipython Notebook applications after Anaconda install (xubuntu 13.10)

I installed Anaconda 2.7. I can run spyder and ipython notebook from the terminal but I can't find the applications at all from the desktop. Is there a specific place I should look? Should I just ...
1
vote
3answers
3k views

Unable to upgrade pip

Apologies for such a basic question... but am new to linux/ubuntu and haven't been able to find answer to this... Was trying to upgrade pip but ran into this... spelee@iggy:~/python$ sudo pip ...
0
votes
0answers
66 views

Python: fail to build tkinter module on fresh 14.04.3 install

I am trying to build Python on Ubuntu 14.04.3 x64. All tk8.6, tk8.6-dev and other build packages are correctly installed. The Python tkinter module does not build, because of the following error (some ...
0
votes
0answers
24 views

“you don't have permission to access /cgi-bin/fp on this server” error on ubuntu localhost

I'm trying to run a website on localhost. When I run localhost, I encounter the following error: How can I fix this problem? Thanks
0
votes
0answers
139 views

error: Command "i686-linux-gnu-gcc …failed with exit status 1

I am executing python setup.py install but this process finish with next error: error: Command "i686-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes ...
0
votes
0answers
24 views

Installing Basemap Error GEOS

I am intalling Basemap but when I install geos-3.3.3, the process is error. I have followed these step: cd geos-3.3.3 export GEOS_DIR=/home/alba ./configure --prefix=$GEOS_DIR make; make install And ...
10
votes
5answers
2k views

Why do most GNOME developers prefer Python over Java for GTK+ programming? [closed]

I only know C and Java. And I really don't want to learn another language when I can work with what I already know. I haven't ever written a GTK+ application, but I am planning to start with an ...
1
vote
0answers
318 views

Cannot create Python 3.5 virtualenv ImportError: No module named 'gdbm'

I'm experiencing the same issue as this individual but unfortunately switching back to Python 3.4 is not an option for me, I need to be running 3.5. I've broken command not found? Here is what ...