0
votes
1answer
89 views

matplotlib Error: No module named matplotlib even though it is installed

I have been through the process of installing matplotlib on my Ubuntu 12.04 computer. However, when I try to run a test program, I get the error Traceback (most recent call last): File ...
0
votes
0answers
22 views

python3-lxc and lxc parallel installation not possible!

every time i try to install one of the package lxc and python3-lxc the other one is removed from my system. How i can fix this problem? I need both for a project. Thank You!
1
vote
1answer
183 views

Python 3.2 script not working and/or importing tkinter when running from desktop

I'm really puzzled by this, but the answer is probably quite simple and just can't see it: I have a series of python modules that work fine from within the python interpreter, but nothing happens ...
1
vote
1answer
262 views

Python 3 with Pylab on Ubuntu 12.04

I have Ubuntu 12.04 and I'm learning via Python 2.7.3 (specifically Pylab - IPython, NumPy, SciPy and Matplotlib). I thought it's better to learn the newest version of Python. Using apt-get tells me ...
2
votes
1answer
667 views

Unable to import tkinter?

I am studying Python and tried to make GUI using python.I am using IDLE 3.2 on 12.04 Ubuntu.When i typed import Tkinter, a error comes, it says following: Traceback (most recent call last): File ...
4
votes
2answers
2k views

Open terminal window and execute Python script on startup

I have a Python script which I would like to execute at every startup. I can run it by adding this to the startup applications: python3 /path/to/script.py That works, but it doesn't open a terminal ...
0
votes
2answers
314 views

Changing symlink “python” to “python3” causes problems [duplicate]

I have Python 2.7.3 and 3.2.3 installed on my Ubuntu 12.04 64bit (by default?). When I type "python", I want python 3.2 instead of 2.7. Changing symlink "python" to link to python3 seems to cause big ...
0
votes
3answers
240 views

Installing Python modules on Ubuntu

I have been using Python on Windows for a while, so I'm into a lot of modules, including Pygame and LiveWires, but how do I install them into Ubuntu? I have the py file for LiveWires, which has been ...
-2
votes
1answer
474 views

Python 3.3.2 with Shared option is incomplete

On Ubuntu 12.04, I am trying to compile and install Python3.3.2. My compile commands: ./configure --prefix=/usr/local --enable-shared make make install Then I run: /usr/local/bin/python3.3 ...
0
votes
0answers
165 views

12.04: I installed python 3.3 and now I can install or remove anything

I downloaded the lastest python 3 source, built it and installed it along side 2.7. These are the commands I used to build and install it: ./configure make make test sudo checkinstall -D make ...
5
votes
2answers
18k views

How to find python installation directory on ubuntu

I have just migrated from Windows environment. I have installed Python 3.2 in a separate directory. How can I get the python installation path on ubuntu shell ? Is there any way I can let shell ...
-1
votes
0answers
25 views

Running Python 3.3.0 on Ubuntu 12.10 (print error) [duplicate]

Possible Duplicate: Python 3 error when running the print command I installed Python 3.3.0 on Ubuntu 12.10(x64)and when I type print 'hello world' it brings syntax error. But when I type ...
1
vote
1answer
496 views

Are python bindings for OpenCV 2.4.3 available?

I have installed the Libraries and files for OpenCV 2.4.3. However, the Software Center lists just the python bindings for OpenCV2.3. Where do i get the python bindings for 2.4.3 ? How do i install it ...
0
votes
1answer
1k views

How to install pycrypto 2.6 in python 3.2 in ubuntu

how do i find and install Pycrypto 2.6 to python 3.2 in Ubuntu 12.04, i have looked everywhere for a package, i managed to get it installed on python 2.7 just fine, but i want be able to use the lib ...
3
votes
2answers
922 views

how to load python3 to eric IDE?

Installed Eric IDE for python 3 Learning by using Ubuntu 12.04 LTS . But Eric showing Python2.7.3 , not showing python 3 even its installed . so how can i configure Eric to show the python as ...
2
votes
0answers
56 views

Install Both Python 2.7 and Python 3.3.0 on Ubuntu 12.04 [duplicate]

Possible Duplicate: need to have 2 versions of python? I have projects that require different resources from the two different versions of Python. My question is can I have both versions of ...