Python 2.7 is a version of the Python programming language released in 2010. Use this tag for questions about using Python 2.7 in Ubuntu.

learn more… | top users | synonyms

2
votes
1answer
80 views

rubber failing after upgrade to 15.10

rubber is a program that compiles LaTeX files into pdf document. After upgrading, I receive the following error when trying to run rubber on a document. My apologies for the huge stack trace, but my ...
2
votes
1answer
127 views

Python to Anaconda

I am completely new to python. I have Python 2.7.9 on my computer. Now I need to install anaconda and do scientific programming. How can I proceed to have anaconda and use it to code some problems?
2
votes
1answer
224 views

Install PyNSource in Ubuntu 12.04

How can i Install PyNSource in Ubuntu 12.04 LTS (the python version is 2.7)
2
votes
1answer
70 views

How to a deb package without Quickly?

I am developing an app now, I'm using GSetting as my setting back-end, but I can't make my .gschema file installed while open the .deb file. I'm wandering if there is some simple guide for green ...
1
vote
1answer
1k views

How can I run programs in /usr/local/bin without sudo or root?

I am on Ubuntu 14.04 LTS. I installed buildozer and it ended up in /usr/local/bin. I can't run it without using sudo or root and that will likely cause problems down the road. Right now trying to run ...
1
vote
1answer
2k views

python-Uno , No Module named Uno

I am using Ubuntu 14.04 with python 2.7.6. I am trying to install python-uno library which allows use of the standard LibreOffice API with the Python scripting language,but i am unable to find the ...
1
vote
1answer
118 views

How to recover Python on Ubuntu 12.10?

I've accidentally removed /user/local/lib/python2.7/dist-packages on ubuntu 12.10. Do I need to reinstall python? Some of the softwares like ibus or software center seem don't work any more. What ...
0
votes
1answer
35 views

uninstall python 2.7.6 and install 2.6 instead

I need to uninstall python 2.7.6 and install 2.6 instead. how can I manage that. which python command gives (/usr/bin/python). my environment is ubuntu 14.04.
0
votes
1answer
55 views

Unresolved dependencies trying to install build-essential on Lubuntu 14.04

I am trying to install build-essential (NB: I want to install the getch module for use in python eventually) and apt-get returns an error because of unresolved dependencies which cannot be fixed ...
0
votes
1answer
78 views

How to install cPickle?

I fail to install cPickle using pip: $ pip --version pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7) $ pip install cPickle ... Could not find any downloads that satisfy the requirement ...
0
votes
1answer
37 views

python deleted from usr/lib/python

$ python Could not find platform independent libraries <prefix> Could not find platform dependent libraries <exec_prefix> Consider setting $PYTHONHOME to ...
0
votes
1answer
391 views

How to make python module run in dist-packages folders in the desired order?

I am using Ubuntu 14.04. I have installed a python module called PyBluez. When I compile and install the module from source code, the output is installed in the folder ...
0
votes
1answer
445 views

Installing python 2.7, numpy, and pandas

So I've installed ubuntu 12.04 on my PC through Wubi It came with python 2.7, but it came with python 2.7 in several places... I have a python 2.7 in /usr/lib, one in /usr/local/lib, and one in ...
0
votes
1answer
1k views

Python's ImportError: No module named repository

I had three versions of Python installed; 2.7, 3.2 and 3.4 When I had just 2.7 and 3.2, everything was fine. But after installing 3.4 manually from source, things began to break down. 3.4 did not have ...
0
votes
1answer
500 views

Checking for 'gee-0.8' >= 0.8.0 : not found

I am trying to install pysoy and at the stage of configuration using ./waf configure it gives an error as seen below Checking for 'gee-0.8' >= 0.8.0 : not found The configuration ...
3
votes
0answers
33 views

Ubuntu 14.04: Is there a way to reset python 2 and all dependencies to the factory setting?

I am a daily user of python 2 and after something (I am not sure but I believe it was pygments) was installed in my system I am not able to make the things work again as before. I have already lost ...
3
votes
0answers
921 views

ERROR: venv: commands failed while installing devstack on ubuntu 14.04LTS

I am trying to install devstack on Ubuntu 14.04 LTS. While installing I came across this error. Up to this I edited the local.conf file and installed libvirt-1.2.15. The detail screenshot is as ...
3
votes
0answers
255 views

Accessibility bus error when packaging

When i do quickly package i get the flowing warning. Not a big deal but because this warning i can't share my package to my ppa. ** (setup.py:5679): WARNING **: Couldn't register with accessibility ...
2
votes
0answers
766 views

rpy2 installation errors

I am trying to install rpy2 but keep running into installation errors. I have found another post that had similar problems: ...
2
votes
0answers
311 views

Pyhton is messed up because of setuptools. Help please

I have trouble getting python working right, after a mixup with python setuptools. after this, I cannot run flexget and other programs without getting this error: flexget execute Traceback (most ...
2
votes
0answers
935 views

Pip issues after 12.02->14.04 upgrade

With Ubutun 14.04LTS, many but not all pip commands fail as so: # sudo pip install --upgrade distribute Downloading/unpacking distribute Downloading distribute-0.7.3.zip (145kB): 145kB downloaded ...
2
votes
0answers
776 views

python-plugin installation

I try to play online radio in the Chrome web browser. It said this following installation: Required plugin could not be found Python(2.7) requires to install plugins to play media files of the ...
2
votes
0answers
281 views

python2.7 help() modules returnd error

# python Python 2.7.3 (default, Aug 1 2012, 05:14:39) [GCC 4.6.3] on linux2 Type "help", "copyright", "credits" or "license" for more information. >>> help() Welcome to Python 2.7! ...
1
vote
0answers
1k views

Python - pip pip2 pip3 pip3.5 packages are installed but cannot be imported in any Python session

As I am using Xubuntu I thought perhaps this was a better forum than Stackexchange for some questions relating to pip and Python Today I have encountered troubles with pip and Python. For some reason ...
1
vote
0answers
41 views

Running MadGraph on Ubuntu

I'm trying to run MadGraph on an Ubuntu virtual machine. The documentation for MadGraph states that I just need python 2.7 and the unzipped MadGraph to be able to run it. Nevertheless, I can't ...
1
vote
0answers
385 views

Numpy/Scipy with Openblas

I've been trying to install Numpy/Scipy and allow them to both use Openblas. I've been following various guides but have been using this one of late. At the end of the guide, there are a couple of ...
1
vote
0answers
2k views

I Get 'Import error : No module named MYSQLdb' in python 2.7. I've tried everything from the other similar thread

The error: import MySQLdb ImportError: No module named MySQLdb. Particulars: OS is Ubuntu 14.04 python 2.7.10 and is the default MySQL 5.5.43 What I've tired: sudo apt-get install ...
1
vote
0answers
70 views

Clicking on debug in PyCharm soft reboots ubuntu 14.10

When I click on debug in Pycharm, communiti edition 4.0.3, on my ubuntu 14.10, the screen blanks out, closes all applications & reports an internal error. How do I debug the rootcause of this ? ...
1
vote
0answers
279 views

Installing Python libraries (difflib and pygments)

I am new to Linux and I need to install difflib and pygments python libraries to my computer. What is the easiest way to do that?
1
vote
0answers
67 views

Hide Terminal and still receive input

I want to run a python script that basically uses the terminal for certain commands, but I don't want it to show the terminal. I've tried running the script as nohup file.py & - this works and I ...
1
vote
0answers
19 views

How to change update At-spi1.32 to At-spi2 core in ubuntu 12.04?

On Ubuntu 12.04 by default At-spi1.32 and py-atspi 1.9.0 are installed. I am trying to intstall atspi2-core and pyatspi2 because in there are new methods I need. When I am trying to import like from ...
1
vote
0answers
283 views

Ubuntu 14.04 + pyes 0.99.2 + Elasticsearch 1.2.1

Im using Ubuntu 14.04 in a Django Project with ElasticSearch and after I install pyes with pip install pyes==0.99.2 and try to acces to the ElasticSearch page, it returns an error from the OS: ...
1
vote
0answers
261 views

Python pip says AttributeError with xmlrpc

I got this error when i update pip. /usr/local/bin/pip run on Tue May 6 15:03:16 2014 Exception: Traceback (most recent call last): File ...
1
vote
0answers
947 views

Eclipse - not opening, it was working before, how to fix it and open the eclipse ide for python?

It was working since last night, this morning stop opening, how to fix this? sun@sun-M14xR2:~/Downloads/easyeclipse-python-1.3.1$ ./eclipse ./eclipse: error while loading shared libraries: ...
0
votes
0answers
11 views

uwsgi doesn't listen on same port if stopped once

I am using uwsgi. While testing i need to re-run the server again and again. But when I run the server once like on port 8080, upon rerunning the server fails to start on port 8080 while it works fine ...
0
votes
0answers
105 views

can't install anaconda 2 on ubuntu 15.10

I downloaded a anaconda installer for linux 32bit which is compatible to my pc, after that i ran the command in terminal bash Anaconda2-2.5.0-Linux-x86_64.sh then i got an error stating no such file ...
0
votes
0answers
115 views

Installing Google Protobuf on Ubuntu 15.10

After downloading, building and installing Google Protobuf, I cannot import it in Python import google.protobuf cannot find the module. Typing protoc --version returns 3. Any suggestion on how ...
0
votes
0answers
35 views

wget changes Excel file size

I'm using wget to download Excel file with xlsx extension. The thing is that when I want to deal with the file using openpyxl, I get the following error "BadZipfile: File is not a zip file". But when ...
0
votes
0answers
62 views

Running python script in Python interpreter

I have recently started using Ubuntu 14.04. I am learning Python and have both Python 2.7 and 3.4 installed. I made some simple scripts and executed them using command python filename.py and it ...
0
votes
0answers
82 views

How do I get python cgi scripts to work with xampp?

I have XAMPP for Linux 5.5.30 or 5.6.15 installed on my Xubuntu partition. I want to work on some CGI scripts and python web development. I have python 2 installed and also want to work with mysql. I ...
0
votes
0answers
44 views

Running .py files in Ubuntu

I am working with BooleanNet1.2.7 in Ubuntu and I am trying to run the file "all-initial-states.py", but I am facing problems. I have installed Python2.7 and I have installed all the other packages ...
0
votes
0answers
73 views

unable to download rethinkdb getting error..so can you provide steps to download and installation for rethinkdb

warn: Cache size is very low and may impact performance. error: TCP socket creation failed for port 29015: Address already in use.
0
votes
0answers
24 views

Manual installation of python causing problem

I am relatively new to Linux and am using Ubuntu 14.04. Basically, I've been messing around with some files trying some random stuff. Well, I though I should do another install of Python2.7 for some ...
0
votes
0answers
100 views

Peculiar observations with Opencv BackGroundSubtractorMOG2 module — Opencv-3.0.0, Python-2.7.X, Ubuntu-14.04

I am using the BackGroundSubtractionMOG2() from Opencv-3.0.0 inside Python-2.7.x. I am observing something peculiar. That is, when I create the BackGroundSubtraction object and apply it to the first ...
0
votes
0answers
68 views

Problem with install Trac 0.11.7 on Ubuntu 14.04

I must install Trac 0.11.7 on Ubuntu 14.04.3. http://trac.edgewall.org/wiki/0.11/TracInstall I Install Trac: sudo easy_install http://ftp.edgewall.com/pub/trac/Trac-0.11.7.tar.gz When Create a new ...
0
votes
0answers
69 views

how can i compile source code with scapy in ubuntu 14.04

I want to make reassembly of fragmented packets which I had received,so that I searched through google and found that "scapy" can make reassembly of those packets.now i downloaded "scapy software for ...
0
votes
0answers
18 views

configuring Python 2.5.6

When give a command : sudo ln -s /usr/local/python2.5/bin/python /usr/bin/python2.5 I got on my screen some processing and at last an error: make: *** [libinstall] Error 1. What wrong am I ...
0
votes
0answers
3k views

How to install python-setuptools properly on Ubuntu 14.04

ivan@MS-7640:~$ python -V Python 2.7.10 sudo apt-get install python-setuptools [sudo] password for ivan: Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
0answers
67 views

Error while compiling kivy

[INFO ] Kivy v1.8.0 Purge log fired. Analysing... Purge finished ! [INFO ] [Logger ] Record log in /home/sulabh/.kivy/logs/kivy_15-07-02_2.txt [INFO ] ...
-1
votes
0answers
538 views

Python PATH issue (Anaconda_Python, minpower and gurobi interfacing)?

I am using Ubuntu 14.04 LTS, installed Anaconda_python recently Installed minpower and gurobi. Extracted gurobi in home directory, added path as mentioned which is gedit ~/.bashrc export ...