Python 2.7 is a version of the Python programming language released in 2010. Use this tag for questions about using Python 2.7 in Ubuntu.

learn more… | top users | synonyms

1
vote
1answer
433 views

Why am i getting an error SyntaxError : invalid syntax [closed]

This is a python code for which i am getting an error... from scipy import * from matplotlib.pyplot import * x=arange(0.1,100,0.1) f=zeros(len(x)) s=-1 for n in range ...
0
votes
1answer
1k views

Where to build wxPython?

I've downloaded wxPython-src-2.9.4.0.tar.bz2 from http://www.wxpython.org; right now I'm trying to follow the build instructions on http://www.wxpython.org/BUILD.html. I've managed to build it using $ ...
6
votes
9answers
19k views

I run `sudo apt-get remove python2.7`, can I restore my Ubuntu now?

I wanted to remove and reinstall python2.7 interpreter on 12.04 But when I did sudo apt-get remove python2.7, The crazy terminal started to remove everything!!! Any idea how I can restore whatever ...
2
votes
1answer
69 views

How to a deb package without Quickly?

I am developing an app now, I'm using GSetting as my setting back-end, but I can't make my .gschema file installed while open the .deb file. I'm wandering if there is some simple guide for green ...
10
votes
2answers
7k views

Install uwsgi 1.2.5 via pip

Welcome, Currently I'm trying to install latest uwsgi on my VPS (Ubuntu 11.10) based on instruction from the site http://projects.unbit.it/uwsgi/wiki/Quickstart pip install uwsgi During ...
0
votes
1answer
344 views

Cannot run cgi as httpd.conf is empty!

For help I checked out these links: This This and This I have an empty httpd.conf file but apache2.conf is not and the formats and tags in apache2.conf are similar to what httpd.conf has in windows ...
0
votes
1answer
593 views

Can not use PIP or easy_install because deleted /etc/lib/python2.7/urllib.py

Like said on title, by a slip of the keys I issued the command: sudo rm /etc/lib/python2.7/urllib.py sudo rm /etc/lib/python2.7/urllib2.py And with that the problems started, Ubuntu still starts, ...
0
votes
1answer
972 views

Built python 2.7.3 from source, now apt-get doesn't work “ImportError: No module named apt_pkg”

I needed to get a bug fix which arrived in Python 2.7.3 Latest version available for 11.10 was 2.7.2, so I built Python 2.7.3 from source Now when I try to apt-get [anything] I get this error at the ...
1
vote
1answer
396 views

python ctypes and pulseaudio segfault after upgrade to 12.04

Today I finally took the plunge and upgraded my desktop machine from 11.10 to 12.04 using the upgrade process, not a fresh install. One of the first things I tested after the upgrade completed was a ...
0
votes
1answer
2k views

apt package for 11.04 for Python 2.7.3?

I want to upgrade Python on my 11.04 server from Python 2.7.1 to Python 2.7.3. I assumed that if I did an apt-get install Python2.7 that 2.7.3 would have automatically been available and would have ...
0
votes
1answer
3k views

add-apt-repository: Problem with the SSL CA cert

user@amd64:~$ sudo add-apt-repository ppa:jd-team/jdownloader [sudo] password for 1: Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 125, in <module> ppa_info ...
1
vote
1answer
691 views

How do I install the latest python-opencv in 64-bit Ubuntu?

I heard that OpenCV supports only 32 bit Python. But my OS is Ubuntu 12.04 64 bit and it has Python 2.7 64 bit. How can I install latest OpenCV-Python bindings on this system for 32 bit Python? .
0
votes
2answers
101 views

Writing to a file

def loadSubredditConfig (self): self.builder.get_object ('cbxR').remove_all () path = os.path.join (xdg.BaseDirectory.xdg_config_home, 'RedThat', 'subreddits') if (os.path.exists (path)): ...
0
votes
1answer
715 views

Python-libnotify showing weird behaviour with xfce4-notifyd and notify-osd

I am trying to play with libnotify's python bindings. I got this code from /usr/share/doc/python-notify/examples and it is showing different behaviour with xfce4-notifyd and notify-osd. Case-1 with ...
3
votes
1answer
342 views

How do i tell ubuntu to only install is asked for and do not bring other dependencies which will break the whole system?

How can i only install python-webkit but not other packages? which is showing to install? (no gstreamer*.*, i do not want to have any single files installed in my distro because of GPL license and it ...
0
votes
1answer
234 views

Strangely quickly runs but debugger crashes with no exception

Firstly, strangely quickly run on my app runs fine and i believe i have made no changes to the source since quickly debug was working (proclaiming it's not user error is distasteful, I know!). winpdb ...
1
vote
1answer
343 views

Can't show preferences dialog

I'm having some trouble with Python, again. I created a project using Quickly, and it created a preferences dialog for me. I am now trying to build up the preferences dialog, but I always get some ...