Python 2.7 is a version of the Python programming language released in 2010. Use this tag for questions about using Python 2.7 in Ubuntu.

learn more… | top users | synonyms

1
vote
0answers
13 views

How can I create a pecan project with oslo RBAC support?

I want to create an application with pecan Python web framework and oslo role-based access control (RBAC). How to do that? Scenarios are as follows: I will call the pecan controller using curl or ...
0
votes
0answers
22 views

Problem installing snapd

I like to install snapd but my computer say message like this: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package snapd how ...
1
vote
0answers
17 views

Plotting with Octave and Matplotlib Broken on Ubuntu 16.04

I'm having a problem using plot commands using python-matplotlib and Octave ever since I installed Octave. Prior to installing Octave v4.0.2, I was able to plot with Matplotlib v. 1.5.1 just fine. ...
0
votes
1answer
21 views

How to install swi-prolog as a shared library?

I need to develop an expert system using prolog as an inference engine and python as interface. I already have the SWI-prolog installed in my machine, but, i can't import the interface PySwip because ...
2
votes
1answer
48 views

Can't import installed packages in python

I installed pip (pip 1.5.4 from /usr/lib/python2.7/dist-packages (python 2.7)). My python version is 2.7. I installed pygame by apt-get install python-pygame and got a success message. But when I try ...
0
votes
1answer
57 views

why wont python-pip install matplotlib work?

I just installed kubuntu 16.04 on my computer and started to install some python packages but some of them wont install. the command I type in is pip install matplotlib and it does not work. I get ...
0
votes
0answers
73 views

How do I install python 3.5.2?

It's my first time using ubuntu so I don't know how to use it very well yet... How can i install python 3.5.2 ? It has already the version 2.7.12 . My Ubuntu version is Ubuntu 16.04 LTS (desktop).
0
votes
0answers
20 views

Python 2.7 and pip from 3.5

I do not know what has happened because this used to work fine but I'm now experiencing a problem where I am running python2.7 but for some reason pip is installing in my python 3.5 dist-packages. At ...
2
votes
0answers
16 views

Python unknown encoding utf8

I need to renew my Letsencrypt certificate, but python doesn't find UTF8 encoding. I had a suggestion to reinstall Python, but I Ubuntu 14 doesn't let me.
0
votes
0answers
26 views

GET Node details

When I call the Maas API with resp = self.client.get(u"nodes/%s/" % node_id, "details") print resp.read() I am getting following o/p How can I iterate over this?
0
votes
0answers
16 views

python-gobject-2 is deprecated , tried installing other packages , not working

Apps like software-center and appgrid don't work. I'm a beginner: can anyone help me please?
1
vote
0answers
34 views

Unable to install Pillow on Ubuntu 15.10

I m trying to install pillow via the command : pip install pillow on my Ubuntu machine but I repeatedly get this error: command 'x86_64-linux-gnu-gcc' failed with exit status 1 How can I fix ...
0
votes
0answers
18 views

why other python modules are not incoorported with virtualenv

Hi I have downloaded pymorph module through virtualenv. I activated it to be able to use that module in my code. It works fine and my code is working under virtualenv. The problem is the other python ...
0
votes
0answers
30 views

Unable to import python module in python after installation

After installation of any python module using pip or apt-get I am unable to import it in python3. I am able to do so in python 2.7 .This probably is a naive question but I am a novice at using ubuntu ...
0
votes
1answer
49 views

How do I run mulitple pythons with virtualenv in production?

I have installed virtualenv to run a different version of Python than the system Python for my django app. I installed Python 2.7.11 using the method described here. I've modified my uwsgi.ini file to ...
1
vote
0answers
97 views

Not able to execute a url from python script running via Cron

I have a script web.py which I am trying to run on the aws EC2 Instance using cron. It basically has these line of codes: import webbrowser webbrowser.open('http://xxxxxxxxxxxxxxxxxxxxxxxxxxxx') If ...
0
votes
1answer
32 views

How to run on ubuntu?

I have to run this file reddit-job-update_popular_subreddits.conf. I go to the file directory using cd command and I put this ./reddit-job-update_popular_subreddits.confbut its not work. "Comand not ...
0
votes
0answers
45 views

terminator not starting when default python is python3.4 but works if it is python2.7

On Ubuntu 15.10 when changing the symlink /usr/bin/python from python2.7 to python3.4 then terminator won t start anymore. Do you know what the problem could be and how to fix it? Thank you :)
0
votes
1answer
31 views

Python 2.7 crashes in pymol application

I am new to ubuntu, please forgive me for any logical comments. While attempting to load a pdb file in pymol, I will get a system crash report: ProblemType: Crash Architecture: amd64 CrashCounter: 1 ...
0
votes
2answers
52 views

Eclipse, for python project not jumping to function definition

In Eclipse, I created a Python project properly by installing all the plug-ins. But now I'm unable to jump to respective module (source file) and method (function definition). Please suggest me ...
0
votes
0answers
35 views

Pygame/SDL graphics jerky/choppy in 16.04 on Dell XPS 9350

When I run the tutorial pygame bouncing-ball I do not get it moving with a uniform speed; instead it seems to be jerky and choppy, lagging as if the system cannot keep up with processing the animation....
0
votes
1answer
491 views

Tostring() has been removed. Please call tobytes() instead

I try to install Reddit on my ubuntu server but I get an error after "make" line. Please see the all lines from the server. [+] including definitions from Makefile.py python setup.py build Cannot ...
0
votes
1answer
54 views

pyhton-pkcs11 package in 16.04

I see that pyhton-pkcs11 isn't included in 16.04 repositories. Only pyhton3-pkcs11. Is there any way to install Python2 package version ?
0
votes
1answer
84 views

uninstall python 2.7.6 and install 2.6 instead

I need to uninstall python 2.7.6 and install 2.6 instead. how can I manage that. which python command gives (/usr/bin/python). my environment is ubuntu 14.04.
0
votes
1answer
68 views

How can I install a newer python on Trusty?

I'd like to install a newer python 2.7 on trusty. Installing "python" installs python 2.7. The newest version available on trusty is 2.7.6. I'd like to install the most updated version of 2.7. I am ...
0
votes
1answer
127 views

Unresolved dependencies trying to install build-essential on Lubuntu 14.04

I am trying to install build-essential (NB: I want to install the getch module for use in python eventually) and apt-get returns an error because of unresolved dependencies which cannot be fixed ...
0
votes
2answers
243 views

change python version from 2.7.9 to 2.7.6 in ubuntu 14.04

I had a Python version 2.7.6 installed on Ubuntu 14.04. By mistake I ran: sudo apt-get install python-dev So it changed to Python 2.7.9. Now I want to revert to 2.7.6. How can I do this?
0
votes
1answer
1k views

How to install cPickle?

I fail to install cPickle using pip: $ pip --version pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7) $ pip install cPickle ... Could not find any downloads that satisfy the requirement ...
1
vote
1answer
129 views

installing python-tabulate

I am trying to install tabulate in my python from terminal but I always receive error. the used command and resulting errors are as follows: Command sudo apt-get update sudo apt-get install python-...
0
votes
0answers
14 views

uwsgi doesn't listen on same port if stopped once

I am using uwsgi. While testing i need to re-run the server again and again. But when I run the server once like on port 8080, upon rerunning the server fails to start on port 8080 while it works fine ...
3
votes
1answer
522 views

How do I switch back to python2 after Anaconda set python3 as the default?

Recently, I installed Anaconda3-2.5.0-Linux-x86_64.sh on my 15.04 and ended up with this! :~$ python --version Python 3.5.1 :: Anaconda 2.5.0 (64-bit) :~$ python2 --version Python 2.7.9 :~$ python3 ...
0
votes
0answers
135 views

can't install anaconda 2 on ubuntu 15.10

I downloaded a anaconda installer for linux 32bit which is compatible to my pc, after that i ran the command in terminal bash Anaconda2-2.5.0-Linux-x86_64.sh then i got an error stating no such file ...
3
votes
0answers
76 views

Ubuntu 14.04: Is there a way to reset python 2 and all dependencies to the factory setting?

I am a daily user of python 2 and after something (I am not sure but I believe it was pygments) was installed in my system I am not able to make the things work again as before. I have already lost ...
0
votes
1answer
354 views

Jupyter Notebook Installation

It is possible to install Jupyter Notebook throughapt-get install? For example, we can install numpy by using apt-get install python-numpy.
0
votes
0answers
242 views

Installing Google Protobuf on Ubuntu 15.10

After downloading, building and installing Google Protobuf, I cannot import it in Python import google.protobuf cannot find the module. Typing protoc --version returns 3. Any suggestion on how ...
0
votes
0answers
42 views

wget changes Excel file size

I'm using wget to download Excel file with xlsx extension. The thing is that when I want to deal with the file using openpyxl, I get the following error "BadZipfile: File is not a zip file". But when ...
0
votes
2answers
31 views

python 2.x beside 3.4

From noob to all... Is it possible to have py2.x beside 3.4, preferably with launcher icons for both? If not, how can I start py2 IDE from command line? I prefer py3, but need py2 and it's modules ...
0
votes
1answer
327 views

Can I install new version of python on ubuntu 14.04?

Considering that the current version on my 14.04 LTS Ubuntu of python is 2.7.6, I need a more recent version for dealing with specific libraries (that need >2.7.7)... I don't really understand. ...
2
votes
0answers
2k views

Python - pip pip2 pip3 pip3.5 packages are installed but cannot be imported in any Python session

As I am using Xubuntu I thought perhaps this was a better forum than Stackexchange for some questions relating to pip and Python Today I have encountered troubles with pip and Python. For some reason ...
0
votes
0answers
79 views

Running python script in Python interpreter

I have recently started using Ubuntu 14.04. I am learning Python and have both Python 2.7 and 3.4 installed. I made some simple scripts and executed them using command python filename.py and it ...
0
votes
0answers
124 views

How do I get python cgi scripts to work with xampp?

I have XAMPP for Linux 5.5.30 or 5.6.15 installed on my Xubuntu partition. I want to work on some CGI scripts and python web development. I have python 2 installed and also want to work with mysql. I ...
0
votes
0answers
59 views

Running .py files in Ubuntu

I am working with BooleanNet1.2.7 in Ubuntu and I am trying to run the file "all-initial-states.py", but I am facing problems. I have installed Python2.7 and I have installed all the other packages ...
0
votes
1answer
102 views

python application migration from python-2.6 to python-3

I'm migrating my python application from python-2.6 to python 3. My application has been developed on Ubuntu 10.04 system having python 2.6 support. Now i want to make it work on Ubuntu 14.04 with ...
1
vote
1answer
231 views

while installing rethinkdb i'm getting some socket error..how to overcome from that error

While installing rethinkdb, I'm get some socket error. How do I fix the error? I tried: $rethinkdb error: TCP socket creation failed for port 29015: Address already in use.
0
votes
0answers
106 views

unable to download rethinkdb getting error..so can you provide steps to download and installation for rethinkdb

warn: Cache size is very low and may impact performance. error: TCP socket creation failed for port 29015: Address already in use.
3
votes
1answer
91 views

rubber failing after upgrade to 15.10

rubber is a program that compiles LaTeX files into pdf document. After upgrading, I receive the following error when trying to run rubber on a document. My apologies for the huge stack trace, but my ...
0
votes
2answers
39 views

unable to run Todo list app in rethinkdb on ubuntu..so can you provide the steps [closed]

When I'm executing cd/user/share/nginx/html, I get No such file or directory.
0
votes
1answer
418 views

Can't install Python ubuntu 14.04

I encountered some troubles after installing python 3.4, so I wanted to go back to 2.7. So I removed python, completely... Now when I run this command: sudo apt-get install python(tried all versions ...
2
votes
1answer
471 views

Using Python 2.6 while python 2.7 is installed

I have an application which when I run it, it gives me the following error: paraview: error while loading shared libraries: libpython2.6.so.1.0: cannot open shared object file: No such file or ...
0
votes
0answers
29 views

Manual installation of python causing problem

I am relatively new to Linux and am using Ubuntu 14.04. Basically, I've been messing around with some files trying some random stuff. Well, I though I should do another install of Python2.7 for some ...