-1
votes
0answers
15 views

How should i upgrade python 2.7.6 ucs2 to ucs4 in ubuntu 14.04?

In my machine, I have installed python 2.7.6 with ucs2. But as of now, one of my application depends on ucs4. Is there any chance to upgrade from ucs2 to ucs4 OR else should i need to install Python ...
0
votes
0answers
27 views

upgrade to 14.04 broken: python error: NameError: name 'MAGIC' is not defined

my release upgrade is broken, shows following error related to python: http://www.pasteall.org/53013 My all python versions are: python python2.7 python3.3 python3m python2 python3 ...
0
votes
0answers
17 views

Can't upgrade Ubuntu 13.04 because of broken python [duplicate]

Because of broken python I can't do anything. apt-get got broken. When I run "do-release-upgrade" I get: root@virtman:/home# sudo do-release-upgrade Could not find platform independent libraries ...
3
votes
1answer
41 views

How to understand apt.log?

First, a little context: I have a machine with Ubuntu 13.10 64bit with Unity, that i use for development. As such, i updated several packages manually, and even installed/compiled some from sources ...
2
votes
1answer
274 views

do-release-upgrade: python install is corrupted

I was upgrading from 13.10 to 14.04 (dev for now, stable in a few hours) using do-release-upgrade and encountered the following problem: Can not upgrade Your python install is corrupted. Please fix ...
3
votes
1answer
332 views

Is it good practice to upgrade .deb packages with pip?

It seems some blogs recommend installing pip and setuptools(actually distribute on Ubuntu) with: $ sudo apt-get install python-pip python-setuptools And then upgrading them with: $ sudo ...
1
vote
2answers
424 views

After PIP install --upgrade Dpkg still lists old python packages

I recently upgraded all python data analysis tools using pip. When I do dpkg -l |grep python I see the old version numbers of the software I just upgraded via pip. How can I ensure that the dpkg ...
0
votes
1answer
106 views

preventing pip from removing system packages during upgrade

I have a fairly straightforward Ubuntu (13.04) desktop installation, which comes complete with several Ubuntu-packaged Python utilities -- these live in /usr/lib/python2.7 and are owned by root. I ...
7
votes
1answer
9k views

Upgrading to python 2.7.5 on Ubuntu 12.04

Ubuntu 12.04 comes with python v 2.7.3 by default. I want to upgrade it to v 2.7.5. I tried the instructions given in this question, sudo apt-get install build-essential sudo apt-get install ...
9
votes
4answers
11k views

Make default `python` command to use Python 3

I can access Python 3 via python3 command. But I want to make the default interpreter to use python command for Python 3. Simple typing python takes me to Python 2. How to upgrade?
4
votes
1answer
2k views

Broken dependencies after upgrade

After an apt-get upgrade I got the following error: Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not ...
0
votes
1answer
156 views

Install PyMC on Amazon EC2

I want to use PyMC on Amazon EC2. According to my package search the python-pymc package is only available under raring. However, EC2 seems to be shipped with precise and after running sudo apt-get ...
-1
votes
1answer
574 views

How to fix error after a release-update to Ubuntu 12.10?

I have freshly reinstalled 12.10 and have NOT updated. After the last update on about March 26th I started getting usr/share/apport/apport-gpu-error-intel.py errors. Reinstalled and updated same ...
2
votes
1answer
173 views

What are the benefits/problems about upgrading Python to a newer version

What advantages and disadvantages does upgrading Python to a newer version not available in the Distro bring. For example, upgrading from 2.6/2.7 to 3.1/3.2. Since there are several questions relating ...
1
vote
2answers
2k views

Software Center won't start: “AttributeError: 'gi.repository.Gtk' object has no attribute 'FontSelectionDialog' ”

When I try to run software-center from the terminal it gives me: Traceback (most recent call last): File "/usr/bin/software-center", line 33, in <module> from gi.repository import Gtk ...
1
vote
1answer
3k views

How can I upgrade to Python 2.7

I am on Ubuntu 11.04 and have Python 2.6 installed. I would like to upgrade to Python 2.7. How should I go about doing this?
0
votes
1answer
578 views

On 10.04, should I upgrade from Python 2.6.5 to 2.6.6?

The default Python version on Ubuntu 10.04 server edition is 2.6.5. The latest version of the Python 2.6 series is 2.6.6. Does Ubuntu support 2.6.6 or should I leave it at the default version. If I ...
19
votes
1answer
24k views

Upgrading to python 3.2

I want to use new functools that provides with the lrucache, I am currently using python 2.6, which doesn't support this, What is the best way I can upgrade to python 3.2? or is there any other ...