1
vote
1answer
41 views

Installing matplotlib on Ubuntu 14.04 after installing Python 3 with pyenv

I am using Ubuntu 14.04 with Python 2.7.6. I have installed matplotlib for Python 2. Now, I just installed Python 3.4.2 using pyenv install 3.4.2. I then ran pip install matplotlib to install ...
1
vote
2answers
46 views

Using specific python version for apt-get in Ubuntu 12.04 LTS

On Ubuntu 12.04 LTS I have python2.7.3-0Ubuntu3.5 package installed. One of the libraries i am trying to install has dependency on (>=2.7.3.6). I went ahead and installed python 2.7.6 and even python ...
0
votes
2answers
159 views

apt-get ends up with errors after nvidia 331 installation

I recently installed nvidia-331 driver via Software & Updates -> Additional Drivers tab. Now when I use: sudo apt-get install <package> or sudo apt-get remove <package> ...
0
votes
1answer
379 views

How can install python-dev for 2.7.8 in 14.04 off apt-get?

I have tried this and this and this and this Well nothing works with me, i got my amd64 system, 14.04 up and runnig, as I try to install wagtail, a django cms, i get the error. pysass.c:4:20: ...
0
votes
0answers
28 views

anki issues how to make work

Hi further to my question ealrier Below is the error message I get from my computer when I try to use Anki (2.0.28) Today, I have ascertained that it is my computer and not the files for anki which ...
1
vote
1answer
84 views

Undo apt-get remove --purge

I wanted a fresh install of Python and ran sudo apt-get remove --purge python. Apparently it has killed almost everything I had installed in my system. Looking at the history.log I guess I could ...
1
vote
1answer
28 views

How can I take a textbox text entry and make it a variable?

I am having trouble with Python and would like to have some help. I am making a apt GUI 'front-end' with a nice UI. def on_textbox_changed(self): self.instvar = ...
0
votes
0answers
74 views

Unable to install bsddb185, Python library for opening Berkeley DB version 1.85 files on Ubuntu

I am writing a python program that makes use of some legacy Berkeley DB 1.85 files. Unfortunately I am unable to install the bsddb185 Python package, either for Python version 2.x and for Python 3. ...
0
votes
1answer
62 views

How can I tidy up the mess that is my Python installations?

I had a Ubuntu 12.04 system which I eventually managed to get Python 2.7 and Python 3.2 working together (with pip and pip3) and Python 3.3 (with pip3.3) for good measure. I've recently upgraded to ...
0
votes
0answers
48 views

By mistake I removed Python. Terminal, music player, video player, Software Center etc. are gone

I work on Ubuntu 14.04 to install Python and other packages I entered the following command : sudo apt-get install python python-pip python-pyparsing python-mysqldb gunicorn nginx git-core ipython ...
3
votes
2answers
1k views

Installing Anaconda python on ubuntu

How to install anaconda python on ubuntu? https://store.continuum.io/cshop/anaconda/ Is there a way to apt-get install it? I only have command line access to my server, how do i install anaconda ...
0
votes
0answers
17 views

Can't upgrade Ubuntu 13.04 because of broken python [duplicate]

Because of broken python I can't do anything. apt-get got broken. When I run "do-release-upgrade" I get: root@virtman:/home# sudo do-release-upgrade Could not find platform independent libraries ...
1
vote
1answer
82 views

Getting error while installing python-kivy packages in Ubuntu

I'm not able to install python-kivy, I got this error: dpkg: error while cleaning up: subprocess installed post-installation script returned error exit status 127 Processing triggers for ...
1
vote
0answers
449 views

ImportError: No module named paramiko

I have install paramiko via "sudo apt-get install python-paramiko", but it can't be import in python. How to solve this? Python 2.7.6 (default, Mar 22 2014, 22:59:56) [GCC 4.8.2] on linux2 Type ...
0
votes
1answer
416 views

Downlaod the latest version of python-pip using apt-get

Ubuntu 12.04 Python 2.7 apt 0.8.16~exp12ubuntu10.17 for amd64 compiled on Jun 13 2014 17:42:13 When I run sudo apt-get install python-pip It installs a a very old version. $ pip --version pip 1.0 ...
-1
votes
1answer
1k views

cannot install lxml in virtualenv (python)

I cannot install lxml. In system i have python-lxml package, but i need other... Please help, if you can - my task is install lxml for development in virtual enviroment using virtualenv. I found this ...
-1
votes
1answer
101 views

How do I resolve not fully installed package (python3-setuptools)?

I was trying to install python3-setuptools, and when i run $ sudo apt-get install python3-setuptools I get this error: Reading package lists... Done Building dependency tree Reading state ...
2
votes
1answer
185 views

Cannot install any package via apt-get

So my problem is quite easy to describe: I can't install anything in my Ubuntu installation. apt-get stopped working after I tried to fix some other package errors I was getting. Now I'm nowhere. Let ...
1
vote
0answers
71 views

Does pip overwrite packages installed by apt-get?

What happens if I accidentally pip install a package that I already installed using apt-get beforehand? Do I simply get to use the latest version (i.e. probably the one I installed using pip)? What ...
1
vote
3answers
74 views

I installed a custom .deb file that provided a package named “python” but now need to remove it [duplicate]

I think I may have botched my system. I have recently installed Ubuntu 14.04 on my computer. One of the first things I did was install python 3.3 from source (using make altinstall); but then I ...
0
votes
0answers
14 views

revkit installation [duplicate]

so i need to install this software called revkit on ubuntu 12.10. below are the instructions as per the manual: Requirements RevKit needs a couple of packages which can easily be installed with the ...
5
votes
1answer
1k views

How to conveniently install cx_Freeze for Python 3?

I want to install cx_Freeze for Python 3. My Ubuntu 14.04 has Python 2.7 and Python 3.4. For Python 2 I could install cx_Freeze very conveniently using: sudo apt install cx-freeze However this only ...
3
votes
1answer
88 views

why does python-sympy need 520MB?

I wanted to install sympy so when I typed sudo apt-get install python-sympy I get the following output: The following NEW packages will be installed: dvipng fonts-cabin fonts-comfortaa ...
3
votes
1answer
47 views

How to understand apt.log?

First, a little context: I have a machine with Ubuntu 13.10 64bit with Unity, that i use for development. As such, i updated several packages manually, and even installed/compiled some from sources ...
1
vote
2answers
327 views

Missing: “/usr/include/python3.3m/Python.h”

I recently moved to ubuntu 14.04. I can't compile blender afterwards. It says the error message below CMake Error at CMakeLists.txt:2220 (message): Missing: "/usr/include/python3.3m/Python.h", ...
4
votes
1answer
447 views

I accidentaly did sudo apt-get remove python [closed]

I accidentaly did sudo apt-get remove python command and now terminal look has changed, rhythmbox, ubuntu software center and everything is quite changed. I reinstlled python with the command sudo ...
0
votes
1answer
146 views

installing python-appindicator in 13.10

I'm trying to install python-appindicator in Ubuntu 13.10 but I'm receiving not found error: E: unable to locate package python-appindicator How can I install python-appindicator in 13.10 ?
0
votes
0answers
233 views

Unmet dependency issue installing libmapnik

I'm trying to install CartoDB, and have run into the dreaded "you may have requested an impossible situation" message: $ sudo apt-get install -y libmapnik-dev python-mapnik mapnik-utils Reading ...
19
votes
2answers
9k views

apt-get install vs pip install

I am a bit confused about the cases in which the above commands must be used when downloading python packages. I was trying to download a package named pyudev in accordance with an answer with this ...
0
votes
0answers
17 views

Fix dpkg error 1 in python-minimal [duplicate]

I have seen a number of fixes on these forums, but they all seem to involve removing the offending package. in my case, that's python-minimal, and if I remove that it will break everything. Can anyone ...
0
votes
0answers
10 views

Problem in installing pip and lxml and importing xml for python [duplicate]

i tried following command apt-get install python-pip it gave message Do you want to continue [Y/n]? y Media change: please insert the disc labeled 'Ubuntu 13.10 Saucy Salamander - Release amd64 ...
0
votes
1answer
3k views

How do I reinstall python on my Ubuntu 12.04 server using apt-get?

Because I totally screwed up my python installation I manually deleted all the python files and am now trying to reinstall it. When I type apt-get install --reinstall python2.7, I get this error ...
3
votes
1answer
327 views

gedit 'broken' after update on Ubuntu 13.10

I have upgraded from Ubuntu 12.10 to 13.10. In the meanwhile I have removed the Enthought Python distribution manually because I want to start back on the 'official' packages. So I removed the python ...
2
votes
1answer
2k views

How do I resolve a “'python-uno' has no installation candidate” error?

I had a script, it is working with the package python-uno on Ubuntu 12.04 lts. The script is in python language and work with OOo to edit XLS files. Now I upgraded to 13.10 and it seems the uno not ...
2
votes
1answer
103 views

Answering debconf questions from a custom GUI in Python? (Custom Front-end)

I'm writing an app that should enable the user to install some additional packages when needed. I'd like to create a custom GUI that collects the packages debconf questions along with some other ...
0
votes
2answers
170 views

How to fix Libreoffice and Python3-uno

I cannot install any new packages because of python3-uno dependency problems. Apt-get said that python3-uno depends on libreoffice-core (=1:3.5.7-0ubuntu4) but 1:3.5.7-0ubuntu5 is to be installed. I ...
1
vote
0answers
128 views

Specifying Python Distribution in Ubuntu 13.10 (for Continuum Anaconda Python)

I've been trying to install Python on my Ubuntu 13.10 VM. Ubuntu already comes with Python, and when I remove it with apt a lot of other apps get removed. I have installed Continuum's Anaconda ...
1
vote
0answers
60 views

aptdaemon simulation not updating dependencies

I started playing with aptdaemon on Ubuntu 13.10 recently, and I'm baffled. Calling simulate() on a transaction doesn't update the dependencies list. Debug from aptd shows that several events are ...
0
votes
1answer
256 views

Problem with kivy installation

I'm trying to install the kivy framework. But first I need to install these packages: python-setuptools python-pygame python-opengl python-gst0.10 python-enchant gstreamer0.10-plugins-good python-dev ...
0
votes
0answers
422 views

Update Out-of-date-in-apt python on Ubuntu Server 12.04

Basically, I have a server running 12.04 LTS, and for some reason apt only has python 2.7.3, which is ~18 months out of date. Unfortunately, there are some bugs in the older version of python ...
1
vote
1answer
343 views

Can't install Python2.7 on Ubuntu 13.04

I'm trying to install Python 2.7 on my Ubuntu 13.04 VPS. I'm issuing; sudo apt-get install python=2.7.4-0ubuntu1 and getting this in return Reading package lists... Done Building dependency tree ...
1
vote
0answers
204 views

Can't Start Carbon - 12.04 - Python Error

I am really hoping someone can help me as I have spent at-least 15 hours trying to fix this problem. I have been given a task by a potential employer and my solution is to use ...
0
votes
0answers
150 views

Installing Mysql Workbench: Package python-minimal cannot be removed

I am a newbie in linux and Ubuntu. I tried to install Mysql Workbench on Ubuntu 12.04.3. I have downloaded .deb installation file and tried to run it. After double click on file, a dialog appeared ...
0
votes
1answer
73 views

pynag package not showing up in apt-get?

I need to install pynag, following the readme: http://code.google.com/p/pynag/source/browse/README.md It says to use apt-get. But it doesn't appear it found any packages? sudo apt-get install ...
0
votes
0answers
14 views

retrieve statistics on Ubuntu packages

how can I retrieve a list of all packages or better specific packages offered by Ubuntu? Preferable, I would like to create a list of certain packages shipped by Ubuntu but on a computer in the cloud ...
2
votes
1answer
4k views

How to install pip (python) to user without root access

Right, fairly new here but here goes: I'm trying to install pip (python installer) to my username since I don't have root privileges and can't just sudo apt-get install python-pip. So what I've ...
0
votes
1answer
91 views

Problems installing python-dev

I am currently working on a project requiring me to extend Python with a C library, and I will be using SWIG on Ubuntu. Worth noting is that I'm doing this on a computer at my university, and I don't ...
2
votes
3answers
10k views

I am not able to install easy_install in my ubuntu

i have to install Review board in ubuntu, i tried following commands but i am getting error sudo apt-get install python-setuptools. Reading package lists... Done Building dependency tree ...
1
vote
1answer
1k views

apt-add-repository raises an error [closed]

I’m trying to install JDE (Java Development Environment), but apt-get fails with the following error: me@ubuntu:~/$ sudo add-apt-repository ppa:webupd8team/java You are about to add the following PPA ...
1
vote
1answer
823 views

Can't install python-dev. Packages have unmet dependencies. I think it's a wrong Python version

root@Managementserver:~# sudo apt-get install python-pip python-dev build-essential -y Reading package lists... Done Building dependency tree Reading state information... Done build-essential ...