PPAs are personal package archives that allows users and groups on Launchpad to make packages available to the public. PPAs can be added with a terminal command or through Software Sources.

learn more… | top users | synonyms

7
votes
2answers
641 views

How to find which PPA contains a specific package?

I would like to know which repository contains a specific package, in order to add the PPA link to the sources.list file. The package can also be outside of the official repositories (multiverse or ...
0
votes
2answers
520 views

install wikidpad

How can I install WikiDPad? I know I have ran it before on ubuntu 14.10 and now I want to run it on 15.04. I have looked for .debs or a ppa for it but I don't know whether to trust the sources that I ...
3
votes
1answer
3k views

Install Scribus 1.5 On Ubuntu 14.10

All HOWTOs I found how to install scribus 1.5 are only for Ubuntu 14.04 or 15.04, but on 14.10 I cannot find the package scribus-trunk in the ppa: sudo add-apt-repository ppa:scribus/ppa sudo apt-get ...
0
votes
0answers
227 views

Gtk-WARNING **: cannot open display: on Ubuntu 14.04

I can't open the computer: (ubuntu 14.04). Please help me. Thanks very much! This is images: http://i.stack.imgur.com/a2mmH.jpg Some error: Failed to fetch http://ppa.lauchpad.net.... p/s: my ...
0
votes
1answer
186 views

How can I remove this PPA?

I have just installed a personal package archive from NodeSource by running curl -sL https://deb.nodesource.com/setup | sudo bash - I would like to know how to remove this. After looking at other ...
1
vote
2answers
17 views

Upgrading things later

I have installed a bunch of apps using debs and ubuntu standard repos. Is it possible that when I add a ppa of such an app at later time ubuntu will update my app. Common examples are apps such as ...
2
votes
2answers
51 views

How do I name a repository [duplicate]

I installed most software from the terminal. I saw that with some programs people give commands like this for example: sudo apt-add-repository ppa:jfi/ppa sudo apt-get update sudo apt-get install ...
0
votes
2answers
338 views

Can't Add ppa:x2go/stable error in 14LTS

This problem kept many Ubuntu LTS users like me from using x2go and forced to choose vnc or other alternatives. A question with same title is existing but it requires some reputation to answer. ...
0
votes
1answer
119 views

Identifying PPA

I have a ppa update error message: W:Failed to fetch http://ppa.launchpad.net/upubuntu-com/office/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found E:Some index files failed to download. ...
2
votes
0answers
36 views

Application rejected on myapps.developer.ubuntu.com. What can I do?

I submitted a desktop application on myapps.developer.ubuntu.com long time ago. But it was rejected today with the following reason: This package submission process is now deprecated. To provide my ...
1
vote
1answer
152 views

Package from a PPA not showing up

I've just added a PPA (more specifically, this one), but for some reason, I can't find any of the packages from it. As the link shows, there are packages there, but a search only comes the very ...
0
votes
3answers
728 views

Inkscape PPA not installing updates? [closed]

I have inkscape 0.48 installed and I'm trying to install inkscape 0.91 on the site they provide me with these commands sudo add-apt-repository ppa:inkscape.dev/stable sudo apt-get update sudo apt-...
1
vote
2answers
758 views

proxy authentication error in using app-ppa-repository after exporting proxy settings in ubuntu 15.04

i am trying to add repositories through the terminal after exporting proxy settings. export http_proxy="http://username:password@proxy":"port" export https_proxy="https://username:password@...
0
votes
1answer
110 views

What should I delete when “Failed to fetch ppa”

So when I tried to update I got the following message error: W: Failed to fetch http://ppa.launchpad.net/floe/libtisch/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found After I googled ...
0
votes
1answer
2k views

multiple repositories throwing a 404 trying to update on 15.04

I have 15.05 installed on my desktop, i recently installed it on my laptop and it was working fine, i opened it today and attempted to do an apt-get update and i'm having multiple repositories in the ...
1
vote
3answers
3k views

How to uninstall youtube-dl by using terminal

I was install Youtebe-dl through Ubuntu Software Center, but now my ubuntu software center is not working. So i can not able to Update and Install youtube-dl. I try following procedure for ...
2
votes
4answers
268 views

How do I fetch a specific package version from a repository?

Adding a PPA then running apt-get update to fetch seems to only fetch the latest version from that PPA, but I would like to install a specific version. Eg: I'm adding the ondrej/php5-5.6 ppa. After ...
0
votes
2answers
382 views

unable to update i:386 packages

I tried to update my repos using sudo apt-get update and I get this error. W: Failed to fetch http://ppa.launchpad.net/glimpse-hackers/stable/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not ...
1
vote
1answer
174 views

Gajim bug; how to safely upgrade to newest version?

I'm using Gajim 0.15.4 on Ubuntu 14.04. Quite a few menu items don't response when clicked. For example, under the "Actions" menu, the only items that work are "Start Chat..." and "Quit". Under the "...
3
votes
2answers
247 views

PPA removed and purged but still showing available upgrades

This is on Ubuntu 14.04 (SERVER, so no GUI) Ok so earlier today I was asked to upgrade GCC to GCC 4.9 (current available is GCC 4.8 for Trusty). So following these directions I installed the PPA ...
0
votes
1answer
346 views

Installing Oracle Java SE SDK 8u31 via apt-get

How can I install the Oracle Java SE SDK 8u31 via apt-get on Ubuntu 12.04 (prevcise)? I tried: apt-get install oracle-java8-installer from ppa:webupd8team/java, but it installed 8u45. After ...
0
votes
1answer
224 views

Cannot install flightgear on Ubuntu 15.04 because of broken packages

I am unable to install flightgear using the information and data provided in the PPA repository indicated on the public site of the simulator. The following packages have unmet dependencies: ...
1
vote
0answers
10 views

How to install Mono 4.0 [duplicate]

I want to use Mono on VSCode, so I installed Mono 3.2.8 but VSCode told me I need Mono 3.10 or higher so I decide to just install Mono 4 but I just can't. I uninstalled Mono-Complete, added PPA for ...
0
votes
2answers
3k views

PCL Ubuntu Installation

I have been trying to install PCL for linux on Ubuntu 14.10: http://pointclouds.org/downloads/linux.html So far, I have done the first two steps, sudo add-apt-repository ppa:v-launchpad-jochen-...
1
vote
1answer
629 views

How can I install the latest version of Tor?

I can't run tor from Iran with obfs3 but when I download the latest version of Tor Browser from https://www.torproject.org/dist/torbrowser/4.5.1/tor-browser-linux64-4.5.1_en-US.tar.xz, it worked ...
2
votes
1answer
1k views

Vlc - package dependencies cannot be resolved [duplicate]

I tried to install Vlc 2.2 in Ubuntu 14.04 LTS as it not available on Ubuntu Software Centre using following commands: sudo add-apt-repository ppa:mc3man/trusty-media sudo apt-get update && ...
0
votes
1answer
406 views

Is there a PPA for the latest proftpd security issue? (May 18th 2015)

I would need the 1.3.4e/1.3.5 package for precise (12.04). Thanks a lot...
0
votes
1answer
148 views

How to correctly version a modified package?

Currently I'm modifying the deja-dup backup tool, my inglorious attempts are documented under: https://answers.launchpad.net/deja-dup/+question/76645 and my source-branch can be found under: lp:~...
1
vote
1answer
584 views

Setting up on Ubuntu 14.04, trusty [duplicate]

This is my current version of Ubuntu: root@vps132318:~# lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty I ...
1
vote
1answer
104 views

Cannot remove mistyped repository

I accidentally mistyped a ppa when adding it. Instead of sudo add-apt-repository ppa:team-xbmc/ppa I used sudo add-apt-repository ppa:team-xmbc/ppa (xmbc instead of xbmc) Now I get an error when I ...
3
votes
1answer
4k views

gdebi vs dpkg : How gdebi automatically gets missing dependancies ? can i use gdebi for all other installations of deb packages?

Recently i happened to reinstall my ubunut in to lubuntu 15.04.. So i was searching for skype installation..and got this nice tute IT was really cool .. what it did was download official package of ...
0
votes
1answer
2k views

sudo apt-get update && sudo apt-get upgrade throws a Error 404 [duplicate]

Some days ago I install Ubuntu 15.04 (x64) and when the installation finished I tried to install cinnamon by doing: sudo apt-get install cinnamon But it seems that didn't work, next I try by doing: ...
3
votes
1answer
1k views

How can I download deb from a PPA?

How can I download deb package from a PPA?
4
votes
2answers
228 views

How long does it take for PPAs to get rebuild? Is it automatic?

I bought a new SSD so I installed Vivid on it today (the killer feature for me was systemd which cuts the shutdown process from 15 seconds to two) despite being on Trusty until yesterday. To my dismay,...
3
votes
1answer
963 views

Unable to find “testdisk” or “testdisk-dbg” packages in 15.04

Hello after a first installation 15.04 working at best, even better than manjaro + now it seems that there were some attacks (as usual) and by this the ppa or sources.lists are a bit affected + how do ...
0
votes
1answer
68 views

Download a package from a PPA as standalone file

I want to download (not install) a package from a PPA repository without adding the PPA by apt-add-repository and then updating APT cache. (Because updating cache can takes a long time and then I have ...
2
votes
1answer
50 views

What's the best way to make a program update from a new PPA (when an old one is no longer maintained)?

Let's say I'd like my FreeFileSync to update from 6.9 (the last version available in the official PPA) to 6.15 (the last version available on the official site). There's a proper Vivid package ...
0
votes
1answer
48 views

Copying packages in PPA fail due to same version

I copied my package from trusty's repository also to utopic's repository of my PPA without re-building the binaries by using Launchpad's copy packages feature. Now I noticed that the utopic package ...
4
votes
2answers
2k views

Why did debuild fail with “configure: error: unrecognized option:”

I was trying to follow the instructions listed in this question/answer. libimobiledevice 1.2 (iOS 8 Support) for Ubuntu 14.04 Trusty The answer said : "Actually I cheated a bit. I couldn't satisfy ...
0
votes
1answer
52 views

Is PPA still the only way to publish free open source app for Ubuntu Desktop?

There is a lot of contradicting information about publishing for Desktop. Some sources say that from 14.10 onwards Click packages also for Desktop can be submitted to USC. Other sources say that Click ...
2
votes
1answer
522 views

ERROR 403: Sorry, not allowed to fetch that type of file: jdk-7u80-linux-x64.tar.gz in 14.04 [duplicate]

I have had oracle's jdk7 installed on my 64bit Ubuntu 14.04 now for some time and it has behaved as expected. However lately all my updates has ended in errors and after some research I found the ...
0
votes
3answers
2k views

Notify OSD config on vivid vervet

I upgraded to Ubuntu 15.04 Vivid Vervet today and was annoyed, but unsurprised, to see that notify OSD was updated and restored to its default, limited, functionality. The thing is, the patched ...
1
vote
2answers
143 views

Need help with installing a package (dpkg problem)

When trying to install insight from some ppa repositories i get these errors. sudo apt-get install insight Reading package lists... Done Building dependency tree Reading state information... ...
2
votes
0answers
2k views

Upgrade Evolution in 14.04? No PPA and overwhelming dependancies to build

Is it reasonable to install a current version of Evolution (say 3.16.1) on Ubuntu 14.04? I added the recommended 'ppa:fta/gnome3', but I'm still only offered 3.10.4 from the Ubuntu archive. It seems ...
0
votes
2answers
2k views

How to fix problematic Ubuntu ppa configuration?

When I do sudo apt-get update I get following errors: Err http://archive.ubuntu.com raring/main amd64 Packages 404 Not Found [IP: 91.189.91.23 ...
3
votes
3answers
145 views

Ordering of the commands used to install from a ppa

To install from a ppa, you have to use the following 3 commands: sudo add-apt-repository example/program sudo apt-get update sudo apt-get install example-program Is there any reason not to do this: ...
0
votes
0answers
43 views

ppa broke my repositorys [duplicate]

I am running Ubuntu 14.04. And added the ppa ppa:nathandyer/vocal-stable. After adding it, I runned sudo apt-get update and got the following error: Fetched 13,1 kB in 8s (1478 B/s) ...
0
votes
1answer
29 views

How Can I Change PPA Fingerprint

I understand that if you create a PPA you have to accept the Ubuntu Code Of Conduct, and that in order to do so you have to register your OpenPGP fingerprint. Now, let's say that I lose my data on my ...
0
votes
2answers
1k views

Install stable release of xfce 4.12 [duplicate]

I want to install the stable release of xfce 4.12 on my Xubuntu 14.04.2. However, when I add the repository (ppa:xubuntu-dev/xfce-4.12) via terminal I get a message about these being pre-releases and ...
2
votes
1answer
665 views

Ubuntu 12.04 - Install newer libqtwebkit4 instead 2.2.1 for ScudCloud

I am trying to install ScudCloud, but it requires libqtwebkit4 version 2.3.2 or greater. Unfortunately, in Ubuntu 12.04 the latest version still remains in 2.2.1. Is there a PPA or an alternative ...