PPAs are personal package archives that allows users and groups on Launchpad to make packages available to the public. PPAs can be added with a terminal command or through Software Sources.

learn more… | top users | synonyms

4
votes
3answers
12k views

How to Remove elementary desktop environment?

I'm running ubuntu 12.10 and yesterday I installed elementary from ppa:elementary-os/daily. I later realized that elementary replaces the stock nautilus with another version that looks misplaced in ...
1
vote
2answers
16 views

Upgrading things later

I have installed a bunch of apps using debs and ubuntu standard repos. Is it possible that when I add a ppa of such an app at later time ubuntu will update my app. Common examples are apps such as ...
0
votes
1answer
165 views

Snes9x-GTK freezing on Ubuntu 13.10 while try to open roms

I just install the snes9x-gtk from ppa on Ubuntu 13.10. But, when i try to open a rom file, the snes9x-gtk frezes and I'm getting this message: Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", ...
1
vote
1answer
397 views

Unmet dependencies - cannot remove package libgbm1

In this case I have the libgbm1 being held, giving me message like: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. Since I carefully read How do I ...
0
votes
1answer
43 views

Can't Add ppa:x2go/stable error in 14LTS

This problem kept many Ubuntu LTS users like me from using x2go and forced to choose vnc or other alternatives. A question with same title is existing but it requires some reputation to answer. ...
0
votes
1answer
44 views

Identifying PPA

I have a ppa update error message: W:Failed to fetch http://ppa.launchpad.net/upubuntu-com/office/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found , E:Some index files failed to ...
2
votes
0answers
24 views

Application rejected on myapps.developer.ubuntu.com. What can I do?

I submitted a desktop application on myapps.developer.ubuntu.com long time ago. But it was rejected today with the following reason: This package submission process is now deprecated. To provide my ...
0
votes
0answers
46 views

Can I map Archlinux's official-packages into a PPA automatically?

I've been using chroagh on my Chromebook to get an Archlinux environment. Unfortunately, maintenance of chroagh is not keeping up with Freon. I'm switching to Ubuntu on my Chromebook, since crouton ...
1
vote
1answer
39 views

Package from a PPA not showing up

I've just added a PPA (more specifically, this one), but for some reason, I can't find any of the packages from it. As the link shows, there are packages there, but a search only comes the very ...
0
votes
3answers
165 views

Inkscape PPA not installing updates? [closed]

I have inkscape 0.48 installed and I'm trying to install inkscape 0.91 on the site they provide me with these commands sudo add-apt-repository ppa:inkscape.dev/stable sudo apt-get update sudo ...
3
votes
2answers
523 views

Why did debuild fail with “configure: error: unrecognized option:”

I was trying to follow the instructions listed in this question/answer. libimobiledevice 1.2 (iOS 8 Support) for Ubuntu 14.04 Trusty The answer said : "Actually I cheated a bit. I couldn't satisfy ...
0
votes
1answer
188 views

proxy authentication error in using app-ppa-repository after exporting proxy settings in ubuntu 15.04

i am trying to add repositories through the terminal after exporting proxy settings. export http_proxy="http://username:password@proxy":"port" export ...
0
votes
1answer
45 views

What should I delete when “Failed to fetch ppa”

So when I tried to update I got the following message error: W: Failed to fetch http://ppa.launchpad.net/floe/libtisch/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found After I googled ...
0
votes
1answer
538 views

multiple repositories throwing a 404 trying to update on 15.04

I have 15.05 installed on my desktop, i recently installed it on my laptop and it was working fine, i opened it today and attempted to do an apt-get update and i'm having multiple repositories in the ...
6
votes
1answer
5k views

libimobiledevice 1.2 (iOS 8 Support) for Ubuntu 14.04 Trusty

Is there a PPA available for the most recent libimobiledevice 1.2 version with support for iOS 8 or can someone explain how to build it from source without messing up everything? ...
1
vote
2answers
175 views

How to uninstall youtube-dl by using terminal

I was install Youtebe-dl through Ubuntu Software Center, but now my ubuntu software center is not working. So i can not able to Update and Install youtube-dl. I try following procedure for ...
0
votes
3answers
564 views

Notify OSD config on vivid vervet

I upgraded to Ubuntu 15.04 Vivid Vervet today and was annoyed, but unsurprised, to see that notify OSD was updated and restored to its default, limited, functionality. The thing is, the patched ...
2
votes
0answers
1k views

Now when there is no neon/kf5 ppa, how can I install KDE 5 in gnome Ubuntu 14.04?

All the other posts suggest to use the neon/kf5 but that doesn't work since early December. How can I do it now?
2
votes
4answers
50 views

How do I fetch a specific package version from a repository?

Adding a PPA then running apt-get update to fetch seems to only fetch the latest version from that PPA, but I would like to install a specific version. Eg: I'm adding the ondrej/php5-5.6 ppa. After ...
0
votes
2answers
86 views

unable to update i:386 packages

I tried to update my repos using sudo apt-get update and I get this error. W: Failed to fetch http://ppa.launchpad.net/glimpse-hackers/stable/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not ...
2
votes
2answers
222 views

Daily builds for VIM

Is there any PPA that allows to be up to date with the latest changes in VIM, even they are buggy or not? I would like to know that I use the latest VIM build even it is unstable. Also, the ...
0
votes
0answers
41 views

unmet dependencies [Wine]

Again with unmet dependencies problem, but this time it's something else... I am running Ubuntu 14.04, and I am trying to install wine but I get this message: The following packages have unmet ...
0
votes
0answers
51 views

Computer doesnt start after installing Oibaf Drivers

I recently installed Oibaf drivers on my computer and after having done that, the computer no longer starts, freezes in gnome logo (I use ubuntu gnome), I install the drivers using these commands: ...
1
vote
1answer
40 views

Gajim bug; how to safely upgrade to newest version?

I'm using Gajim 0.15.4 on Ubuntu 14.04. Quite a few menu items don't response when clicked. For example, under the "Actions" menu, the only items that work are "Start Chat..." and "Quit". Under the ...
6
votes
1answer
6k views

How to install VLC 2.2 in Ubuntu 14.04?

I want to install VLC 2.2 Weatherwax in the Ubuntu (well, Xubuntu) 14.04 LTS release. There is a PPA from Videolan on Launchpad that offers more recent VLC releases for Ubuntu Trusty 14.04. Except ...
1
vote
1answer
35 views

What's the best way to make a program update from a new PPA (when an old one is no longer maintained)?

Let's say I'd like my FreeFileSync to update from 6.9 (the last version available in the official PPA) to 6.15 (the last version available on the official site). There's a proper Vivid package ...
2
votes
1answer
4k views

Ghdl in Ubuntu 13.04

Just installed Ubuntu 13.04 after formating my laptop, and for some reason I can not install ghdl. After adding the ppa with this command : sudo add-apt-repository ppa:pgavin/ghdl everything is ...
1
vote
2answers
48 views

PPA removed and purged but still showing available upgrades

This is on Ubuntu 14.04 (SERVER, so no GUI) Ok so earlier today I was asked to upgrade GCC to GCC 4.9 (current available is GCC 4.8 for Trusty). So following these directions I installed the PPA ...
0
votes
1answer
90 views

Installing Oracle Java SE SDK 8u31 via apt-get

How can I install the Oracle Java SE SDK 8u31 via apt-get on Ubuntu 12.04 (prevcise)? I tried: apt-get install oracle-java8-installer from ppa:webupd8team/java, but it installed 8u45. After ...
3
votes
2answers
99 views

Install package from without adding PPA

Is there a way to install a package via a simple URL without having to add a PPA beforehand? Something like apt-get https://url.to.package.deb? Or perhaps some command line options that would add the ...
3
votes
3answers
286 views

How do I purge Pantheon desktop?/Why does this window appear?

This browser window showing http://elementary.io/ appears after I installed then uninstalled the Pantheon environment: Originally this occurred after (and possibly before) ppa-purging the PPA only ...
0
votes
1answer
91 views

Cannot install flightgear on Ubuntu 15.04 because of broken packages

I am unable to install flightgear using the information and data provided in the PPA repository indicated on the public site of the simulator. The following packages have unmet dependencies: ...
27
votes
2answers
17k views

Difference between “ppa-purge” and “add-apt-repository -r”?

What is the main difference between ppa-purge and add-apt-repository -r. Which one better clear residual items and reason to use one over another? Does add-apt-repository -r should do what ppa-purge ...
0
votes
0answers
8 views

How to install Mono 4.0 [duplicate]

I want to use Mono on VSCode, so I installed Mono 3.2.8 but VSCode told me I need Mono 3.10 or higher so I decide to just install Mono 4 but I just can't. I uninstalled Mono-Complete, added PPA for ...
0
votes
2answers
182 views

PCL Ubuntu Installation

I have been trying to install PCL for linux on Ubuntu 14.10: http://pointclouds.org/downloads/linux.html So far, I have done the first two steps, sudo add-apt-repository ...
0
votes
0answers
58 views

PPA Pinning, trying to install qemu with glusterfs packages

I need to have glusterfs enabled qemu, however default repository qemu is not built with glusterfs support. I have found a ppa & added it, I made the pinning in apt preferences, however even when ...
1
vote
1answer
118 views

How can I install the latest version of Tor?

I can't run tor from Iran with obfs3 but when I download the latest version of Tor Browser from https://www.torproject.org/dist/torbrowser/4.5.1/tor-browser-linux64-4.5.1_en-US.tar.xz, it worked ...
0
votes
1answer
265 views

Vlc - package dependencies cannot be resolved [duplicate]

I tried to install Vlc 2.2 in Ubuntu 14.04 LTS as it not available on Ubuntu Software Centre using following commands: sudo add-apt-repository ppa:mc3man/trusty-media sudo apt-get update && ...
0
votes
1answer
91 views

Is there a PPA for the latest proftpd security issue? (May 18th 2015)

I would need the 1.3.4e/1.3.5 package for precise (12.04). Thanks a lot...
5
votes
3answers
4k views

Installing Node.JS through a PPA does not fetch the latest version

yeah yeah I know, this has been asked before. But when using the chris-lea ppa or the "official way" (which I think is actually the same thing?), after installing you get this: ~$ node --version ...
0
votes
0answers
48 views

Graphics changed after relogin on Ubuntu 15.04

So, a little background. While trying to fix the issue with chrome and other video player freezing when waking up from suspend, I think I accidentally changed some settings. And from my history I'm ...
0
votes
1answer
26 views

How Can I Change PPA Fingerprint

I understand that if you create a PPA you have to accept the Ubuntu Code Of Conduct, and that in order to do so you have to register your OpenPGP fingerprint. Now, let's say that I lose my data on my ...
4
votes
2answers
527 views

PPA for recent versions of mercurial

Im trying to access mercurial repositories that were created on windows with mercurial version 1.8.2. As the version in the repositories is a few numbers behind, its not playing ball. Does anyone ...
0
votes
1answer
43 views

How to correctly version a modified package?

Currently I'm modifying the deja-dup backup tool, my inglorious attempts are documented under: https://answers.launchpad.net/deja-dup/+question/76645 and my source-branch can be found under: ...
1
vote
1answer
182 views

Setting up on Ubuntu 14.04, trusty [duplicate]

This is my current version of Ubuntu: root@vps132318:~# lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty I ...
128
votes
12answers
306k views

How to install Eclipse?

I want to install the latest version of Eclipse but the Ubuntu Software Centre contains an older version. Is there a PPA or some other way to install latest Eclipse? Please describe the steps for ...
1
vote
1answer
280 views

gdebi vs dpkg : How gdebi automatically gets missing dependancies ? can i use gdebi for all other installations of deb packages?

Recently i happened to reinstall my ubunut in to lubuntu 15.04.. So i was searching for skype installation..and got this nice tute IT was really cool .. what it did was download official package of ...
1
vote
1answer
64 views

Cannot remove mistyped repository

I accidentally mistyped a ppa when adding it. Instead of sudo add-apt-repository ppa:team-xbmc/ppa I used sudo add-apt-repository ppa:team-xmbc/ppa (xmbc instead of xbmc) Now I get an error when I ...
157
votes
2answers
201k views

How do I install latest PHP in supported Ubuntu versions (like 5.4.x in Ubuntu 12.04)?

I am trying to update to php 5.4 in Ubuntu 12.04, and I can only get 5.3.6 using official repositories (using apt-get). I'm not really sure how to do a manual update – I'm sorta new to ubuntu, but I ...
0
votes
1answer
328 views

sudo apt-get update && sudo apt-get upgrade throws a Error 404 [duplicate]

Some days ago I install Ubuntu 15.04 (x64) and when the installation finished I tried to install cinnamon by doing: sudo apt-get install cinnamon But it seems that didn't work, next I try by doing: ...