PPAs are personal package archives that allows users and groups on Launchpad to make packages available to the public. PPAs can be added with a terminal command or through Software Sources.

learn more… | top users | synonyms

0
votes
0answers
15 views

Upgrade Evolution in 14.04? No PPA and overwhelming dependancies to build

Is it reasonable to install a current version of Evolution (say 3.16.1) on Ubuntu 14.04? I added the recommended 'ppa:fta/gnome3', but I'm still only offered 3.10.4 from the Ubuntu archive. It seems ...
0
votes
2answers
27 views

How to fix problematic Ubuntu ppa configuration?

When I do sudo apt-get update I get following errors: Err http://archive.ubuntu.com raring/main amd64 Packages 404 Not Found [IP: 91.189.91.23 ...
3
votes
4answers
103 views

Ordering of the commands used to install from a ppa

To install from a ppa, you have to use the following 3 commands: sudo add-apt-repository example/program sudo apt-get update sudo apt-get install example-program Is there any reason not to do this: ...
0
votes
0answers
32 views

ppa broke my repositorys [duplicate]

I am running Ubuntu 14.04. And added the ppa ppa:nathandyer/vocal-stable. After adding it, I runned sudo apt-get update and got the following error: Fetched 13,1 kB in 8s (1478 B/s) ...
0
votes
0answers
13 views

How Can I Change PPA Fingerprint

I understand that if you create a PPA you have to accept the Ubuntu Code Of Conduct, and that in order to do so you have to register your OpenPGP fingerprint. Now, let's say that I lose my data on my ...
-1
votes
2answers
30 views

Install stable release of xfce 4.12 [duplicate]

I want to install the stable release of xfce 4.12 on my Xubuntu 14.04.2. However, when I add the repository (ppa:xubuntu-dev/xfce-4.12) via terminal I get a message about these being pre-releases and ...
0
votes
0answers
37 views

GPG error: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key [on hold]

I really understand same topic already exist but there is no solution. I have done tries clean install of Elementary OS Based on 14.04 32bit & 64bit as well. I keep on receiving error while doing ...
0
votes
0answers
22 views

The update information is outdated (notification icon) ubuntu 14.10

hi i have some problems whit this ... i tried to manual update and still stays there... i went to software & updates and tried to check the problem there and i get this W:Failed to fetch http: ...
0
votes
0answers
16 views

Can't install Ubuntu Touch on Nexus 7 [duplicate]

I have been trying to download the desktop installer for Ubuntu for Nexus 7 (for reference wiki.ubuntu.com/Nexus7/Installation) I've successfully added the PPA with the following command sudo ...
0
votes
0answers
14 views

Sigil PPA with fix for missing menu bar? [on hold]

I've read How do I install Sigil?, which mentions several PPAs, and I've successfully installed Sigil 0.8.2 from the i2p PPA. However, the build in that PPA is afflicted by issue #2500 -- the menu ...
1
vote
1answer
18 views

Ubuntu 12.04 - Install newer libqtwebkit4 instead 2.2.1 for ScudCloud

I am trying to install ScudCloud, but it requires libqtwebkit4 version 2.3.2 or greater. Unfortunately, in Ubuntu 12.04 the latest version still remains in 2.2.1. Is there a PPA or an alternative ...
0
votes
2answers
57 views

Ubuntu doesn't download files using apt-get update [closed]

When I type the command sudo apt-get update on Ubuntu 14.04, it downloads most of the files but the other ones say for example: Failed to fetch ...
0
votes
1answer
22 views

Unable to update battery-status ppa

I'm using Ubuntu 14.04. I'm getting this error W: Failed to fetch http://ppa.launchpad.net/iaz/battery-status/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found W: Failed to fetch ...
0
votes
0answers
63 views

Can't install DeVeDe, failed to fetch libavcodec-extra-54_1.2.6-1~trusty1_amd64.deb [duplicate]

While attempting to install DeVeDe, I get this error: sudo apt-get install devede Err http://ppa.launchpad.net/jon-severinsson/ffmpeg/ubuntu/ trusty/main libavcodec-extra-54 amd64 7:1.2.6-1~trusty1 ...
2
votes
0answers
30 views

I have a PPA, but I can't figure out how to add an image to the Software Center listing

So I have made a PPA: https://launchpad.net/~stefansundin/+archive/ubuntu/truecrypt After adding the ppa and updating the sources, I can see it in the software center. It is using the default icon ...
0
votes
1answer
24 views

Cannot add PPA: 'ppa:gluster/ubuntu-glusterfs-3.5'

I am runnning into problem adding a repository. ~# add-apt-repository ppa:gluster/ubuntu-glusterfs-3.5 Cannot add PPA: 'ppa:gluster/ubuntu-glusterfs-3.5'. Please check that the PPA name or format is ...
0
votes
1answer
55 views

Red Triangle with an exclamation point [duplicate]

I am new to Ubuntu 14.04, having just installed it 2 weeks ago. I am running Ubuntu 14.04 as my only OS. I am a new user and I have to say I love the OS but I am having a difficult time learning it. I ...
0
votes
2answers
68 views

Installing Java 8 and Setting environment variables

I just completly shifted to Ubuntu from Windows 7. I am a java developer and now I need to install Java 8 JDK and JRE. I installed 64 bit ubuntu 14.04.02 and it seems like there are lot of ways to ...
0
votes
0answers
21 views

Error installing deluge on ubuntu server (unmet dependencies)

I am getting the error that I have an unmet dependency "deluge-common" when I run the command: dprogers@homeserver:~$ sudo apt-get install deluged [sudo] password for dprogers: no talloc ...
3
votes
2answers
120 views

How do I purge Pantheon desktop?/Why does this window appear?

This browser window showing http://elementary.io/ appears after I installed then uninstalled the Pantheon environment: Originally this occurred after (and possibly before) ppa-purging the PPA only ...
0
votes
1answer
16 views

Build failed LaunchPad “Dependency wait on lgw01-31”

I have got a PPA on LaunchPad and a pack which depends on gawk (>= 1:4.1.1+dfsg-1) (this is set in the control file). But when uploading the .change file to LaunchPad with dput I get this error: ...
0
votes
1answer
22 views

How to upload to a launchpad team PPA?

I have built and signed a package which I now wish to upload to my launchpad team with dput, but every time that I try to upload it I get this email: Rejected: Source/binary (i.e. mixed) uploads are ...
1
vote
1answer
28 views

What is a '.orig.tar.xz' file in packaging?

I have recently started packaging a bash script of mine into a .deb file so that I can upload it to my PPA, and I have noticed a lot of talk about a file which seems to have been created from my ...
2
votes
0answers
18 views

What does this dput message mean?

I uploaded a new package to a PPA (the PPA contains no reference of any uploads of this package in the past), and dput output this curious message: Package includes an .orig.tar.gz file although ...
0
votes
0answers
19 views

Packaging an app that uses autotools

Hopefully someone can help me, I maintain a ppa and lately I've been trying to package a few apps which utilize autotools in their source. I've tried various different configurations in my debian ...
0
votes
1answer
49 views

What is the correct address for precise/12.04 restricted, multiverse and universe ppa?

I am running Ubuntu 12.04. When I run sudo apt-get update now I get the following errors at the end: W: Failed to fetch ...
7
votes
4answers
2k views

Google Chrome PPA upgrade invalid signature

When running: sudo apt-get update && sudo apt-get dist-upgrade I got this output: Ign http://security.ubuntu.com utopic-security InRelease Ign http://gb.archive.ubuntu.com utopic InRelease ...
1
vote
1answer
438 views

libimobiledevice 1.2 (iOS 8 Support) for Ubuntu 14.04 Trusty

Is there a PPA available for the most recent libimobiledevice 1.2 version with support for iOS 8 or can someone explain how to build it from source without messing up everything? ...
0
votes
1answer
34 views

The latest version of translations

How can I get the latest versions of translations for Ubuntu? In Launchpad I can see that there are many improvements for translations in my language, some of them were made even a year ago (Uzbek ...
0
votes
2answers
139 views

ppa problems while adding new ones [closed]

I am new to ubuntu so it might be a silly problem(im running ubuntu 15.04), but I get these problems everytime i try to add a ppa or update: W:Failed to fetch ...
0
votes
1answer
19 views

self created .deb package has versioning problems

I did my first steps in creating a PPA, containing a recent fossil version. I unpacked the tarball and ran bzr dh-make fossil 1.32 ../fossil-src-stable.tar.gz on it, editet the debian files till ...
0
votes
0answers
34 views

How to use xorg-edgers properly? [duplicate]

I am looking for a way to get the latest "stable" Nvidia drivers for Ubuntu (the .run version that would be available from Nvidia website). I heard that the .run method of installation can cause your ...
1
vote
1answer
122 views

Unmet dependencies - cannot remove package libgbm1

In this case I have the libgbm1 being held, giving me message like: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. Since I carefully read How do I ...
0
votes
0answers
339 views

How I can upgrade gnome to latest(Testing or Unstable release) on ubuntu?

Now I'm using gnome shell version 3.14.3 on ubuntu 14.10 utopic.How I can upgrade gnome-shell to 3.16 or 3.15 91(on ppa:ricotz/testing repository). Currently I added following ppa repository ...
1
vote
2answers
32 views

What happens to PPA and applications installed from PPA if Ubuntu is updated to the next release

What happens to PPA and applications installed from PPA if Ubuntu is updated to the next release? Since Ubuntu-provided repositories are specific to Ubuntu releases, I'm guessing the same is for PPA? ...
3
votes
1answer
88 views

What are the 'Other Software' PPAs?

In my "System Settings > Software & Updates > Other Software" section I have always (since install) had the two at the top disabled, and seem to always had these Independent ones which say that ...
0
votes
1answer
17 views

Launchpad: Build package on utopic, but release for older versions

Let's say I want to build an application, that has certain Build-Depends, that can only be satisfied on utopic. To be more specific: openjdk-8-jdk*. The resulting binary will no longer have this ...
0
votes
1answer
23 views

PPA build fails only in one distribution and on one architecture

I'm trying to publish a package to my PPA, which builds find on my system, both native and using pbuilder (both trusty and precise). But when I upload it to PPA, the trusty AMD64 build fails for some ...
0
votes
0answers
54 views

redis-server - What difference between rwky/redis and chris-lea/redis-server?

What difference between https://launchpad.net/~chris-lea/+archive/ubuntu/redis-server and https://launchpad.net/~rwky/+archive/ubuntu/redis?
1
vote
1answer
45 views

How to easily bump a package for a PPA?

What's the easiest way to bump the version number for a package that shall be uploaded to a Launchpad PPA? For instance, what I do now is that on each new release I unpack the previous ...
3
votes
1answer
98 views

“apt-get update” gives many [Ign] errors - is that a problem?

I just ran sudo apt-get update once again and I thought that there are many lines starting with Ign instead of Hit in the output. I wondered what it means and researched on Ask Ubuntu and Super User, ...
1
vote
1answer
233 views

xorg-edgers or mamarley ppa?

I've been having issues (it seems many have been experiencing the same problems) with the NVIDIA drivers and NVIDIA prime lately. More specifically, being unable to switch to the card and getting ...
-1
votes
1answer
65 views

How to fix GPG error on Intel Linux Graphics Installer?

I'm trying to use Intel Graphics Installer, but i get the following error: E:GPG error: http://ppa.launchpad.net trusty InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require ...
0
votes
0answers
18 views

Trouble adding a PPA and verifying with signing ring [duplicate]

I'm trying to add the ppa deb http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu trusty main I've tried adding it to /etc/apt/sources.list but during the update process I get this error. W: ...
1
vote
2answers
1k views

installing latest node.js through ppa (not a duplicate!)

yeah yeah I know, this has been asked before. But when using the chris-lea ppa or the "official way" (which I think is actually the same thing?), after installing you get this: ~$ node --version ...
5
votes
1answer
65 views

PPA package: Specify different dependencies for different Ubuntu versions

Let's say I have a PPA package that depends on the libtool executable to build. In Vivid, this executable is provided by the libtool-bin package. For earlier Ubuntu versions, it is provided by the ...
0
votes
1answer
38 views

How do I 'remove' a redundant repository

I have a ppa 'installed' which has many packages which have been installed (replacing packages installed from Ubuntu standard repos) on my Ubuntu Trusty PC. I want to no longer use that ppa and want ...
1
vote
1answer
69 views

Edgers PPA Graphic Drivers Automatic Update

This may be a dumb question but does the Edgers PPA provide automatic updating? IE will the Edgers PPA automatically install newer releases of Nvidia drivers? Thanks.
0
votes
1answer
165 views

grive-tools : Depends: libcurl4-openssl-dev but it is not going to be installed

recently I tried to install Grive Tools, following the instructions from this website Ubuntu Google Drive Client with Grive and Grive Tools. Everything worked perfect until I reached the point where I ...
0
votes
1answer
42 views

How to add a PPA which does not include my Ubuntu distribution?

I am trying to add ppa:stevedh/smap to my repository with the following command: sudo add-apt-repository ppa:stevedh/smap It gets added. When i sudo do apt-get update I recieve the following ...