PHP is a server-side scripting language, used for building browser-based applications. This includes websites as well as programs that don't really need any form of interaction with the user.

learn more… | top users | synonyms (2)

0
votes
0answers
11 views

connect from ubuntu server to pgsql in windows

I have a website that is on Ubuntu server but my database is in windows and i have config file too. how can I connect these one together? this my config file : * PostgreSQl : pgsql * MySQL : ...
1
vote
1answer
19 views

What's the difference between the php7.0-sqlite and php-sqlite3 packages?

When you use apt-get, what's the difference between the php7.0-sqlite package and the php-sqlite3 package? I'm trying to get a php PDO package
0
votes
1answer
29 views

PHP5 versus PHP7.0

I have two programs written in PHP that have been running fine in Ubuntu Linux 12.04 LTS with PHP5. Now I am trying to run them on a new installation of Ubuntu Linux 16.04 LTS with PHP7.0. Each asks ...
0
votes
0answers
12 views

Unable to use expect_popen() after upgrading from PHP 5.5.9 to 5.6

Some PHP code I wrote requires syntax which is only available from PHP5.6 onwards. I decided to upgrade my Ubuntu 14.04 LTS server to PHP version 5.6, but unfortunately I encountered a problem doing ...
0
votes
1answer
49 views

Ubuntu Server unable to create directory in PHP

I have setup a little Ubuntu Server for developing some web apps. I have a little script that uses mkdir() to create a directory, but i am getting a permission denied, its a simple command mkdir($...
0
votes
1answer
32 views

Apache does not load php files

Everything working fine until I upgraded php version to php5.6. I have installed php5.6 using composer. when I restart apache2 server and start it again, server stopped loading php files.help please, ...
0
votes
0answers
121 views

PHP Warning: PHP Startup: Unable to load dynamic library

I got error like PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/php_intl.dll' - /usr/lib/php/20151012/php_intl.dll: cannot open shared object file: No such file or ...
0
votes
1answer
43 views

Limited size of MySQL INSERT

I am inserting data from .csv to MySQL database using PHP but I can't INSERT more than 922 lines. Every time the number of the lines is different, usually it is 841 or 837 but after restart my mysql-...
1
vote
1answer
18 views

Is libsqlite3-0 installed by default?

I'd like to know if libsqlite3-0 is installed by default, or if it is installed when running apt-get install phpmyadmin. I am currently running Ubuntu 16.04 I'd like to know what it is and why I can'...
84
votes
14answers
26k views

What's the easiest way to set up a LAMP stack?

I set up a new VPS instance of Ubuntu and am wondering what the easiest way is to get up and running with a basic LAMP stack (i.e. which packages are required, which configuration options need to be ...
1
vote
1answer
4k views

mbstring is missing for phpmyadmin in ubuntu 16.04

When I installed phpmyadmin in Ubuntu 16.04 LTS, it gives me an error mentioned below. The mbstring extension is missing. Please check your PHP configuration then I tried to install php-mbstring, ...
0
votes
0answers
9 views

bWAPP installation ERROR

I am trying to install bWAPP on my ubuntu gnome 16.04 computer. With this tutorial. When I try out number 6 I get an error 500. My guess is that I didn't set up php correctly. But it could be ...
0
votes
0answers
19 views

Eclipse Error Ubuntu 16.04: “Could not create the view: Plug-in org.eclipse.php”

Fellows, I have installed the eclispe via repos. I also installed the PTD tools for php development. But When I start it I get the following error: "Could not create the view: Plug-in org.eclipse....
0
votes
0answers
9 views

Adding extensions to PHP installation

I want to add the pthreads extension to my existing vagrant Ubuntu 14.04 installation. For that to work, PHP needs to be configured with --enable-pthreads=static --enable-maintainer-zts. What is the ...
70
votes
2answers
270k views

Find the correct php.ini file

I am currently trying to locate the correct php.ini file to edit it and restart apache so the changes will take place and I'm stumped. What I have done... I have found three different php.ini files (...
0
votes
2answers
5k views

Cannot install php5-fpm, Error: No Installation Candidate

I am unable to install php5-fpm from sudo apt-get install php5-fpm. It says: No installation candidate. No .deb repository link available. Does anyone have a solution?
1
vote
2answers
15 views

Using logrotate to manage logs generated by PHP

My PHP scripts generate log files and I am trying to use logrotate to manage them. File /etc/logrotate.d/php-logs: /srv/cache/*.log { daily notifempty size 800K rotate 5 missingok ...
0
votes
1answer
23 views

How to give permissions to user www-data (apache+php) to access media/user/sd card slot?

I have a php script that runs from apache2 call that needs to read files in a SD card. The SD card appears mounted in /media/user/name of SD card partition. I tried to read this answer Default file ...
0
votes
0answers
23 views

PHP Scripts doesn't executed

I installed LAMP server successfully.But,I didn't have permission to save my php scripts in var/www/html folder.Then I ask it from this forum and fix it. Now what happen is I can save my phps scripts ...
0
votes
1answer
33 views

Lampp (xampp) stop after reboot, not work autostart on Ubuntu

I am working with Ubuntu Server 15.04, I have a problem at some point in the night the computer restarts or shuts off the power goes out or simply stops working the lampp (Xampp) apachefriends, I ...
0
votes
1answer
41 views

You don't have permisission necessary to save the file,PHP Apache [duplicate]

I just installed LAMP server, which works fine. But when I code a PHP script and try to save it in /var/www/html, it says: You don't have permisission necessary to save the file Help me! How do I ...
-1
votes
1answer
25 views

Symfony2 variable does not pass to twig [closed]

I am trying to pass variable to the twig with this function in the controller public function profileAction(Request $request) { $items = $this->getDoctrine()->getManager()->...
1
vote
1answer
4k views

/lib/x86_64-linux-gnu/libz.so.1: could not read symbols: Invalid operation

I installed Ubuntu Desktop 13.10 64-bit in VMware. I am trying to compile PHP 5.4.14 on the machine. Here's the bit where make stops due to an error: /usr/bin/ld: ext/mysqlnd/.libs/mysqlnd_net.o: ...
0
votes
0answers
18 views

drush status error

I am a newbie to Linux. I need to install drush on my Ubuntu 14.04. Application is built with PHP 5.3 and Drupal 6 (my version is 5.3.29, PHP was installed with phpbrew and then switched to 5.3.29). ...
6
votes
3answers
31k views

apache2 - php5 file upload and post max size

I've installed from the official repos the LAMP server. Into the file /etc/php5/apache2/php.ini i've changed post_max_size = 8M to post_max_size = 32M and upload_max_filesize = 2M to ...
3
votes
2answers
17k views

Changes for upload_max_filesize, memory_limit & post_max_size in the php.ini aren't affect

I'm trying to increase the upload_max_filesize etc in order to import bigger files with PHPMyadmin. I have changed the php.ini and restart Apache. I can see the changes on the PHPMyadmin import ...
0
votes
1answer
32 views

14.04 php5-mcrypt openCart

I have a problem with php5 extension mcrypt. The command php5 -m | grep mcrypt Outputs: mcrypt But during openCart install I see extension mCrypt not installed. I've restarted apache with: ...
-2
votes
1answer
33 views

chmod not assigning permissions properly?

We are testing osTicket which is an open source ticketing system and have set everything up, but when we try to connect to the page we get blank results with the following error logs: [:error] [pid ...
0
votes
0answers
28 views

PHP errors in /usr/sbin/a2query

I am new to Ubuntu, currently on 14.04, I develop on Windows but want to do same on Linux(Ubuntu) I tried to open a PHP file from localhost, I get a blank page. I checked if the PHP module is loaded I ...
0
votes
2answers
105 views

15.10 upgraded to 16.04 and PHP broke

I accidentaly upgraded my system instead of just putting the updates on, and not my moodle won't work because PHP is messed up. It tells me I have unmet dependencies, and problems with PHP5-cli. ...
8
votes
1answer
36k views

How to make Curl and PHP available when installed from Xampp

I have installed a recent copy of XAMPP on Ubuntu 14.04. However, when I issue this command: curl -sS https://getcomposer.org/installer | php I get the following error messages: The program 'curl'...
-3
votes
0answers
10 views

Amazon Linux AMI server (Centos), PHP 5.3.29 does not have mysql functions included [closed]

We have a legacy server, it's internal, and there is no way I'm going to be able to update PHP, so that's not an option. Currently it runs 5.3.3. The command cat /etc/issue returns Amazon Linux ...
0
votes
0answers
30 views

How do I fix: PHP Fatal error: Call to undefined function Illuminate\\Encryption

PHP Fatal error: Call to undefined function Illuminate\Encryption\mcrypt_get_iv_size() in /var/www/html/application/vendor/laravel/framework/src/Illuminate/Encryption/Encrypter.php on line 303 I am ...
0
votes
2answers
151 views

502 Bad Gateway nginx php7 fpm

I tried to install nginx and PHP7 with fpm using this tutorail https://www.digitalocean.com/community/tutorials/how-to-upgrade-to-php-7-on-ubuntu-14-04 When i try to access any php file I get 502 Bad ...
0
votes
0answers
26 views

fastcgi cache in nginx is not caching the same page for all users

I'm using Ubuntu 14.04 server, and I just found out that fastcgi cache is not caching the same page for everybody. I thought it did. I ran some new PHP GeoIp code that displays the user's country name,...
1
vote
1answer
97 views

Ubuntu 16 php5.6 gd extension

I'm running ubuntu 16 and I'm trying to install php5.6 extension GD. I understand that php5.6 isn't available anymore in the default ubuntu repo's. I followed How can I downgrade from PHP 7 to PHP 5....
0
votes
0answers
18 views

Problem with non-root users crontab and CLI PHP

I'm stuck with the following problem and cannot seem to resolve it and would like some help if possible... I have created a user (lets call it user) and have edited the crontab for that user and have ...
0
votes
1answer
8k views

Ubuntu 13:10 - Downgrade php 5.5.3 to 5.4

Can someone give me step my step instructions on how to do this? Will I have to worry about and data/databse loss doing this. Thanks! sudo apt-get remove --purge dpkg -l | grep php | grep -w 5.5 |...
0
votes
0answers
27 views

Cannot access phpmyadmin on xampp on 16.04 LTS

Every time I try to access phpmyadmin on my XAMPP I get this message: Error during session start; please check your PHP and/or webserver log file and configure your PHP installation properly. Also ...
0
votes
1answer
62 views

Ubuntu 16.04 phpinfo shows blank Page

After installing MYSQL APACHE2 and PHP7 when I go to see phpinfo page it shows a blank page. During installation process I am not able to install libapache2-mod-php7 in Ubuntu 16.04. It give error ...
0
votes
1answer
23 views

Could not find driver error

When I try to run index.php using this command - php -S localhost:8080 I get "could not find driver" error. But php files not using mysql runs correctly. What may be the issue and how do I fix ...
69
votes
6answers
157k views

Global Installation of Composer (manual)

I followed composer manual (global installation of composer (manual)) to install composer on Ubuntu. $ ll /usr/local/bin/ total 4760 drwxr-xr-x 2 root root 4096 2012-03-29 08:29 ./ drwxr-xr-x 10 ...
1
vote
1answer
4k views

Call to undefined function sqlite_open() in CLI mode

12.04 AMD 64 apt-get install sqlite php5-cli php5-sqlite php -r '$x = sqlite_open();' PHP Fatal error: Call to undefined function sqlite_open() in Command line code on line 1
2
votes
2answers
211 views

installing composer

I'm new on Unix-like systems, and using Ubuntu now. Experiencing trouble trying to install Composer with command: (sudo) curl -sS https://getcomposer.org/installer | (sudo) php mv composer.phar /usr/...
0
votes
0answers
24 views

url with controller and action name not working

I am new to Ubuntu. I installed php, mysql and apache successfully. Now when I type http://localhost/my_project_name/, it works properly but when I type http://localhost/talentrack/my_project_name/...
0
votes
0answers
19 views

Can I use one phpMyAdmin per virtualhost?

I worked on ubuntu 16.04 server, I will host multiple domains on my ubuntu server with apache virtualhost, my question is how to make phpmyadmin show only database created on my virtual host ? For ...
0
votes
0answers
27 views

website displaying php code instead of running it

5 and ioncube to run GameCP but when i go to the installer page it comes up with the whole php code it's self it doesn't run the php to install what am i missing?? if you have any idea please help i ...
41
votes
5answers
64k views

How to have two version of PHP installed and switch easily?

I want to have both PHP 5.2.17 and PHP 5.3.5 installed on my Ubuntu machine and switch as per my necessity. How can I achieve this?
0
votes
0answers
28 views

localhost host files not running ..its downloading..? [duplicate]

While clicking or running a project in http://localhost in my ubuntu machine,... its just downloading a file..? why.?
2
votes
2answers
10k views

Unable to get error stack trace or error log while using php-fpm + nginx on Ubuntu 14.04

I am using php-fpm 5.5.9 along with nginx 1.4.6 on my Ubuntu 14.04 machine. I have installed them using apt-get package manager. I am unable to get a stack trace of the error that my index.php script ...