PHP is a server-side scripting language, used for building browser-based applications. This includes websites as well as programs that don't really need any form of interaction with the user.

learn more… | top users | synonyms (2)

3
votes
1answer
2k views

Update to PHP 5.4.7 [duplicate]

I am currently running PHP 5.4.6-1ubuntu1.1 (cli) (built: Nov 15 2012 01:18:34) on xubuntu . I would like to update to latest version or >= 5.4.7. Is there another way to do instead of making it from ...
0
votes
1answer
2k views

Installing php imagick to xampp

I am trying this: sudo apt-get install imagemagick libmagickwand-dev sudo pecl install imagick And I getting an error at the end like: /tmp/pear/temp/imagick/imagick_class.c:9534:2: error: 'struct ...
1
vote
1answer
548 views

403 error on PHP - lighttpd

I have set up the fastcgi properly, unhashed it from the module.conf, [root@xlh lighttpd]# service lighttpd status Redirecting to /bin/systemctl status lighttpd.service lighttpd.service - Lightning ...
0
votes
2answers
571 views

What happened to php-5.4.11 from Ondrej PPA? [closed]

I am in 12.04 so I added Ondrej's PPA to get PHP 5.4. So far so good but php-5.4.12 seems to be broken with our code and after a while of struggling I decided to downgrade to php-5.4.11 but apt-cache ...
2
votes
3answers
4k views

How to run PHP code in browser directly from Geany?

I'm using a latest Geany version from official repositories, same with a php5 package. There is my question: How to run PHP code from Geany directly in web browser instead of terminal? I know, ...
2
votes
1answer
825 views

Compiling php 5.2 from source under 12.04, apxs2 (via libtools) ignores the -prefix used with ./configure

In the source directory: ./configure --prefix=/home/ashkan/Development/php/bin/php-5.2 --with-mysql --with-apxs2=/usr/bin/apxs2 make works fine but make install says: Installing PHP SAPI module: ...
8
votes
2answers
59k views

How do I completely remove phpmyadmin?

I messed up my phpmyadmin, I haven't logged in phpmyadmin for a while, and as a result I forgot my password, so I purge it like so: sudo apt-get purge phpmyadmin. I did get some error messages asking ...
6
votes
3answers
11k views

Is there any repository for installing PHP 5.2.x on Ubuntu 12.04?

I would like to know if there is any repository I can add to install php5.2.9+ on Ubuntu Server 12.04.
1
vote
1answer
2k views

How to enable Multiviews in Ubuntu 12.10

https://help.ubuntu.com/12.10/serverguide/httpd.html It said that: Multiview - Support content-negotiated multiviews; this option is disabled by default for security reasons. How to enable ...
6
votes
1answer
14k views

Installing Roundcube Web Server, gave date and time error while checking PHP configuration

Installing Roundcube Web Server, gave date and time error while checking PHP configuration. I am trying to configure the webamil using roundcube. Below is the details. pop / smtp service is working ...
0
votes
1answer
280 views

Can someone make this modx .htaccess file work for me? I am trying to make friendly URLs work

I now have my ModX install working but am unsure how to edit my htaccess file so my friendly urls (trying to alias pages) can anyone help? If you can a copy of my htaccess can be found at ...
3
votes
2answers
10k views

How do I change the timezone on PHP5 for Apache?

Ok I have a VPS running Ubuntu Server 12.10 32Bit and I need to set the timezone in my PHP.ini file so my PHP Script's time and date features will work (I am trying to setup ModX) I have tried to go ...
0
votes
1answer
63 views

wordpress installed but not opening the page

I have installed wordpress under /var/www/wordpress and when I try to access my site using mydomainname/wordpress/wp-admin, it downloads a file rather than opening anything. Can anyone help. Please. ...
0
votes
2answers
2k views

How to stop cron from mailing me?

I have setup a ssmtp server with my gmail username and password. After that i have been getting constant emails from my laptop to my gmail. Here the mails. The first one is somewhat like this: The ...
0
votes
1answer
734 views

hiphop, nginx, spdy

I'm about a month young at linux and brand new to ubuntu. I can do this to install hiphop https://github.com/facebook/hiphop-php/wiki/Building-and-installing-HHVM-on-Ubuntu-12.04 (I installed ...
3
votes
1answer
10k views

Error Installing PHP 5.3.21 on Ubuntu 12.04

I'm trying to install PHP 5.3.21 on a Rackspace Cloud Server running Ubuntu 12.04 but I keep running into errors during configure. It keeps giving me the following error: configure: error: Cannot ...
0
votes
0answers
20 views

Does Ubuntu support PHP? [duplicate]

I was on Fedora and tried to use PHP but I was having a really hard time trying to use it so I'm switching to Ubuntu since it is important that I'm able to code PHP. On Fedora, I couldn't write to ...
0
votes
2answers
661 views

Error 504 while accessing a php page from Internet

I'm trying to access to a test website from Internet but I mostly get 504 errors. Any php pages take long time to show, when they show. My web server is an Ubuntu Server 12.10 on a virtual machine ...
1
vote
2answers
4k views

Error configuring PHP and MySQL installed from source

I'm using ubuntu 12.04. the system requires php5.2 and mysql5.1. I installed php and mysql from source. I encountered the following problem while configuring php: ./configure \ ...
1
vote
1answer
85 views

How can I get php errors reported?

Currently installed php version 5.3.10. It is not reporting any kind of errors like syntax error e.g. <?php define("variable" , 10); variable++; echo variable; ?> This code has an error and ...
0
votes
1answer
220 views

Windows share locks up when php-fpm tries to access it

I have Ubuntu Desktop 12.10 running in VMware on my Windows 7 machine for development purposes. The VM is set up as "bridged", so effectively, it looks like it is directly connected to the same switch ...
4
votes
1answer
2k views

PHP 5.4.* already comes with xdebug installed?

Ubuntu 12.10 fresh install here. So I just installed php with sudo apt-get install php5 + a few other packages like php5-curl. I executed php -v and noticed something pretty bizarre: PHP ...
2
votes
4answers
4k views

How to set netbeans 7.2 as my default PHP IDE on ubuntu 12.10

I'm using Ubuntu 12.10 64 bit ... I have installed XAMPP and Netbeans 7.2 IDE. The problem is I can't open any PHP file using Netbeans IDE and when I click "open with" I can't find Netbeans within the ...
3
votes
3answers
4k views

Why can't I install php-mysql?

In Windows I use Xampp. I have tried to install MySQL from the command-line and I can access MySQL through workbench software. Now if I try to run Wordpress on my computer, I get an error that "Your ...
13
votes
7answers
43k views

Unable to set password for the mysql “root” user

I am new to Ubuntu. I am running Ubuntu 12.10. I am trying to install apache,php,mysql. However I have installed apache and it is running perfectly. sudo apt-get install apache2 But when I tried to ...
1
vote
3answers
402 views

Erased root trash but still getting no memory

I was coding my site on Apache Server. Suddenly an error came and I got the warning This computer has only 1.3 GB remaining. I knew that this was because of the log file in ...
0
votes
1answer
111 views

No response from Ubuntu One Oauth request

According to the documentation at https://one.ubuntu.com/developer/files/store_files/cloud, I should be able to get files with 'https://one.ubuntu.com/api/file_storage/v1/~/Ubuntu One', but ...
1
vote
1answer
683 views

ubuntu server: can't access apache hosted pages after changing ip

I moved my server to a different office. Since they wanted to access it, I joined their network by changing my server's IP. The server hosts LAMP + postgres. Now I can't get the basic web apps to ...
1
vote
0answers
29 views

How to relay gmail using postfix? [duplicate]

Possible Duplicate: How can I configure Postfix to send all email through my Gmail account? I want to test php mail function from my ubuntu desktop. I heard that postfix can do this. But I ...
2
votes
1answer
2k views

Unable to install pecl extension for perl in Ubuntu Server 12.10

I need to call a perl script from my php file. I attempted to install the PECL extension for Perl. I was unsuccessful. I tried the following: pecl channel-update pear.php.net Updating channel ...
0
votes
1answer
97 views

Postfix working with home network but not with USB 3G dongle

Does postfix with php's mail command get configured during installation based on the network connection? I am asking this because I installed it when I was connected to my home network. and I can ...
3
votes
1answer
2k views

#!/usr/bin/php sometimes not working on 12.10 server

I've recently moved some working code from a 12.04 server to a 12.1 server. Everything working well except.... Some of my scripts include #!/usr/bin/php -q at the top so I can run them from the ...
0
votes
1answer
1k views

Unable to install php5 on 12.10 [duplicate]

I am trying to install php5 on Ubuntu 12.10 Desktop and getting the following error: sudo apt-get install php5 php5-cli libapache2-mod-php5 Reading package lists... Done Building dependency tree ...
1
vote
2answers
3k views

Can I install the ordinary php and php-cli on the same machine?

I want to install php5 on my machine and also php5-cli. I want to first install the ordinary php5 package and then php5-cli. Are there likely to be any conflicts if I do this: sudo apt-get install ...
0
votes
1answer
33 views

Installing Repos and DEBs from CD

I'm a Ubuntu User from 2009 and I have loved every bit of it. If it wasn't for Dreamweaver and Photoshop, I'd only use Ubuntu! I have an Ubuntu Desktop which I want to make a DNS, DHCP, Webserver ...
6
votes
2answers
8k views

PHP and MySQL not communicating

I have come to the conclusion that my PHP installation and my MySQL installation are not getting along; I’m working on making my first web page that uses MySQL for content, but after two days, man ...
1
vote
1answer
2k views

PHP mail() with ssmtp

I have a very peculiar problem... I have a Ubuntu Server 12.04 with LAMP installed and ssmtp installed and configured properly... Now I can send mails from my terminal with and without sudo. This ...
3
votes
1answer
2k views

How to apply a php bug patch

I want to uptake fix for this PHP Bug: https://bugs.php.net/bug.php?id=52043 I am not sure on how can I install this patch. Conceptually I understand I need to follow following steps: get php code ...
0
votes
1answer
169 views

PHP not properly configured

I just installed php.5.1.2 on ubuntu server. I tried to run simple test: <? phpinfo() ?> it displayed the information but, also display the html tags: </table><br /> ...
2
votes
1answer
995 views

PHP 5.4 in official repository

When PHP will be updated to version 5.4.x in official repositories?
0
votes
1answer
851 views

Eclipse ide unable to locate files in localhost

I am trying to get "hello" to pop up on a web page using localhost. Software involved: OS: Ubuntu 12.04 Eclipse IDE, configured for PHP Apache installed from here Problem: ...
1
vote
3answers
2k views

PHP configured with “magic_quotes_gpc=Off” but phpinfo() shows it as 'On'

I've a problem on my Ubuntu Server 12.04 with PHP. As per /etc/php5/apache2/php.ini: ; http://php.net/magic-quotes-gpc magic_quotes_gpc = Off But the phpinfo.php says that Magic quotes are ON... ...
0
votes
1answer
2k views

Ubuntu server 12.04 upgrade php version to 5.3.19

i am working on a ubuntu 12.04 server edition as a virtual machine. Basically, I want to upgrade the PHP version to the freshly released 5.3.19, but obviously I have absolutely no clue on how to do ...
1
vote
1answer
1k views

Image Magic Make Fails - PHP extension

So I was doing the following: sudo apt-get install php-pear php5-dev sudo apt-get install imagemagick libmagickwand-dev sudo pecl install imagick It all works till I get the error: make: *** ...
8
votes
2answers
25k views

How can I configure Postfix to send all email through my Gmail account?

I'm trying to send an email through Google from my localhost. (via PHP5.3) But Google keeps on blocking my requests. I tried to follow the solutions given to a few similar questions, but for some ...
2
votes
1answer
4k views

Is plugin needed for php code completion in Geany?

I'm new to Geany IDE. I have installed basic Geany without any plugins from ubuntu software center. I couldn't find code completion for php when I press Ctrl space. Is plugin needed for this ...
6
votes
1answer
19k views

PhpStorm theme installation

I want to install PhpStorm color scheme from XML. Official PhpStorm's IDE website says To install a theme, download the corresponging xml file, copy to ~/Library/Preferences/RubyMine10/colors/ ...
1
vote
1answer
5k views

Symfony2 - Apache vhost for app_dev different port

As I'm using url rewriting to access my Symfony2 application, it is directly available from http://my_application.my_domain.net Now I'd like to be able to access the dev environment simply using a ...
7
votes
2answers
2k views

PHP 5.4 interactive mode on Ubuntu 12.04

I'm a big fan of PHP interactive mode (php -a). Today I decided to install PHP 5.4 to play around a little bit. It's fun to use the new built-in server and all that stuff, but I was very sad when I ...
1
vote
1answer
3k views

“Unable to load dynamic library ” error when trying to run curl with PHP

I ran : sudo apt-get install curl libcurl3 libcurl3-dev php5-curl Put: extension=php_curl.so in both /etc/php5/cli/php.ini and /etc/php5/apache2/php.ini But running php from the command line ...