PHP is a server-side scripting language, used for building browser-based applications. This includes websites as well as programs that don't really need any form of interaction with the user.

learn more… | top users | synonyms (2)

3
votes
2answers
384 views

Vagrant ssh (terminal freezes)

I have virtual machine with vagrant and ansible, when i connect to virtual machine with vagrant ssh, the terminal always freezes if i don't type something, the terminal is freezed. I can't type ...
8
votes
2answers
29k views

Apache2 start error when using php5 module ( Ubuntu Server)

I am using Ubuntu Server. When I start apache2 everything is fine, but when enabling php5 module and restarting apache2 I get this error: ERROR: *** Restarting web server apache2 ...
9
votes
8answers
12k views

phpmyadmin not working due to missing extensions

I am about to use phpmyadmin on Ubuntu 16.04. But it shows that the page is not working. the error log says error 500 PHP Fatal error: require_once(): Failed opening required '/usr/share/php/php-...
0
votes
0answers
24 views

DNS lookup failed

I have an ubuntu VPS running apache2 with all php5 packages, mysql and phpmyadmin installed. I was following a tutorial to set up something and a required command was "a2enmod rewrite". After I ...
0
votes
1answer
5k views

`mkdir()`: Permission denied to create folders with PHP

I have this PHP script: $dir = FCPATH . 'uploads' . DIRECTORY_SEPARATOR . 'posts'; // is in CodeIngiter if (!is_dir($dir)) { mkdir($dir, 755); } Which creates a folder for storing posts' images....
83
votes
13answers
26k views

What's the easiest way to set up a LAMP stack?

I set up a new VPS instance of Ubuntu and am wondering what the easiest way is to get up and running with a basic LAMP stack (i.e. which packages are required, which configuration options need to be ...
0
votes
1answer
48 views

unable to apt-get -y build-dep php5 php5-mcrypt

when I try to do "apt-get -y build-dep php5 php5-mcrypt" the resault is : Reading package lists... Done Picking 'php-mcrypt' as source package instead of 'php5-mcrypt' Reading package lists... Done ...
0
votes
1answer
24 views

403 with php in lighttpd

ubuntu server 16.0.4 LTS, MySQL, lighttpd, php, phpMyAdmin followed the instructions in https://www.howtoforge.com/tutorial/installing-lighttpd-with-php7-php-fpm-and-mysql-on-ubuntu-16.04-lts/ html ...
0
votes
0answers
37 views

Problem with installing php on Ubuntu 16.04

Entering this into the terminal: sudo apt-get install php7.0 php-pear libapache2-mod-php7.0 php7.0-mysql gives me this output: it@it-Latitude-E6410:~$ sudo apt-get install php7.0 php-pear ...
2
votes
2answers
862 views

Compiling php 5.2 from source under 12.04, apxs2 (via libtools) ignores the -prefix used with ./configure

In the source directory: ./configure --prefix=/home/ashkan/Development/php/bin/php-5.2 --with-mysql --with-apxs2=/usr/bin/apxs2 make works fine but make install says: Installing PHP SAPI module: ...
2
votes
0answers
350 views

php application asking intl but already installed

My (Symfony) application currently crashs telling ("The Symfony\Component\Intl\Collator\Collator::__construct() method's argument $locale value 'fr' behavior is not implemented. Only the locale "...
0
votes
0answers
93 views

PHP Warning: PHP Startup: Unable to load dynamic library

I got error like PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/php_intl.dll' - /usr/lib/php/20151012/php_intl.dll: cannot open shared object file: No such file or ...
0
votes
2answers
52 views

PHP-APC error please help

I am trying to install php-apc plugin and I am getting an error. sudo apt-get install php-pear php5-dev libpcre3-dev Reading package lists... Done Building dependency tree Reading state information.....
1
vote
0answers
36 views

PHP not working after updating from 5 to 7

I updated PHP 5 to PHP 7, but I noticed the old version was still configured in my Apache server, so I uninstalled it. Then everything got messy and being all this confusing as this is unless you're ...
0
votes
0answers
29 views

Apache Installation Validation

I install apache for web server by following method and this Question is for Validate my installation sudo apt-get update sudo apt-get install libapache2-mod-fastcgi php5-fpm apache2-mpm-event ...
4
votes
2answers
7k views

How can I get the `bcmath` plugin in php5 in Ubuntu?

I've seen a PHP BC-MATH installation for YUM but not apt-get. Does one know of a working apt-get solution? Unfortunately, from this SO thread, apt-get install php5-bcmath gives the error Unable to ...
0
votes
2answers
1k views

UID of script “/var/www/html/phpinfo.php” is smaller than min_uid

My Apache works and I get the default page when I access it from a browser. But when I created a PHP test script phpinfo.php and placed it in /var/www/html I get the following error occuring in /var/...
0
votes
0answers
17 views

Ubuntu ufw external url calling

I got a Network firewall related issue While calling one external(third party web service) URL from Ubuntu server. It showing one warning in Apache logs as follows file_get_contents failed to open ...
15
votes
4answers
11k views

Upgrade to 16.04. php7 not working in browser

I just upgraded from 14.10 to 16.04 and am not sure how to configure PHP 7 in apache. I did modify the php7.0.conf file to uncomment that last lines, restarted apache2 and no change. Do I need to ...
10
votes
2answers
27k views

How do I correctly enable PHP 5.5's OPCache in Ubuntu 14.04?

I'm setting up a local server to test configurations; it's a clean 14.04 LAMP server, as selected during OS install. If I understand correctly, OPCache comes with PHP 5.5 (php -v confirms this) but ...
33
votes
5answers
131k views

How to solve the phpmyadmin not found issue after upgrading php and apache?

Recently I have install the PHP, Apache, MySQL, phpMyAdmin, python in my Ubuntu Desktop 12.04.3 LTS to use it as a LAMP server. The commands I used to install these are given below: 1: sudo passwd 2: ...
0
votes
1answer
5k views

Error in apache configuration

Initially my PHP was running well and after that when I installed perl CGI modules in order to run my CGI programs, there was problem. From the local host, I am not able to compile my PhP files nor ...
3
votes
3answers
3k views

localhost/phpmyadmin not working on ubuntu 16.04

recently fresh installed Ubuntu 16.04 removing Ubuntu 14.04. I am trying to setup LAMP on local machine and have installed PHP7.0, mySql and phpMyadmin. All is working fine, http://localhost is ...
0
votes
1answer
67 views

Uncaught PDOException: could not find driver after upgrading to ubuntu 16.04

After upgrading my php automatically upgraded to php7.but phpinfo(); shows no value on PDO section. and P.S pdo is showing Uncaught PDOException: could not find driver
0
votes
1answer
58 views

Running out of inodes constantly, sessionclean throwing up errors

I keep running out of inodes (Ubuntu 14.04). In my root mail I get the following message: From root@web.site.com Sun May 29 04:09:01 2016 Return-Path: <root@web.site.com> X-Original-To: root ...
0
votes
0answers
46 views

Can't get correct permissions for /var/www/html/

I've read several threads here talking about this issue and tried all the solutions provided, none of them are working. Whenever I try composer install I get a bunch of errors saying cannot install [...
1
vote
1answer
175 views

E: Unable to locate package php5-intl Ubuntu 16.04

I try to update composer but got this error: Your requirements could not be resolved to an installable set of packages. Problem 1 - The requested PHP extension ext-intl * is missing from your ...
0
votes
1answer
56 views

MYSQL and PHPMYADMIN Error

I'm new here and totally new to ubuntu. Though, i have been using 14.01LTS for few weeks, but i wanted to upgrade to 16.04LTS. I started the upgrade, but i had some power issues. After i brought my PC ...
-2
votes
4answers
133 views

Any good alternatives to Notepad++ for code editing in Lubuntu? [duplicate]

what are the good alternatives to Notepad++ for code editing in Lubuntu? I'm a web designer mostly wanting a good editor for php, html and css editing. I've been using Notepad++ on Windows so ...
0
votes
0answers
12 views

laravel 4.2 environment not working with homestead on ubuntu

I created this question in stackoverflow too. Anyhow I know there's a post in ubuntu with the same question and they mentioned upgrade vagrant but I am already using 1.8.1 but no luck. How to make ...
17
votes
4answers
66k views

How do I upgrade PHP version to the latest stable released version?

I'm using a system running on Ubuntu 12.04 LTS 64-bit OS. I'm currently using following PHP version on this machine: Command used to get the below info at terminal : php -v Details I got are as ...
-1
votes
0answers
28 views

apache2 problem

I've installed apache2, php, mysql and wordpress. After some time I deleted all of them (purged). Now when I fresh installed them again (this time without wordpress), my localhost isn't showing ...
0
votes
0answers
36 views

how to install php7-java bridge in ubuntu

When i give php -v in terminal i am getting this result mukund@mukund-ThinkPad-Edge-E431:/var/www$ php -v PHP 7.0.6-9+donate.sury.org~trusty+2 (cli) ( NTS ) Copyright (c) 1997-2016 The PHP Group ...
0
votes
0answers
13 views

Problems with PHP and / or quexf

first of all: I am a newbie. I wanted to set up a localserver with apache on Ubuntu 14.04, which worked quite well so far. --> I received the "It works" page. So I went on with installing stuff for ...
0
votes
0answers
48 views

PHP project showing up in plain text

I've installed apache2, php7, mysql and wordpress and it all works great for wordpress of course. Every time I open localhost on webpage, wordpress is waiting to be managed and it is all great. But ...
0
votes
0answers
15 views

Cannot install SSH2

I'm noob in ShellCommands and cannot install PHP-SSH2, I'm using apache2 and tried by following this but didn't worked for me, if someone could help me (I'm under Debian 7).
0
votes
0answers
80 views

PHP 7 and apache displays plain text and cannot be restarted

I just switched over to Ubuntu from Windows and am trying to get php 7 and Apache working. I'm running php 7 and apache 2.4.18 PHP 7.0.4-7ubuntu2.1 (cli) ( NTS ) Server version: Apache/2.4.18 (...
0
votes
0answers
57 views

16.04: how to fix broken packages for php?

When I run this command to install php modules sudo apt-get install php-curl php-gd php-mbstring php-mcrypt php-xml php-xmlrpc I get the following output Reading package lists... Done Building ...
1
vote
0answers
23 views

libapache2-mod-ruid2 broken in combination with http2

I am having the same issue in ubuntu 16.04. When i enable libapache2-mod-ruid2 i get the following error in my apache error log: [Tue May 31 10:53:07.681923 2016] [core:notice] [pid 7534] AH00051: ...
0
votes
1answer
82 views

Sh: php command not found when trying to execute file from web broeser

I have one file with code shell_exec (php test.php) When I run this file from command prompt, It run successfully and when same file I am trying to run through web browser this will give error as ...
0
votes
2answers
5k views

Errors installing php5-mysql extension

Getting error when installing php5-mysql. Looks like a dpkg error. Perhaps a broken package. Have tried to fix the broken package. Have reinstalled the lamp server and everything seems fine except ...
30
votes
1answer
28k views

Installing PHP 5.6 on Xenial (16.04)

I need to use php5 (5.6) because I'm working on a Drupal 7 project which doesn't support php7. The problem is I recently updated to ubuntu 16.04 Xenial which seems to no longer support php5. I tried ...
-1
votes
0answers
115 views

Compile php 5.3.22 using phpfarm on ubuntu 16.04

I have problem with compiling multiple PHP using phpfarm with version 5.3.22. in my previous version of Ubuntu, i succeed to install dual PHP using PHP 5.5.9 and 5.3.22, but when I try to build ...
3
votes
3answers
12k views

Getting error from apt-get when trying to install php5 package

I am new in ubuntu and I try to run a website by my own computer but I can't install php5. When i typed: sudo apt-get install php5 I received: Package php5 is not available, but is referred to ...
3
votes
2answers
260 views

Are updates to libapache2-mod-php5 update causing apache to crash?

The latest security updates on 5/25/2016 seem to have cause apache-php5 module to fail loading. Anyone else seeing this? Reboot resolves but here is the error detail. Possibly this security update ...
0
votes
0answers
23 views

Adding a new dev-site to Apache 2. What am I missing?

I've got an issue when trying to access the frontend of a site I've added to an Apache server that is already hosting another live site. Here are the steps I took: added a directory /var/www/new-...
0
votes
0answers
26 views

“Access denied for user 'root'@'localhost'” when updating vendors in a symfony app while deploying on a remote server

I am trying to deploy my symfony application on a remote amazon server. While updating the vendors using: composer install --no-dev --optimize-autoloader command this error occurs Access denied for ...
0
votes
1answer
91 views

PHP-GD ownCloud issue

I'm trying to set up my ownCloud for my school but there is just 1 problem PHP module GD not installed. Please ask your server administrator to install the module. PHP modules have been ...
0
votes
0answers
70 views

Installing phpmyadmin on php7 : Ubuntu 14.04

I have LAMP stack on Ubuntu 14.04. I have upgraded from php 5.0 to php 7.0 but i couldn't install phpmyadmin. I went to my public folder which is var/www/domain.com/html and ran that code, git ...