PHP is a server-side scripting language, used for building browser-based applications. This includes websites as well as programs that don't really need any form of interaction with the user.

learn more… | top users | synonyms (2)

7
votes
2answers
25k views

How to solve the phpmyadmin not found issue after upgrading php and apache?

Recently I have install the PHP, Apache, MySQL, phpMyAdmin, python in my Ubuntu Desktop 12.04.3 LTS to use it as a LAMP server. The commands I used to install these are given below: 1: sudo passwd 2: ...
2
votes
3answers
16k views

default permissions for /var/www

I was trying to open a file and write to it with PHP at /var/www folder but it wasn't working so I did sudo chmod 777 var/www now I want to set the permissions for var/www to the default. what are ...
0
votes
1answer
709 views

failed to open stream

My problem is that when I send my php file as root to the htdocs directory it appears as this. root mustafa # sudo cp programa.php /opt/lampp/htdocs/archivos The php file appears with a big X on ...
0
votes
1answer
930 views

Apache2 server failed to start after enabling `mod_rewrite`, returns “Operation Not Permitted” errors

I am trying to install cakephp ( a php framework) which requires to enable mod_rewrite. For this I followed Enable mod_rewrite answer. But after restarting my server It says: nitish@nitish-G31T-M7:~$ ...
-1
votes
0answers
64 views

Cannot Access my localhost/version.php ? in Ubuntu 13.04 ,,,

http://zetcode.com/db/sqlitephp/ (the tutorial in this link)... Seriously can anyone help me with the PHP and SQLite3..assist me on how to link with sqlite3 and php...i already installed all the ...
0
votes
2answers
187 views

Printing to Ubuntu Terminal and File

If I want log everything that happens on the websites on my server into the terminal (where you type) and into a file, well how would I do that using PHP?
0
votes
1answer
3k views

install php 5.3 in ubuntu 13.10?

My problem is I have scripts online that work in php 5.3 not more recent versions. I wish to develop web sites locally instead of uploading partial changes. After much reading, I made the following ...
0
votes
1answer
89 views

cannot find a way to install php's pecl bbcode exentsion

Is there an easy way to install php's pecl bbcode extension on ubuntu? When using it on LAMP?
4
votes
1answer
8k views

Magneto not seeing mcrypt in LAMP

I am running Ubuntu 13.10 desktop and installed a lamp stack (Apache 2.4.6, and PHP Version 5.5.3-1ubuntu2), and I set up virtual hosts. I also apt-get'ed php5-curl, and php5-mcrypt (no errors when ...
0
votes
1answer
48 views

Upgrading Ubuntu Server to a recent version would update PHP too? This result in any problems?

I use Ubuntu Server 10.04 and PHP 5.3.2, if I upgrade the server to a more recent version, the PHP would update too? Would this process result in some problem in the settings of PHP, like previously ...
2
votes
2answers
2k views

Install older version of PHP with apt-get

I am trying to install an older version of PHP on my system. I installed Ubuntu 12.04.3 and have tried sudo apt-get install php This does successfully install php 5.3.10-1ubuntu3.8, however I ...
2
votes
0answers
103 views

Coordino permission issues?

I have downloaded the Coordino and wanted to run it on Ubuntu, tried to run it but its giving the following errors Warning: require(app/webroot/index.php): failed to open stream: Permission denied in ...
1
vote
1answer
49 views

Packages for web development

Could somebody tell me what packages do I need to download to have an Apache server on my PC and to be able to use Php, JQuery, javaScript and mysql? Thanks in advance!
7
votes
3answers
29k views

How to configure Apache to run PHP as FastCGI on Ubuntu 12.04 via terminal?

I'm relatively new to the world of unix command line web server management/administration. Many hosts with control panel administration options allow you to change how PHP is run with a simple ...
1
vote
2answers
336 views

Testing a php file for school with fopen() function, which does not work because of… permission issues?

I'm using Ubuntu in my laptop. Every time I turn it on, and after Ubuntu initializes, it ask me for my admin password, wich I do provide, in order to be able to use it. I've installed Sublime2, and ...
0
votes
1answer
2k views

cannot access ‘xampp-linux-x64-1.8.3-1-installer.run’: No such file or directory

I am a complete novice with Linux Ubuntu. When installing xampp it occurs to me this message: Can not access 'xampp-linux-x64-1.8.3-1-installer.run': No such file or directory I followed these ...
1
vote
1answer
3k views

403 forbidden error for all local projects after updating php and apache

I have 5 web app projects in my local machine with Ubuntu 12.04 installed on it. Everything was good, but today when I started a new project with symphony, I found that I should upgrade php to 5.4.x, ...
0
votes
1answer
219 views

apache2 wont display a folder - while another folder works…confused

I am on Ubuntu 13.10 PHP5 and am an intermediate PHP developer Exact same file (1.php) in 2 diff folders - one works and the other doesnt... http://localhost/vetpro2/1.php The above works as ...
0
votes
1answer
164 views

Changed apache www folder

So I changed it from /var/www to /home/John/Dropbox/www and I also did chmod 755 /home/John/Dropbox/www but it still says You don't have permission to access / on this server. I forgot how to do ...
2
votes
1answer
468 views

Please install an MTA on this system if you want to use sendmail!

I get this message in /var/log/apache2/error.log everytime a cronjob on my desktop wgets a php page that tries to send an email. How can I install a dummy so this message is gone? I already have ...
1
vote
2answers
524 views

LAMP Server with multiple PHP Versions

I am looking for a way to install multiple versions of PHP on my notebook to work on different projects that require different versions of PHP. I have Ubuntu 13.10 and installed apache2, php5, mysql ...
1
vote
2answers
370 views

Are Apache, PHP and MySQL installed by default?

Are the Apache server, PHP, and MySQL installed by default when you install Ubuntu 13.10, or should you install them separately later? Original question: Quiero saber si en la instalación de ...
0
votes
1answer
692 views

Can't Install php5-msql

Hello friends I'm finishing the process of installing Apache/Php/mysql installations but this shows up: # sudo apt-get install mysql-server php5-msql Reading package lists... Done Building ...
0
votes
3answers
703 views

Debugging PHP apps with Kdevelop

I am using kdevelop 4.5.1 and I would like to debug php apps. I made a search and I found this article: http://nikosams.blogspot.com.es/2010/02 ... ugger.html which is from 2010 but I don't know how ...
1
vote
1answer
970 views

How do we install PHP extensions for Phoronix Test Suite?

The phoronix-test-suite package provides a good way to benchmark one's hardware. After installation using Software Centre on Ubuntu 13.10 Saucy Salamander, the package does not run properly. The ...
0
votes
1answer
212 views

libc-bin errors when trying to install php

i am trying to update and install php into my ubuntu server 12.04 using the command below: apt-get upgrade php apt-get install php5-curl php5-gd php5-mysql php5-pgsql However i receive this error ...
0
votes
1answer
329 views

I deleted /etc/php5. How do I restore the folder?

I removed the folder /etc/php5, after I removed the php5 package. Then I tried to install the package, but it said the folder did not exist. I looked in trash folder and couldn't find it. How do I ...
3
votes
2answers
10k views

Ubuntu 13.10 gives “Package 'libapache2-mod-auth-mysql' has no installation candidate” error [closed]

UPDATE: Because Apache 2.4 is the default version (instead of the previous 2.2) this error occurs. However as can be seen here all future versions of Ubuntu 13.10 and above will not support this ...
1
vote
1answer
5k views

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I am using ubuntu 13.10 on evaluation board and my internet is not working. Also i need to install softwares and apt-get install is also not working. Terminal says : E: Unable to fetch some ...
1
vote
0answers
594 views

Problems with php-Server (Now: Broken Apache2) - “Unmet Dependencies" - Ubtuntu Server with Plesk

I have a Ubuntu Server with Plesk insalled. My Englisch and my "linux" ist not very great! Since a few Days my PHP doesn't work. If i load a php site my Browser download the php file instead of ...
3
votes
2answers
5k views

How to install php 5.4.x on ubuntu 13.10 saucy salamander

How do I install php 5.4 on ubuntu 13.10 saucy ? On ppa:ondrej/php5-oldstable ( https://launchpad.net/~ondrej/+archive/php5-oldstable ) there are only packages up to 13.04 Please help. Thank you, ...
0
votes
1answer
250 views

Not able to install PHP5-dev in 13.04

I'm trying to run phpize in ubuntu. However, it seems that the php5dev is not installed. So I run apt-get install php5-dev However the terminal returning some error messages : Err ...
7
votes
4answers
14k views

downgrade php5 5.5.3 to php5 5.3 in ubuntu 13.10

I just upgraded to ubuntu 13.10.. I was working on a project that uses php 5.3 and now phpmyadmin is not working and when i try to open a page i see a ton of warning and the sign in page doesnt sign ...
23
votes
1answer
12k views

Apache virtualhosts no longer working after update to 13.10

I updated my kubuntu to 13.10 today and my virtualhosts that worked perfectly before are no longer working. the s2ensite and a2dissite commands claim "site xxxxxx does not exists" even the files are ...
13
votes
7answers
32k views

php is not working well on ubuntu 13.10 and mcrypt is missing in phpmyadmin

I've upgraded from UBUNTU 13.04 to 13.10 but I can not work with php pages or phpmyadmin . I've tried this way to install lamp on ubuntu sudo apt-get install lamp-server^ phpmyadmin and I've done all ...
23
votes
2answers
16k views

what happened to json_encode in 13.10 php?

Just updated to saucy 13.10 and json_encode is missing from the bundled php. json doesn't appear in the phpinfo() output and i'm getting this error in my app: PHP Fatal error: Call to undefined ...
1
vote
2answers
138 views

ASP.Net Developer wanting to migrate to Ubuntu

First time poster, long time admirer... I develop a lot of ASP.net web pages using Umbraco and DotNetNuke. I've decided that i want to take everything over to Ubuntu and don't mind learning new ...
2
votes
1answer
944 views

Can't use PHP extension Solr in Ubuntu 13.10 (Apache)

After I upgraded to Ubuntu 13.10, the local development version of my website stopped working with a PHP warning: include(SolrQuery.php): failed to open stream: No such file or directory I checked ...
15
votes
2answers
29k views

Can't use PHP extension Mcrypt in Ubuntu 13.10 (Nginx, PHP-FPM) [duplicate]

I installed a fresh Ubuntu 13.10 on my laptop. Like I usually do, I install the packages I need for Web development, which are nginx, php5-fpm, mysql, php5-mysql, php5-mcrypt and a few others. After ...
0
votes
0answers
20 views

Can't remove phpmyadmin [duplicate]

I am having great difficulty trying to remove this so I can then start over building a forum. But I made some errors and so have removed some stuff but yet to remove this. This is one of the error ...
0
votes
1answer
155 views

Process not running in background

<?php while(true) { set_time_limit(2); $reas ="wake up from sleep!!!!!!!!!! \n "; echo $reas; sleep(5); // $readlen = 0; } ?> I try to run this code. In foreground, ...
3
votes
4answers
35k views

how to correctly install apache2, php5, mysql and phpmyadmin

What is the most correct method of installing apache 2 server, php5, mysql and phpMyAdmin? I installed it this week, and I had a lot problems without solutions, so now that I reinstalled Ubuntu 13.04 ...
1
vote
0answers
583 views

Disable Zend Optimizer PHP 5.4

I am trouble-shooting an installation of Anahita, which requires APC to be installed and Zend Optimizer to be disabled. I have PHP 5.4 running on a Ubuntu 10.04.4 LTS server. I've been trying changes ...
0
votes
1answer
2k views

Internal server Error while accessing a php page in apache2

After install apache2 it work fine, but if reinstall php5 that the server doesn't work, if I try to access http://127.0.0.1 a give the error 500, or a file of www folder, if I try to access a folder ...
0
votes
1answer
529 views

How to update libpango and install Cairo in Ubuntu?

I want to install "php gtk", but I get the following error message: `libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed I downloaded the latest pango from ...
14
votes
2answers
60k views

Find the correct php.ini file

I am currently trying to locate the correct php.ini file to edit it and restart apache so the changes will take place and I'm stumped. What I have done... I have found three different php.ini files ...
0
votes
2answers
4k views

How can I connect to a Microsoft Access database using PHP?

I tried to connect to MS Access database using PHP PDO from my ubuntu webserver but couldn't. I got this error: Connexion Access échouée : SQLSTATE[IM002] SQLDriverConnect: 0 [unixODBC][Driver ...
0
votes
1answer
776 views

Why doesn't php (cli) have a default memory limit?

After coming across a server that had an Out of Memory issue from a commandline php-script, I discovered that default (vanilla 12.04 LTS server install) the cli php.ini does not have a memory limit ...
1
vote
1answer
2k views

php5-fpm : Depends: php5-common (= 5.3.10-1ubuntu3.8) but 5.4.6-1ubuntu1.4 is to be installed

I want to set up PHP behind Nginx with FastCGI but I stuck on the sudo apt-get -f install php5-fpm what i've tried: sudo apt-get -f install php5-fpm Reading package lists... Done Building ...
1
vote
1answer
2k views

Install and Configure XHProf

Problem I'm trying to configure and use XHProf. I've managed to get it installed and running on my server but I get a blank page when I try to access localhost/xhprof_html This is the general post ...