0
votes
0answers
18 views

Managing PHP Versions on an LTS [duplicate]

First of all, I wish to stay on Ubuntu 12.04 LTS. I know that upgrading my version is a possibility but I don't want to do that. I know the dogma is to stick with your repos for your distribution, ...
3
votes
2answers
9k views

Ubuntu 13.10 gives “Package 'libapache2-mod-auth-mysql' has no installation candidate” error [closed]

UPDATE: Because Apache 2.4 is the default version (instead of the previous 2.2) this error occurs. However as can be seen here all future versions of Ubuntu 13.10 and above will not support this ...
2
votes
3answers
4k views

PHP5-FPM (PHP 5.5) won't install - can't install libsystemd-daemon0

My server is down because I don't know how to fix this. I'm on Ubuntu 12.04 I use this PHP5 repository: http://ppa.launchpad.net/ondrej/php5/ubuntu precise main I've never had a problem until today. ...
0
votes
0answers
136 views

How do I remove Dotdeb version of PHP and replace it with official Ubuntu repo

I'm a UBUNTU and CLI Noob. I'm running UBUNT 12.04 LTS I'm trying to get CURL to work for my PHP install and come to find out that PHPCURL does not work with the Dotdeb version of PHP that installed ...
0
votes
1answer
8k views

I can't get “apt-get install php5-suhosin” to work

I am running ubuntu 13.04. I cannot get my php website to work because I cannot install php5-suhosin. It said this each time that I have tried apt-get install php5-suhosin: Package php5-suhosin is ...
0
votes
1answer
793 views

Unable to install php5 on 12.10 [duplicate]

I am trying to install php5 on Ubuntu 12.10 Desktop and getting the following error: sudo apt-get install php5 php5-cli libapache2-mod-php5 Reading package lists... Done Building dependency tree ...
0
votes
2answers
1k views

How do I install an older version of the php5-mhash package?

I have my PHP Version pinned at 5.2.x, Here is the command line output php -version PHP 5.2.10-2ubuntu6 with Suhosin-Patch 0.9.7 (cli) (built: Oct 23 2009 16:30:10) Copyright (c) 1997-2009 The PHP ...
2
votes
1answer
2k views

How do I install the SSH2 extensions of PHP?

I want to be able to run PHP functions like ssh2_connect. But, those functions are not available on my machine. What do I need to do to install them? I am using Ubuntu 8.04 Hardy Heron.
6
votes
4answers
18k views

How to compelety remove php?

I need to clean up my server from PHP 5.3 packages (there are plenty of them) in order to be able to compile PHP 5.2. I am wondering what is the easiest/safest method to get rid of them all? Thanks
9
votes
4answers
4k views

How to rollback to PHP 5.2?

I have just installed a 10.04 LTS on my development server but the system that I need to run on it (Magento ecommerce) is not compatible with PHP 5.3 which ships with the newest version of Ubuntu. Is ...