0
votes
0answers
22 views

How can I resolve package conflicts when installing old version of PHP with apache2?

I have a legacy app which requires a specific version of php. I've downloaded debs for php, pear, etc. from old-releases.ubuntu.com, and I am writing a script to install them when provisioning a ...
0
votes
0answers
116 views

dpkg: error processing package libapache2-mod-php5

I have a problem at moment of use my apt-get/aptitude package manager When I want install some packages I get the following output: sudo aptitude install libxslt1.1 libxml2 The following partially ...
0
votes
1answer
29 views

Replace DEB.SURY.ORG PHP with original

I added Ondřej Surý's repository which was a great help at the time. Now I have issues installing cURL and I think returning to "original" PHP would solve the problem. Currently all my PHP packages ...
0
votes
0answers
33 views

“php-clamav: depends on: phpapi-20090626+lfs but it is not going to be installed”

I want to install "php-clamav" . But... msy@msy-Inspiron-One-2020:~$ sudo apt-get install -f php-clamav 正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 ...
1
vote
1answer
226 views

Packages are not installing!

I am trying to install packages using apt-get These are the following packages: root@ubunto:/# sudo apt-get install build-essential libssl-dev libcurl4-gnutls-dev libexpat1-dev gettext unzip Reading ...
1
vote
0answers
68 views

Why my apache service does not work correctly?

I am just a newbie using Ubuntu 12.04 LTS. In the beginning, I just want to install mcrypt, I followed this solution: cd /etc/php5/mods-available ln -sf ../conf.d/mcrypt.ini . php5enmod mcrypt ...
2
votes
5answers
250 views

How to completly remove php libraries?

I use zsh. when I try to upgrade the system, some packages related to php pop up, I want to remove them sudo apt-get upgrade Reading package lists... Done Building dependency tree ...
2
votes
2answers
547 views

Unable to install php5-mcrypt on Ubuntu 14.04

I can't install php5-mcrypt on ubuntu 14.04. I'm doing this: $ sudo apt-get install php5-mcrypt And getting this: Reading package lists... Done Building dependency tree Reading state ...
0
votes
0answers
41 views

install php5-curl without upgrading php-cli

I am using imageantialias for php and php -r "var_dump(function_exists('imageantialias')); returns bool(true) I do have requirement for php5-curl, and if I install php5-curl using php5-curl (sudo ...
2
votes
1answer
301 views

How to know if there are updates available?

I am running a 12.04 LTS ubuntu server. And I think it would be nice if I could be informed when updates are available. But I can't find how to know... I have tried looking at apt-get man page. From ...
1
vote
0answers
200 views

Subdirectories Show 404 Not Found on 13.10 web server

I recently set up a web server on Ubuntu 13.10 and when I enter the external IP it works fine showing the index file of var/www/ but whenever I try to add a folder, say one called test, and I go to ...
0
votes
2answers
727 views

owncloud -problem installing packages

I have just installed these packages for building my owncloud, but always get an installation aborted error: rqie@rqie-VirtualBox:~$ sudo apt-get install apache2 php5 php5-json php5-gd php5-sqlite ...
1
vote
1answer
67 views

Installing tomcat5.5 from source

I want to install PHP/Java Bridge. I installed Tomcat7 for it, but it failed: sudo dpkg -i /home/asif/jbridge/php-java-bridge-j2ee_5.4.4.2-3_all.deb Selecting previously unselected package ...
0
votes
0answers
13 views

Unable to install php5-sqlite [duplicate]

$ sudo apt-get install php5-sqlite [sudo] password for umpirsky: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
0
votes
1answer
2k views

Installation problem libssh2-php on Ubuntu 13.10

New here, be gentle... I am setting up a server using Ubuntu Server 13.10 64 bit. So far all went well, but now running into a problem during installation of libssh2-php. Setting up libssh2-php ...
4
votes
1answer
2k views

apt-get doesn't install latest PHP 5.4 from oldstable sources [closed]

I have two servers running 13.04, and at some point I added the oldstable package sources for PHP 5.4. For some reason I'm not able to update it anymore though — one server doesn't upgrade from 5.4.23 ...
0
votes
1answer
77 views

if i manually compile php, should i uninstall it in dpkg first?

Around 2 years ago I attempted my first PHP compile and succedded. I occasionaly upgrade my compile script as I add modules and new versions come out. However, I'm finding that apt-get unattended ...
2
votes
2answers
2k views

Install older version of PHP with apt-get

I am trying to install an older version of PHP on my system. I installed Ubuntu 12.04.3 and have tried sudo apt-get install php This does successfully install php 5.3.10-1ubuntu3.8, however I ...
0
votes
1answer
648 views

Can't Install php5-msql

Hello friends I'm finishing the process of installing Apache/Php/mysql installations but this shows up: # sudo apt-get install mysql-server php5-msql Reading package lists... Done Building ...
0
votes
1answer
4k views

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I am using ubuntu 13.10 on evaluation board and my internet is not working. Also i need to install softwares and apt-get install is also not working. Terminal says : E: Unable to fetch some ...
1
vote
0answers
516 views

Problems with php-Server (Now: Broken Apache2) - “Unmet Dependencies" - Ubtuntu Server with Plesk

I have a Ubuntu Server with Plesk insalled. My Englisch and my "linux" ist not very great! Since a few Days my PHP doesn't work. If i load a php site my Browser download the php file instead of ...
0
votes
1answer
227 views

Not able to install PHP5-dev in 13.04

I'm trying to run phpize in ubuntu. However, it seems that the php5dev is not installed. So I run apt-get install php5-dev However the terminal returning some error messages : Err ...
0
votes
0answers
20 views

Can't remove phpmyadmin [duplicate]

I am having great difficulty trying to remove this so I can then start over building a forum. But I made some errors and so have removed some stuff but yet to remove this. This is one of the error ...
1
vote
1answer
2k views

php5-fpm : Depends: php5-common (= 5.3.10-1ubuntu3.8) but 5.4.6-1ubuntu1.4 is to be installed

I want to set up PHP behind Nginx with FastCGI but I stuck on the sudo apt-get -f install php5-fpm what i've tried: sudo apt-get -f install php5-fpm Reading package lists... Done Building ...
2
votes
3answers
5k views

PHP5-FPM (PHP 5.5) won't install - can't install libsystemd-daemon0

My server is down because I don't know how to fix this. I'm on Ubuntu 12.04 I use this PHP5 repository: http://ppa.launchpad.net/ondrej/php5/ubuntu precise main I've never had a problem until today. ...
3
votes
1answer
10k views

PHP OpenSSL extension has a package?

I know that OpenSSL extension is in PHP source, but I can't enable it when I perform apt-get install php5. There is not even a apt-get install php5-openssl. How I must proceed?
0
votes
1answer
83 views

php version in apt - does it correspond to version on php.net and if not how to upgrade to latest release [duplicate]

So I'm setting up a lamp web server based on ubuntu 13.04 raring. I've installed all required software and run apt-get update and upgrade. When I run php info it reports php version 5.4.9-4ubuntu or ...
0
votes
2answers
2k views

PHP Fatal error: Call to undefined function mysql_connect() [duplicate]

I'm trying to connect my PHP page to MySQL database, but I'm getting this error : PHP Fatal error: Call to undefined function mysql_connect() I'm working on Ubuntu 11.10 MySQL 5.5 and PHP 5.3. I ...
0
votes
1answer
10k views

I can't get “apt-get install php5-suhosin” to work

I am running ubuntu 13.04. I cannot get my php website to work because I cannot install php5-suhosin. It said this each time that I have tried apt-get install php5-suhosin: Package php5-suhosin is ...
1
vote
1answer
574 views

Mysql5.6 and problem of php5-mysql , mysql-common packages

I install Mysql 5.6 with this documentaion(in ubuntu 13.04) , now I need to install php5-mysql and mysql-common packages. can I install them with apt-get? I think they will install mysql5.5 ...
3
votes
1answer
990 views

Why am I getting the error E: Package php5-gd has no installation candidate when trying to install php5-gd?

I am trying to install php5-gd and receive this error Reading package lists... Done Building dependency tree Reading state information... Done Package php5-gd is not available, but is referred to by ...
0
votes
1answer
49 views

how do I find location of packages

I am trying to install several things on my machine. For example php-pear. I need to put to location of the repository in sources.list How can I locate it?
0
votes
1answer
704 views

Php repository without suhosin

I don't really know how to or want to compile php from source, but i need php without suhosin. As you may know the main repository comes with suhosin patch. this is causing errors on my website and I ...
0
votes
2answers
518 views

What happened to php-5.4.11 from Ondrej PPA? [closed]

I am in 12.04 so I added Ondrej's PPA to get PHP 5.4. So far so good but php-5.4.12 seems to be broken with our code and after a while of struggling I decided to downgrade to php-5.4.11 but apt-cache ...
0
votes
1answer
836 views

Unable to install php5 on 12.10 [duplicate]

I am trying to install php5 on Ubuntu 12.10 Desktop and getting the following error: sudo apt-get install php5 php5-cli libapache2-mod-php5 Reading package lists... Done Building dependency tree ...
0
votes
0answers
27 views

Ubuntu apt-get bricked, what should I do? (From SO) [duplicate]

Possible Duplicate: Ubuntu apt-get bricked, what should I do? Somehow my Ubuntu install can't find what I believe to be very common packages.... E: Unable to locate package php5-curl E: ...
3
votes
2answers
3k views

Can't add repository due to 'missing' fingerprint

I am trying to install nginx with php but when I am following a guide, like this one: http://www.justincarmony.com/blog/2011/10/24/setting-up-nginx-php-fpm-on-ubuntu-10-04/ I am always told to add ...
0
votes
1answer
2k views

Missing php.ini after apt-get install php5

I just installed php5 as root via apt-get install php5, and for whatever reason I can't find my php.ini file. Running locate php.ini or ls /etc/ | grep php.ini both yield no results. Is there ...
14
votes
5answers
53k views

How to downgrade from PHP 5.4 to 5.3

Recently I upgraded PHP to 5.4, but it seems to be failing on me because APC isn't working with it, however this gave me no choice but to downgrade to 5.3, how can I do this? I executed apt-get ...
1
vote
3answers
3k views

Getting error from apt-get when trying to install php5 package

I am new in ubuntu and I try to run a website by my own computer but I can't install php5. When i typed: sudo apt-get install php5 I received: Package php5 is not available, but is referred to ...
1
vote
1answer
1k views

Why do apache2 upgrades remove and not re-install libapache2-mod-php5?

We repeatedly see that when an apache2 update arrives and is installed it causes the libapache2-mod-php5 package to be removed and does not subsequently re-install it automatically. We must ...
4
votes
1answer
2k views

How to install php 5.3.8 and mysql 5.5?

What is the best way to install mysql 5.5 with php 5.3.8 (latest version)? as most of common repositories have only older versions.
0
votes
2answers
1k views

How do I install an older version of the php5-mhash package?

I have my PHP Version pinned at 5.2.x, Here is the command line output php -version PHP 5.2.10-2ubuntu6 with Suhosin-Patch 0.9.7 (cli) (built: Oct 23 2009 16:30:10) Copyright (c) 1997-2009 The PHP ...
2
votes
2answers
2k views

How to install older version on PostgreSQL and PHP5?

Because of differencies in package versions between my development machine and my provider's server, I have to downgrade packages installed on my computer. In Ubuntu 10.04 LTS default PostgreSQL ...
8
votes
1answer
9k views

How to set up PHP with Nginx, APC and PostgreSQL?

I use Ubuntu Server 10.10 and I would like to set up a web server environment with NginX, PHP 5.3.3, PostgreSQL and preferably APC and PHP Suhosin. I have already set up PostgreSQL with apt-get ...