0
votes
0answers
54 views

Ubuntu downgrade PHP 5.5.17 to 5.5.16

There is a bug in PHP 5.5.17 which is preventing me putting something into production. I need to downgrade to 5.5.16. I have php5-cli and php5-fpm through apt-get. How can I remove 5.5.17 and install ...
1
vote
1answer
37 views

Php not running for fog web management server

I am making an imaging server for my computer engineering course. I have installed ubuntu server 12.04 32bit on the dual processor server, then I upgraded using d-release-upgrade to 14.04. I then ...
0
votes
1answer
35 views

Alternatives to Cron

I'm doing a server running Ubuntu Server 12.04 and Apache. The users have continuous updates in the dinamic pages through a Java script, downloading JSON files through Ajax request to server. All the ...
2
votes
1answer
286 views

Should I upgrade to “Ubuntu 14.04 'Trusty Tahr'” from “Ubuntu 12.04 LTS” and what care do I need to take if I upgrade? [duplicate]

I'm basically a Web Developer(PHP Developer) by profession. I mainly work on PHP, jQuery, AJAX, Smarty, HTML and CSS, Bootstrap front-end web development framework. I've also installed and using ...
2
votes
1answer
56 views

DISABLE all mail functions in Ubuntu [closed]

I have a standard staging environment on a Ubuntu server (LAMP), with a couple of webpages on it. There are some webpages that send Emails on particular workflow events. I have to run few tests on ...
0
votes
0answers
106 views

Error While Accessing Custom Class in PHP-JAVA-BRIDGE on tomcat7 in ubuntu 12.04

HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception javax.servlet.ServletException: ...
0
votes
1answer
62 views

Unexpected PHP version 5.5.15rc1 from ppa:ondrej/php5

I've just upgraded from Ondrej's oldstable 5.4 to 5.5 package on 12.04 - which was smooth. The version installed is 5.5.15rc - I wasn't expecting the rc bit. Will an upgrade regularly include RC ...
0
votes
1answer
1k views

php5enmod returns command not found

I've tried a number of guides on this issue, but so far I cannot get php5enmod mcrypt to work. Ubuntu 12.04 PHP 5.3.10 Here is the output ls of /etc/php5/conf.d and /etc/php5/mods-available ...
0
votes
1answer
107 views

Ubuntu 12.04 - upgraded to PHP5.4 - error on PHP Suhosin

I have a Linode VPS with Ubuntu 12.04. I had PHP5.3.10 installed and I just upgraded to PHP5.4.30 - by following the instructions given at ...
0
votes
0answers
447 views

Apache/PHP generates blank pages and a 500 internal server error (Ubuntu 12.04 PHP 5.3.10)

I'm having troubles with my PHP. When I open a file on localhost, it generates a blank page. I looked at my browser's console and it is giving a 500 Internal Server Error. The page I try to open ...
0
votes
0answers
53 views

Install php 32 bits on ubuntu 64 bit

I'm currently upgrading servers and I have a nasty bug with php and a database driver. Long story short using the 32 bit version of php should fix the issue. I'm unable to install php5-common:i386. ...
0
votes
1answer
242 views

New PHP5.3.10 update error

After receiving the latest announcement about security vulnerabilities of PHP5 (Ubuntu Security Notice USN-2254-1) I decided to upgrade my server, but I ran into some problems. The new packages listed ...
0
votes
1answer
123 views

PPA with latest PHP 5.3.x branch for 12.04

Is there a PHP 5.3.x PPA for 12.04?
0
votes
1answer
107 views

Ubuntu 12.04 — php-config5 points to 5.3 instead 5.4

I have a problem installing a php extension (Phalcon framework) due to having upgraded from php 5.3 to 5.4 some time ago. I upgraded using ondrej-php5-precise repository. Everything is working ok and ...
1
vote
2answers
137 views

PHP Memcache Extension Incomplete on Ubuntu 12.04

The issue is this. I have several servers all running the php5-memcache extension on Ubuntu 12.04. The PHP documentation (on php.net) has several functions like cas that are not part of the default ...
0
votes
1answer
89 views

PHPmyAdmin with MySQL on the other host

How can I install PHPmyAdmin with MySQL on the other node? I actually have OpenStack cloud deployed and want to have installed Apache and PHP on one node and MySQL on the other node. Now I want to ...
0
votes
1answer
341 views

Can't get latest PHP or Pear in Ubuntu 12.04 LTS

I'm attempting to install PEAR, and other components.. but getting the following. $ sudo apt-get install php5 libapache2-mod-php5 php5-mysql Reading package lists... Done Building dependency tree ...
1
vote
2answers
90 views

index.php is downloading instead of displaying

I have set a local website from following here, I have followed everything as it is but when I access my site via Mozilla Browser, it asks me where to download and save instead of displaying the ...
0
votes
2answers
203 views

Not able to install CURL on Ubuntu 12.04 [duplicate]

When I am trying to install the following error is coming sudo apt-get install php5-curl Reading package lists... Done Building dependency tree Reading state information... Done You might want ...
0
votes
1answer
209 views

Error installing two PHP Versions Ubuntu 12.04 with Plesk 11.5

I'm trying to install a additional PHP Version (5.5.10) on a Root Server running Ubuntu 12.04 but I keep running into errors during configure. It keeps giving me the following error: error: Cannot ...
0
votes
1answer
83 views

Can I install PHP 5.3/5.4?

I'm moving my vBulletin boards to a new server and after going through the regular steps to install LAMP, it seems it has installed PHP 5.5 which vBulletin apparently cannot work with. Can I install ...
0
votes
1answer
399 views

pecl install zip giving error ubuntu 12.04

I am trying to install zip using this command pecl install zip but I am getting below error running: make /bin/bash /tmp/pear/temp/pear-build-root9LqSPb/zip-1.12.4/libtool --mode=compile cc -I. ...
1
vote
1answer
98 views

How to develop application for OpenStack

I have installed OpenStack and everywhere I see tutorials about installing and deploying but no example about how to develop a simple app on OpenStack? using PHP Can anyone guide me?
0
votes
1answer
504 views

Cannot run PHP after upgrading from apache 2.2 to apache 2.4

Im trying to upgrade Apache from 2.2.22 to Apache 2.4.x on Ubuntu 12.04. I have PHP5.3.10 running on my server for the application. When i install the new version of Apache 2.4 it uninstall the ...
1
vote
1answer
94 views

Make Ubuntu acknowledge that a custom built version of PHP is installed

I'm trying to install PHP from source code on my Ubuntu 12.04 VPS. I'm using these parameters in the configure command: --enable-intl --with-openssl --without-pear --with-gd --with-jpeg-dir=/usr ...
1
vote
1answer
406 views

Unable to locate package php5-readline

samitha@ubuntu:~$ sudo apt-get install php5-readline Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package php5-readline What ...
0
votes
0answers
39 views

Xdebug not worked with lampp, am I working with wrong php.ini?

I have installed xampp on ubuntu 12.04 32bit below are my phpinfo details for php.ini Configuration File (php.ini) Path /opt/lampp/etc Loaded Configuration File : /opt/lampp/etc/php.ini now ...
0
votes
0answers
62 views

Can't upgrade PHP version from 5.2.10 to any newer version on 12.04 desktop

I know this question has been asked and answered several many on this forum so I hate to ask it again. Unfortunately none of the solutions I've seen posted have worked for me to upgrade my PHP sever. ...
0
votes
0answers
201 views

Updated from PHPUnit 3.7.32 to 4.0.6, broke my UnitTesting

So I was unit testing some code with PHPUnit 3.7.32 or so and it was working fine but I tried to upgrade to version 4.0.6...big mistake it seems. I really don't know where to go at this point; wasted ...
0
votes
1answer
218 views

'file --mime-type' vs 'mimetype' for php files

I'm trying to understand the difference between file --mime-type and mimetype. They are giving me different results on Ubuntu 12.04.4 LTS for this simple php file. <?php echo 'Hello world!'; ...
0
votes
1answer
76 views

Where do I get PHP-CGI binaries for Ubuntu?

I want to set up an Nginx or Apache server which is PHP-capable. In order to use multiple PHP versions in parallel I need to use CGI. I can set up the CGI stuff, but where do I get PHP binaries from? ...
0
votes
1answer
44 views

Laravel serves a phtml file

I tried running Laravel php framework from my own custom folder (not in '/var/www'). I've set up vhost, and permissions and it seems to work correctly, but Instead of seeing the laravel welcome page, ...
1
vote
2answers
54 views

Is the latest provided php5 package in an LTS distribution secure?

I need to update php5 on a 12.04 LTS production server. The latest candidate provided is 5.3.10-1ubuntu3.9. Is that version patched to be secure for use in a production environment? PHP is up to ...
0
votes
0answers
184 views

Wired behaviour of PHP SOAP Webservice on Ubuntu and apache2

We got a SOAP Webservice written in PHP. We also got PHPUnit Tests for this Webservice. Till last week we used Xampp on Ubuntu 12.04.4. Using Xampp the Webservice worked fine. Then last week we ...
2
votes
1answer
592 views

Upgrade php5-gd on 12.04

I'm aware there's already a post with the same title, but my question is different: as I explain it in a Stack Overflow post, I need to use a more recent version of php-gd in my 12.04 Ubuntu than the ...
0
votes
1answer
140 views

HTML doesn't show php script on Uuntu 12.04 ( PHP5, Apache2, mysql) all are installed properly

But info.php in /var/www/ does show the info. Only PHP embedded in html doesn't show the script. please help me.. I have tried the previous askubuntu questions and didnot get anything useful so ...
1
vote
1answer
807 views

Ubuntu 12.04 - Installing PHP with -fastcgi

Does anyone know how to install PHP on Ubuntu with fastcgi enabled? I've installed my PHP from the following site: http://www.dev-metal.com/how-to-setup-latest-version-of-php-5-5-on-ubuntu-12-04-lts/ ...
2
votes
1answer
161 views

Install both libmemcached10 and libmemcached6 ubuntu 12.04

Just wondering if someone can help me here, I'm still quite new to Ubuntu an Linux in general and seem to be having a problem with two packages: libmemcached10 is required for php5-memcached but ...
0
votes
2answers
1k views

Problems with the /var/www folder

I am new to Ubuntu, I've installed 12.04. I used to use wamp server on Windows, and after changing OS I moved some files from www folder to /var/www on Ubuntu. But when I try to view that folder in a ...
0
votes
1answer
64 views

upgrading pdftk 1.41 to 1.44 how can I check for breaking changes?

I have the wonderful task of finding out what ( if any ) breaking changes are if we upgrade from PDFTK 1.41 to 1.44 Here is our use-case We use PDFTK on the command line from a PHP application ...
1
vote
1answer
939 views

Ubuntu 12.04 PHP5.3 opcache.so installtion problem

I got this error when i call php -v Failed loading opcache.so: opcache.so: cannot open shared object file: No such file or directory PHP 5.3.10-1ubuntu3.9 with Suhosin-Patch (cli) (built: Dec 12 ...
2
votes
1answer
7k views

How can I install and configure an SMTP server?

How can I go about setting up an SMTP server to send email as *@mydomain.com? How can I then use this SMTP server with a PHP script that grabs data posted from my website's contact form and send it ...
0
votes
1answer
64 views

php and mysql issues

I've recently read Wallace Wang's “Beginning Programming for Dummies, 7 books in 1” and found it to be very enlightening, as it highlighted various differences between the three main operating systems ...
1
vote
1answer
213 views

ubuntu 12.04 - fuser high cpu

The problem is fuser high cpu and server load high. root 20 0 7580 840 692 D 10 0.0 0:00.31 fuser 16061 root 20 0 7580 844 692 D 10 0.0 0:00.31 fuser 16062 root ...
0
votes
1answer
141 views

Cannot load module after updating php to 5.5

after updating php and restarting the apache2 i get this error: Cannot load /usr/lib/apache2/modules/mod_R.so into server: /usr/lib/apache2/modules /mod_R.so: undefined symbol: ap_log_rerror This ...
0
votes
1answer
37 views

Http 500 while running .php code [closed]

I'm trying to create a VirtualBox that I can recycle across multiple projects, using a shell script to install all packages I need. I got Apache2, MySQL and PHP5 installed regularly and running a page ...
2
votes
1answer
40 views

how to manage ubuntu users from php

I have an Ubuntu 12.04 server machine in a local net, and I would like to log in my user through php. I have tried with pam_auth() but it wasn't configured neither activated for php. I tried a ...
0
votes
0answers
51 views

Windows -> Ubuntu 12.04 Migration: RedBean PHP Error

I am moving a WAMP server to Ubuntu and started getting a weird error related to the RedBean ORM library for PHP: b>Fatal error: Class RedBean_Driver_PDO contains 9 abstract methods and must ...
0
votes
0answers
195 views

what is Ubuntu 12.04 LTS PHP 5.3.10-1ubuntu3.6 equivalent to official PHP?

I m in a middle of weird situation where date('Y-m-d', '0000:00:00') returns '1969-12-31' on localhost running AMPPS , PHP 5.3.21 date('Y-m-d', '0000:00:00') returns '-0001-12-31' on staging server ...
1
vote
1answer
2k views

403 forbidden error for all local projects after updating php and apache

I have 5 web app projects in my local machine with Ubuntu 12.04 installed on it. Everything was good, but today when I started a new project with symphony, I found that I should upgrade php to 5.4.x, ...