A patch is usually a new correction to already issued software, correcting bugs or adding features.

learn more… | top users | synonyms

0
votes
0answers
27 views

How to install ACS override and i915 VGA patch?

When using arch linux you can just install the "linux-vfio-lts" kernel using a single program, called pacaur. However I am attempting to try use GPU pass through using Ubuntu Server 16.04 LTS and I am ...
1
vote
2answers
46 views

how to patch the kernel from a repo

I would like to patch my kernel so that it would do zerocopy. I found this nice repo on github but i'm not too sure how to go about doing it. https://github.com/Basler/linux-usb-zerocopy it says on ...
1
vote
1answer
75 views

Redirecting apt-get output

So there's some output from apt-get that I can't seem to redirect anywhere else. Here's a sample of what I see: sudo apt-get -qq -y --force-yes install cowsay 2>&1 > /tmp/tmp.txt This is ...
0
votes
0answers
46 views

Kpatch in Ubuntu Proper

I noticed that there is a kpatch packages being maintained and it appears to be available for Xenial and Yakkety. Is there a plan to start releasing kernel patches as kpatch patches? Will we get Live ...
0
votes
1answer
25 views

how to use a kernel patch?

I have a problem with my sound card and there is a patch on git that seem to repair my problem. here the patch But I don't know how to use patch. Someone can help me? edit :I saw that how to build ...
0
votes
0answers
29 views

Testing the newest kernel without rebooting

I've reported a bug (1568635) on launchpad. They replied, asking me to test the latest kernel. I have a live DVD iso, can connect to lan Internet and have a link to the newest kernel files (.deb). I ...
0
votes
0answers
26 views

How do I patch a kernel module without compiling the entire kernel?

I have read these instructions https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel but I also read somewhere that I do not need to recompile the entire kernel to patch one module. Ho do I patch just ...
0
votes
1answer
96 views

How can I rebuild the faac package to get mp4/m4a support and higher bitrates?

The copy of faac under Ubuntu Trusty Tahr 14.04 has 2 limitations: It does not have mp4/m4a support It cannot use high bitrates How can I rebuild faac, using correct Debian packaging techniques, ...
0
votes
0answers
96 views

Would Apache need to be recompiled after patching glibc?

Unfortunately I'm not experienced in this realm, but I'm working on patching our Ubuntu system in light of the new glibc vulnerability. We're using a version of Apache that we compiled ourselves from ...
0
votes
1answer
178 views

Ubuntu 14 not updating or upgrading!

I'm running into issues running sudo apt-get update && apt-get upgrade After I run it, I get this: Reading package lists... Done Building dependency tree Reading state information... Done ...
3
votes
1answer
32 views

Should I patch any of vulnerabilities manually?

There are list of vulnerabilities for Ubuntu: http://www.ubuntu.com/usn/ Should I patch them manually or patches are already in updates ? I asked because some said here that users should apply some ...
2
votes
1answer
852 views

How to apply kernel patches

I've been installing kernels from mainline repository - all simple there, just *.deb files, one can do simple dpkg -i on them. But how can one apply the patches 0001-base-packaging.patch , 0002-debian-...
2
votes
1answer
37 views

landscape registration

I am trying to use landscape for small environment consists of 5 vm ubuntu servers. I tried following How do I install Landscape for personal use? It lets me register on browser ->https://x.x.x.x/new-...
0
votes
1answer
156 views

Apply multiple patches at different levels

I am trying to apply patches for multiple files. These files are present in different directories at different levels in a top-level directory. The directory structure is same for the patch files also....
0
votes
0answers
30 views

Centralized Patching in Ubuntu

Is there an Ubuntu equivalent to patching systems of Red Hat Satellite? Something that would allow me to: Take a snapshot of the official Ubuntu Repositories. Modify the packages per any errata that ...
0
votes
0answers
145 views

need to apply unstable security patch for ssh (1:6.6p1-2ubuntu1) on 14.04

I am running ubuntu 14.04 as a proxy server. It has failed PCI scan due to CVE-2014-2653. I see there is a patch for this, but it is listed as unstable. I'm not sure how to apply this patch to the ...
-1
votes
1answer
399 views

VMWare player Ubuntu 15.10

I have been working on this problem for a while now and can't seem to find a solution anywhere. I've installed VMWare Player 5.0.4 for Linux 64-bit on my machine running Ubuntu 15.10. Installation ...
0
votes
2answers
82 views

How to patch the kernel with a specific commit

For a project I am working on I need to have this commit in my kernel: https://git.kernel.org/cgit/linux/kernel/git/bluetooth/bluetooth-next.git/commit/?id=a6ad2a6b9cc1d9d791aee5462cfb8528f366f1d4 ...
0
votes
1answer
57 views

LFS Troubles - Applying Patch in Section 5.7.1 [closed]

Apologize in advance if this has been asked before, and if it is very obvious. I'm following the guide pretty literally at this point to get started. The page in question is this: http://...
0
votes
0answers
65 views

How do you install a nagios plug-in or patch?

This may be a basic question, but I have absolutely no idea how to do this. And I've looked everywhere online and I haven't found a decent article or instructions how to do so. So perhaps some of you ...
0
votes
0answers
165 views

Turkey DST 2015

Turkey's 2015 DST (Day Light Saving Time) is changed from 25 October to 8 November yesterday, We need a DST pacth for our ubuntu servers. Is there Anybody know how we get this patch.
1
vote
1answer
71 views

How I can install the “linux-signed-lts-vivid package” security update?

I am an Ubuntu Trusty Tahr (14.04.3 LTS 64 Bit) user. In generally I do not know how to install "diffs" patches published in the Launchpad.net. How can I install the security patch given in this ...
0
votes
1answer
31 views

patching kernel (every update?)

I'm about to apply that famous patch that makes vgaarb see nvidia as a VGA device to the kernel. But Linux releases a new kernel only every 2 month as I know. And Ubuntu kernel releases are even ...
0
votes
0answers
17 views

Patching Ubuntu servers in Landscape

How do I schedule patches to run on my Ubuntu servers, in Landscape ? Also, after I have scheduled a server to restart (right now), it does not do it. The request is queued, and when I tried to ...
2
votes
1answer
32 views

How do I make a unified patch with diff?

I have two directories src and src-with-fixes. I want to make a unified patch, so people can download the src dir and the patch file and run patch -p1 < patch.diff and get the fixes in the src dir.
0
votes
0answers
101 views

troubleshooting my wireless card to use aircrack-ng

I am using Mediatek MT7630E as my wireless card. I am bit confused about my injection capabilities of my wireless card . Wherever I try to de-authenticate a client I get a following error "--ignore-...
3
votes
1answer
30 views

How to apply a fix to a bug?

I have reported a bug a few months ago. And now seems that bug has been fixed as its status shows "fix committed". And also sounds that it is going to be released in the next version of Ubuntu, i.e. ...
1
vote
1answer
490 views

inox browser: build and patch chromium from source

I recently stumbled over a set of patches for chromium which promise to focus on privacy by disabling data transmission to google. You can read more about it here. It originates from a Archlinux AUR ...
2
votes
1answer
130 views

Patching LoL with TuxLoL

I seem to have exactly the same issue as Guga had in this question. I was receiving the same message "invalid Directory." But in this case, I have removed all spaces from the path name. I have no ...
5
votes
1answer
326 views

There is a way to patch AMD catalyst 14.12 in order to make it work with kernel 4.0.1?

here I go: my OS is Ubuntu 14.04. I was wondering about upgrading the kernel to the recent and latest stable 4.0.1 version (my current one is 3.16). Since I have already installed AMD Omega drivers (...
0
votes
1answer
78 views

Is there a resource which lists Ubuntu Security Notices?

Every week, I check the Ubuntu Security Notices page, to see what's going on in the world of vulnerabilities. Is there anywhere the information from these posts is kept in a more reviewable format? ...
1
vote
2answers
114 views

Do I need to install kernel source to apply a patch?

I'm using Ubuntu 14.04 with Linux version 3.16.0-30-generic. I've installed Beignet for OpenCL support. I'm running into some errors and the Beignet documentation says to resolve them by applying this ...
1
vote
0answers
333 views

INSTALLING POSTFIX: VDA patch

I am trying to install the VDA POSTFIX patch on a server (http://vda.sourceforge.net/) without success. I downloaded it: wget http://vda.sourceforge.net/VDA/postfix-vda-v13-2.10.0.patch cd ...
0
votes
1answer
46 views

how to patch a file of an ubuntu package in launchpad

I found a solution to a bug in one of the package but I'm unable to understand how to update the package. The Code tab of the project at launchpad.net says "You cannot upload to this branch. Members ...
1
vote
1answer
260 views

Someone Knows of a Viewer GUI opening Patch file for Reading Only?

Back in Precise 12.04 I was using a GUI Viewer for *.patch files which only opened them for reading, which is fine, as they are generated by cmd. line. This GUI did set itself as default I think ...
1
vote
1answer
131 views

Using a patch to modify drivers for surface pro 3

I don't know much about the command line aspect of things and have always been terrible with driver modification and things like that. currently when attempting to apply a patch on ubuntu for my ...
0
votes
2answers
62 views

How to apply an “undocumented” kernel patch

I am unable to use the touchpad on my new GigaByte P35 v2. I seem to have the problem documented here (elantech touchpad not detected on gigabyte laptop), and here (https://bugzilla.kernel.org/...
1
vote
2answers
1k views

Pen tablet/ MousePen doesn't work in Ubuntu

My problem is almost same as in here & bug 1391260 Genius MousePen i608X doesn't work in Ubuntu My OS is Ubuntu 14.10. The pointer moves, but no button is sensing. It seems to share the same ...
1
vote
0answers
37 views

How can I apply a patch to Gnome manually?

I have this bug: gvfsd-afp-browse. I have Ubuntu 14.04 and bug is not fixed in this, or in 14.10. Last post in bug report indicates it is possible to manually patch. How would I go about doing so?
0
votes
1answer
523 views

What is the patch Level of Ubuntu 12.04.4

I need to confirm the patch level of 12.04.4 as being Level 4.
0
votes
0answers
23 views

How Do I Install Patch On Older Ubuntu? [duplicate]

My Ubuntu 10.10 does not have patch installed, so I am wondering on how I can get it installed. I found a source copy at https://launchpad.net/ubuntu/+source/patch/2.5.9-4 but am unsure how to ...
1
vote
0answers
353 views

How to Patch for Shellshock [duplicate]

So, in light of this closed thread, and this article, how can we patch for the shellshock bug/exploit/vulnerability for currently supported Ubuntu versions? 13.10 and 14.04?
3
votes
3answers
1k views

How to use a .patch file?

I did the instructions found in here. During the process it seems that it is looking for another file as it displays something in my terminal like this: > patch -p1 < HID-core-fix-computation-...
0
votes
1answer
143 views

Compiling custom kernel with ubuntu patches

I have compiled my own custom kernel but it uses a modified source from github. It doesn't have any patchset, or atleast in my knowledge, or any ubuntu patches like the one required by ureadahead. ...
-1
votes
2answers
516 views

How To Apply Wireshark Patch [closed]

Running Wireshark Version 1.10.6 (v1.10.6 from master-1.10) on 14.04 LTS. It crashes anytime i Open a VoIP Graph Flow. Got the patch at https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9179 Can't ...
1
vote
1answer
232 views

Problem with nVidia drivers (how do I apply a patch)?

Up until my most recent apt-get upgrade, I was using bumblebee to manage my nvidia graphics card, and it was working perfectly - using primusrun, I could get upwards of 700 fps with glxgears. Now, ...
0
votes
1answer
182 views

Installing 403-ath_regd_optional.patch

I'm new to patching and I need to install this patch https://dev.openwrt.org/browser/trunk/package/kernel/mac80211/patches/rev=39442 This is supposed to patch backports-3.15.1-1 package As you can ...
3
votes
1answer
2k views

How to install a 'patch' program?

I am unable to install patch program. It is showing: unable to locate packages. Also the folder etc/apt/sources.list is showing main restricted How to overcome this?
0
votes
1answer
3k views

texinfo downgrade

Can anyone help me with downgrading a texinfo package from version > 5 to 4.13? This version comes with ubuntu 13.04 or higher and I urgently need 4.13 version. I've found this .patch files but don't ...
2
votes
0answers
454 views

how to turn on Touch pad disable or enable double tap led?

I have a synaptic touch pad with a led in right corner, and in Windows when I tap two times on led it starts blinking and touch pad turns off. On Google I found many posts on this, also this but I ...