In this context, packaging refers to the creation and maintenance of Debian packages. Whether you are looking to update a package for your personal use or wondering how to get your software into the hands of Ubuntu users, this tag is for you.

learn more… | top users | synonyms

0
votes
0answers
18 views

How to create Ubuntu package from binary file? [duplicate]

I have downloaded sqlite source and encryption extension for sqlite "See". After that I added support for encryption into sqlite3.c, I created binary file which has enabled encryption. Command which ...
2
votes
2answers
37 views

How do you access control file information?

Is there a way for the postinst, pre, etc. scriptlets to access the information in the Debian control file when installing? e.g. Package: name Version: 0.1-1 Depends: ...
0
votes
0answers
41 views

How to package a theme?

I've modified a theme (GTK+ Theme, Gnome-shell) and i want to package it, then upload it to a ppa. I tried following this tutorial but with no luck. ...
1
vote
1answer
203 views

Lintian error: source-is-missing while building deb package for ubuntu

I'm trying to build a deb package for a software. I'm following this tutorial for the same. When trying to build the package using bzr builddeb -- -us -uc, I'm getting a lot of lintian errors for ...
0
votes
0answers
44 views

Creating linux-tools-*.deb packages

Is there any convenient way to create linux-tools-*.deb packages? For linux-headers-* and linux-image-* I can use make-kpkg. Is there anything similar for tools?
3
votes
1answer
163 views

Installing Plotmtv

I'd like to install plotmtv. For this reason I used simply the command sudo apt-get install plotmtv but I get an error message saying that the package is missing, it is not available or it is ...
1
vote
2answers
2k views

MegaSync client requires libcrypto++9

So, I was trying to install the sync client for Mega (http://mega.nz) on my Ubuuntu 15.10 install. Yes, I know it's pre-release, but here is my question: When i install the .dep file, I get that ...
0
votes
0answers
110 views

How to create .deb package of my JavaFx application?

I've built an application using JavaFx. Now I want to make a .deb package of my application to use it into Ubuntu/Debian platform. How can I do it?
3
votes
2answers
233 views

how do you create a “signed” deb package

I want to create a number of deb packages, but I don't know how "signing" packages works. So I was wondering how to create a signed deb package.
0
votes
0answers
79 views

I'm creating deb package, in that particualr folders i.e node module and src folders alone not copying

I'm trying to make deb file, in that particaluar folder i.e node_module and src folder alone not copying dpkg-source: info: using source format `3.0 (quilt)' dpkg-source: error: unwanted binary file: ...
0
votes
0answers
12 views

Packaging existing software

I've found guides on packaging new software, but what is the workflow to package already maintained packages; the packages tagged with 'needs-packaging' in Launchpad for example. I'm not sure how to ...
1
vote
0answers
54 views

while making debian package from source i'm seeing the error

While making Debian package I'm seeing the below error. ubuntu@ip-10-232-76-3:/opt/uat/elasticsearch-1.4.4$ sudo dpkg-buildpackage -b -rfakeroot -us -uc dpkg-buildpackage: warning: using a ...
1
vote
1answer
653 views

dpkg-buildpackage: dpkg-source: no upstream tarball found

I'm trying to untar the files and try to create deb package. This is for my testing purpose. My intention for this testing is, I would like to just provide a folder which contains data to install, and ...
0
votes
0answers
39 views

Is it necessary or advised to have devscripts in debian/control Build-Depends?

debuild is provided by the devscripts package. Is it compulsory or advised to have devscripts in the Build-Depends line in the debian/control file? Do the official Debian packaging manuals write ...
0
votes
0answers
21 views

How can I automatically rebuild a package with a different compiler?

I would like to build a specific package, say upx-ucl with my local installation of afl-fuzz. Is there an easy way to do that? It would be perfect if the result was the deb package with a new build.
3
votes
3answers
203 views

How to detect architecture of a .deb package?

There is a .deb package in a repository which is declared to be 32bit, but installs 64bit binaries. This is the case for both installing through apt-get from the repository as well as with downloading ...
1
vote
1answer
280 views

dh_install fails with missing files

I am attempting to build a deb from an existing autotools based library. I am following the tutorial here. When I do a spkg-buildpackage -us -uc the command fails with an error stating that files are ...
0
votes
1answer
253 views

Error when creating debain source package with dpkg

When entering this dpkg-source -b <packagename> into the terminal to create a debian source package, I get the following error: dpkg-source: error: syntax error in ...
1
vote
0answers
187 views

xz-utils 5.2.1 on trusty: how to compile and re-package? Or ppa available?

I want to compile and use a newer version of xz-utils, in this case version 5.2 as well as create deb-packages to be distributed on different ubuntu (14.04) machines. The recent changes to xz were ...
1
vote
1answer
287 views

What is dquilt and how do I get it?

I have been doing some packaging lately, including patching. I read here that I should do: $ dpkg-source -x gentoo_0.9.12.dsc $ cd gentoo-0.9.12 $ dquilt import ../foo.patch $ dquilt push $ dquilt ...
1
vote
1answer
46 views

How to version the PPA package for a new application?

I have a PPA set up to allow an application that I wrote to be installed by others. Currently, I have no plans for the application to be included in the official Ubuntu or Debian repos. I recently ...
0
votes
1answer
294 views

Oracle JDK 8 is NOT installed

Recently I installed jdk1.8.0_51 on my Xubuntu OS, and now I need to install ant for pyhton-for-android package, but after running the following command : sudo apt-get install ant I get the ...
0
votes
0answers
20 views

How do i manage metapacket architecture?

I'm building a debian package compose only of bash/perl script. Those scripts aim to interact with an architecture specific program (amd64) and are completely useless without this program. On debian ...
0
votes
0answers
76 views

How does Click/Snappy solve dependency issues?

There is a bit of confusion surrounding click and snappy. For one, I understand that there are certain packages that are not allowed to be shared due to app-armor. For example, if I write a Qt ...
1
vote
1answer
153 views

What are dynamic and static linking?

I hear the terms "Dynamically linked" and "Statically linked" tossed around in regards to packaging, and I have never been clear on what these terms actually mean. What are dynamic and static ...
3
votes
2answers
106 views

Are Click packages obsoleted by Snappy packages?

Are Click packages obsoleted by Snappy packages? Should I focus on learning how to make snappy packages, and ignore the click documentation?
1
vote
0answers
27 views

How can I specify a Qmake file during packaging?

I'm trying to package a piece of software that I wrote for Debian/Ubuntu. I've read that dh supports Qmake natively. However, my .pro file is not in the root directory of the source tree, but rather ...
3
votes
0answers
47 views

Why does 3rd digit in Ubuntu kernel version not match 3rd digit in its mainline upstream kernel version number?

From the Ubuntu Kernel FAQ ( https://wiki.ubuntu.com/Kernel/FAQ ) : Given an Ubuntu kernel package version how do we find the release it is from? The kernel package version is of the following ...
0
votes
1answer
28 views

How to prepare my program for Launchpad

I wrote Python program and made DEB (https://github.com/CyberTailor/vk-stats/releases/download/0.9/vk-stats_0.9-1_all.deb). Now, I want to upload this package to Launchpad, but it doesn't accept DEB ...
0
votes
0answers
39 views

Authenticated Packages for Flocker

The current installation instructions for Flocker on Ubuntu 14.04 state that one should run: sudo apt-get update sudo apt-get -y install apt-transport-https software-properties-common sudo ...
0
votes
0answers
33 views

“Unable to satisfy dependencies” error with self-built .deb package

I have built a .deb package from source, however I get the error Unable to satisfy dependencies when attempting to install it. I think this is due to putting Dependencies: none in the Debian control ...
3
votes
1answer
290 views

Conditional file and directory installation in `.deb` Packages

Is it possible to create a binary .deb package with conditional files and directories installation (e.g. installation of an init script in /etc/init.d/ after being confirmed by the user)?
1
vote
0answers
20 views

How to view number of downloads of packages from Ubuntu Software centre? [duplicate]

Is there a way through which I can see the number of times an application or package from the Ubuntu Software Center has been downloaded? If not, is there some sort of way in which I can view the ...
0
votes
0answers
109 views

Copy directory on destination machine during .deb installation in Ubuntu 14.04, 64 bit

I just want to copy directory (which contains some files) on destination machine during .deb installation at path /opt/myProjectName in Ubuntu 14.04, 64 bit. Right now I am successfully able to ...
1
vote
1answer
10 views

What should I name my install instructions for ubuntu centric applications?

Just wondering if there was a standard for this sort of thing, particularly for debian packages. I see in here for the license, LICENSE.LGPL I'd like to add some install instructions to my own, but ...
0
votes
1answer
67 views

How do I use Ubuntu mercurial package to create updated .deb?

I've been using the mercurial ppa, but that seems to be updated sporadically (at best) and attempts to reach the dev have failed. I'm looking at building these packages myself now. There's also the ...
0
votes
0answers
58 views

Problem compiling with QT4 libraries in pbuilder

I am having trouble getting pbuilder or launchpad to build a package that uses the QT4 libraries. The build script that I am using is below ( I didn't write it ). It compiles fine on a vanilla ...
0
votes
0answers
27 views

Copyrights of Rebranded and Customized Ubuntu [duplicate]

I'm sorry if this is not about programming or technical usage of Ubuntu. if this is not allowed to ask here, please recommend a site for it. I am creating a hardware-software solution, which is ...
7
votes
1answer
594 views

How do I repackage a .deb for Ubuntu Snappy?

// , I want to convert some Ubuntu software in .deb, specifically guake, to packages for Ubuntu Snappy*. According to the documentation on the Ubuntu dev tools, All metadata lives in ...
2
votes
1answer
71 views

Good book or guide for Debian packaging using Bazaar and Ubuntu Distributed Development

It seems that Ubuntu provide several tools to help you building Debian packages with the bazaar version control. So far I just found online documentation, but I personally prefer to learn from books. ...
0
votes
1answer
26 views

Package Creation Error

I was experimenting with building packages, and I got into a bit of a trouble. After setting everything up, I ran dch -i And edited the changelog to look like this: packagekit-qt (0.9.5-2ubuntu2) ...
1
vote
1answer
37 views

What to use for building ubuntu/debian packages?

I've been inspecting different howto's and guides on how to build packages lately. And there seems to be a lot of ways one could go about it. So I'm a bit confused about what exactly to use. That is ...
1
vote
2answers
497 views

Untrusted packages warning

When I try to update my system I get following warnings: W: GPG error: http://archive.canonical.com vivid Release: The following signatures couldn't be verified because the public key is not ...
1
vote
1answer
47 views

sbuild error: Only one build is permitted

I am trying to build a package for ubuntu trusty using sbuild, but few dependencies are available in vivid repo. So, I added the vivid repo with --extra-repository tag with sbuild command. But I am ...
3
votes
1answer
107 views

How to build .deb package that adds a GUI program to session startup?

I have a built .deb installer that installs the GUI(1) program myprog. I would like this .deb installer to add myprog to the Session Startup programs for all the users on the system. Should this be ...
0
votes
1answer
158 views

How to build a package for my QML app?

I want to build a package for my app, written with C++ and QML. For this I'm using Ubuntu SDK. I'm working on Ubuntu 15.04. Here is the project tree : Player : player.qmlproject components (a ...
0
votes
0answers
8 views

how to package a python application for publishing in Ubuntu Software Center [duplicate]

I have a running python application, I am wondering how package it for publishing into myapps
0
votes
1answer
29 views

How Can I Change PPA Fingerprint

I understand that if you create a PPA you have to accept the Ubuntu Code Of Conduct, and that in order to do so you have to register your OpenPGP fingerprint. Now, let's say that I lose my data on my ...
-1
votes
0answers
79 views

Prompt the user to overwrite/compare config file own repo/package

I created my own repository so I can provide a newer version of a package than the one the Ubuntu repository currently holds. I'm using reprepro and fpm to create the .deb package. The issue that I'm ...