Questions about software packages, installing them, removing them, updating them and finding them.

learn more… | top users | synonyms (1)

0
votes
1answer
16 views

Unable to install mesa-common-dev:i386 on my ubuntu system

I am using Ubuntu(12.04 LTS) x86_64 GNU/Linux. I have to setup my build environment on my Ubuntu system. While trying to instal the mesa-common-dev:i386 package, I am facing the following error. sudo ...
0
votes
0answers
14 views

“You can install it by typing…” missing on 14.04 LTS (server)

In previous versions of Ubuntu, I've received a prompt that tells me which package to install, if I try to run something that isn't installed yet. For example, when entering mongo: The program ...
6
votes
4answers
5k views

Where can I find Vagrant packages?

Vagrant is a tool to build and manage virtual machines for developers. It has a getting started on Ubuntu guide that contains iffy-looking suggestions like $ sudo ln -s /usr/bin/ruby1.8 ...
2
votes
3answers
4k views

alien cannot built package for architecture “ubuntu amd64”

I'm using ubuntu i686. Need to install i386 .rpm packages. tried this code: alien -i [file.i386.rpm] Tried to install ia32-libs... apt-get install ia32-libs ...and tried alien again but didn't ...
-1
votes
1answer
21 views

How to extract a installed program to a .deb file

How do you extract a installed program to a .deb file, in ubuntu 13.10 ?
0
votes
1answer
17 views

How can I make the goaccess package available in Lucid (10.04)?

GoAccess is an open source real-time web log analyzer and interactive viewer that runs in a terminal in *nix systems. For some reason, it appears that it is only available in the repos for 12.04 and ...
0
votes
0answers
10 views

Is there a package manager which allows arbitrary queries for status, name, last change timestamp

I imagine at least stable sortable columns (or better columns with sort priority) to show information for the equivalent of a query like "show me installed packages whose status changed today, sorted ...
9
votes
2answers
161 views

How do I find if a package is installed by default for each Ubuntu release?

I know how to check if a package is installed and if its available for install but I cannot find any list of packages that are installed with a release from Ubuntu. Sometimes I am trying to answer ...
0
votes
3answers
27 views

Can't find or install package “libiberty”

I'm running a ./configure script to install a program on a newly installed 13.10 ubuntu. I'm told that libiberty should come with binutils or gcc, but it is not being found. There is no information ...
0
votes
0answers
16 views

Is there a way to bundle package installations for a new os? [duplicate]

I use a webdesign development for my desktop and laptop, I also sometimes use vmware. This forces me to install the same packages multiple times to properly set up my webdesign environment. I have to ...
-2
votes
0answers
23 views

How to install packages WITHOUT using apt

Apt doesn't allow me to get the versions of libffi I require to install Glib. I have searched around and can't find answers. Only responses were comments on how difficult it was rather than actual ...
0
votes
0answers
17 views

How to delete broken download package?

I wanted to install eclipse from the software center on 12.04, after download the software center shows an error and said something like "connection broke" (I do not remember the exact error). Also, ...
0
votes
1answer
20 views

cannot install any packages using terminal

Whenever I tried to install synaptic or other libraries like sudo apt-get install git-core, etc... it's showing errors. When it starts running but stops at 22% and also with many errors. I am not ...
0
votes
1answer
31 views

How to remove a package after incorrect installation attempt

I was trying to install PostgreSQL 9.3 from the downloaded installer: postgresql-9.3.4-3-linux-x64.run Still learning the ropes with Linux, I believe I originally installed it using an incorrect ...
0
votes
0answers
22 views

Unable to correct problems, you have held broken packages

trying to install this, I am getting the 'Unable to correct problems, you have held broken packages' error message. Apache version Server version: Apache/2.4.2 (Ubuntu) Server built: Jun 27 2012 ...
9
votes
4answers
4k views

Create deb repository with several versions of the same package

I want to create my own deb repository to store some packages. I've tried reprepro and it works fine, except for one fundamental feature. Reprepro can't store several versions of the same package in ...
0
votes
1answer
33 views

Software Center Not working and many other issues with Ubuntu 12.04 [on hold]

First problem; Software center crashes as soon as I open every time I try to open it. Which led me to try and purge it and restart it. It stops at 62% read files and says this: E: Read error - read ...
3
votes
1answer
29 views

Install package from without adding PPA

Is there a way to install a package via a simple URL without having to add a PPA beforehand? Something like apt-get https://url.to.package.deb? Or perhaps some command line options that would add the ...
0
votes
0answers
11 views

ubuntu with out internet how can i install packages? lsb_4.0-0ubuntu8_all.deb [duplicate]

I have an Ubuntu Machine with out any possible connection to the internet. So my problem is how do I update packages used to run the Bradford_Dissolvable_Agent.bin, using "sudo ./Bradford....". How ...
0
votes
2answers
89 views

Ubuntu updates blocked apt-get

last week ubuntu asked to install some updates. After doing that a series of problem came out (everything worked fine before...) and now I can't use and apt-get command because or these "missing ...
3
votes
1answer
40 views

Doubt about SIGINT and SIG_IGN

I am undergoing a course on Operating System and in that as the OS used is Linux we were taught with a program using SIGINT and SIG_IGN. When I tried to program the code taught in my PC compiler ...
0
votes
0answers
43 views

How do I install `Platypus` (and NaturallySpeaking 12 Premium) on Ubuntu 13.10 x64?

For the record, I have all of the following packages installed on my machine: wine wine-gecko1.4 wine-gecko1.4:i386 wine1.4 wine1.4-amd64 wine1.4-dev wine1.4-i386-i386 winetricks I created a ...
0
votes
0answers
12 views

Xubuntu package broken : conflict between Open Office en Libreoffice

I use Open Office software, version 4.0.1 on a Xubuntu system. Since I tried to install also the libreOffice-writer on the system: The system package of Xubuntu is broken. It is not possible any ...
0
votes
1answer
16 views

Cannot install pidgin

I am trying to install pidgin-ppa from software centre but it's showing The installation or removal of a software package failed perl: warning: Setting locale failed. perl: warning: Please check that ...
-2
votes
0answers
39 views

Package operation failed - other answers did not work [closed]

I am just running Ubuntu 14.04 beta, completely out of the box on a wiped hard drive. Some software installation can't seem possible. Here goes : Installing VLC through Ubuntu software center ...
0
votes
1answer
18 views

How can I install a tar.gz package in the terminal? [duplicate]

How do I install a tar.gz package in Ubuntu 13.10 in the terminal? Must I use apt-get? I have tried to use the .deb package commands, but that doesn't work. Ubuntu software center will not open the ...
3
votes
1answer
2k views

How to have Ubuntu Chrome Canary?

Ubuntu how can i have Google Chrome Canary? https://www.google.com/intl/en/chrome/browser/canary.html
1
vote
1answer
45 views

Cannot find package (pymol)

I'm trying to install the program pymol (https://apps.ubuntu.com/cat/applications/raring/pymol/) on my system (I have Ubuntu 13.04). I've tried it via this link to the softwarecentre and via the ...
5
votes
4answers
5k views

Find (and reinstall) packages with corrupted files (without breaking anything)

I usually prefer to fix a Linux system than to reinstall from scratch. My computers have seen many distribution upgrades and a list of PPAs or third-party repositories. APT usually makes sure that ...
1
vote
1answer
89 views

How Do I manually remove malformed Packages?

I tried to install typo3 via the apt-get package manager on Ubuntu 13.10 Saucy. During the installation the Package typo3-dummy could not be configured and remained in status: half-installed sudo ...
0
votes
1answer
66 views

Problem with broken package system

Yesterday I found that the Code::Blocks 13.12 on my Ubuntu 12.04 LTS is broken, when I clicked the icon, it reacted nothing, so I tried to reinstall. I tried to use the instructions from codeblocks' ...
1
vote
1answer
3k views

'mount: error while loading shared libraries: libudev.so.0 : no such file or directory' error while booting

I was trying to load a version of CGminer which was returning a libudev type error, and followed a supposed solution here but it destroyed my system (so it seems). I loaded the system in recovery ...
2
votes
1answer
52 views

Problem loading LaTeX KOMA-script and fontspec after freshly installing vanilla texlive

I have just installed vanilla TeXlive according to the TUG instructions on my Ubuntu 13.10. A standard minimal example properly compiles the way it is supposed to do: ...
8
votes
6answers
10k views

Dependency error while installing WINE

Every time I try to install "WINE" VIA the Software Center on Ubuntu 12.10, I get this error: The following packages have unmet dependencies: wine1.4: PreDepends: dpkg (>= 1.15.7.2~) but ...
4
votes
0answers
199 views

Can I set the gold linker as the default one in saucy?

Previously, the /usr/bin/ld symlink was pointing to ld.gold when the binutils-gold package was installed. Gold now comes with the binutils package itself, and it installs the /usr/bin/ld symlink ...
0
votes
2answers
53 views

Debconf got a corrupted perl script. How to reinstall it?

I got some power issues at home and got a bunch of files in my computer corrupted. I could fix most of them, but one that's bugging me is a debconf script. Everytime I try to install something I get ...
12
votes
2answers
5k views

How do you see what packages are available for update

FreeBSD user joining your ranks. I've been asked to look after an Ubuntu Server running 10.04 LTS. I see from /usr/lib/update-notifier/update-motd-updates-available that there are a number of ...
1
vote
0answers
10 views

Getting a ksplice error after installing from ubuntu software center

There's a red circular icon with a white horizontal dash in my taskbar which says : An error ocurred, please run package manager from the right-click menu or apt-get in a terminal to see what is ...
0
votes
1answer
28 views

Why isn't launchpad building my package?

I attempted to upload files to launchpad for building, using dput ppa:sparhawkthesecond/ahm xserver-xorg-input-evdev_2.8.2-1ubuntu2ahm0ly1_source.changes It completed fine, and I was told that it ...
0
votes
1answer
17 views

Failing to Download Package Information [duplicate]

I was wondering if someone can please help me to rectify this problem with my Repository failing to download the package software (it was last updated 200 days ago). I am not too techy with Ubuntu, ...
0
votes
3answers
4k views

what is the linux-kernel-devel equivalent in 12.04.2 LTS 3.5.0?

apologies for the noob question, but when I try to sudo apt-get install Linux-kernel-devel I get the following: sudo apt-get install linux-kernel-devel Reading package lists... Done Building ...
0
votes
0answers
27 views

Trying to install updates and it fails with the following description ubuntu 12.04

installArchives() failed: (Reading database ... (Reading database ... 5%% (Reading database ... 10%% (Reading database ... 15%% (Reading database ... 20%% (Reading database ... 25%% (Reading database ...
0
votes
0answers
47 views

Is it possible to downgrade the default version of Python from my Ubuntu installation?

I have installed Ubuntu 14.04 which comes with Python 3.4 installed by default. But I wish to downgrade it to Python 3.3 for my needs. However, when I try to remove it, it also wants to remove other ...
2
votes
0answers
26 views

Can't install package libclassicclient

This is the output of "sudo apt-get install libclassicclient": user1@laptop:~$ sudo apt-get install libclassicclient Reading package lists... Done Building dependency tree Reading state ...
37
votes
4answers
16k views

If I build a package from source how can I uninstall or remove completely?

I used source code to build one package such as below: ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --with-package-name="Myplugin" ...
0
votes
1answer
7k views

uninstall packages using dpkg

I want to uninstall openoffice package and want to do this using single command or regular expression i.e dpkg -r openoffice-org* but dpkg doesnot accept wild cards how can i uninstall all the ...
1
vote
0answers
11 views

How to install software packages on Ubuntu? [duplicate]

I have read everywhere possible to know how to install software packages on ubuntu, but i didn't understand exactly how to do that, they write many steps and I try them but never got satisfying ...
10
votes
3answers
4k views

How do I get the version of an application from the command line?

I would like to know how to get the version information of an installed program that doesn't have the --version or -version method implemented.
0
votes
1answer
4k views

How to install openVPN server in Ubuntu 12.04 to have PPTP access using username and password?

I am trying to install OpenVPN Server with PPTP type enabled, so that only using username/password someone can have my network access. But my OpenVPN Access server is not allowing me to login via the ...
1
vote
2answers
87 views

How to install python-guestfs and libguestfs-tools in python virtual environment?

Can any one help me out to install python-guestfs and libguestfs-tools in python virtual environment? I tried to install those packages with the help of pip install but it fails to install because ...