Questions about software packages, installing them, removing them, updating them and finding them.

learn more… | top users | synonyms (1)

4
votes
2answers
1k views

What is the standard for naming deb file name?

I want to find out the standard for the deb file names. For example I have file with the name foo_1.0.0-1_all.deb. As I have found out in Debian FAQ there is such convention: ...
3
votes
2answers
1k views

I'm having dependency problems with wine and multiarch on 12.04x64. I need a solution

EDIT 3: See bottom, for TL;DR-ish version. I want to install wine1.5, from the ppa:ubuntu-wine/ppa repository. Fair enough right? (I'm running 12.04 x64 and a custom kernel.) I added their ...
2
votes
2answers
4k views

'Make' command compiling errors

Im trying to locally install a program which is written in C++. I have downloaded the program and am attempting to use the "make" command to compile the program as the programs instructions dictate. ...
2
votes
2answers
42 views

is there some sort of all-purpose logging tool I can download as a package?

As in, a tool that will give me easy to read logging information all in one convenient place, divvied up into categories. Logs for say, ssh daemon, user logins/logouts and other activity, installed ...
2
votes
2answers
955 views

Kolab groupware(Mail Server) fails to install because of dependency problems

I need some help. I'm trying to setup a kolab sever to be used by computer science students at my college, starting this fall. I had a bit of some trouble setting up ldap, bur after some experimenting ...
1
vote
2answers
30 views

Can't update and can't install any package - files list file for package 'libatk-adaptor' is missing final newline

Whenever I try to install any package I receive this error 0 upgraded, 1 newly installed, 0 to remove and 124 not upgraded. Need to get 19.6 kB of archives. After this operation, 81.9 kB of ...
1
vote
2answers
74 views

apt-get does not install any programs or update after upgrade from 11.04 to 14.04 (LTS)

I've upgraded from 11.04 to 14.04 and I have some issues when using apt-get. Below is an example of what I get when trying to install mysql-server (same issue for any package installation): ~$: sudo ...
1
vote
2answers
205 views

What is the purpose of the RTAI package in Ubuntu

RTAI (Realtime Application Interface) is a Linux kernel patch, that exposes an API to userland processes, which can be used to create very low latency and jitter programs for realtime tasks. I've ...
1
vote
2answers
491 views

Broken Package on Ubuntu!-Failed to Remove or Fix it

I have a problem. I open the SYNAPTIC PACKAGE MANAGER and an error message appear and show me that there is a BROKEN PACKAGE on my system. I am going to FIX IT on Terminal by typing 'sudo apt-get ...
1
vote
2answers
115 views

Ubuntu not Booting and package missing

My Ubuntu is not booting anymore, after I wrote this command on terminal: sudo apt-get autoremove eclipse Then logged off. Now it keeps trying to boot, but fail in some background-proccess on the ...
1
vote
2answers
84 views

Packages are not available under 13.04?

I have a small problem with installing packages under Ubuntu 13.04. Yesterday I wanted to install "pdfshuffler" (https://apps.ubuntu.com/cat/applications/raring/pdfshuffler/). If I go to the Ubuntu ...
1
vote
2answers
388 views

Where is the result of the “apt-get update” package list stored

I have 20 to 3o computers on my network and I have a copy of the debian packages on /var/cache/apt/archives but when I take this downloaded copy to any other machine I need to hit an "apt-get update" ...
1
vote
2answers
648 views

unable to install any software or package

I am recently shifted to ubuntu from windows and i installed ubuntu 12.04 32 bit i am unbale to install any packages like google talk plugins, teamviewer it flash a message "package operation failed" ...
1
vote
2answers
185 views

Ubuntu software center is not allowing me install Nintendo DS emulator, giving a message “check the internet connection”

The Software Center didn't work and ask to check connection but my internet connection is working. Also, sometimes it says I have an a problem and asks me if I want to report it. Anway, How could I ...
1
vote
2answers
651 views

Dependancies not met while instaling digikam 2.9

I'm trying to install digikam 2.9 from http://ppa.launchpad.net/philip5/kubuntu-backports/ubuntu Here is the message I got: Les paquets suivants ont des dépendances non-satisfaites : digikam: ...
1
vote
2answers
684 views

How do I tell apt not to install X11 & gnome dependencies cause I will use X11 forwarding?

I want to run virt-manager from the server itself (so that I can use the interface management feature which is not available over ssh connection). However, I plan to launch virt-manager over an ssh ...
1
vote
2answers
1k views

unmet dependencies with linux-tools-common

When i try to install a (random) package i got the following error. The following packages have unmet dependencies: linux-tools-3.2.0-24 : Depends: linux-tools-common but it is not going to be ...
0
votes
2answers
51 views

Package dependencies cannot be resolved Ubuntu 14.04 vlc-audacius

vlc: Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but 2.1.4-0ubuntu14.04.1 is to be installed Depends: libc6 (>= 2.15) but 2.19-0ubuntu6 is to be installed Depends: libfreetype6 (>= 2.2.1) but ...
0
votes
2answers
34 views

Wine Corrupted, stream libraries, everything?

I can't remove wine at all, I cannot sudo apt-get remove, purge, or autoremove without error.I've tried removing the /usr/bin/wine files, everything. I am at a complete loss, as every suggestion I've ...
0
votes
2answers
131 views

citrix receiver for 14.04 lts

I am trying install icaclient-modified.deb and getting error. Workstation@home:~/Downloads$ dpkg -b ica_temp icaclient-modified.deb dpkg-deb: building package `icaclient' in `icaclient-modified.deb'. ...
0
votes
2answers
47 views

Ubuntu Stopping at Boot Screen

So, I was installing some packages via Synaptic. They were for my fan and hot keys. It froze durning installation, so I rebooted it, only to get stuck at the splash screen. I'm guessing it's just not ...
0
votes
2answers
22 views

How can I add a package to the default installation of Ubuntu?

I want to add the xclip package as default package in Ubuntu. When I install Linux then xclip package should also be installed with it. How can I do it?
0
votes
2answers
18 views

Getting list of packages from recovery

I have a copy of Ubuntu that won't boot into the GUI, how can I get a list of the installed packages on the system so I can drop it into another system? I tried using dpkg --get-selections from ...
0
votes
1answer
429 views

Installation issue with safari

I was trying to download and install safari on my desktop (Ubuntu 12.04). For that I used the below: How to Install Safari on Ubuntu. Now after running the command as per above link : sudo apt-get ...
0
votes
1answer
402 views

Ubuntu 12.04 ltib package issue

I tried to install the ltib package and the following errors were displayed : Package Minimum ver Installed info ------- ----------- --------------- glibc-devel ...
0
votes
1answer
34 views

Cant upgrade or get package manager to refresh

I used Ubuntu a long time ago and was ok with it. I went away from it because I needed a Windows computer to do work. Now that I have a second computer I back on it but now I'm relearning everything ...
0
votes
1answer
39 views

How do I disable the “CD as package” source from the command line for ubuntu 12.04 LTS server?

I am trying to install or update software for Ubuntu server 12.04 LTS. I get this error: W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/precise/InRelease and other such lines. ...
0
votes
1answer
103 views

Having a Problem After Installing Mac-osx Theme and setting it up With Cairo dock

When i write sudo apt-get upgrade This message Shows Up:"dpkg: error: cannot scan updates directory `/var/lib/dpkg/updates/': No such file or directory E: Sub-process /usr/bin/dpkg returned an error ...
0
votes
1answer
359 views

How do I download and install packages without an internet connection?

I need to install some packages to add a NIC driver to my kernel. Because I don't have it yet, it's not possible for me to do this from my system. What is the best way to solve my problem?
0
votes
1answer
1k views

How do I get wireless usb adapter TL-WN727N working in 12.04?

annyone knows how to get the drivers for TL-WN272N? Tried the command: sudo apt-get install linux-backports-modules-wireless-generic wich didnt work (didnt find the package). the info from lsusb Bus ...
0
votes
1answer
191 views

Unable to install software

I'm unable to install packages using apt-get install command. It produces an error which says: E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing. After updating it ...
0
votes
1answer
154 views

How can I backup Gnome-shell extensions

I'm creating my post-instalation script for my Ubuntu 12.04 LST x64 and I would like to know how can I backup current installed extensions. Can I create own extension package to easy install? Is here ...
0
votes
1answer
434 views

Some packages failed to repair after reinstalling 12.10

I reinstalled Ubuntu 12.10. It was not clean reinstall, since I wanted to save my personal files. However, since then, apport message keeps popping out about packages that failed to install, and ...
0
votes
1answer
43 views

Softwares and lib files

I have been using suse until now. I am trying to learn Ubuntu and I need to install some packages and library files but I could not find some (maybe due to they are named different from suse). For ...
0
votes
1answer
35 views

Reporting an error from an undetermined package

I am using Ubuntu 12.04 and regularly get errors related to printing on an HP750 PSC. I am asked to accept filing a report, which I do and then the message returned is Could not determine package or ...
0
votes
1answer
56 views

Installing Eclipse-cdt installs jdt and bunch of others as well

I wanted to install eclipse-cdt for c++ development. But it looks like it cant be installed alone in ubuntu. Why are there separate packages if they can't be installed alone? [balakrishnan@mylap ...
0
votes
1answer
463 views

Is Ubuntu 12.04.1 windows wubi installer broken?

I installed the newest release of Ubuntu 12.04 with the wubi installer. The computer is up and running with Ubuntu, I am typing this in Firefox and I can use all the software that was supplied with ...
0
votes
1answer
220 views

krb5-multidev, libk5crypto3, libk5crypto3:i386 package dependency

Using Ubuntu 12.04 Asus U43F I can no longer update, install or remove packages via software center because of package dependency errors. sudo apt-get install -f reads the following: Reading ...
0
votes
1answer
151 views

How to create a PPA package from existing launchpad source package?

There a source package for ruby1.9.1 versioned 1.9.3.194-1 on launchpad.net, at: https://launchpad.net/debian/sid/+source/ruby1.9.1/1.9.3.194-1/ How do I upload this to my PPA and compiling it for ...
0
votes
1answer
109 views

Installing from Local Dependencies?

I have a folder with all dependencies needed for my program (gimp) in a folder. I don't have internet connection on that System. How can i install Gimp Dependencies from that Folder. Note: All ...
0
votes
1answer
302 views

Amnesia: the dark descent not installing

I've tried 3 times now to install amnesia from USC, but every time I do, it gives an error and the code below. installArchives() failed: (Reading database ... (Reading database ... 5% (Reading ...
0
votes
1answer
973 views

Packages (gstreamer, etc.) cause Broken Cache

When installing "Teamviewerx64", a package error occurs. Output of the error: Title: Package operation failed In a nutshell: The installation or removal of a software package failed. Details: ...
0
votes
1answer
212 views

Unable to locate package blind9

When I try to install Blind9 package in Ubuntu server, I am getting error: Unable to locate package blind9 How can resolve this problem?
0
votes
1answer
46 views

Strategy for package searching

I am using 11.10 the amd64 version (I assume, but I don't know how to figure that out). Now when I add a section to /etc/apt/source.list.d/foo.list: deb http://<myserver>/download/public stable ...
0
votes
1answer
115 views

aptitude package install error

apt-get install -f gives following Errors were encountered while processing: flashplugin-downloader:i386 flashplugin-installer E: Sub-process /usr/bin/dpkg returned an error code (1) I am unable ...
0
votes
1answer
665 views

AppArmor reinstall fails

I use apparmor together with libapache2-mod-apparmor to sandbox some websites. However After a recent reinstall it stopped working. I keep getting this error: Setting up apparmor ...
0
votes
1answer
106 views

How do I navigate and select menu options when using GMAMEUI?

I am using 11.10. I installed mame and gmameui from the software center. Downloaded a couple of ROMS. When I try to play a game I hit TAB to find out the key bindings. I get a menu shown (Input ...
-1
votes
1answer
44 views

Why does Ubuntu GNOME recommend make?

Running apt-cache depends ubuntu-gnome-desktop lists, among other things, GNU Make as a recommend. apt-cache depends gnome doesn't list Make. Why? It doesn't seem like Make and GNOME would be in any ...
-2
votes
1answer
42 views

Tons of problems a new user is encountering

I've borrowed this laptop from a friend. I wanted to install AdBlock to boost performance. First weird thing was that even though I was on Chrome, Chrome suggested me installing him? So I tried to ...
-2
votes
1answer
237 views

Broken packages in upgrade

I get this when trying to update Ubuntu 12.04 nobook@ubuntu:~$ apt-get dist-upgrade E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permission denied) E: No se encontró un ...