Tagged Questions

Questions about software packages, installing them, removing them, updating them and finding them.

learn more… | top users | synonyms (1)

0
votes
1answer
47 views

Remove optional ubuntu packages for speeding up release-upgrade [duplicate]

I have to update ubuntu 13 to ubuntu 14. When I issued release-upgrade it is showing that about 700 MB data is to be downloaded from internet. I have slow internet connection now. So it will take ...
5
votes
2answers
11k views

Not able to install software on Ubuntu 12.10 [duplicate]

I am newbie with Ubuntu.I am trying to download Okular pdf reader from Software Center but I am getting some error. At first it was asking for installation of packages from not authenticated ...
0
votes
1answer
191 views

How can I install nvidia-331-updates without automatically installing a full-fledged unity desktop?

I'm trying to run XBMC from an ubuntu 14.04 sever install. In order for my HDMI audio to function properly, I require the latest Nvidia drivers, located in package nvidia-331-updates. Here is the ...
0
votes
0answers
105 views

MySQL Broken Package on Xubuntu 14.04

Installing LAMP on Xubuntu today with apt-get install lamp-server^, I got the following error: E: Failed to fetch ...
0
votes
0answers
23 views

1 Depends on 2 but 2 is not going to be installed

On my Ubuntu 14.04, for almost every second package I want to install I get an error: sudo apt-get install 1 Depends: 2 but it is not going to be installed. then I try sudo apt-get install 2 get ...
1
vote
0answers
40 views

For an automated install of .deb I need to set DPkg::Options before installing package with new conffile

I have a custom Debian package that creates a touch-screen calibration file and will be deployed for automatic updating. I want to preserve the calibration file if the user has changed it, so my new ...
0
votes
2answers
504 views

successful installing packages but dpkg has error [closed]

happy Ramadan I'm live in Iran and Some corporation ban us like ORACLE so I installed Oracle Java SDK 8 manually and after it my "dpkg" has been showing error always. no different between ...
0
votes
2answers
55 views

When installing packages (particularly those with graphical UIs) how do you determine which is fitting for your distribution?

I'm having a hard time understanding the dependencies of software on (the combination of) Ubuntu distributions, desktop environments, window managers, file managers and what have you. What I'm ...
1
vote
5answers
2k views

Package dependencies cannot be resolved Ubuntu 14.04 vlc-audacius

vlc: Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but 2.1.4-0ubuntu14.04.1 is to be installed Depends: libc6 (>= 2.15) but 2.19-0ubuntu6 is to be installed Depends: libfreetype6 (>= ...
0
votes
0answers
73 views

How to install libinput 0.4.0?

I'm using Ubuntu Gnome 14.04 and I tried installing libinput package from source. export WLD=$HOME/install git clone git://anongit.freedesktop.org/wayland/libinput cd libinput ./autogen.sh ...
0
votes
0answers
50 views

How do I resolve unmet dependencies installing Noise on 14.04? [duplicate]

I'm trying to install Noise on my Ubuntu 14.04. I ran: $ sudo add-apt-repository ppa:elementary-os/daily and $ sudo apt-get update and received the following error: The following packages ...
1
vote
2answers
99 views

What is the best way to build a package that targets a single Ubuntu release only?

At the moment I build and package our software for Ubuntu 14.04 aka 'trusty' via dpkg-buildpackage. I get a .deb package that can be installed on Ubuntu 14.04 but also on other Ubuntu releases e.g. ...
0
votes
1answer
42 views

Updating packagelist

The installation guide at kivy.org (this one) says that I have to update my packagelist using my package manager. How to do this?
1
vote
1answer
76 views

Package 'libdconf0' has no installation candidate [closed]

My system settings do not persist. I have been trying to set system wide proxy settings. BUt once I set it and if I open the settings dialogue again, the last saved settings vanish. I tried setting ...
0
votes
3answers
135 views

Uninstall a package that I have installed using a .sh script [duplicate]

I have more older versions of NetBeans installed on my system and I would like to uninstall them. The problem is that I have installed them all from a .sh shell installer script simply running from ...
0
votes
1answer
85 views

How to reinstall linux-libc-dev:amd64

I used "sudo dpkg --configure -a" to repair an uncomplete update. It solved at least most of the problems, but says dpkg: error processing package linux-libc-dev:amd64 (--configure): package is in a ...
2
votes
0answers
47 views

Build a Ubuntu debian package [duplicate]

I would like to create an Ubuntu package from a single bash script I wrote. Is there a simple instruction how to build an Ubuntu package, that can be uploaded to launchpad? (I already created the PPA ...
1
vote
1answer
320 views

Printer driver issue - install from repository failed Epson Stylus SX425W

I have tried to install my printer from the repositories using Synaptic and it failed with the following output: (synaptic:5958): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' ...
0
votes
1answer
85 views

Dpkg error processing for installing packages

I want to install any packages but when I use apt-get install I have the following error: Reading package lists... Done Building dependency tree Reading state information... Done htop is ...
0
votes
2answers
117 views

Unmet Dependencies while Installing default-jre [duplicate]

I am getting the following error while trying to install default-jre. How can I solve this issue? Reading package lists... Done Building dependency tree Reading state information... Done Some ...
0
votes
2answers
249 views

Wine Corrupted, stream libraries, everything?

I can't remove wine at all, I cannot sudo apt-get remove, purge, or autoremove without error.I've tried removing the /usr/bin/wine files, everything. I am at a complete loss, as every suggestion I've ...
0
votes
0answers
45 views

dpkg dependency error, even when said dependency is installed

I'm trying to install some software on Ubuntu 14.04 (BlackMagic Desktop Video version 10.1.1). My command is: dpkg -i <packagefilename>.deb I get the following error: Preparing to unpack ...
0
votes
1answer
17 views

% signs on deb package names?

I just wanted to create a copy of (/var/cache/apt/)archives directory and clean it to save some space. Noticed % signs on certain packages (ex-ffmpeg_6%3a0.8.12-1_amd64.deb). Just wondered what that ...
1
vote
1answer
384 views

How can i install anaconda on Ubuntu?

I need help to install the anaconda python distribution on Ubuntu 14.04. I ran in terminal the bash script Anaconda.sh, but I thing I have to do something else after that.
0
votes
2answers
49 views

Doing a fresh ubuntu install without having to reinstall packages

I'm currently on debian wheezy and I want to install Ubuntu. I'm on a slow broadband connection and I do not want to download all the packages again that I installed on the debian installation. Is ...
0
votes
1answer
131 views

Ubuntu on armhf: “using PPAs with apt-get source -b”?

In brief, the problem I seem to be having is that apt-get "ignores" whatever PPA I add. I assume that this is because the respective PPA's limit their debs to i386 and AMD64 builds. (I'm using armhf.) ...
0
votes
1answer
255 views

i m getting problem in installing traceroute utility

I m getting this atul@ubuntu:~$ sudo apt-get install traceroute [sudo] password for atul: Reading package lists... Done Building dependency tree Reading state information... Done Package ...
2
votes
1answer
21 views

How do I get a list of needed packages

I want to know how to get a list of needed packages for a program. I want to get one program/application from one computer to another, by taking every package that is needed and compile it on the ...
1
vote
0answers
21 views

Local APT repository for specific packages [duplicate]

I'm trying to set up an APT repository on my local network that will work similar to apt-mirror except, I don't want to mirror an entire repository, I only want to serve specific packages of my ...
0
votes
0answers
19 views

Unable to run Package Manager on Ubuntu 14.04 LTS [duplicate]

Error Message being displayed in Notification: 'Error: Opening the cache (E:Encountered a section with no Package: header,E: Problem with ...
1
vote
0answers
17 views

xubuntu/xfce4 package to hold to prevent breakage by updates

I've painfully set up my xubuntu desktop to look exactly how I want it to look. I have previously experienced a well built setup crumble due to unfortunate updates. Though I would like to keep getting ...
0
votes
2answers
33 views

postgresql vs postgresql-server-dev package

What is the difference between postgresql and postgresql-server-dev packages. What are the purposes served by installing different packages and what are the use-cases of these?
1
vote
1answer
65 views

libjansson repositories? [duplicate]

I'm trying to get the deb repository for libjansson4 which includes version 2.6-1, but when I go to this page here https://launchpad.net/ubuntu/utopic/amd64/libjansson-dev/2.6-1 I can't get the PPA ...
0
votes
0answers
179 views

novnc error unrecognized service on ubuntu 12.04

I am trying to do the setup for openstack. I installed novnc but when i try the command "service novnc restart" i get the error "novnc : unrecognized service". What should I do ?
2
votes
1answer
674 views

Where did the easy_install and pip packages go?

I wrote a Bash script which automates the installation of an application based on ERPNext 3.6.1* on my Ubuntu 14.04 LTS laptop. Part of the script installs required dependencies using apt-get ...
2
votes
3answers
371 views

sudo sh -c ‘echo “deb http://archive.canonical.com/ubuntu trusty partner” >> /etc/apt/sources.list.d/canonical_partner.list’ not woking

I'm trying to skype on ubuntu 14.04, but when I type: sudo sh -c ‘echo “deb http://archive.canonical.com/ubuntu trusty partner” >> /etc/apt/sources.list.d/canonical_partner.list’ It says ...
0
votes
0answers
46 views

Extra unneeded packages

I have Ubuntu 12.04 installed. It was an upgrade from 11.10. I removed the GUI so that I just have the command line. I was wondering if there was a way to remove all the unnecessary packages that ...
0
votes
0answers
86 views

Problems in downloading and installing packages

I am a newbie in Ubuntu. I have installed 12.04 LTS in my laptop and it was moreover all fine. I want to install packages like wine,VLC,Chromium Browser,etc I was getting various error messages. 1). ...
0
votes
0answers
16 views

Dpkg options passed to apt apply to dependencies?

On 12.04, I'm running a script with the following line: apt-get -q -y -o Dpkg::Options::="--force-confnew" --auto-remove --purge --no-install recommends install foo I'm wondering if the passed dpkg ...
0
votes
0answers
14 views

Upgrading PHP_CodeSniffer from Software Center

I have installed the PHP_CodeSniffer from Ubuntu Software Center, this gives me the version 1.1.0 What I'm trying to do is update it the latest stable version. Seeing this came from Software Center, ...
0
votes
1answer
55 views

How to replace/update python-eggtrayicon in 14.04?

I've wrote a pygtk script using python-eggtrayicon but not available in Trusty. However, I've this package installed in my Trusty, because I come from Saucy. How can I replace it? Is it possible to ...
0
votes
0answers
42 views

Install MediaTomb server on lubuntu

I have old Asus Netbook with Intel 32 bit celeron processor. Because of resource constraint, I installed Lubuntu 14.04 (command line only) version. I tried apt-get install mediatomb, but no luck. ...
1
vote
0answers
28 views

Cannot login after Clam AV removal purge mistake

I would like some help repairing my Ubuntu installation please, I am having problems logging in after a mistake trying to uninstall Clam AV. I accidentally deleted some files / libraries whilst ...
14
votes
4answers
693 views

How to manage software that is installed from source?

From time to time, we may have to install something from source due to various reasons. While it is fairly standard how to install software given appropriate dependencies, it is not clear to me how to ...
0
votes
2answers
330 views

How to pause installation package in ubuntu software center

How can I pause one big installation package operation and install another small package then resume paused package again. I'm using ubuntu software center to installing the big package. Is this ...
0
votes
1answer
287 views

Is this possible to uninstall one package during another package is installing

Is this possible when I installing one package I allow to uninstall another package at the same time?
0
votes
0answers
43 views

Asking to install package when it is already installed - Ubuntu 12.04

I am asked to install a package libldns-dev in order to install some software (FreeSwitch). Although it is installed already and I have already run the command updatedb but still it is asking me to ...
3
votes
3answers
251 views

Were is the Debian package for Blender 2.70a?

In the official repository of Ubuntu and Debian is only the 2.6 version of Blender. I searched with Google to find a Debian package to download. But I found nothing.
19
votes
2answers
578 views

What security differences are between click and .deb package?

Installing a random (nasty?) .deb can be dangerous because it will grant all privilege to the apps and daemon installed because the .deb has some configs asking to applied if the user valid his ...
2
votes
0answers
71 views

Installing a Package that asks debconf questions doesn't work with the Software-Center

I am building an automatic configure Package for our environment and it has to ask a few debconf questions when installing. Until Ubuntu 13.10 it was no problem installing it via the GUI but since ...