Questions about software packages, installing them, removing them, updating them and finding them.

learn more… | top users | synonyms (1)

1
vote
1answer
32 views

libjansson repositories? [duplicate]

I'm trying to get the deb repository for libjansson4 which includes version 2.6-1, but when I go to this page here https://launchpad.net/ubuntu/utopic/amd64/libjansson-dev/2.6-1 I can't get the PPA ...
0
votes
0answers
76 views

novnc error unrecognized service on ubuntu 12.04

I am trying to do the setup for openstack. I installed novnc but when i try the command "service novnc restart" i get the error "novnc : unrecognized service". What should I do ?
2
votes
3answers
154 views

sudo sh -c ‘echo “deb http://archive.canonical.com/ubuntu trusty partner” >> /etc/apt/sources.list.d/canonical_partner.list’ not woking

I'm trying to skype on ubuntu 14.04, but when I type: sudo sh -c ‘echo “deb http://archive.canonical.com/ubuntu trusty partner” >> /etc/apt/sources.list.d/canonical_partner.list’ It says ...
2
votes
1answer
288 views

Where did the easy_install and pip packages go?

I wrote a Bash script which automates the installation of an application based on ERPNext 3.6.1* on my Ubuntu 14.04 LTS laptop. Part of the script installs required dependencies using apt-get ...
21
votes
3answers
50k views

What is the Difference Between `apt-get purge` and `apt-get remove`? [duplicate]

Possible Duplicate: What is the correct way to completely remove an application? Is there any difference between sudo apt-get purge <package-name> and sudo apt-get remove ...
18
votes
2answers
513 views

What security differences are between click and .deb package?

Installing a random (nasty?) .deb can be dangerous because it will grant all privilege to the apps and daemon installed because the .deb has some configs asking to applied if the user valid his ...
0
votes
0answers
47 views

Problems in downloading and installing packages

I am a newbie in Ubuntu. I have installed 12.04 LTS in my laptop and it was moreover all fine. I want to install packages like wine,VLC,Chromium Browser,etc I was getting various error messages. 1). ...
0
votes
1answer
29 views

I get a notification with an error message, the message is: 'Error: BrokenCount>0. How can I fix it?

It is also telling me that my installed packages have unmet dependencies. I do not know what does it mean. I'm a new user for this OS. I have a Acer C7 Chromebook. 3 days ago I installed Ubuntu 12.04 ...
1
vote
1answer
215 views

Unable to install Eclipse, how can I locate the missing package?

I can't install eclipse with sudo apt-get install eclipse-platform The response is: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to ...
0
votes
0answers
14 views

Dpkg options passed to apt apply to dependencies?

On 12.04, I'm running a script with the following line: apt-get -q -y -o Dpkg::Options::="--force-confnew" --auto-remove --purge --no-install recommends install foo I'm wondering if the passed dpkg ...
0
votes
0answers
12 views

Upgrading PHP_CodeSniffer from Software Center

I have installed the PHP_CodeSniffer from Ubuntu Software Center, this gives me the version 1.1.0 What I'm trying to do is update it the latest stable version. Seeing this came from Software Center, ...
0
votes
1answer
28 views

How to replace/update python-eggtrayicon in 14.04?

I've wrote a pygtk script using python-eggtrayicon but not available in Trusty. However, I've this package installed in my Trusty, because I come from Saucy. How can I replace it? Is it possible to ...
0
votes
0answers
21 views

Install MediaTomb server on lubuntu

I have old Asus Netbook with Intel 32 bit celeron processor. Because of resource constraint, I installed Lubuntu 14.04 (command line only) version. I tried apt-get install mediatomb, but no luck. ...
1
vote
0answers
21 views

Cannot login after Clam AV removal purge mistake

I would like some help repairing my Ubuntu installation please, I am having problems logging in after a mistake trying to uninstall Clam AV. I accidentally deleted some files / libraries whilst ...
1
vote
1answer
529 views

Ubuntu 12.04 package issues

I have a fresh install of 12.04 ran the updates just fine. (I hate not having my synaptic package manager) I went to fetch k9copy and this is what I got. Package uudeview is not available, but is ...
0
votes
2answers
314 views

how to correct glib-2.35.x 'g type_init is deprecated' error when compiling from source

Hi I'm trying to compile gnome-packagekit from source git://git.gnome.org/gnome-packagekit and when I try and make I get the error above error: ‘g_type_init’ is deprecated (declared at ...
0
votes
2answers
23 views

How to pause installation package in ubuntu software center

How can I pause one big installation package operation and install another small package then resume paused package again. I'm using ubuntu software center to installing the big package. Is this ...
0
votes
1answer
9 views

Is this possible to uninstall one package during another package is installing

Is this possible when I installing one package I allow to uninstall another package at the same time?
0
votes
0answers
38 views

Asking to install package when it is already installed - Ubuntu 12.04

I am asked to install a package libldns-dev in order to install some software (FreeSwitch). Although it is installed already and I have already run the command updatedb but still it is asking me to ...
1
vote
0answers
262 views

How to make Revobase package work in R 3.0.1?

I have just moved to Ubuntu 12.04 LTS and I am having a hard time with R packages and installation. I need to use the Revobase package. I installed it this way: sudo apt-get install revolution-r ...
3
votes
3answers
159 views

Were is the Debian package for Blender 2.70a?

In the official repository of Ubuntu and Debian is only the 2.6 version of Blender. I searched with Google to find a Debian package to download. But I found nothing.
1
vote
2answers
2k views

inxi installation on ubuntu

I have migrated from Linux Mint to Ubuntu 64(KDE installed). I want check my hardware with inxi -F command but it returns : inxi: command not found and as I want to install inxi (sudo apt-get install ...
1
vote
0answers
240 views

Getting Error after installing libgl-dev?

I had tried to install libgl-dev, then I had this problem: E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable) E: Unable to lock the administration directory ...
0
votes
1answer
125 views

Upgrading to Bluez 5.19 from source

I've successfully compiled Bluez 5.19 from source using ./config and then make, but I'm stuck on the next step. Make install doesn't seem to overwrite the old Bluez (when checked with dpkg -l, it ...
0
votes
1answer
46 views

gstreamer bad plugin of file .dep are not allowing me to install any software

For any install in ubuntu It is giving the same error. How can I remove all these gstreamer package errors? The error is installArchives() failed: dpkg: dependency problems prevent configuration ...
2
votes
0answers
35 views

Installing a Package that asks debconf questions doesn't work with the Software-Center

I am building an automatic configure Package for our environment and it has to ask a few debconf questions when installing. Until Ubuntu 13.10 it was no problem installing it via the GUI but since ...
0
votes
1answer
25 views

Problem in system update; failed install and removal of software packages

I can not install and uninstall software I used these comments: sudo dpkg --configure -a sudo apt-get clean sudo apt-get update sudo apt-get update sudo dpkg-reconfigure -a What shall I do ? ...
0
votes
0answers
36 views

“Basic Ubuntu Server” in Taksel

I have Ubuntu Server installed What will be removed if I used tasksel to uninstall "Basic Ubuntu Server" task? What are the features going to be removed Thank you
3
votes
4answers
15k views

installing “ia32-libs” problem - Ubuntu 12.10 x64

I'm trying to install ia32-libs and i tried nearly all commands to install this package but always i got an error. Here is what i've tried so far; sudo apt-get install ia32libs orkun@ubuntu:~$ sudo ...
1
vote
0answers
332 views

Installing a .deb package to /usr/local directory using dpkg(1)?

I want to install a binary .deb package under the "/usr/local" directory rather than the default "/usr" directory but I can't because the database "/usr/local/var/lib/dpkg" doesn't exist: $ sudo dpkg ...
1
vote
1answer
41 views

Exclude package installation to resolve conflict

when I try to install a package by doing apt-get install abc* it gives me an error between two packages that abc-x : | Conflicts: abc-y E: Unable to correct problems, you have held broken ...
1
vote
2answers
38 views

Can't update and can't install any package - files list file for package 'libatk-adaptor' is missing final newline

Whenever I try to install any package I receive this error 0 upgraded, 1 newly installed, 0 to remove and 124 not upgraded. Need to get 19.6 kB of archives. After this operation, 81.9 kB of ...
0
votes
1answer
237 views

sudo apt-get install <multiple packages> cannot read packages

I am trying to setup ruby on rails on a new ubuntu machine. I want to install all the dependencies at once after a sudo apt-get update, but encountered errors saying the packages has no installation ...
1
vote
1answer
73 views

need help errors and lots of missing packages ubuntu 13.10

i am running ubuntu 13.10 on an msi notebook, i am in no way computer literate and to try and fix one small problem i have unintentionally gotten in way over my head, created more problems and am in ...
2
votes
1answer
102 views

How to install Trimaran on 12.10? [closed]

I am not able to install the trimaran package on Ubuntu 12.10. I have tried this how-to guide. Can someone help me find the solution to this problem?
1
vote
1answer
170 views

Unable to install php5-mcrypt on Ubuntu 14.04

I can't install php5-mcrypt on ubuntu 14.04. I'm doing this: $ sudo apt-get install php5-mcrypt And getting this: Reading package lists... Done Building dependency tree Reading state ...
-1
votes
1answer
621 views

There are no repos [closed]

I have PC Engines Apu . I wanted to install Linux to Apu over PXE. I m trying to install this on ubuntu 14.04 LTS. I am Using Ubuntu 14.04 LTS #yum install tftp-server syslinux httpd dhcpd There ...
0
votes
1answer
35 views

Debian Packaging Dependencies Checking [closed]

How to force a debian package to check some dependency installed?
1
vote
1answer
3k views

Where to find package manager in Xubuntu 13.10

I'm a newbie to linux and I have a Xubuntu 13.10 relase installed on my PC. I need to install some packages for web development but I can not find the package manager utility in the applications menu. ...
44
votes
4answers
21k views

If I build a package from source how can I uninstall or remove completely?

I used source code to build one package such as below: ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --with-package-name="Myplugin" ...
0
votes
1answer
1k views

Package operation failed in package management

When I try to install or remove any application from ubuntu software center I get this error: Package Operation Failed. As suggested in many posts in this forum I did this sudo apt-get -f install: ...
0
votes
1answer
33 views

Trying to build/install patched gtk3-engines-oxygen to test bugfix, get shared changelog.Debian.gz is different from other instances of package

I want to just quickly test the patch in this bug report to gtk3-engines-oxygen so it can go upstream. I could test it either temporarily or permanently; I would just like to do it. I currently have ...
-1
votes
1answer
70 views

Application Software updater not working anymore (Ubuntu 14)

As soon as i log in a this red sign appears top a and it says : And error occurred .please run package manger from the right-click menu or apt-getin a terminal to see what is wrong The error ...
5
votes
4answers
1k views

Avoiding installation of certain dependency packages (texlive)

As Ubuntu's TeXLive is quite old (version 2009), I always hear TeX people recommending installing the latest TeXLive directly from CTAN. (Yes, I need the same package mentioned in that question.) I ...
0
votes
3answers
77 views

Update Package list in repository after motherboard change

I just installed a new motherboard / microprocessor on my computer, I want to do an update to it using apt-get and I've tried to do it from the GUI as well. the issue is the package list still have ...
3
votes
2answers
1k views

“Failed to load the package list”

When attempting to remove, install or update software through the Ubuntu Software Center, I came upon an error like this... Failed to load the package list This is a serious problem. Try ...
4
votes
2answers
204 views

Write List of Packages installed via Manual Invocation of apt-get to File

I'm trying to install a new version of Ubuntu from scratch, but I would like a list of the packages which I manually installed (as opposed to installed as a dependency or that came with the system). ...
3
votes
3answers
334 views

How can I list all packaged installed by me?

I am trying to clean my installation up a bit, so I decided to clean up my packages a bit. However, I'm having trouble with that: My wish is to make apt-get list all packages installed by me. If I ...
1
vote
0answers
22 views

Recent version of libpng

The libpng in the Ubuntu 14.04 is still at version 1.2. Is there an alternative apt source that contains more recent version? If not, will I end up in trouble aka dependency hell if I compile my own ...
1
vote
1answer
46 views

List (Head) packages available from specific ppa by command-line

I want to list all Head packages available from specific ppa. Example: webupd8 ppa:nilarimogard/webupd8 has following head packages for trusty: Can I list them by command-line?