Questions about software packages, installing them, removing them, updating them and finding them.

learn more… | top users | synonyms (1)

5
votes
4answers
5k views

Find (and reinstall) packages with corrupted files (without breaking anything)

I usually prefer to fix a Linux system than to reinstall from scratch. My computers have seen many distribution upgrades and a list of PPAs or third-party repositories. APT usually makes sure that ...
8
votes
2answers
2k views

How to forbid a specific package to be installed?

Can I configure Ubuntu to never install a specific package even if it is required by another package I install?
1
vote
2answers
2k views

Is it better to compile from source or to install from a .deb package?

Sometimes, when downloading software from the Internet, I find that there is a .deb package ready for either my Debian/Ubuntu and also a tarball to be compiled. In the beginning I would simply use the ...
14
votes
1answer
3k views

What exact purpose have transitional packages?

What are transitional packages and what exact purpose do they have?
10
votes
3answers
4k views

How do I get the version of an application from the command line?

I would like to know how to get the version information of an installed program that doesn't have the --version or -version method implemented.
6
votes
2answers
104 views

How can you suggest the addition of a new package?

This bug has had a solution proposed in comment 4 which involves the addition of a new package to the system. How would I bring this to the attention of the developers?
3
votes
2answers
247 views

Any way to list similar commands?

When you write the command name wrong, bash often does this: septi@norbert:~$ good No command 'good' found, did you mean: Command 'gold' from package 'binutils' (main) Command 'gmod' from package ...
2
votes
3answers
5k views

Is there a standalone version of soapUI for Linux?

I want to run soapUI on Ubuntu 11.10. If I am not able to install via the package manager, I'd prefer not to install at all, and instead run as a standalone application. Looking at the soapUI download ...
5
votes
2answers
2k views

How do I list the default installed packages?

I am developing a offline installer for ubuntu all version. I need ubuntu's default installed packages list. We can get installed packages list by command in ubuntu dpkg --get-selected But is there ...
3
votes
1answer
1k views

I can't update, upgrade and remove my app from kubuntu

I have a problem upgrading software. I can't update, upgrade or remove my software. The notification of update manager signs 46 security packets and 83 other packets and when I click on it to install ...
3
votes
3answers
13k views

installing “ia32-libs” problem - Ubuntu 12.10 x64

I'm trying to install ia32-libs and i tried nearly all commands to install this package but always i got an error. Here is what i've tried so far; sudo apt-get install ia32libs orkun@ubuntu:~$ sudo ...
2
votes
2answers
1k views

How do i configure the live usb to install additional packages?

I have saved all the packages from the directory /var/cat/apt/archives to Usb. Is it possible to configure the live Usb to accommodate all these extra packages /var/cache/apt/archives; so that it ...
2
votes
4answers
2k views

How can I burn an ISO file to a blank disk?

I have downloaded the Ubuntu 10.10 ISO file and am trying to burn it to a blank disc so that I can install it, using Ubuntu 8.04. I have a dual boot system with Windows and Ubuntu. Here's my ...
1
vote
3answers
3k views

Package operation failed Errors were encountered while processing: xserver-common-lts-raring

Before starting with my problem description, I would like to say that this is my very first time using Ubuntu or anything related to Linux! Now my question! I have installed the very last ...
1
vote
2answers
10k views

Fixing broken myslq-server package after upgrade to 12.04

After upgrade to 12.04 mysql server was unable to start. I tried many different things but without any luck. Now when I try to install it, I get: $ sudo apt-get install mysql-server-5.5 Reading ...
0
votes
1answer
47 views

Override Distro Package with Custom Package?

Ubuntu 12.04 LTS provides OpenSSL 1.0.1e, but it disables TLSv1.1 and TLSv1.2. In the past it was an interop decision because of broken client implementations. In 2014, its really not appropriate ...
22
votes
5answers
15k views

Will python2.7 be available for 10.04 in the future?

Since Ubuntu 10.04 is an LTS release will it support python 2.7 as a default package maintainer version or at least have a python2.7 package in future? Since it will be the last major python 2.x ...
11
votes
1answer
4k views

How to download, modify, build and install a Debian source package?

If I want to make minor changes to the source code of a Debian package, how do I go about downloading, incrementing the package version, building the (modified) source, and installing it on my ...
2
votes
2answers
14k views

Installing Skype on 12.10 64 bit causes errors

I have installed Ubuntu 12.10 64bit (clean install) and updated it. After that i tried to install skype, and i get error that skype depends skype-bin, but it could not install it, and that there are ...
12
votes
1answer
346 views

Is there a usage count for packages or programs?

Motivation: I want to remove applications I do not use to speed up my package processing tasks like dist upgrades, regular updates, but also for saving disk space and other reasons. I know this is a ...
10
votes
3answers
7k views

How do I safely remove gwibber?

I'm really in love with Ubuntu but I'm not used to Gwibber, for some reason. I can't remove gwibber without removing the ubuntu-desktop package. Is it safe to remove it, without ruining my desktop?
8
votes
3answers
415 views

Search Launchpad for PPAs matching software or package name?

Is there a way to search though LaunchPad's PPAs for a certain package name? For instance if I was looking for PPAs with Firefox packages I could search for "firefox" and retrieve a list of all the ...
6
votes
2answers
703 views

How do I get the bleeding edge Chromium?

The following versions of Chromium are available at the moment : Chromium Stable PPA (13.0.782.218) Chromium Beta PPA (14.0.835.126) Ubuntu Repo (14.0.835.202) Chromium Dev PPA (15.0.865.0) Chromium ...
6
votes
2answers
669 views

How do I rebuild a package to include debugging information?

I want to rebuild a package to include debugging symbols, how would I do that? There is no -dbg package available and also no -dbgsym package from the ddebs repository.
5
votes
1answer
907 views

How can I upload package for several ubuntu versions to Launchpad automatically?

See the title. I using dput and in my /etc/dput.cf : [ppa] fqdn = ppa.launchpad.net method = ftp incoming = ~onto/onto/ubuntu/ login = anonymous allow_unsigned_uploads ...
19
votes
2answers
351 views

Is there a congrats ubuntu page?

Say for example I use a particular package and want to say "Way to go maintainers" is there a way for me to do this?
8
votes
2answers
4k views

Cant run FoxitReader after installing it

I'm trying to install Foxit reader. I've downloaded the .deb, opened with Ubuntu Software Center (or gdebi, etc) and clicked install. The progress bar do her job and an icon appears when I search ...
5
votes
2answers
3k views

'adobe-flashplugin conflicts with flashplugin-downloader' error while trying to install adobe-flashplugin

I'm having some hard time getting straight with my adobe flash plugin. $ sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper Reading package lists... Done Building dependency ...
2
votes
4answers
3k views

How do I create a .deb file?

Yes, I know that this question has been asked many times before, but none of the answers really helped. I'd like to package the Minecraft launcher (which has no proprietary code, AFAIK,) into a .deb ...
2
votes
3answers
22k views

How do I install the build dependencies for Android?

I'm trying build the Android source using these packages. ButI am getting this error: $ sudo apt-get install git-core gnupg flex bison gperf build-essential zip curl zlib1g-dev gcc-multilib ...
13
votes
4answers
11k views

How not to install recommended and suggested packages?

I use Ubuntu 12.04 64-bit, I did the following, sudo gedit /etc/apt/apt.conf and added APT::Install-Recommends "false"; APT::Install-Suggests "false"; but did not work. When I try to install a ...
10
votes
4answers
353 views

How do I list commands a package provides? [duplicate]

I'm curious what commands a certain package provides my system with. By command, I mean an in-path executable that I can run from the command line (ls, grep, sed, etc). I'm not trying to work out the ...
8
votes
1answer
405 views

Authentication problem with my PPA

I created a package and uploaded it to my PPA. After it got built, I went to install it, but was faced with this message: ******@******-laptop:~$ sudo apt-get install stackapplet Reading package ...
6
votes
3answers
388 views

Why do many GNOME application packages depend on `libunity9`?

When investigating this question, I discovered that many GNOME applications' packages depend on the libunity9 package. If I try to uninstall libunity9 on Precise, it tries to uninstall lots of ...
4
votes
1answer
10k views

How to install a tar.bz2 package

How can I install a tarbz2 package. Example: I have downloaded firefox 8 tar.bz2 . I want to know a general method for installation of tar.bz2 package.
3
votes
1answer
734 views

What factors should be considered when installing packages manually?

I have seen many packages' readme or install files on instructing how to install a package manually. But many times the results are erroneous. They instruct us to do many thing with for example the ...
2
votes
1answer
494 views

How do I save Updates/Installed Packages?

So I've been messing with thing that probably shouldn't be messed with trying to learn my way around Linux, and I seem to have messed something up. I'm getting a lot of error messages, reduced speed, ...
1
vote
1answer
1k views

Cannot Install anything from the Software Center in 12.10

I just downloaded 12.10 and I can't seem to download and install anything, from plugins to programs, from the Software Center. It says Not Found. There isn’t a software package called “name” in ...
1
vote
2answers
5k views

Shows “unable to locate package unzip” error

I have installed Ubuntu 12.04 server , shows E:unable to locate the package unzip the above error is also shown, if I try to install packages also. Can any one help me out to get out from this ...
0
votes
2answers
286 views

Php broken, “held broken packages” error on install [duplicate]

I've completely destroyed everything and now php wont install. I had php5.4 and everything was great. I then needed to run Magento locally which wasnt working. I saw one of the requirements was ...
0
votes
1answer
6k views

32 bit packages in 64 bit ubuntu

Can I install the downloaded 32 bit packages to 64 bit OS? (now using UBUNTU 12.04(32bit) and going to install UBUNTU 12.04(64bit) on another PC.)
0
votes
1answer
122 views

How can I save my installed packages on an external device so that i don't have to connect to internet on every new install [duplicate]

Possible Duplicate: How can I install software or packages without Internet (offline)? I have a compac presario laptop. Whenever i try to install a new ubuntu my wireless driver (broadcom) ...
0
votes
6answers
4k views

Is there a native Picasa version for Linux? How can I install it?

How can I install Google Picasa 3.9 or whatever the latest version is. I don't want the Wine version, I want the native Linux version. I'm trying to avoid using programs via Wine because it is very ...
12
votes
3answers
22k views

How do I download and install Opera in 12.04?

I've heard that we can use it. Then how can I install it because I dont see it in the Ubuntu Software Center.
4
votes
4answers
8k views

How to reinstall a package

I am getting this while installing libebml3: Errors were encountered while processing: libebml3:i386 Error in function: dpkg: error processing libebml3:i386 (--configure): Package is in a very bad ...
3
votes
2answers
8k views

Ubuntu 13.10 gives “Package 'libapache2-mod-auth-mysql' has no installation candidate” error [closed]

UPDATE: Because Apache 2.4 is the default version (instead of the previous 2.2) this error occurs. However as can be seen here all future versions of Ubuntu 13.10 and above will not support this ...
3
votes
1answer
2k views

“nvidia-304-updates” vs “nvidia-304” (and similar)?

What is the difference between these two modules? Whoever created them didn't seem to think of including a clear description.
3
votes
4answers
2k views

How can I find the name of a Package?

I want to create links to software within Software Center using the APTURL - However, I'm not sure how to find out the true "package name". What is the easiest way to discover a package's name for use ...
1
vote
1answer
19k views

The following packages have unmet dependencies [duplicate]

The following packages have unmet dependencies: apache2: Depends: apache2-mpm-worker (= 2.2.22-1ubuntu1) but 2.2.22-1ubuntu1.2 is to be installed or apache2-mpm-prefork (= ...
1
vote
2answers
2k views

I Cannot install or remove packages

I tried to install the openoffice.org package but it gave an error. Now i cannot repair, remove or install nothing. The Software center of xubuntu gives this error log. Nothing seems to solve this. I ...