Questions about software packages, installing them, removing them, updating them and finding them.

learn more… | top users | synonyms (1)

8
votes
6answers
11k views

Dependency error while installing WINE

Every time I try to install "WINE" VIA the Software Center on Ubuntu 12.10, I get this error: The following packages have unmet dependencies: wine1.4: PreDepends: dpkg (>= 1.15.7.2~) but ...
71
votes
3answers
60k views

How do I deal with “unauthenticated sources” errors in the Software Center?

Any install that I'm trying through the Software Center is telling me: Requires installation of untrusted packages: The action would require the installation of packages from not authenticated ...
42
votes
3answers
50k views

Requires installation of untrusted packages?

I tried installing VLC Player yesterday, and I got the Requires installation of untrusted packages error. I searched for hours for a solution to this problem, and finally came upon a suggestion that ...
43
votes
4answers
20k views

If I build a package from source how can I uninstall or remove completely?

I used source code to build one package such as below: ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --with-package-name="Myplugin" ...
12
votes
3answers
77k views

how to install packages with apt-get on a system connected via proxy?

I've got an Ubuntu 11.10 system connected via a proxy to the internet, and I would like to install packages via apt-get. When I try to do that I get this error message: sudo apt-get install ...
10
votes
4answers
60k views

trying to overwrite '/usr/bin/opencv_haartraining', which is also in package libopencv2.3-bin 2.3.1+svn6514+branch23-12~oneiric

After installing some packages and libraries I have an error on Package Manager, I can't run any update because it says: The package system is broken If you are using third party repositories ...
24
votes
4answers
14k views

How to set up an APT repository?

I would like to set up an APT repository on a server that will provide a couple of packages. Is there a way to set one up without installing any software on the server? How do the files have to be ...
18
votes
8answers
5k views

What is a “bad quality” package?

What does it mean to have a Bad Quality Package (What qualities would it have to be a Bad quality package) and what happens if I install a package that has bad quality but still installs.
55
votes
5answers
62k views

How to Downgrade a Package via apt-get?

How to downgrade a package to an older version via apt-get?! Another tools are also accepted but apt-get is preferred.
9
votes
7answers
12k views

How can I update Ubuntu offline without using Synaptic or Keryx?

I use Ubuntu 12.04 at my home and have good internet connection and my system works fine. One of my friend is having small office and he is thinking to switch from Windows to Ubuntu 11.10 or above. ...
13
votes
2answers
438 views

Why doesn't Ubuntu ship an application, or the latest versions of some applications?

What reasons are there for applications in Ubuntu not being the most up-to-date, and why are some applications not available, in its repositories?
7
votes
4answers
30k views

Remove Gnome Shell completely after installing it?

I wanted to try gnome-shell in 11.10 (also 12.04 now) I removed it, however, classic Gnome is still there and the battery icon is changed (too big and can't use a icon pack on it like faenza) Also, ...
29
votes
1answer
3k views

How to create a meta-package that automatically installs other packages?

I'd like to be able to create a package that doesnt contain any code or programs itself, but instead installs other packages that exist in the repositories onto a computer, sort of how the ...
17
votes
4answers
5k views

What is the difference between a meta-package and a package?

I've heard some packages being classified as a meta-package. So now I am left wondering what is the difference between a meta-package and a package?
0
votes
1answer
966 views

error occured while running sudo apt-get install -f

I get this error Sub-process /usr/bin/dpkg returned an error code (1) so I tried sudo apt-get clean and autoclean. When I ran sudo dpkg --configure -a: Errors were encountered while processing: ...
20
votes
6answers
6k views

How do I figure out what package something is in without resorting to Google?

I often find myself wanting to install something, but I'm unsure of what package it's in. This is a very common occurrence for me: $ make html sphinx-build -b djangohtml -d _build/doctrees . ...
7
votes
0answers
5k views

Updates don't install because of “untrusted packages” [duplicate]

Possible Duplicate: Update Error : Require Installation Of Untrusted Packages I have "darktable + extras" installed (I added their ppa repository to the sources manually). The extras ...
9
votes
1answer
4k views

Install packages from newer release without building (apt pinning)

I need these packages with the latest upstream version backported for ubuntu/natty libccid_1.4.5-0ubuntu1_amd64.deb libpcsclite1_1.8.1-0ubuntu1_amd64.deb libpcsclite-dev_1.8.1-0ubuntu1_amd64.deb ...
21
votes
2answers
3k views

How do I create a PPA for a working program?

Let's assume I have a working application written in C, C++ or Python. I want to create a Launchpad PPA so others can easily install it from a package. Please give step by step instructions for doing ...
-2
votes
1answer
152 views

How to solve Unable to locate package error

There are many question in which users face error: E: Unable to locate package ... . The following error while sudo apt-get install <package>: sudo apt-get install package Reading package ...
19
votes
4answers
15k views

How to disable multiarch support?

I don't want to install any i386 package. Is there any way to disable functionality?
10
votes
2answers
16k views

How can I check dependency list for a deb package

How can I check dependency list for a deb package. I am running Ubuntu 11.10 and I have backed up all deb packages from var/cache/apt/archives. I want to format my pc and re-install selected ...
12
votes
8answers
11k views

How do I find packages to install via apt-get

After doing a man apt-get and cursory Google search it's not clear how I find new programs to install (from the internet) using apt-get (which is amazingly powerful and simple coming from another ...
18
votes
4answers
19k views

How to install GUI desktop on a server?

After installing Ubuntu server how do I install the desktop environment?
10
votes
1answer
3k views

How does the fglrx package's version relate to AMD's version numbers, like Catalyst 12.3?

When I learn about a new version of AMD's graphics driver, I usually see something like "Catalyst 12.3." However, the fglrx package in Ubuntu has a version like 2:8.960-0. Are these two version ...
9
votes
2answers
3k views

How to forbid a specific package to be installed?

Can I configure Ubuntu to never install a specific package even if it is required by another package I install?
24
votes
6answers
3k views

Why the software center doesn't allow multiple downloads?

I was wondering why the software center doesn't download all the requested apps and install one by one as they finish to download. Or instead why the software center doesn't download an app while the ...
13
votes
2answers
1k views

What are the downsides of removing ubuntu-desktop metapackage?

I once advised someone to remove a package that depends on ubuntu-desktop meta-package, if she didn't need it (EG: if one uses a different editor than gedit). Someone else said that doing so (removing ...
10
votes
4answers
6k views

How do I get the version of an application from the command line?

I would like to know how to get the version information of an installed program that doesn't have the --version or -version method implemented.
8
votes
0answers
315 views

Keep the Ubuntu package version I'm using now [duplicate]

Possible Duplicate: How to prevent updating of a specific package? I just installed a package (wine). I want to keep this version I'm using now. How can I disable updates for this package? ...
3
votes
4answers
1k views

Why does Update Manager give me a 404 error with these Google repositories?

I have a red warning sign in my toolbar. When I click on it, it asks me to check for updates. When I check for updates, I get this: W:Failed to fetch ...
2
votes
4answers
2k views

How can I burn an ISO file to a blank disk?

I have downloaded the Ubuntu 10.10 ISO file and am trying to burn it to a blank disc so that I can install it, using Ubuntu 8.04. I have a dual boot system with Windows and Ubuntu. Here's my ...
12
votes
1answer
6k views

How to download, modify, build and install a Debian source package?

If I want to make minor changes to the source code of a Debian package, how do I go about downloading, incrementing the package version, building the (modified) source, and installing it on my ...
14
votes
3answers
356 views

How can I know what programs does some apt-get package contains?

I would like to know what does some specific package install, for example, when installing ncurses, I have found that TAB key expands: sudo apt-get install ncurses- to show: ncurses-base ...
20
votes
1answer
4k views

What's the difference between flashplugin-installer and adobe-flashplugin?

I usually installed flashplugin-installer and by chance noticed that in the partner repository the Flash entry says it's not installed. It also says the package flashplugin-installer will be removed ...
10
votes
2answers
3k views

apt-get remove with wildcard removed way more than expected. why?

Last night I was trying to burn CDs. Being annoyed with k3b and choosing to use brasero instead, I went to remove k3b. I typed in: sudo apt-get remove k3b I hit tab twice and saw that I had both ...
10
votes
2answers
9k views

How do I install KDE and retain LightDM as a login manager?

I want to install KDE in my Ubuntu 12.04 . I am using LightDM. So how can I fully install KDE? I do not want to remove LightDM. I want KDE but without any confliction with it.
3
votes
1answer
5k views

Unable to repair packages in Ubuntu Software Center

When I open up the Software Center it gives me, "Items cannot be installed or removed until package catalog is repaired". Can someone help me?
2
votes
3answers
447 views

Why does 'quickly package' fail with “An error has occurred when creating debian packaging”?

I've got a big problem with packing my quickly application for the Ubuntu App Showdown. When I try to package or submit my application, I get some warnings: quickly package --verbose ........ ...
2
votes
1answer
2k views

How to obtain installed package files?

I need to download all packages I already installed on Ubuntu 11.10 x64. There should be in /var/cache/apt/archives I know, but there are only 300 Mb of deb files. I installed a lot of development ...
12
votes
2answers
4k views

What exactly is in ubuntu-desktop?

I'm also interested in its variants, like kubuntu-desktop. It appears to include GNOME (or KDE) and a bunch of other things. But it's quite large - is there a breakdown of what is included in ...
6
votes
4answers
17k views

How do I locate and remove Broken Packages that I have installed?

I was browsing some questions here to find a solution to locating and removing broken packages. Being a relative novice I installed some PPAs designed for 11.10 on my 12.04 LTS machine. In terminal ...
6
votes
2answers
3k views

How to install one GUI program on Ubuntu Server?

I am using Ubuntu Server 10.10 in a VirtualBox. I need to install a single GUI program (RubyMine) on it. I checked out installing ubuntu-desktop with apt-get, and it wants me to install 430 new ...
6
votes
3answers
5k views

Where is the “pysdm” package?

I am new to Ubuntu. I have some old hardware lying around so I decided to build a backup/storage device. I am trying to follow this lifehacker article. It asks me to open a terminal and run sudo ...
82
votes
5answers
226k views

How to install updates via command line?

Good day, When I log into my web server via SSH I see the information: 88 packages can be updated. 80 updates are security updates I tried apt-get update then apt-get upgrade but each time I log ...
28
votes
2answers
761 views

What precautions should I take with .debs I find on the internet?

So I was browsing the web the other day, and I came across a few places that wanted me to download .deb files - and since those are installed by root (and as such have the "powers" and capabilities of ...
9
votes
8answers
40k views

How to fix a broken package, when “apt-get install -f” does not work?

I tried to install Scala with the typesafe stack and got into trouble. Now I cannot do much with apt (except update), the broken package seems to be impossible to remove/clean: Here's the result of ...
8
votes
3answers
8k views

Getting + installing gcc/g++ 4.9 on Ubuntu?

How do I install the latest version of gcc and g++? I am using a variety of C++11 and C++1y features; which is why I need this.
15
votes
4answers
14k views

How do I add the kernel PPA?

I can get Ubuntu mainline kernels from this kernel PPA - is there a way to add it to my repository list the same as regular Launchpad PPAs?
9
votes
3answers
1k views

How can I make a live CD/DVD from my harddisk installation?

How can I make a live CD/DVD from my harddisk installation? In other words, I would like to create a boot CD from Ubuntu that is installed on my PC, because I want to include the updated packages in ...