Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

8
votes
0answers
518 views

Confused about building OpenStack Packages?

I found OpenStack build task on Ubuntu QA site, but I am a little confused about the build steps. Here's the link for build steps: ...
4
votes
0answers
72 views

Is there Ubuntu's analogue of snapshot.debian.org?

Debian users have a kind of "wayback machine": snapshot.debian.org , which is really great. There are regressions sometimes, and if I don't have local deb package with old version, I'm getting sad ...
3
votes
0answers
27 views

creating a deb package to install extension

I want to create a deb package that will install this and that extensions. I want to automate the steps of adding the extension to LibreOffice and Firefox. How do I create a package for this?
3
votes
0answers
64 views

Ubuntu 14.04 64bit - Provides in a package not working

I have recently switched over to 14.04 64bit from 12.04 32bit. I use packages that are built by my company and I have added architecture dependency in the sources.list file like: deb [arch=i386] ...
3
votes
0answers
218 views

How can I accept the Lience agreement for steam prior to apt-get install?

I'm currently fiddling around with using ansible to setup my machine with my chosen configuration/apps etc... I've hit a stumbling block with steam and it's licence agreement. I've been trying to use ...
3
votes
0answers
63 views

Publish a package on Ubuntu Software Center?

Recent, I uploaded a package on MyApps. After uploading finished, I received a notice: Thank you for submitting a gratis Free Software application through MyApps. At this time we are unable to ...
3
votes
0answers
1k views

Boot Repair - 'Close all package managers…' Dual Boot Installation

After almost a week I've just about manged to install Ubuntu 12.04.3 LTS alongside Windows 8 on a Dell XPS 14 Ultrabook. I have created a partition in Windows to store Ubuntu, rebooted from Windows ...
3
votes
0answers
282 views

Issue Backporting SQLite 3.8.1 to Ubuntu Precise from Trusty

I'm pretty new to all of the packaging of Ubuntu applications and what not so this may not be the correct place to ask this question or there may be a more appropriate place to re-ask this question. ...
3
votes
0answers
393 views

How to package shared library in deb packages

My application uses some shared libraries, which i need to package with the binary, and as per Debian Policy Rules It is recommended that supporting files and run-time support programs that do not ...
3
votes
0answers
159 views

How can I update my custom repository?

I created a local repository and I used it in my ubuntu clients. This repository contains only some packages. Now I would upgrade these packages. How can I do it, as there are many packages and ...
2
votes
0answers
74 views

How do i detect if I'm missing drivers or packages?

I am fairly new to Ubuntu and I encountered my biggest problem yesterday. I was getting low graphics mode error. I, pretty much tried everything I could understand from "low graphics mode" questions. ...
2
votes
0answers
18 views

How do I hold package regardless of revision change?

Only yesterday, I realized that apt-get forces a package, even if it is only a repackage of the same content with revision change. Many package-maintainers do this for newer release versions. I have ...
2
votes
0answers
76 views

Perl package not found with apt

When I try to do an upgrade or install something, apt(-get or aptitude) throw an error, saying that perl can't find XML/SAX/Debian.pm while trying to configure libxml-libxml-perl. Here is the full ...
2
votes
0answers
132 views

Why does libapache2-mod-php5 get removed whenever I upgrade apache2?

I hope someone can help me figure out what is going on with my apache upgrades. For years, whenever I upgrade apache2, it tries to install apache2-mpm-itk even though I use the prefork module ...
2
votes
0answers
324 views

libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed (on 14.04.2 64)

Please, do not mark this as duplicate, I already studied libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed and How do I resolve unmet dependencies after adding a PPA? and tried ...
2
votes
0answers
55 views

How can I use equivs-build to build packages that can be installed on older versions of Ubuntu?

I have several versions of Ubuntu installed, including 14.04 and 10.04. When I build packages using equivs-build on 14.04, it generates .debs that contain .xz-compressed data. The version of dpkg on ...
2
votes
0answers
41 views

Aptitude is unmarking packages as “Auto”, is this a bug or feature?

I have a brand new Ubuntu server installation and go in to aptitude. Whenever I set a package to remove, the default action is the equivalent of apt-get autoremove. However, it seems that when you go ...
2
votes
0answers
178 views

xfonts installation failed and apt compromised

I started the installation of all the xfonts packages on my Ubuntu 14.04.1 system with sudo apt-get install xfonts-* While extracting a package (one of the hundreds of the list), the system got ...
2
votes
0answers
132 views

Why has 14.04 LTS no static libraries in some packages?

These are the udev development packages for the last three Ubuntu LTS releases. File list of package libudev-dev in lucid File list of package libudev-dev in precise File list of package libudev-dev ...
2
votes
0answers
50 views

apt-file equivalent to search for source files

I find the apt-file utility very comfortable to find the package that delivers a given file. If I wanted to find the package that delivered /bin/bash I would simply type apt-file find /bin/bash and ...
2
votes
0answers
160 views

libssl-dev and libssl1.0.0 on confilcting versions

My problem on 12.04lts is that somehow my libssl1.0.0 got upgraded to 1.0.1-4Ubuntu5.17 and my libssl-dev requires 1.0.1-4Ubuntu5.14 apt won't update libssl-dev because libssl1.0.0 was upgraded first. ...
2
votes
0answers
2k views

Tex-common troubleshooting on Ubuntu 14.04 LTS

I recently upgraded my computer from 12.02 LTS to 14.04 LTS, but experienced problems with launching Google Chrome and being able to use Rhythmbox. Rhythmbox asked if I wanted to install additional ...
2
votes
0answers
294 views

How to fix a Failed Package Operation Error?

Launched the software center and I am getting this error: installArchives() failed: E: Invalid archive signature E: Internal error, could not locate member control.tar.{gzbz2xzlzma} E: Prior ...
2
votes
0answers
168 views

Installing a Package that asks debconf questions doesn't work with the Software-Center

I am building an automatic configure Package for our environment and it has to ask a few debconf questions when installing. Until Ubuntu 13.10 it was no problem installing it via the GUI but since ...
2
votes
0answers
50 views

Can I reset all packages to repo versions without ppa-purge?

This is just a theoretical for me (it's a real problem for another user) but let's say: I upgrade a load of packages from a PPA onto 12.04 I upgrade to 14.04 Some packages are held in because my ...
2
votes
0answers
56 views

Server Gets Restarted while installing Ubuntu

I'm using Fujitsu Primergy Rx200 S8 server, when I installing Ubuntu 13.10 server edition the server gets restarted itself at the time of "Installing the system" after partitioning step. The media ...
2
votes
0answers
85 views

Aptitude - Both 64 & 32-bit packages being selected

In aptitude, I selected the xubuntu-desktop task and was presented with a large number of package conflicts, per this example: It seems that both the 32- and 64-bit versions of packages are being ...
2
votes
0answers
32 views

Is it possible to search and remove files that aren't part of a package?

So, I've wrecklessly installed tarballs into / and /usr thinking this is what I'm supposed to do! Apparently its not and updating now kind of is difficult. I'm wondering, save for a full blown ...
2
votes
0answers
410 views

Binary package for gcc 4.8.2 on Ubuntu 12.04?

Following this answer, I have installed gcc 4.8.1 on Ubuntu 12.04 a couple of months ago. Unfortunately, I encounter bugs very frequently, varying from failing to compile valid programs to crashing. ...
2
votes
0answers
627 views

Installing objdump on Ubuntu that recognizes mach-o binaries?

Anyone know how to install a version binutils on Ubuntu that has an objdump that can recognize a mach-o binary? Currently when I run, objdump -P load binary, I get objdump: /path/to/binary: File ...
2
votes
0answers
76 views

How to remove packages from my own Debian package?

I know the basics of creating a Debian package. But I wish to create one that marks other packages for removal as it is installed. Under the Debian folder of the package at the control file, I tried ...
2
votes
0answers
49 views

How do I block a certain package from being installed without disabling recommends?

I want to blacklist the package ttf-mscorefonts-installer forever. How can I make sure upgrading my system will never install this package without disabling other "recommends" from being installed? ...
2
votes
0answers
345 views

How can I preseed package installation without a network connection?

I am working to create an unattended offline installation of the Ubuntu Server 12.04. I have everything preseeded so far, but I still can't figure out how to install other packages without requiring ...
2
votes
0answers
337 views

ubuntugis demands a partial upgrade? Is this safe?

I would like to do some GIS in ubuntu. When I use the repo: sudo apt-add-repository ppa:ubuntugis/ubuntugis-unstable Update manager asks me to do a partial upgrade. The packages it wants to ...
2
votes
0answers
258 views

configure says I don't have lib, but aptitude says I do

I've just run a configure script which alerts me: checking for gcry_control in -lgcrypt... no configure: error: libgcrypt not found. Install libgcrypt or use --disable-libgcrypt. Have a nice day. ...
2
votes
0answers
10k views

Cannot install “ATI/AMD proprietary FGLRX graphics driver” (SystemError)

I have just installed a fresh copy of 12.04.1 64bit. I formatted my PC completely and enabled updates during the installation. After the installation was complete, I went on updating my software. ...
2
votes
0answers
128 views

12.04 upgrade hosed my system

I wish I could be more specific. I installed the upgrade from the update manager and after the computer rebooted, I found I could not run a lot of programs. I tried running them from the command ...
2
votes
0answers
894 views

Why did Ubuntu remove SpiderMonkey package?

I noticed Ubuntu didn't support SpiderMonkey since 10.04. I guess it may have something to do with license. Can You Tell Me The Reason Why?
2
votes
0answers
458 views

Cannot update using Update manager because “Package operation failed”

I have 390 updates after opening up 32 bit through VM Ware Fusion. When tried to update, I got "Package operation failed" error and I can't even open up .run to install the application. Here are the ...
2
votes
0answers
86 views

Trouble installing package and updating

I almost nothing about Ubuntu. When I try to run the command to install of a package, I am said that 'unable to locate package' When I try to run sudo apt-get update, the system seems being blocked! ...
1
vote
0answers
10 views

downgrade libsqlite3

I get some errors which hint to libsqlite3. Therefore I want to downgrade libsqlite3 on Ubunutu 14.04 root:/usr/src# dpkg -l | grep sqlite ii libqt4-sql-sqlite:i386 ...
1
vote
0answers
9 views

package remove fail. postgresql-contrib-9.1: subprocess installed pre-removal script returned error exit status 127

Do you want to continue? [Y/n] y (Reading database ... 404522 files and directories currently installed.) Removing postgresql-contrib-9.1 (9.1.15-0ubuntu0.12.04) ... ...
1
vote
0answers
10 views

Reinstall an official package when custom one has overwritten it

I recently installed the Debian packages produced by running make deb-pkg to compile my own version of the Ubuntu kernel. I had given the kernel the release version 3.19.0-21-secure. All of the ...
1
vote
0answers
40 views

Problem with umnet dependencies

I did a fresh installation of ubuntu 14.04, did updates and upgrades, when i tried installing softwares smplayer, synaptic package manager, ubuntu-restricted-extras, gdebi, etc.. getting a umnet ...
1
vote
0answers
94 views

Upgrading from 14.04 LTS (Trusty Tahr) to 15.04 (Vivid Vervet)

How long does it take to upgrade from 14.10 LTS to 15.04 ? The procedure of Saving installed packages is going on for last 18 hrs on my system. I have chosen the option of keeping all my personal ...
1
vote
0answers
43 views

enabling proposed repos in 15.04 server fails to update packages

i am trying to use the proposed repo of vivid on ubuntu 15.04 server system. user@controller:~$ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=15.04 DISTRIB_CODENAME=vivid ...
1
vote
0answers
10 views

how to install packages which is not in the cache with python

i install packages in my application using python apt. Some example: import apt cache = apt.cache.Cache() pkg = cache["brukkon"] pkg.mark_install() cache.commit() In this example, brukkon is not in ...
1
vote
0answers
21 views

Coherence between package version and served files

Currently, I am trying to understand how distro maintainer build and choose names for their packages and there is (from my point of view) a lack of coherence for a specific package. Take the libzmq ...
1
vote
0answers
56 views

Unpacking linux-image-3.16.0-34-generic (3.16.0-34.47) over (3.16.0-34.45)

I want to change Java 8 to Java 7. I planned to Remove Java 8 First. I run the Following cmd sudo apt-get purge oracle-java8-installer I got the Following Error Reading package lists... ...
1
vote
0answers
292 views

unmet dependencies when trying install wine1.7

I'm trying to install wine1.7 from official ppa,my OS is Ubuntu 14.04 64bit, however when I use the apt-getcommand to install wine, the output is: The following packages have unmet dependencies: ...