Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
2answers
14 views

(K)Ubuntu 16.04 can't install mysql server unmet dependencies

When I try to sudo apt-get install mysql-server I keep getting following error: The following packages have unmet dependencies: mysql-server : Depends: mysql-community-server (= ...
1
vote
1answer
33 views

ClipGrab was removed automatically from my PC and i coudn't install anymore

I did the following steps: sudo apt-add-repository ppa:clipgrab-team/ppa sudo apt-get update sudo apt-get install clipgrab But the terminal result was: Package clipgrab is not available, but is ...
0
votes
0answers
6 views

Installing cuda 6.5: likely some package issues

So I had successfully install Cuda 7.5. Turns out I needed something pre 6.5, and I was having difficulty installing it. Seemed like no matter what i did it stayed there, so I did a good search for ...
0
votes
0answers
25 views

Samba won't install becuase of broken packages

I am running Ubuntu Server 14.04.4 and I didn't install Samba with the original OS setup. I would like to install it now but I keep getting a error about broken packages. It appears that the main ...
1
vote
1answer
9k views

“Unable to correct problems, you have held broken packages” while installing NFS server

I am trying to install an NFS server on my Ubuntu 12.04 machine but everytime it gives me an error like this: david@machineA:~$ sudo apt-get install nfs-common nfs-kernel-server Reading package ...
0
votes
1answer
42 views

Ubuntu 14.04 System Settings: Bluetooth is disabled

I did something I don't know how to fix, and now I need help. I was trying to get bluetooth working, so I installed Bluez 5.39 with bluez-5.39.tar.xz from the download page with ./configure, make, and ...
1
vote
0answers
11 views

Cant install libgl1-mesa-glx:i386

I was trying to get wine to work and end up screwing up the system. Steam used to work but now it keeps saying I need libgl1-mesa-glx:i386 which I cant get it to install. I tried many ways and spent ...
0
votes
0answers
6 views

Could not initialize the package information. An unresolvable problem occurred while initializing the package information

Recently I had an update prompt while working on my Dell Vostro Machine with Linux(Ubuntu) 12.04 LTS, after complying with the same when the package was getting downloaded, suddenly an error message ...
0
votes
0answers
9 views

Is ita safe to delete uninstalled packages with orphaned configuration files with gtkorphan?

I'm running xenial right now, and since my computer is actually slow on startup, I wanted to free a little bit more of space, though I do not have many files in my hdd. So I ended up using GtkOrphan ...
0
votes
0answers
20 views

python and package manager are broken

After upgrading Ubuntu from 15.04 to 16.04, python and package manager are broken. When running apt-get update I receive the message use apt-get -f install, but when running this command I get ...
1
vote
1answer
151 views

E: Malformed entry 54 in list file /etc/apt/sources.list (Component)

I'm relatively new to Ubuntu 16.04, and everything has been going fine until my OS threw this error today. Below is the source code from /etc/apt/sources.list for line 54: deb ...
0
votes
1answer
51 views

Unable to locate pipelight-multi package

sudo apt-get install --install-recommends pipelight-multi Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package pipelight-multi I got ...
0
votes
1answer
13 views

apt-get install fails because of libmagic1

my apt-get install is failing because of following error with respect to libmagic1. My Ubuntu version is 12.04 LTS. Can you please help if anyone aware of it? I need to fix this to update some ...
0
votes
0answers
6 views

How can I make sure O/S doesn't use a particular Signing Key (gpg)

Actually this is two (2) different questions. I am on Xubuntu 14.04 but I believe the answers would be the same for all *buntu variants. The first one is in the title of this message. The second is ...
1
vote
1answer
18 views

“loop involving service”: apt-get install breaks dpkg

One apt-get install went bad, now every apt command results in it trying to get apache2 into a consistent state, which of course crashes. I'm not sure that the package that did it matters, but it was ...
0
votes
0answers
10 views

How to make pre-depends install packages in debian packaging

I am building a package that depends on package X, Y, Z. So i put them into the control file und der Pre-Depends: X, Y, Z However, this doesn't install the packages it just says my package can't ...
0
votes
3answers
239 views

After Ubuntu 16.04 installation can't install almost anything

I fresh installed Ubuntu 16.04 to my laptop recently and since that I can't install lots of things. I know there is a bug in the Software Center but the problem is not limited to that. I can't install ...
0
votes
1answer
28 views

Upgrading kubuntu: error trying to overwrite package

I am trying to pgrade my kubuntu to the latest version. When running sudo apt-get dist-upgrade, I get: (Reading database ... 558588 files and directories currently installed.) Preparing to unpack ...
0
votes
0answers
14 views

PyBFD cannot find Binutils in 16.04

I've upgraded my distro from 15.10 to 16.04 LTS. In 15.10 everything was okay. I am using pybfd 0.1.1 with binutils 2.26 (In 16.04). The python package pybfd used to be okay with binutils of 15.10. ...
0
votes
1answer
20 views

Configure cron-apt to use smtp relay

I've setup cron-apt on Ubuntu 14.04.3 to automate updates. I'd like it to email notifications and have configured MAILTO="user@example.com", and MAILON="upgrade" options in /etc/cron-apt/config. I ...
2
votes
1answer
17 views

Cannot read repositories after update

This morning my system gave me a security update that I installed. Now I cannot read or update Repositories, either from Update Manager or Terminal with sudo apt-get update. I am getting the ...
0
votes
1answer
16 views

installed package with snap - command not available

I saw that tmux is available with snap find and apt-cache. I decided to install with snap. Howto use now tmux? I am normal desktop user, not cloud computing. # snap error: Please specify one ...
0
votes
1answer
18 views

Version range in debian/control

When declaring dependencies in debian/control to create a package, I can specify a lower or upper bound on the version. For example, if I depend on libvtk6-dev being at least version 6.0.0 I can write ...
1
vote
0answers
12 views

Is there a way to build a snappy pakage from a unstable repo like the arch repo or DebianUnstable repo

I am wondering if you can truly get new package versions with snappy? Maybe something like running a chroot of DebianUnstable and using deb2snap to build snappys? Is this possible?
0
votes
1answer
43 views

How do I fix a lot of broken packages?

I'm currently running on Ubuntu 15.10, but I want to update to 16.04. But the updater says I have broken packages. But, in my opninion, I have way too much broken packages and I have no idea why they ...
0
votes
0answers
11 views

debian package that installs other debian packages

I am trying to get familiar with debian packages and trying a couple of tutorials, so far this is the only one that makes sense and also works. So my goal is to build a package that downloads and ...
2
votes
2answers
25 views

Expanding APT-GET Repositories

Wow, I'm here posting about Linux. Never thought I'd see the day, but I've been shown the light by a smart guy and a few VMs and man pages later and her I am. I think I've managed to get my Ubuntu ...
1
vote
2answers
20 views

On Ubuntu, is there a way to find out what files are NOT associated with installed apt packages?

I know in RedHat, you can use find / –exec rpm -qf {} \; |grep "is not" to find files that are not associated with packages. One reason I need this is to find files that are installed from source so ...
2
votes
2answers
201 views

Regexp/config var for apt-cacher to allow repo files for 16.04 clients (Metadata, Components-*.yml)?

I use apt-cacher on a Debian server, and doing an apt-get update with a 16.04 client I'm finding that it's blocking a bunch of repo files including icons-64x64[.tar[.gz]], some xz extensions, Metadata ...
1
vote
0answers
16 views

Error:dependency is not satisfiable

I'm a new Ubuntu user, and I don't know so much about this system. So, when I tried to install a game (Lonely Survivor) I got this error: "Error: dependency is not satisfiable: ...
15
votes
4answers
15k views

Can I install Portage, Pacman or other package managers on Ubuntu?

I want to install a non-Ubuntu package manager like Portage (Gentoo) or Pacman (Arch) on Ubuntu 12.04 LTS. How do I do that?? PS - I'm a Newbie to Linux.
0
votes
0answers
7 views

Debian Packages | Post-Install - Configuration

In my Postinstall script i have a whiptail dialog popping up to fill in a password for MySQL. This password will be stored in my configuration file in /etc//.conf At this current moment i don't care ...
0
votes
0answers
11 views

Debian Packages | Maintainer Script - Postinst

Hey i'm having troubles with updating my packages (with patches using quilt). Whenever i'm updating the source everything is alright and the patches work. But when i want to update a maintainer script ...
-1
votes
0answers
32 views

Can't install aptitude on Ubuntu Gnome 16.04 LTS

Where I try to install aptitude, i get this: Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct ...
0
votes
0answers
129 views

how to fix update problem on ubuntu 16.04

While update I have got error like this W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and ...
0
votes
0answers
93 views

pip use on Ubuntu 16.04

I installed python packages on Ubuntu Trusty using pip and was able to call the installed packages as expected, but on Ubuntu Xenial (installed in a virtual machine) I did the same thing using pip but ...
0
votes
0answers
19 views

I happen to destroy WIFI driver when upgrading gcc-4.8 to gcc-5.3

I am working on Ubuntu 14.04.03 Trusty Tahr. As we know, the default GCC package version for this release is 4.8.2, but recently I upgraded it to GCC 5.3 (the latest version) following this answer: ...
1
vote
1answer
68 views

RabbitVCS on Ubuntu 16.04 LTS

Recently I installed Ubuntu 16.04, and I would like to install RabbitVCS on my system. I already add the PPA and apt update and seem no build yet for xenial ...
0
votes
2answers
180 views

Ubuntu 16.04 “Nvidia GPU Driver” can not use proprietary driver

After a fresh install (16.04) to my notebook which have Nvidia GT 750m, I want to change GPU driver from "Software & Updates" --> "Additional Drivers". System identifies my graphic card, no ...
-1
votes
1answer
94 views

Ubuntu 16.04 broken packages after fresh install

After fresh install of Ubuntu 16.04, i have broken packages and can not install most of applications. I tried from Synaptic "Fix broken packages" but it is not working. An example; sudu apt-get ...
1
vote
1answer
55 views

Why no more “python-support” in 16.04?

I'm curious why the python-support package no longer exists in 16.04 - is this related to changing Python3 to be the default? Furthermore, is there any package that "requires" it that actually doesn't ...
1
vote
0answers
2k views

Wrong sources.list entry or malformed file

I'm kinda new to this website so I don't know the policies, but I really need some help with an ongoing issue that has become quite annoying. I moved from Ubuntu 14.04 to Linux Mint 17.2 Rafaela (I ...
0
votes
0answers
14 views

kubuntu-desktop dependencies problem, now forbidden icon

A week ago, one of my friends said that the kubuntu-desktop is cool. So I installed it. But now there are dependencies problem with kde-telepathy-minimal, and the forbidden icon turned up and said ...
37
votes
2answers
51k views

How to set up and use a virtual python environment in Ubuntu?

Python virtual environments are used to create isolated python environments to avoid dependency and version conflicts, and also indirectly takes care of permission issues. But what is the easiest way ...
0
votes
1answer
161 views

Package libgeotiff-epsg is not available and has no installation candidate

I am installing openstreet server on Ubuntu and for that I need to install libgeotiff-epsg package. When I do sudo apt-get install libgeotiff-epsg, it it returning that Package libgeotiff-epsg is ...
3
votes
1answer
13 views

Where can I find the source code for the apt package manager?

I would like to modify some functionalities in the apt-get package manager, but I can only find the apt-get binaries. Where is the source code for the package manager?
20
votes
4answers
98k views

How to resolve “Failed to download repository information”?

Whenever I try to install anything with the Ubuntu Software Center, the following error appears. Failed to download repository information Check your Internet connection. E:Unable to ...
1
vote
0answers
40 views

Apt-get install -f and apt-get autoremove error

I've tried to install new software on Ubuntu and it told me to use that command apt-get install -f, but I get back an error message and I have no idea how to fix it. After that, I tried to use ...
0
votes
2answers
471 views

How to make packages for ARM in Launchpad?

When I request builds in this recipe it only creates 32 bit and 64 bit packages. How to create packages for ARM? I am using Quickly.
0
votes
1answer
45 views

Required installation of untrusted package

Today I was updating my Ubuntu software and suddenly a 'not possible to update because package system is broken' error came up. Somehow I try to follow from Ubuntu community in Google and something ...