Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
1answer
7k views

how do i install Video Codec on ubuntu 12.04 ?

On my machine mp3 files are playing perfectly . I want to downlaod video codec for playing populer types of format ! like mp4 3gp mkv flv avi ..etc . is there any way to play those files without ...
1
vote
2answers
39 views

How do I generate a list of packages added since installation

A number of useful pages show how to generate a list of all installed packages, eg How do I generate a package download list? Is there a way to restrict the generated list to those I have added since ...
0
votes
0answers
40 views

Problems in installing packages from terminal [duplicate]

Whenever I try to install any missing packages from my terminal by using the command sudo apt-get install (package name) It shows the following error: E: Could not get lock /var/lib/dpkg/lock - ...
3
votes
2answers
4k views

Boost unmet dependencies

I heard it is easy to install libraries on Ubuntu so I switched to Ubuntu, I tried to install boost so I write: sudo apt-get install libboost-all-dev and I get this: Reading package lists... Done ...
1
vote
1answer
754 views

Is there an application for HR Management in ubuntu?

Is there an application available in Ubuntu that can : Keeps attendance details of the employees. Overtime hours Can make salary of employees. It should be easy to use than Libre Calc.
0
votes
1answer
2k views

How do I create a multiarch deb?

I am trying to make a package that will install on Ubuntu 12.04 - 13.* on 1386 and amd64. I've figured out that on the amd64 the only difference is that I need to install the 32 bit libraries. ...
-1
votes
2answers
122 views

Start installing packages while further fetching the update

Is there a package manager that during installation/update will already start installing first fetched packages whlie other packages are still being downloaded? Example made up scenario: Chromium ...
0
votes
1answer
37 views

Where to find information sources about the APT system?

The APT seems to have developed into a very comprehensive environment, hosting a multitude of command-line, and GUI based tools. Comprehensive information regarding the APT system, specially from the ...
0
votes
1answer
502 views

Override Distro Package with Custom Package?

Ubuntu 12.04 LTS provides OpenSSL 1.0.1e, but it disables TLSv1.1 and TLSv1.2. In the past it was an interop decision because of broken client implementations. In 2014, its really not appropriate ...
0
votes
1answer
461 views

Problem with kivy installation

I'm trying to install the kivy framework. But first I need to install these packages: python-setuptools python-pygame python-opengl python-gst0.10 python-enchant gstreamer0.10-plugins-good python-dev ...
1
vote
1answer
1k views

gnome ppp installation without connection

Is there any way to install the gnome ppp package without an online connection. It opens in the software center but the install button is not active. I currently have wvdial package and gnome ppp ...
2
votes
1answer
584 views

upgrade from 13.04 to 13.10 failed and broken dependencies

I tried running the upgrade from my Ubuntu 13.04 to 13.10 but it failed to upgrade a latex package with the error from [here] (Upgrading from 13.04 to 13.10 stops) and calmed to try to roll back. ...
0
votes
1answer
2k views

How do I configure the package manager on server setup?

I am trying to install ubuntu server 12.04 LTS and there is a screen that comes up during the setup called "Configure the Package manager": If you need to use a HTTP proxy to access the outside ...
1
vote
1answer
160 views

Exclude package installation to resolve conflict

when I try to install a package by doing apt-get install abc* it gives me an error between two packages that abc-x : | Conflicts: abc-y E: Unable to correct problems, you have held broken packages....
0
votes
2answers
394 views

Difference between the host and the guest OS kernel versions

I had installed Ubuntu 12.04 64-bit on my Laptop (host OS) when it was released (around April, 2012) and after applying all the patches (sudo apt-get update;sudo apt-get dist-upgrade), the version of ...
0
votes
1answer
300 views

Unmet dependencies/ Broken packages

I am trying to install the necessary plug-ins to play a video but I always get the "broken packages" message. After searching on Ask Ubuntu I've already performed the sudo apt-get autoclean and sudo ...
1
vote
2answers
4k views

How to install libdb4.8++-dev or equivalent on 13.10?

I am trying to test a mod that I've created of Peercoin. I need to install libdb4.8++-dev, but it is not available. How can I install it or an equivalent? Note: this is not a dupe since I cannot ...
18
votes
3answers
26k views

Is it safe to use the command apt-get autoremove in this particular scenario?

The last time I used sudo apt-get autoremove, nearly every important display driver or parts got deleted. This made me very squeamish about using the command again. However, each time I install ...
3
votes
1answer
7k views

Adding repository error

I'm trying to add a repository on my VPS with Ubuntu 12.04 installed using this command : sudo add-apt-repository ppa:chris-lea/node.js But terminal is showing command not found Then I've ...
0
votes
1answer
242 views

apt-get moodle ERROR 1045

When in Ubuntu and I try to install a program not related to Moodle I get an error message that refers to Moodle processing errors: # apt-get install screen Reading package lists... Done Building ...
0
votes
2answers
378 views

Reinstall ubuntu keeping data

I have done 2 distribution upgrades in the past and each time I ended up with grave problems after that, so I decided not to do any automatic upgrades. However, I do want the newest distribution, ...
0
votes
1answer
82 views

How to deal with unmet dependencies when installing packages?

I'm trying to install tmux, but getting this error. I'm also curious to how to resolve such issues as this comes up pretty often when installing these packages sometimes. When it says Depends on a ...
4
votes
0answers
2k views

Boot Repair - 'Close all package managers…' Dual Boot Installation

After almost a week, I've just about managed to install Ubuntu 12.04.3 LTS alongside Windows 8 on a Dell XPS 14 Ultrabook. I have created a partition in Windows to store Ubuntu, rebooted from Windows ...
3
votes
0answers
363 views

Issue Backporting SQLite 3.8.1 to Ubuntu Precise from Trusty

I'm pretty new to all of the packaging of Ubuntu applications and what not so this may not be the correct place to ask this question or there may be a more appropriate place to re-ask this question. I'...
3
votes
1answer
3k views

“But is referred to by another package.” - Finding that package

It is not unusual for an Ubuntu (or other distro with apt package management) user to encounter the error: user@box ~ $ sudo apt-get install x [sudo] password for user: Reading package lists... Done ...
-1
votes
1answer
186 views

How to run g++-4.7 installed in the machine using g++ command?

I am using Ubuntu 13.10(Saucy). I installed g++-4.7 in my machine. But when I tried to run g++ or tried to check the version it is showing that the package is not installed. $ g++ --version The ...
1
vote
1answer
735 views

What is the minimal installation to run .NET application created in C# by monodevelop?

I am a bit noobish when it comes to .NET but I am wondering what is the bare minimum of packages needed to be installed to run .NET application. It is a simple input output console app and with ...
2
votes
3answers
11k views

Not able to install g++ in ubuntu 13.10 because of broken packages

When I try to install g++ in my machine I am getting the following message. support:/$ sudo apt-get install g++ Reading package lists... Done Building dependency tree Reading state information....
1
vote
1answer
33 views

How to decrypt information from package versions?

What these numbers mean? Take look at concrete example from aptitude: chromium-codecs-ffmpeg-extra could be upgraded to version 31.0.1650.63-0ubuntu0.13.10.1~20131204.1, but it ...
0
votes
1answer
2k views

Ubuntu 12.10: package manager is broken (I think)

Please note: I'm a newbie with Ubuntu, only just beginning to get a grasp on terminal, etc. Whenever I try to install anything using terminal, with sudo apt-get install vlc it works fine untill ...
0
votes
1answer
94 views

Architecture specific debian package

I have created debian package XYZ. It has control file which look's like Package: XYZ Version: 1.0 Section: kernel Priority: optional Architecture: i386 Depends: Installed-Size: 1024 I just ...
1
vote
2answers
469 views

Is it possible to install packages from another linux distribution?

To be more precise, an executable returns this error: error while loading shared libraries: libftdi1.so.2: cannot open shared object file: No such file or directory I can't find that library ...
2
votes
1answer
3k views

Command line tool for removing orphaned packages?

Just exactly that. A command line equivalent of gtkorphan? An Ubuntu equivalent of urpme --auto-orphans? Please do not suggest apt-get autoremove as it's not exactly the same thing.
0
votes
4answers
139 views

Removing only the broken package

So was about to install some packages so I could get programs that I want. And somehow one package got broken, I have no idea how. So now when I try to do sudo apt-get -f install it says broken one ...
1
vote
1answer
384 views

Error pkgProblemResolver::Resolve generated breaks

I have Ubuntu 12.04 LTS installed on my machine, I tried to install a new version of libc6 which I downloaded from here I made that because a new version of libcv depends on it, I thought after ...
0
votes
1answer
45 views

BrokenCount <0 broken packages [duplicate]

So,ive have had problems with my packages and software center for sometime. I can't download any packages, and can't open software center obviously. It says that i have Brokencount <0. How can i ...
1
vote
2answers
216 views

Why two libpango exist?

$ dpkg -l '*pango*' Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) |...
0
votes
0answers
8 views

E:Encountered a section with no Package: header [duplicate]

i get error message whenever i use the sudo apt command in terminal. also i cant open my ubuntu software center. Plz help. My ubuntu version is 12.04
0
votes
1answer
323 views

Can't install lamp-server^ after upgrading from 13.04 to 13.10

I installed 13.04 because installing with 13.10 directly wouldn't work in UEFI mode. When I sudo apt-get install lamp-server^ it fails with: The following packages have unmet dependencies: apache2 :...
0
votes
1answer
114 views

Delete all ubuntu desktop stuff from ubuntu server

I have Ubuntu server VPS, I installed 3 months ago some packages to try to get a remote connection, without success. Anyway, now I'm cleaning some stuff from my server, the problem is that I found a ...
0
votes
1answer
375 views

Broken packages 'libxfixes3' and 'libxi6' after update from 13.04 to 13.10

After doing a system upgrade from Ubuntu 13.04 to 13.10 I am facing a problem with packages 'libxfixes3' and 'libxi6'. The system upgraded, but all my custom-installed software is gone. And also when ...
4
votes
1answer
820 views

Is it possible to install a newer version of cloud-init on Lucid?

I'm using EC2 user-data to configure certain services before they are launched on newly spun up instances. I've been using #cloud-boothook as the beginning of user data, and it worked like a charm on ...
0
votes
1answer
1k views

How to upgrade openSSH version in ubuntu 10.04

I need to upgrade the openSSH version present in my ubuntu server to a higher version. Please provide me steps to do so.
0
votes
1answer
70 views

Is Norwegian language supported?

Can I get Norwegian language support in Ubuntu? I don't want to get an operating system that doesn't support my language. I also wonder if I can type in Norwegian, can I do that? Can I install Ubuntu ...
18
votes
1answer
11k views

Difference between emacs and emacs-lucid packages

After Ubuntu installation(13.10), I found two versions of Emacs 24 in my software center: GNU Emacs 24(emacs24) GNU Emacs 24(emacs24-lucid) I don't understand what the difference between them is ...
2
votes
2answers
2k views

Trying to uninstall vmware packages but get 'unmet dependencies' error

So when I do dpkg --get-selections | grep vmware I get... vmware-tools-core install vmware-tools-esx-nox install vmware-tools-foundation install vmware-tools-...
0
votes
3answers
111 views

How to install a single package from Launchpad

How do I download and install a proposed ubuntu package from Launchpad? I am technical but not THAT technical so if you could give me a hint it would be much appreciated. To give you a background on ...
0
votes
1answer
483 views

Webmin packages update

I'm running Ubuntu Server 13.10 + Webmin 1.660. Since I have upgraded from 13.04 to 13.10, Webmin don't detect any package update anymore. In console when I run "apt-get upgrade", I have some packages ...
0
votes
1answer
214 views

How to make apt-get known the imported deb package in apt-cacher

I compiled memcached with sasl enabled, and made a deb package: memcached_1.4.15-1_amd64.deb by checkinstall with package name: memcached-sasl-enabled. I imported it to apt-cacher repo by /usr/share/...
0
votes
1answer
1k views

An error occured please run the package manager from the right click menu

I am facing some issue my ubuntu bar was showing some triangle with ! sign and I tried to find out some solution and by mistake i deleted /etc/apt/sources.list I tried to search for some solution but ...