Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
1answer
203 views

How to make apt-get known the imported deb package in apt-cacher

I compiled memcached with sasl enabled, and made a deb package: memcached_1.4.15-1_amd64.deb by checkinstall with package name: memcached-sasl-enabled. I imported it to apt-cacher repo by ...
0
votes
1answer
1k views

An error occured please run the package manager from the right click menu

I am facing some issue my ubuntu bar was showing some triangle with ! sign and I tried to find out some solution and by mistake i deleted /etc/apt/sources.list I tried to search for some solution but ...
0
votes
1answer
998 views

Lost settings menu and unity lenses after uninstalling Gnome 3

I installed gnome 3 in Ubuntu 13.10- I later decided to remove it. Now Everything has gone. When I right click the desktop I can't access the settings and all the unity lenses are missing apart from ...
0
votes
1answer
873 views

problem in downloading vlc [duplicate]

i am new to ubuntu 12.04 i am facing a lot of problem while installing vlc in my laptop every time i try to install it i get an error that the packages are broken. i have tried repairing, cleaning and ...
0
votes
2answers
76 views

Reinstall package that was not from repo from ubuntu repository

I've added ppa repository with some package(s) with versions greater that versions in official ubuntu repository. After that I upgraded (sudo apt-get install upgrade), then I delete ppa. Now I want ...
2
votes
2answers
1k views

How to install AFNI? “unable to locate package libXp”

I am trying to follow some instructions given to me for downloading AFNI on ubuntu. The first thing it tells me to do in the terminal is: sudo yum install libXp tcsh sudo yum install PyQt4 R but ...
0
votes
1answer
4k views

Error compiling a package: “configure: error: no gstreamer-1.0 >= 1.0.0”

I am trying to compile a package, which requires gstreamer-1.0 >= 1.0.3. I think I have an older vesion installed on my system. So I downloaded and compiled gstreamer-1.0.4 and it got installed in ...
0
votes
1answer
57 views

Connection Problem with update [closed]

I have installed Ubuntu 12.04 and trying to install synaptic package manager using sudo apt-get update. This command has stuck at 0%. I use a network proxy setting. Internet is not working in Update ...
1
vote
2answers
3k views

subprocess paste was killed by signal (Broken pipe)

I'm trying to install the package: libhdf5-serial-dev using the following terminal command: sudo apt-get install libhdf5-serial-dev This gives me the following output: Reading package lists... ...
-1
votes
1answer
12k views

Qt (headers and libraries) not found

I'm trying to install a program and i used the following command: ./configure But, an error occurred: checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and libraries) not found. ...
0
votes
1answer
136 views

Synaptic Package Manager Removed Ubuntu

I am a newbie to Ubuntu. Using it since a couple of months back and still learning it. But today something weird happened. I was trying to free some disk space from my /boot directory. To do that I ...
0
votes
1answer
364 views

problem while removing package from ubuntu 13.10 [duplicate]

$ sudo apt-get --purge remove libpixman-1-0 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that ...
0
votes
1answer
718 views

Both Software Center and Synaptic Package manager won't download packages

I am running Ubuntu 13.10 on a Toshiba Satellite Laptop. I am trying to download Labyrinth mind-mapping tool. However, neither the software center nor the synaptic package manager will download ...
0
votes
2answers
144 views

Is there a place or software in ubuntu like controol panel add/remove programs [duplicate]

is there a software or add/remove programs like windows that keeps a list of all installed used programs list on ubuntu. gui is prefered here. so that its easy. we do not have to use terminal.
-2
votes
1answer
1k views

Installing Google Earth in a 64-bit system

ok. solved the problem with lib-core now I get this error. jacob@jacob-desktop:~$ sudo -s dpkg -i google-earth-stable_current_amd64.deb Selecting previously unselected package google-earth-stable. ...
1
vote
1answer
233 views

How to re-download unauthenticated packages

I live in egypt. we have a country specific server here. I used to download everything from there. but when I got to download encryptfs, synaptic said the package could not be authenticated, so I ...
0
votes
2answers
130 views

dpkg: error processing mfc8500lpr:i386 (--remove)

I uninstalled this package with synaptic but it does not appear to have been completely removed. I used autoremove and the result is below. Reviewed several help requests but non seemed to work. ...
3
votes
2answers
2k views

Why do I get 404 error on .canonical.com on some archive servers?

I've been having a broken package problem for a fair amount of time now, and it was giving me trouble earlier when I was trying to install rvm. After some searching, I opened the software sources ...
1
vote
0answers
68 views

Optimal Ways of Installing and Maintaining Ubuntu Installations while off line (Starting with DVDs)? [duplicate]

I got my installations from Raring Ringtail which offers Xubuntu, L, K, GNOME and Unity. Let me also state that I know these version are already probably dated, since open source is always moving. I ...
1
vote
1answer
488 views

How to install Fogger?

I Want to know that how to install Fogger application, which Interact with different web accounts including Facebook on Ubuntu 13.10. In main Ubuntu repository, it is only available for Ubuntu 12.10 ...
0
votes
1answer
611 views

Installation of libsasl2-modules-gssapi-mit failed : unmet dependencies

Trying to install CDH4 (Cloudera Hadoop) and Manager on 12.04 LTS with 3.2.0-56-generic kernel and the installation aborts on the following: The following packages have unmet dependencies: ...
1
vote
0answers
137 views

libjpeg-turbo-dev Undefined reference and package issue

i am trying to do some coding using the lib but i cannot even compile a simple code, and when i asked about it in help section for the developers i got that the issue is from the package on the system ...
0
votes
3answers
185 views

How do I see what PPA or PPAs are installed or in use

Sometimes I install good guy PPAs because someone on askubuntu says to use add-apt-repository . Later I wonder, where have they gone? Where can I find a list of Personal Package Archives that are ...
0
votes
2answers
47 views

Retaining packages while upgrading

How can I retain installed package from a previous version of Ubuntu after upgrading that only the packages are retained and I don't have to download and install them again? or can I make a installer ...
5
votes
3answers
7k views

Problem with package installation - linux-image-server

I know similar issues have been resolved, but I'm kind of stuck. I ran out of space on / partition and needed to remove some packages since apt-get remove, autoremove and clean were not able to do ...
6
votes
2answers
593 views

Write List of Packages installed via Manual Invocation of apt-get to File

I'm trying to install a new version of Ubuntu from scratch, but I would like a list of the packages which I manually installed (as opposed to installed as a dependency or that came with the system). ...
27
votes
5answers
250k views

“Unable to locate package” while trying to install packages by apt

When I try to install any package through the command line, I get an error. Can anyone help me on this? $ sudo apt-get install <package> Reading package lists... Done Building dependency tree ...
4
votes
1answer
254 views

Can a deb package contain a PPA dependency and install packages from the PPA?

When creating a .deb package I create a file named control that contains some fields: Package: my-qt-app-name Version: 0.01 Architecture: all Maintainer: my name <my email address> ...
1
vote
3answers
1k views

Can't install gloobus-preview Ubuntu 13.10

I was trying to install gloobus-preview following this site: http://ubuntuhandbook.org/index.php/2013/08/install-gloobus-preview-in-ubuntu-13-04/ The problem is that when I try to install the ...
1
vote
2answers
2k views

How can I recover my system after attempting to install experimental packages?

I've been having issues with extremely frequent screen lockups and scrambled text. One possible fix was in mesa 9.2.3. Unfortunately, the latest version in the official repos was mesa 9.2.1. Hence, I ...
1
vote
1answer
8k views

Where to find package manager in Xubuntu 13.10

I'm a newbie to linux and I have a Xubuntu 13.10 relase installed on my PC. I need to install some packages for web development but I can not find the package manager utility in the applications menu. ...
11
votes
2answers
11k views

What is the difference between default-jdk, ecj, gcj and openjdk?

This morning, I tried to install something and came across a statement like this: The program 'javac' can be found in the following packages: * default-jdk * ecj * gcj-4.6-jdk * gcj-4.7-jdk * ...
0
votes
1answer
54 views

Add packages to Ubuntu Distro installation [duplicate]

I wanna create small change to Ubuntu Install CD. I want to add a few packages so when Ubuntu is installing, those packages also would be installed. So I wondering if it has some maybe ...
2
votes
1answer
3k views

OpenCV install problems on Studio 12.04 - broken dependencies [duplicate]

Problem: I'm trying to install OpenCV (video analytics) and am following the Ubuntu OpenCV installation documentation. The provided script has a line which executed for some time, taking away more ...
2
votes
0answers
554 views

Binary package for gcc 4.8.2 on Ubuntu 12.04?

Following this answer, I have installed gcc 4.8.1 on Ubuntu 12.04 a couple of months ago. Unfortunately, I encounter bugs very frequently, varying from failing to compile valid programs to crashing. ...
3
votes
2answers
4k views

Is Not Installed (Residual config) safe to remove all?

In Synaptic Manager I noticed I had a lot of packages in that list, and was wondering if any shouldn't be removed for some reason? Or if that is all safe to be removed. Is it possible that some should ...
1
vote
1answer
8k views

X11 Development Libraries [closed]

I am new to ubuntu, I am using ubuntu 13.10, and trying to install NS-2. During the installation I am facing the following error; X11/Xlib.h: No such file or directory Then i tried to install ...
1
vote
1answer
441 views

Ubuntu Saucy: What is the default console tool for parsing XML?

I used xmllint package for parsing xml files. Also, I know, that we can use xml2, xmlstarlet too. But I do not see those packages in Ubuntu Saucy. Does Saucy contain any default xml parsers? I ...
1
vote
0answers
2k views

How Do I fix my particular broken package system?

So I'm having a bit of trouble with my Ubuntu 13.10 installation. I cannot for the life of me figure out what I did to break it, I think it had something to do with an update not finishing. Anyway, ...
10
votes
2answers
16k views

What package do I need to build a Qt 5 & CMake application?

I'm trying to build sdrangelove, which wants Qt 5 and uses CMake for its build system, on Ubuntu 13.10. What package do I need to install to give it the file it's asking for here? There are a lot of ...
2
votes
2answers
4k views

How to repair a broken package?

My libboost package is broken. I don't know how to fix it. I tried: sudo apt-get autoremove and it was the result: Reading package lists... Done Building dependency tree Reading state ...
0
votes
1answer
349 views

Installing both lxml 3.1.2 and lxml2 on ubuntu 12.04

I asked this on SO: http://stackoverflow.com/questions/19852911/lxml-3-1-2-and-lxml2-both-on-ubuntu/19856674#19856674 But it is perhaps more appropriate for AskUbuntu. So here it is again, ...
1
vote
2answers
6k views

How to install the newest Mono?

I want to install the newest version of Mono on my Ubuntu 13.10 installation, but obviously it requires me to download a lot of packages from the Debian website, which is not ideal as it is hard to ...
-1
votes
1answer
348 views

my probleme about “The installation or removal of a software package failed”

Recently, when I open Ubuntu software center, it ask me repair package Then I found this message . installArchives() failed: (Reading database ... (Reading database ... 5% (Reading database ... 10% ...
2
votes
1answer
125 views

Display name for DEB package in Ubuntu Software Center

Suppose I have a package mypack_1.1.0_i386.deb. When I open it via Ubuntu Software Center it displays "mypack" as a display name. Obviously it gets the name from the "Package:" attribute of the ...
3
votes
3answers
2k views

apt-get update : Unable to change to (unreachable)// - chdir (2: No such file or directory)

Today I have tried to update the package lists and I have encountered strange error $ sudo apt-get update ... Ign http://archive.ubuntu.com saucy-security/universe Translation-en_US Ign ...
4
votes
1answer
20k views

Using dpkg to install upgrade and dist-upgrade packages

So I'm playing around with offline package installation on 12.04 Server, having downloaded packages by retrieving and wgetting their URIs using the instructions here: ...
-1
votes
2answers
2k views

installing python-xml packages [duplicate]

I want to install python-xml package on ubuntu. I see this command for installing it: sudo apt-get install python-xml but $ sudo apt-get install python-xmlReading package lists... Done Building ...
0
votes
3answers
56 views

How do I sort packages

I'm trying to remove some packages that I installed a long time ago but don't need any more, when I type dpkg --get-selection I get a list of all the packages installed in my system, but I need to ...
0
votes
2answers
465 views

How to make packages for ARM in Launchpad?

When I request builds in this recipe it only creates 32 bit and 64 bit packages. How to create packages for ARM? I am using Quickly.